Jump to content


Photo

Bestanden verkeerde datum

Enigma2

  • Please log in to reply
22 replies to this topic

#1 ni_hao

  • Senior Member
  • 820 posts

+5
Neutral

Posted 25 December 2010 - 09:44

De bestanden op mijn dm8000 in OpenPLi 2 hebben voor mij een verkeerde datestamp. Ze hebben de UTC tijd en niet de lokale tijd.
Aanvankelijk wilde ik de hardware klok veranderen met: /sbin/hwclock --systohc.

Heb getracht de hardware clock time te achterhalen met: /sbin/hwclock -r omdat ik denk dat die op UTC staat
hwclock is een symlink naar busybox (/bin), maar ik krijg een foutmelding nadat ik /sbin/hwclock -r uitvoer
hwclock: can't open '/dev/misc/rtc': No such file or directory
Of is er een andere manier om de bestanden te voorzien van de voor mij juiste tijd, nl. de lokale tijd (lees: systeemtijd)

Re: Bestanden verkeerde datum #2 Erik Slagter

  • PLi® Core member
  • 24,315 posts

+198
Excellent

Posted 25 December 2010 - 10:01

On 25-12-10 09:47, ni_hao wrote:

De bestanden op mijn dm8000 in OpenPLi 2 hebben voor mij een verkeerde datestamp. Ze hebben de UTC tijd en niet de lokale tijd.
Aanvankelijk wilde ik de hardware klok veranderen met: /sbin/hwclock --systohc.

Heb getracht de hardware clock time te achterhalen met: /sbin/hwclock -r omdat ik denk dat die op UTC staat
hwclock is een symlink naar busybox (/bin), maar ik krijg een foutmelding nadat ik /sbin/hwclock -r uitvoer

     hwclock: can't open '/dev/misc/rtc': No such file or directory

Of is er een andere manier om de bestanden te voorzien van de voor mij juiste tijd, nl. de lokale tijd (lees: systeemtijd)

_________________________________________________________________________________________________
http://www.pli-image...692#post_174692
Sent using ExiteCMS Mail2Forum: http://www.exitecms.org


De dreamboxen hebben wel een RTC (in de frontprocessor) maar die kun je
niet via hwclock instellen. Volgens mij hebben de dm500 en dm800 zelfs
helemaal geen RTC.

De tijd wordt bij het opstarten ingesteld vanaf een transponder-tijd (ik
kan je niet precies vertellen wat het selectie-criterium is voor welke
transponder). Meestal is dat vrij goed, maar sommige transponders zitten
er gewoon minuten of uren naast :-(

Als je files achteraf van een andere tijd wilt voorzien helpt het niet
om de klok te verzetten, maar dan zul je "touch" moeten gebruiken,
eventueel in combinatie met "find .. -exec touch ..".

Als de klok van je dreambox niet goed staat, dan is de tijd vanaf een
brakke transponder ingesteld of je hebt geen ontvangst (door driver bug
;-), had ik laatst ook).

NTP-ondersteuning zou ook wel erg fijn zijn (hint, hint).

* Wavefrontier T90 with:
- 5E/1W/5W single LNB's via uncomitted switch 8->1 on remote tuner
- 28.2E/23.5E/19.2E/13E quattro LNB's via committed 17->6 switch
UPC digital cable TV (FTA) on all receivers


Re: Bestanden verkeerde datum #3 ni_hao

  • Senior Member
  • 820 posts

+5
Neutral

Posted 25 December 2010 - 10:41

zover ik weet:
ntp zijn plugins voor, maar daar gaat het niet om. De systeemtijd is immers goed en die wordt van de transponder overgenomen (mits dit niet is uitgezet).
De systeemtijd vind je o.a. met het commando date.
Het gaat om de hardware tijd in de dm8000, deze staat standaard op UTC (mede vanwege juiste zomer-/wintertijd schakeling)
Echter dit heeft tot gevolg dat de bestanden worden voorzien van UTC en dat wil ik dus niet omdat ik het verleidend/misleiden vind.

Re: Bestanden verkeerde datum #4 MiLo

  • PLi® Core member
  • 11,185 posts

+227
Excellent

Posted 25 December 2010 - 10:50

NTP-ondersteuning zou ook wel erg fijn zijn (hint, hint).


Zit er al jaren in.

opkg install ntpdate

Real musicians never die - they just decompose

Re: Bestanden verkeerde datum #5 Robb

  • Senior Member
  • 195 posts

+1
Neutral

Posted 25 December 2010 - 10:58

Het gaat om de hardware tijd in de dm8000, deze staat standaard op UTC (mede vanwege juiste zomer-/wintertijd schakeling)
Echter dit heeft tot gevolg dat de bestanden worden voorzien van UTC en dat wil ik dus niet omdat ik het verleidend/misleiden vind.



Dit is zoals het in Linux altijd werkt.
De systeemklok (in ieder geval de software klok en als het zo geconfigureerd is ook de hardware klok) loopt in UTC.
De bestanden worden voorzien van deze UTC tijd als timestamp.
Op het moment dat een commando zoals "date" of "ls -l" deze tijd moet afdrukken, wordt de UTC tijd geconverteerd naar locale tijd.
Dit gebeurt door middel van de ingestelde "timezone", die dan tevens de correcties voor zomer en wintertijd aanbrengt.

Dus meestal krijg je de UTC tijd van de bestanden helemaal niet te zien.
Geeft je "ls -l" de tijd verkeerd weer dan staat de timezone verkeerd. Die kun je instellen via de afstandsbediening.
Maar dan staat de klok-in-beeld ook verkeerd.

Re: Bestanden verkeerde datum #6 pieterg

  • PLi® Core member
  • 31,760 posts

+228
Excellent

Posted 25 December 2010 - 11:50

waar zie je die utc dan? Weergave aan gebruiker is in de regel altijd localtime.
En zoals Robb al zegt, localtime is onder linux slechts een offset op UTC, dus puur cosmetisch.
Als het in 2.0 ergens niet goed gaat, hebben we mogelijk nog geen juiste zoneinfo in 2.0?
Hoewel ik vrij zeker weet dat e2 overal de juiste tijd weergeeft.

Re: Bestanden verkeerde datum #7 Erik Slagter

  • PLi® Core member
  • 24,315 posts

+198
Excellent

Posted 25 December 2010 - 13:11

>> NTP-ondersteuning zou ook wel erg fijn zijn (hint, hint).

Zit er al jaren in.

     opkg install ntpdate


Ik bedoel eigenlijk een fatsoenlijke ntpd, niet een one-shot. Op linux
is ntpdate eigenlijk al een tijd "obsolete", je schijnt daar dan weer
ntp in een one-shot mode voor te moeten gebruiken. Anyway, ik zie net
dat in het package "ntp" ook een echte ntpd zit :-) Ik hoop alleen dat
die niet enigma dwarszit en v.v.

* Wavefrontier T90 with:
- 5E/1W/5W single LNB's via uncomitted switch 8->1 on remote tuner
- 28.2E/23.5E/19.2E/13E quattro LNB's via committed 17->6 switch
UPC digital cable TV (FTA) on all receivers


Re: Bestanden verkeerde datum #8 Erik Slagter

  • PLi® Core member
  • 24,315 posts

+198
Excellent

Posted 25 December 2010 - 13:26

Linux (als in: de kernel) kent helemaal geen UTC (noch CET, etc.) Linux
rekent net als alle andere unixen in een aantal seconden vanaf 1 januari
1970. Deze timestamp wordt ook op files gezet. Op het moment dat je een
datum wilt zien (van "nu" of van een file) wordt deze waarde omgezet in
"human readable form". Afhankelijk van hoe je TZ en "locale" variablen
staan, wordt er omgerekend naar een bepaalde timezone. Dat de kernel de
tijd in de BIOS-klok op x86-PC's in UTC opslaat, staat hier he-le-maal
los van.

TS zou je nog eens _precies_ kunnen vertellen wat je probleem is,
volgens mij zijn we langs elkaar aan het praten.

* Wavefrontier T90 with:
- 5E/1W/5W single LNB's via uncomitted switch 8->1 on remote tuner
- 28.2E/23.5E/19.2E/13E quattro LNB's via committed 17->6 switch
UPC digital cable TV (FTA) on all receivers


Re: Bestanden verkeerde datum #9 ni_hao

  • Senior Member
  • 820 posts

+5
Neutral

Posted 25 December 2010 - 15:02

Probleem is dat ik, zoals op (bijna) elke linux distro, hwclock wil gebruiken.
Op de dm8000 zit een hwclock (ook al is het een symlink), maar die geeft bij gebruik een foutmelding zoals eerder beschreven.
Laten we de discussie over hardware clock en wel of niet in linux nu maar voor wat het is.

Wat ik zou willen is de hardware clock dezelfde te laten zijn als de systeemtijd, zoals dat op (bijne) elke linux distro gaat met : hwclock en de parameter --systohc
Ik loop nl. tegen het feit aan dat op mijn dm8000 alle bestanden niet de systeemtijd als timestamp hebben.
Indien je dus via je windows pc naar je ontvanger gaat dan zie je de verkeerde tijden en is voor mij uiterst lastig.
Ook al denk ik dat het probleem wellicht thuis hoort bij DMM, is het toch vreemd dat hwclock op de dm8000 zit maar het niet doet, terwijl ik het wel graag werkend wil hebben.

Re: Bestanden verkeerde datum #10 pieterg

  • PLi® Core member
  • 31,760 posts

+228
Excellent

Posted 25 December 2010 - 15:08

de rtc zit in het frontpanel, en is alleen beschikbaar via een closed source driver.
Daarom kan de linux kernel niet bij de rtc komen, en is hij in feite onbruikbaar onder linux.
That's the way it is.

overigens, de enige reden dat dat ding er in zit, is om wakker te worden uit deep standby.
Had alleen beter geen 'rtc' genoemd kunnen worden, zoals je ziet leidt dat tot verwarring.

Re: Bestanden verkeerde datum #11 pieterg

  • PLi® Core member
  • 31,760 posts

+228
Excellent

Posted 25 December 2010 - 15:10

Als je trouwens je box op localtime wilt laten draaien, daar heb je helemaal geen rtc voor nodig.
Gewoon je timezone op GMT zetten, en de tijd een uur verzetten. Heb je geluk, de GMT daylightsaving gaat in/uit op hetzelfde moment als in CE(S)T, hoef je zelfs daar geen rekening mee te houden.

edit: o wacht, je wilt helemaal geen offset, dus ook geen daylightsaving. Dan moet je localtime op UTC zetten ipv GMT, maar dan dus wel 2x per jaar de tijd verzetten...

Re: Bestanden verkeerde datum #12 ni_hao

  • Senior Member
  • 820 posts

+5
Neutral

Posted 25 December 2010 - 15:21

tnx pieterg; dat weet ik maar "thats the other way round" ;)
Oftewel is de omgekeerde weg en hebben de bestanden nog steeds niet de lokale tijd ofschoon ze dan wel gelijk aan de systeemtijd zijn.

Re: Bestanden verkeerde datum #13 Robb

  • Senior Member
  • 195 posts

+1
Neutral

Posted 25 December 2010 - 15:35

Wat ik zou willen is de hardware clock dezelfde te laten zijn als de systeemtijd, zoals dat op (bijne) elke linux distro gaat met : hwclock en de parameter --systohc
Ik loop nl. tegen het feit aan dat op mijn dm8000 alle bestanden niet de systeemtijd als timestamp hebben.
Indien je dus via je windows pc naar je ontvanger gaat dan zie je de verkeerde tijden en is voor mij uiterst lastig.
Ook al denk ik dat het probleem wellicht thuis hoort bij DMM, is het toch vreemd dat hwclock op de dm8000 zit maar het niet doet, terwijl ik het wel graag werkend wil hebben.


Ik denk dat je van de hardware klok iets verwacht wat die niet gaat bieden.
De bestanden krijgen de systeemtijd als timestamp, in UTC (in seconden sinds 1970) en dat staat helemaal
los van de hardware klok.
Als de bestanden er in Windows niet goed uit zien dan zit er aan die kant iets fout.

Re: Bestanden verkeerde datum #14 ni_hao

  • Senior Member
  • 820 posts

+5
Neutral

Posted 25 December 2010 - 15:48

@Robb: er staat in windows helemaal niks fout; dat heb ik ook niet geschreven.
Als de harware clock dezelfde tijd als de systeemtijd heeft worden de bestanden volgens mij voorzien van de systeemtijd dus en niet in UTC.

Re: Bestanden verkeerde datum #15 WanWizard

  • Forum Moderator
    PLi® Core member
  • 19,871 posts

+185
Excellent

Posted 25 December 2010 - 16:06

Het is me nog steeds niet duidelijk wat nu het probleem is.

De (interne) timestamp in linux ligt vast, en is gedefinieerd in UTC, in seconden sinds 1-1-1970. En daar kun je niks aan doen. De tijd die je ziet als je iets uit het filesystem op vraagt is altijd localtime, en deze wordt gestuurd door de timezone instellingen.

Wat wil je nu precies waar zien?

Many answers to your question can be found in our wiki.

Currently stacked up: VU+Solo, VU+Duo, VU+Duo2, ET4000, ET7500, ET9000, ET10000, Formuler F1 and an XP1000. Surplus: 3 x DM7000's and a brand new DM7025+. Shout if you can use one!


Re: Bestanden verkeerde datum #16 ni_hao

  • Senior Member
  • 820 posts

+5
Neutral

Posted 25 December 2010 - 16:11

Ik wil de tijd van de bestanden zien nadat ik de hardware clock dezelfde laat zijn als de systeemtijd. Zowel als ik de box benader via linux als via windows. Maar als het niet gaat, dan gaat het niet.

Re: Bestanden verkeerde datum #17 Robb

  • Senior Member
  • 195 posts

+1
Neutral

Posted 25 December 2010 - 16:14

@Robb: er staat in windows helemaal niks fout; dat heb ik ook niet geschreven.
Als de harware clock dezelfde tijd als de systeemtijd heeft worden de bestanden volgens mij voorzien van de systeemtijd dus en niet in UTC.


Dat heb je dan mis. Het gelijkstaan van hardware clock en systeemtijd heeft daar niks mee te maken.

Als de bestanden in Windows een andere tijd hebben dan in de dreambox, dan staat je timezone in
windows waarschijnlijk verkeerd. Of anders in de dreambox.

Hier zie ik dat probleem niet, tijd is hetzelfde.

Re: Bestanden verkeerde datum #18 pieterg

  • PLi® Core member
  • 31,760 posts

+228
Excellent

Posted 25 December 2010 - 16:18

Ik wil de tijd van de bestanden zien nadat ik de hardware clock dezelfde laat zijn als de systeemtijd. Zowel als ik de box benader via linux als via windows. Maar als het niet gaat, dan gaat het niet.


de 8000 heeft geen hardwareclock (alleen een frontprocessor die de box wakker kan laten worden uit deepstandby op een bepaalde tijd, maar dat is iets heel anders).

Maar wat je in feite wilt is niet zozeer 'hardwareclock gelijk aan systeemclock', maar 'localtime offset 0'.
Zelfs als je een hardwareclock had, en die gelijk zou zetten aan de systeemclock, zou je nog steeds daarnaast nog moeten instellen dat de systeemclock op localtime stond, en niet meer op UTC (wat de unix default is).

Kortom, localtime op UTC zetten is in dit geval voldoende, omdat je geen hardwareclock hebt.

Re: Bestanden verkeerde datum #19 ni_hao

  • Senior Member
  • 820 posts

+5
Neutral

Posted 25 December 2010 - 16:18

Tnx Robb, dan moet ik verder zoeken.
De tijden van bestanden zijn fysiek in UTC
De tijden van de bestanden worden via ls -l wel in de local timezone geprojecteerd
De tijden van de bestanden worden in windows via ftp in UTC getoond, terwijl de windows tijd uiteraard goed is ingesteld.

Re: Bestanden verkeerde datum #20 pieterg

  • PLi® Core member
  • 31,760 posts

+228
Excellent

Posted 25 December 2010 - 16:23

dus ftp is het probleem?
vftpd heeft wellicht geen weet van de timezone,of kiest er bewust voor utc weer te geven (omdat vftpd niet weet in welke timezone de ftp client zich bevindt).
En dat is in feite correct, nu ik er over nadenk, het ftp protocol heeft geen mogelijkheid de timezone van de client over te sturen.





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users