Jump to content


Photo

OpenWebIf error after update on DM800, ET9200


  • Please log in to reply
15 replies to this topic

#1 jeco92

  • Senior Member
  • 91 posts

+1
Neutral

Posted 28 October 2012 - 22:14

I just updated a DM800 HD (first generation, OpenPli 2.1) and a ET9200 (OpenPli 3.0).

These two receiver were not update since end of august so this last update download more than 100 package for each receiver.

After update and reboot, everything work well except OpenWebIF full browser mode (the mobile interface works).

When I connect to OpenWebIf, I get the left menu column (with a strange "TV in new window" just below the Radio menu item), the header but no information on the right of the page.

Clicking on every menu item give..... no result.

On the top right part of the page there is an error message saying "Sorry, this function is not yet implemented."

I tried on the DM800 :

- uninstall OpenWebIf
- reboot
- install OpenWebif
- reboot

but I still get the same problem (it is exactly the same on my ET9200).

Any idea ? (see the attached picture)

Attached Files


DM5620, DM500S, DM600, DM7000, DM7020, DM7025, DM800, DM8000, ET9200, ET6500, ET7500, ET8500, VU+DUO, VU+ULTIMO, GB800SE, GB800HD all with OpenPLi

Only the DM5620 went off in 2012 ! DM500S, DM600, DM7000 & DM7020 have been sold in 2014.


Re: OpenWebIf error after update on DM800, ET9200 #2 Frenske

  • Forum Moderator
    PLi® Core member
  • 26,423 posts

+345
Excellent

Posted 28 October 2012 - 22:17

Problem is known and hopefully fixed quickly. You can also flash yesterday's image to avoid this issue.

Mijn schotel is een T90 met 10 LNB's. Daarnaast voor de fun nog een draaibaar systeem met een Triax TD 78.

Dreamboxen heb ik niet meer echt actief. Verder heb ik ook nog een een VU+ duo2 met 500Gb harddisk + een VU+ Uno, Zero, Solo 4K, Ultimo 4K, Zero 4K, Uno 4Kse. + ook nog een Xtrend ET7x00. Daarnaast heb ik ook nog diverse andere modellen w.o. een Formuler F4, ET8500, ET7500, Mut@nt 2400HD, Xsarius Fusion HD se en verder nog wel het e.e.a. waarmee op verzoek vanalles wordt getest. Iemand moet het tenslotte doen. ;) :)
Los van de eerder genoemde modellen heb ik nog wel een rits aan testsamples als Mut@nt 2400HD, HD60, GB UE4K, GB Trio4K, Maxitec Multibox combo en Twin, Octagon sf8008, sf8008 mini en last but nog least enkele modellen van het Grieks Duitse Edision.

Voor centrale opslag van media gebruik ik een Qnap 219P 
met tweemaal 2 Tb harddisks + een Synology DS414 met 12 Tb Totale opslag.

-------------------------------------------------------------------------------------------
Many answers to your question can be found in our wiki: Just one click away from this "solutioncentre".

Als ik alles al wist hoefde ik ook niets te vragen. If I had all the knowledge I had no questions at all.


Re: OpenWebIf error after update on DM800, ET9200 #3 jeco92

  • Senior Member
  • 91 posts

+1
Neutral

Posted 28 October 2012 - 22:41

Thank you for the answer, I will wait for next update.

Jérôme

DM5620, DM500S, DM600, DM7000, DM7020, DM7025, DM800, DM8000, ET9200, ET6500, ET7500, ET8500, VU+DUO, VU+ULTIMO, GB800SE, GB800HD all with OpenPLi

Only the DM5620 went off in 2012 ! DM500S, DM600, DM7000 & DM7020 have been sold in 2014.


Re: OpenWebIf error after update on DM800, ET9200 #4 maigais

  • Senior Member
  • 431 posts

+4
Neutral

Posted 27 April 2013 - 13:57

after updates :(

Attached Files


BlackHole-3.1.0F_DM800 ,Tuner + ALINK DTU & Digital USB DVB-T HDTV TV Tuner Recorder Receiver , HDD TOSHIBA MK2552GSX 250gb,usb 16gb,skins Glamour_X-Infinity mod


Re: OpenWebIf error after update on DM800, ET9200 #5 fcs001fcs

  • Senior Member
  • 244 posts

+2
Neutral

Posted 28 April 2013 - 11:36

after updates :(

 

Same issue with me, did update yesterday (27 Apr 13) after a long time with no update and OpenwebIF has error " No module named fnmatch". Did a reflash to a few days ago "OpenPLi-2.1-beta-dm800-20130425.nfi" and it works fine now. Seems somthing went wrong in the last few days with the updates.

 

DM800HD



Re: OpenWebIf error after update on DM800, ET9200 #6 JaNuZz

  • Member
  • 13 posts

0
Neutral

Posted 28 April 2013 - 17:19

Here also no more webinterface after update 27 april, error: some plugins are not available no module named fnmatch



Re: OpenWebIf error after update on DM800, ET9200 #7 michaels

  • Member
  • 2 posts

0
Neutral

Posted 1 May 2013 - 16:05

I had the same problem. Here is a temporary fix:

 

1. Apply the following patch on /usr/lib/enigma2/python/Plugins/Extensions/OpenWebif/controllers/models/mediaplayer.py

 

--- /usr/lib/enigma2/python/Plugins/Extensions/OpenWebif/controllers/models/mediaplayer.py.orig
+++ /usr/lib/enigma2/python/Plugins/Extensions/OpenWebif/controllers/models/mediaplayer.py
@@ -3,7 +3,7 @@
 from enigma import eServiceReference
 
 import os
-import fnmatch
+#import fnmatch
 
 def getMpInstance(session):
 	try:
@@ -291,13 +291,13 @@
 
 def mediaPlayerFindFile(session, path, pattern):
 	rfiles = []
-	for root, dirs, files in os.walk(path):
-		for filename in fnmatch.filter(files, pattern):
-			rfiles.append({
-				"name": filename,
-				"path": root
-			})
-	
+	# for root, dirs, files in os.walk(path):
+	# 	for filename in fnmatch.filter(files, pattern):
+	# 		rfiles.append({
+	# 			"name": filename,
+	# 			"path": root
+	# 		})
+	# 
 	return {
 		"result": True,
 		"files": rfiles

 

2. Delete /usr/lib/enigma2/python/Plugins/Extensions/OpenWebif/controllers/models/mediaplayer.pyo (it will be regenerated after the next reboot)

 

3. Reboot

 

I assume that the problem is known and will be fixed with the next update (which will overwrite this file again)...



Re: OpenWebIf error after update on DM800, ET9200 #8 emer

  • Member
  • 36 posts

+1
Neutral

Posted 2 May 2013 - 14:45

doesnt work on 800HD ... and stilI dont have Openwebif :(



Re: OpenWebIf error after update on DM800, ET9200 #9 emer

  • Member
  • 36 posts

+1
Neutral

Posted 2 May 2013 - 15:24

I installed image from 17 april - is OK



Re: OpenWebIf error after update on DM800, ET9200 #10 ck32

  • Member
  • 1 posts

0
Neutral

Posted 2 May 2013 - 19:03

I had the same problem. Here is a temporary fix:

 

1. Apply the following patch on /usr/lib/enigma2/python/Plugins/Extensions/OpenWebif/controllers/models/mediaplayer.py

 

--- /usr/lib/enigma2/python/Plugins/Extensions/OpenWebif/controllers/models/mediaplayer.py.orig
+++ /usr/lib/enigma2/python/Plugins/Extensions/OpenWebif/controllers/models/mediaplayer.py
@@ -3,7 +3,7 @@
 from enigma import eServiceReference
 
 import os
-import fnmatch
+#import fnmatch
 
 def getMpInstance(session):
 	try:
@@ -291,13 +291,13 @@
 
 def mediaPlayerFindFile(session, path, pattern):
 	rfiles = []
-	for root, dirs, files in os.walk(path):
-		for filename in fnmatch.filter(files, pattern):
-			rfiles.append({
-				"name": filename,
-				"path": root
-			})
-	
+	# for root, dirs, files in os.walk(path):
+	# 	for filename in fnmatch.filter(files, pattern):
+	# 		rfiles.append({
+	# 			"name": filename,
+	# 			"path": root
+	# 		})
+	# 
 	return {
 		"result": True,
 		"files": rfiles

 

2. Delete /usr/lib/enigma2/python/Plugins/Extensions/OpenWebif/controllers/models/mediaplayer.pyo (it will be regenerated after the next reboot)

 

3. Reboot

 

I assume that the problem is known and will be fixed with the next update (which will overwrite this file again)...

 

Thanks a lot ! I have applyed this solution on my 800HD and it works ! Can you tell us what is fnmatch ? And what are doing the lines I removed ?

thanks again


Edited by ck32, 2 May 2013 - 19:04.


Re: OpenWebIf error after update on DM800, ET9200 #11 jeco92

  • Senior Member
  • 91 posts

+1
Neutral

Posted 6 May 2013 - 11:26

Thank for the fix, it runs on my DM800.

 

Will you add a fix to normal upgrade dor DM800 ?


DM5620, DM500S, DM600, DM7000, DM7020, DM7025, DM800, DM8000, ET9200, ET6500, ET7500, ET8500, VU+DUO, VU+ULTIMO, GB800SE, GB800HD all with OpenPLi

Only the DM5620 went off in 2012 ! DM500S, DM600, DM7000 & DM7020 have been sold in 2014.


Re: OpenWebIf error after update on DM800, ET9200 #12 fcs001fcs

  • Senior Member
  • 244 posts

+2
Neutral

Posted 9 May 2013 - 12:07

Re-flashed my DM800HD with "OpenPLi-2.1-beta-dm800-20130506.nfi" (latest availabe NFI) and had same problem with FNMATCH as I did last week.

 

Found an easy fix from MiLo in another thread not directly related to this issue. See http://openpli.org/f...ndpost&p=203765

 

I used Putty and ran "opkg install python-shell". This fixed my OpenWebIF fnmatch problem.

 

 

Question to Admins: Will this problem be fixed in upcoming updates for the DM800HD?



Re: OpenWebIf error after update on DM800, ET9200 #13 hemertje

  • Forum Moderator
    PLi® Core member
  • 33,302 posts

+118
Excellent

Posted 23 May 2013 - 09:42

The fix has been applied, but currently the nightly 2.1 builds are not working.         


on the Glassfibre 1GB DVB-C...


Re: OpenWebIf error after update on DM800, ET9200 #14 JaNuZz

  • Member
  • 13 posts

0
Neutral

Posted 4 June 2013 - 22:13

Hi Hemertje,

 

any idea when that is going to be fixed? the latest online version of openpli  OpenWebIF  is corrupt, and the fix here isn't working for me.

 

Or where can i download an older version that doesnt has this problem?

 

Greetings,

 

Jan

The fix has been applied, but currently the nightly 2.1 builds are not working.         



Re: OpenWebIf error after update on DM800, ET9200 #15 hemertje

  • Forum Moderator
    PLi® Core member
  • 33,302 posts

+118
Excellent

Posted 4 June 2013 - 22:33

we have other priorities then the 2.1 builds for now


on the Glassfibre 1GB DVB-C...


Re: OpenWebIf error after update on DM800, ET9200 #16 technic

  • Senior Member
  • 81 posts

+9
Neutral

Posted 22 July 2013 - 15:16

You need to install python-shell package.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users