Jump to content


Photo

mgcamd for Pli 4.0 @ littlesat


  • Please log in to reply
57 replies to this topic

Re: mgcamd for Pli 4.0 @ littlesat #21 littlesat

  • PLi® Core member
  • 54,001 posts

+645
Excellent

Posted 8 October 2013 - 14:34

For some rare reason they were indeed moved out of our feed... I just put them back so hopefully they are back after the next builds....

 

When not I'm scared the older version for OpenPLi3.0 might remove them...


WaveFrontier 28.2E | 23.5E | 19.2E | 16E | 13E | 10/9E | 7E | 5E | 1W | 4/5W | 15W


Re: mgcamd for Pli 4.0 @ littlesat #22 mirakels

  • Forum Moderator
    PLi® Core member
  • 7,576 posts

+62
Good

Posted 8 October 2013 - 16:27

yes the version checks will move the older one away.

 

Guess the need to be renamed so the can be seen as different packages

 

for example

enigma2-plugin-softcams-mgcamd-old_1.35a-r6_mips32el.ipk

enigma2-plugin-softcams-mgcamd-old-ssl1_1.35a-r6_mipsel.ipk

enigma2-plugin-softcams-mgcamd-ssl1_1.38c_mipsel.ipk

 

everything after the first underscore (looking from the left) will ignored to determine if it concers the same package.


Geen wonder... Had slechts een dm7000, maar wel ook een rotor. eigenlijk al een tijdje ook een dm600 en dm7025. Maar nu kijkend met een et9000 en vuduo

Re: mgcamd for Pli 4.0 @ littlesat #23 Alias1

  • Senior Member
  • 574 posts

+13
Neutral

Posted 1 November 2013 - 01:01

Anyone bothered to do this yet???


DM800se Vu+Duo ET-9000 Vu+Ultimo


Re: mgcamd for Pli 4.0 @ littlesat #24 littlesat

  • PLi® Core member
  • 54,001 posts

+645
Excellent

Posted 1 November 2013 - 08:03

Someone needs to change the ipk packages....

WaveFrontier 28.2E | 23.5E | 19.2E | 16E | 13E | 10/9E | 7E | 5E | 1W | 4/5W | 15W


Re: mgcamd for Pli 4.0 @ littlesat #25 Alias1

  • Senior Member
  • 574 posts

+13
Neutral

Posted 1 November 2013 - 12:59

Someone needs to change the ipk packages....

Which ones and changed to what???


DM800se Vu+Duo ET-9000 Vu+Ultimo


Re: mgcamd for Pli 4.0 @ littlesat #26 littlesat

  • PLi® Core member
  • 54,001 posts

+645
Excellent

Posted 1 November 2013 - 13:31

The package name (the name itself, but also inside the ipk) needs to be changed such a way that it does not through away old mgcamd packages...

 

E.g. inlcude oldssl remarks just behand mgcamd...

 

enigma2-plugin-softcams-mgcamdold_1.35a-r6_mips32el.ipk

enigma2-plugin-softcams-mgcamdold-ssl1_1.35a-r6_mipsel.ipk

enigma2-plugin-softcams-mgcamdssl1_1.38c_mipsel.ipk

 

So "the rest" is not seen as revision number...


WaveFrontier 28.2E | 23.5E | 19.2E | 16E | 13E | 10/9E | 7E | 5E | 1W | 4/5W | 15W


Re: mgcamd for Pli 4.0 @ littlesat #27 Alias1

  • Senior Member
  • 574 posts

+13
Neutral

Posted 1 November 2013 - 22:33

If some one is kind enough to post them here I don't have them I will do it

 

 

Cheers


DM800se Vu+Duo ET-9000 Vu+Ultimo


Re: mgcamd for Pli 4.0 @ littlesat #28 Alias1

  • Senior Member
  • 574 posts

+13
Neutral

Posted 3 November 2013 - 04:36

Just gimmie gimmie gimmie

Attached Files


DM800se Vu+Duo ET-9000 Vu+Ultimo


Re: mgcamd for Pli 4.0 @ littlesat #29 littlesat

  • PLi® Core member
  • 54,001 posts

+645
Excellent

Posted 3 November 2013 - 10:43

After the next builds they hopefully will become available...

 

But there is still a mistake...  I suggest that the 135a-ssl will not appear as 135a-r6 is a higher revision...

 

Make it mgcamdoldssl or so


Edited by littlesat, 3 November 2013 - 10:45.

WaveFrontier 28.2E | 23.5E | 19.2E | 16E | 13E | 10/9E | 7E | 5E | 1W | 4/5W | 15W


Re: mgcamd for Pli 4.0 @ littlesat #30 Alias1

  • Senior Member
  • 574 posts

+13
Neutral

Posted 3 November 2013 - 11:16

Here you go the last one

Attached Files


DM800se Vu+Duo ET-9000 Vu+Ultimo


Re: mgcamd for Pli 4.0 @ littlesat #31 littlesat

  • PLi® Core member
  • 54,001 posts

+645
Excellent

Posted 3 November 2013 - 11:22

Done...


WaveFrontier 28.2E | 23.5E | 19.2E | 16E | 13E | 10/9E | 7E | 5E | 1W | 4/5W | 15W


Re: mgcamd for Pli 4.0 @ littlesat #32 dOOds

  • Senior Member
  • 59 posts

0
Neutral

Posted 4 November 2013 - 18:12

still one thing to do on this....When installing 1.38c it shows in ect/init d that it is still 1.35a 

 

Easy to change myself but thought you should know.



Re: mgcamd for Pli 4.0 @ littlesat #33 Alias1

  • Senior Member
  • 574 posts

+13
Neutral

Posted 4 November 2013 - 23:20

Thanks dOOds
Da fix :)

Attached Files


DM800se Vu+Duo ET-9000 Vu+Ultimo


Re: mgcamd for Pli 4.0 @ littlesat #34 dOOds

  • Senior Member
  • 59 posts

0
Neutral

Posted 5 November 2013 - 09:10

Top man...Thank You Alias1.

 

Re: mgcamd for Pli 4.0 @ littlesat #35 MiLo

  • PLi® Core member
  • 14,023 posts

+296
Excellent

Posted 5 November 2013 - 10:44

Eh, you guys are aware of this?

http://sourceforge.n...c4ac69fd3e3c85/

In other words, the packages for scam and mgcamd in the feed should work just fine.
Real musicians never die - they just decompose

Re: mgcamd for Pli 4.0 @ littlesat #36 Alias1

  • Senior Member
  • 574 posts

+13
Neutral

Posted 5 November 2013 - 12:09

Eh, you guys are aware of this?

http://sourceforge.n...c4ac69fd3e3c85/

In other words, the packages for scam and mgcamd in the feed should work just fine.

That for 1.30d only???
Because I just modified the binary in the others they wouldn't run on the otherwise check for yourself mate :)

DM800se Vu+Duo ET-9000 Vu+Ultimo


Re: mgcamd for Pli 4.0 @ littlesat #37 MiLo

  • PLi® Core member
  • 14,023 posts

+296
Excellent

Posted 5 November 2013 - 14:09

I know nothing about mgcamd, others will have to test if it actually works.

Any dependency on old SSL libraries can be satisfied with the "libssl-compat" package dependency, which will build and install the 0.9.8 version and link it to 0.9.7 for good measure. This will co-exist with the 1.0 versions in the OpenPLi 4 feed.

If that doesn't work, report.
Real musicians never die - they just decompose

Re: mgcamd for Pli 4.0 @ littlesat #38 htc3htc

  • Member
  • 28 posts

0
Neutral

Posted 5 November 2013 - 17:03

Thanks dOOds
Da fix :)

Hi

 

what´s different whit the 1.38c on page 1 and this, i run 4.0 on my duo and works very well :)



Re: mgcamd for Pli 4.0 @ littlesat #39 Alias1

  • Senior Member
  • 574 posts

+13
Neutral

Posted 5 November 2013 - 19:58

I know nothing about mgcamd, others will have to test if it actually works.

Any dependency on old SSL libraries can be satisfied with the "libssl-compat" package dependency, which will build and install the 0.9.8 version and link it to 0.9.7 for good measure. This will co-exist with the 1.0 versions in the OpenPLi 4 feed.

If that doesn't work, report.

To be honest this is starting to piss me off.
First you get this attitude
http://openpli.org/f...c/30586-mgcamd/
After I bother to make the changes to mgcamd to bring it up to compatibility with PLi4.0 you then modify to this "reverts commit 2aaeb77eb23f54b9d30c1ab4161be0bb22f3e24a.
Now there are compatibility libs for 0.9.7 and 0.9.8"
you are going backwards to go fowards

Edited by Alias1, 5 November 2013 - 20:03.

DM800se Vu+Duo ET-9000 Vu+Ultimo


Re: mgcamd for Pli 4.0 @ littlesat #40 Alias1

  • Senior Member
  • 574 posts

+13
Neutral

Posted 5 November 2013 - 20:02

Thanks dOOds
Da fix :)

Hi
 
what´s different whit the 1.38c on page 1 and this, i run 4.0 on my duo and works very well :)
Nothing really modified the init.d file in it to show 1.38 instead of 1.35

DM800se Vu+Duo ET-9000 Vu+Ultimo



0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users