Jump to content


Photo

Strange look in channellist

Germany-Austria-Switserland

  • Please log in to reply
5 replies to this topic

#1 delagroov

  • Senior Member
  • 1,579 posts

+21
Neutral

Posted 29 September 2010 - 09:06

Last week i noticed that the epg info for germany is looking strange in the channelist

Attached Files


Vu+ Solo2 / Atemio Nemesis / Et9000 / TM Twin / Spark2

Astra 1/2/3 en HB / Harmony Touch, & 600
https://github.com/d...in-PLi-Full-HD-Night


Re: Strange look in channellist #2 doglover

  • Rytec EPG Team
  • 14,328 posts

+478
Excellent

Posted 29 September 2010 - 09:29

I think, this is the result of my efforts of applying some formatting to the imported epg data.

When I import the data, I loose all the formatting. In order to restore some of it, i apply some rules to it, to at least have some line breaks in the text, so not everything looks like on continues block of text.

As a results also some of the titles will have a line break in them.

I agree it looks odd, but not all the channels or all the programs have it.

Willy

~~Rytec Team~~
ZGemma StarS OpenPli (used as mediaplayer)
Mutant HD2400 OpenPli
Vu+ Duo OpenPli (backup)

Synology NAS

Sat: 13E, 19.2E, 23.5E and 28.2E
*Pli/Rytec EPG POWERED*


Re: Strange look in channellist #3 delagroov

  • Senior Member
  • 1,579 posts

+21
Neutral

Posted 29 September 2010 - 10:03

Okay, but before last week it did not occure.

As workaround I disabled the german xmltv source.

Vu+ Solo2 / Atemio Nemesis / Et9000 / TM Twin / Spark2

Astra 1/2/3 en HB / Harmony Touch, & 600
https://github.com/d...in-PLi-Full-HD-Night


Re: Strange look in channellist #4 SiennaRoot

  • Member
  • 21 posts

0
Neutral

Posted 29 September 2010 - 10:06

I think, this is the result of my efforts of applying some formatting to the imported epg data.

When I import the data, I loose all the formatting. In order to restore some of it, i apply some rules to it, to at least have some line breaks in the text, so not everything looks like on continues block of text.

As a results also some of the titles will have a line break in them.

I agree it looks odd, but not all the channels or all the programs have it.

Willy


I understand :)

It's possible to change the rules ?

Because it looks only strange with LF's on titles in the form : <title text> - <text 2>
so only on titles with a dash "-" in the text. The LF is after the "-" in the EPG title.

maybe when LF is after <text 2> or delete LF after the "-" it looks nicer ? :)

Re: Strange look in channellist #5 doglover

  • Rytec EPG Team
  • 14,328 posts

+478
Excellent

Posted 29 September 2010 - 13:35

This is correct. I use the dash to enter LF's.

It is not as simple as you expect. But I will look for a solution. But it is not my first priority.

Willy

~~Rytec Team~~
ZGemma StarS OpenPli (used as mediaplayer)
Mutant HD2400 OpenPli
Vu+ Duo OpenPli (backup)

Synology NAS

Sat: 13E, 19.2E, 23.5E and 28.2E
*Pli/Rytec EPG POWERED*


Re: Strange look in channellist #6 SiennaRoot

  • Member
  • 21 posts

0
Neutral

Posted 3 November 2010 - 10:03

Thanks for fixing this ...

seems no more "\n" in EPG Titels now





2 user(s) are reading this topic

0 members, 2 guests, 0 anonymous users