Jump to content


Photo

How do you get "Mgcamd 1.37" working on Openpli 2.01?

Mgcamd 1.37 - Openpli 2.01

  • Please log in to reply
18 replies to this topic

#1 Lukin

  • Senior Member
  • 134 posts

+8
Neutral

Posted 7 October 2011 - 18:04

Hi everyone!!!

How do you get "Mgcamd 1.37" working on Openpli 2.01 (dm 800hd)?

I looked everywhere..googled it..but didn`t find anything available for download for Openpli 2.01....i read somewhere someone posted a "bin" for Mgcamd 1.37 for Openpli 2.0 (which would work as an update after you download the one available from the online feed)..dunno if it could be used on Openpli 2.01?

Any help would be really appreciated, thx!

Edited by Lukin, 7 October 2011 - 18:06.


Re: How do you get "Mgcamd 1.37" working on Openpli 2.01? #2 hemispherical1

  • Senior Member
  • 1,596 posts

+49
Good

Posted 7 October 2011 - 18:20

I don't use mgcamd, that said I would guess...

Install whatever mgcamd is available from PLi's feed. This example we'll use enigma2-plugin-softcams-mgcamd_1.35a-r5_mipsel.ipk. Find a MIPS version of your desired mgcamd version and overwrite the existing /usr/bin/mgcamd with your preferred version. Make sure it is named identical to the previously existing installed mgcamd, overwriting the original.

I don't know if the config files have changed between those versions, if they did change than you'll need to track down working confs and replace the ones that 1.35a installed. Restart mgcamd through the cam manager and it will use your replaced version rather than 1.35...

If you want to be overly "neat", you can edit the /etc/init.d/softcam.mgcamd file, replacing any instances of 1.35 with your version, but that is not required, it should work fine regardless...


--
hemi

Edited by hemispherical1, 7 October 2011 - 18:22.


Re: How do you get "Mgcamd 1.37" working on Openpli 2.01? #3 Lukin

  • Senior Member
  • 134 posts

+8
Neutral

Posted 7 October 2011 - 18:29

Thx Hemispherical1 for laying it out...will give it another shot...this time being overly neat, well to some extent.

Re: How do you get "Mgcamd 1.37" working on Openpli 2.01? #4 Lukin

  • Senior Member
  • 134 posts

+8
Neutral

Posted 7 October 2011 - 19:47

Thx Hemispherical1,

It worked just like you explained it, but somehow the emu isn`t fully working....some signals are decrypted o.k., some aren`t, even though the keys are updated and working on other images.

I couldn`t find that "softcam.mgcamd" you mentioned, could it be why it isn`t fully functional?
Is there a way to troubleshoot; as to how pinpoint where it`s stuck or smth?

Re: How do you get "Mgcamd 1.37" working on Openpli 2.01? #5 Alias1

  • Senior Member
  • 574 posts

+13
Neutral

Posted 7 October 2011 - 22:19

No the bin file needs modding if some posts the bin file for mgcamd 1.37 I can be persuaded to mod it and do an ipk file for it.
The file softcam.mgcamd should be in /etc/init.d the other files you need a newcamd.list and mg_.cfg file both of these belong in /usr/keys.

DM800se Vu+Duo ET-9000 Vu+Ultimo


Re: How do you get "Mgcamd 1.37" working on Openpli 2.01? #6 Lukin

  • Senior Member
  • 134 posts

+8
Neutral

Posted 7 October 2011 - 23:01

No the bin file needs modding if some posts the bin file for mgcamd 1.37 I can be persuaded to mod it and do an ipk file for it.
The file softcam.mgcamd should be in /etc/init.d the other files you need a newcamd.list and mg_.cfg file both of these belong in /usr/keys.


Here`s the Mgcamd 1.37 for openpli 2.0 that i found.
http://www.mediafire...r3cd99gk0xb3yqh

Re: How do you get "Mgcamd 1.37" working on Openpli 2.01? #7 Alias1

  • Senior Member
  • 574 posts

+13
Neutral

Posted 8 October 2011 - 02:16

First off the bin file wasnt modified.
Let me know how you go :)
At littlesat dont put this on on the server its a hacked version of 1.35a

Attached Files


DM800se Vu+Duo ET-9000 Vu+Ultimo


Re: How do you get "Mgcamd 1.37" working on Openpli 2.01? #8 Lukin

  • Senior Member
  • 134 posts

+8
Neutral

Posted 8 October 2011 - 09:13

Thx Alias1 for your effort,

i started from scratch, removed the old one, rebooted, and then installed your package, but still it`s still the same...
the emu for some signals is working fine, just like it used to, but other signals are still out even though everything is in place.

I hope there is smth you or someone else can do, because on other images it`s working just fine.

feel free to pm me if you or anyone else wants to.

thx so much once again for your input!

Re: How do you get "Mgcamd 1.37" working on Openpli 2.01? #9 littlesat

  • PLi® Core member
  • 53,694 posts

+638
Excellent

Posted 8 October 2011 - 09:35

As it is a hacked version... what is hacked and of so I would prefer a ipk package that will not upgrade a non-hacked version...

WaveFrontier 28.2E | 23.5E | 19.2E | 16E | 13E | 10/9E | 7E | 5E | 1W | 4/5W | 15W


Re: How do you get "Mgcamd 1.37" working on Openpli 2.01? #10 Taykun345

  • Senior Member
  • 1,279 posts

+40
Good

Posted 8 October 2011 - 09:35

which packages dont work on mgcamd? I use mgcamd 1.37 and it works OK! Maybe its your config, i dont know.

Try mine config, it works 100% on all boxes (ET,VU+,DM).Attached File  mg_cfg.rar   1.66KB   437 downloads
Army MoodBlue HD skin modification by me: https://github.com/T...-MoodBlueHD-mod
Matrix10 MH-HD2 skin modification by me: https://github.com/B...-MX-HD2-OpenPli
MetrixHD skin modification by me: https://github.com/T...xHD-WPstyle-mod
Slovenian translation for OpenPLi E2: https://github.com/T...ion-for-OpenPLi

Re: How do you get "Mgcamd 1.37" working on Openpli 2.01? #11 Lukin

  • Senior Member
  • 134 posts

+8
Neutral

Posted 8 October 2011 - 10:05

Thx Taykun345 for your mg_cfg, just replaced mine with yours but still nothing, by the way, I`m talking about "C+nl".

it didn`t change anything, Are you on Pli 2.01? if so, can you post your Mgcamd 1.37?

Re: How do you get "Mgcamd 1.37" working on Openpli 2.01? #12 Taykun345

  • Senior Member
  • 1,279 posts

+40
Good

Posted 8 October 2011 - 10:51

Send me PM with channels that do not work, will test myself!
Army MoodBlue HD skin modification by me: https://github.com/T...-MoodBlueHD-mod
Matrix10 MH-HD2 skin modification by me: https://github.com/B...-MX-HD2-OpenPli
MetrixHD skin modification by me: https://github.com/T...xHD-WPstyle-mod
Slovenian translation for OpenPLi E2: https://github.com/T...ion-for-OpenPLi

Re: How do you get "Mgcamd 1.37" working on Openpli 2.01? #13 Lukin

  • Senior Member
  • 134 posts

+8
Neutral

Posted 8 October 2011 - 11:57

Thx Taykun345..i just did...you`ve got mail!!!

Re: How do you get "Mgcamd 1.37" working on Openpli 2.01? #14 Lukin

  • Senior Member
  • 134 posts

+8
Neutral

Posted 8 October 2011 - 19:46

I waited all day for feedback but still didn`t hear from "Taykun345",

so I`m asking if anyone can try out the file that "Alias1" posted this morning on your end and see if it`s working, i still think "maybe, there is something i`m doing wrong"

Thx for your help!.

Re: How do you get "Mgcamd 1.37" working on Openpli 2.01? #15 Jeroensky

  • Senior Member
  • 2,177 posts

+12
Neutral

Posted 8 October 2011 - 20:01

OScam support MGcamd servers.

Dreambox Dm8000 with all hardware addons donated to OpenPli. No interests anymore in policy of CanalDigitaal / M7 group and now-a-days channel encryption (like CI+ / HD+).

Good luck Enigma2 / OpenPli, it was fun with Sky Movies and so on, collected a nice collection of movies. Now back to basic boring lineair TV with KPN iTV (VDSL2 pair bonding 219 / 63 Mbps).

The VDSL pair bonding is excellent for... torrents to NAS in higher quality then HDTV (Like Dolby-TrueHD or DTS-Master-Audio soundquality ) :D


Re: How do you get "Mgcamd 1.37" working on Openpli 2.01? #16 Lukin

  • Senior Member
  • 134 posts

+8
Neutral

Posted 9 October 2011 - 09:58

Thx J3r03n5ky for your feedback,

I spent the entire day yesterday fiddling around with that mg_cfg, turned out that some settings in there might be the culprit that had me looking in the wrong direction:

"G" Network mode needs to be set to "32" to get thru to your other softcam, provided that a ".list" for that cam is already configured, this setting is already enabled in Taykun345`s mg_cfg,

The other setting is "R" Reread files which is disabled by default, needs to be set to "02" if you update the keys manually, and "04" if you replaced your "key" file altogether.

This is pretty much what i came up with, by the way, I installed that Mgcamd that "Alias1" posted above with Taykun345`s mg_cfg...starting from scratch after uninstalling the old package and rebooting.

Please post your feedback for future references, if you were stuck but managed to get back at it by editing configs eventually.

Thx for your help, someone could use it someday.

Edited by Lukin, 9 October 2011 - 10:00.


Re: How do you get "Mgcamd 1.37" working on Openpli 2.01? #17 Taykun345

  • Senior Member
  • 1,279 posts

+40
Good

Posted 9 October 2011 - 12:33

sorry, i forgot to answer you. Well i tested NL package (622 CAID) and i was able to watch all channels that i tried (NED, etc.).
Army MoodBlue HD skin modification by me: https://github.com/T...-MoodBlueHD-mod
Matrix10 MH-HD2 skin modification by me: https://github.com/B...-MX-HD2-OpenPli
MetrixHD skin modification by me: https://github.com/T...xHD-WPstyle-mod
Slovenian translation for OpenPLi E2: https://github.com/T...ion-for-OpenPLi

Re: How do you get "Mgcamd 1.37" working on Openpli 2.01? #18 Lukin

  • Senior Member
  • 134 posts

+8
Neutral

Posted 9 October 2011 - 13:38

No sweat Taykun345!!! and thx anyways!!!....it kept me busy yesterday but i nailed it like i mentioned, can`t complain!!!

Re: How do you get "Mgcamd 1.37" working on Openpli 2.01? #19 Lukin

  • Senior Member
  • 134 posts

+8
Neutral

Posted 25 October 2011 - 18:10

Here`s an update to the latest 1.38

Download the file below
Overwrite the files in usr/bin & usr/keys with the ones from the download link

http://www.mediafire...tcag831mts8a98v

Edited by Lukin, 25 October 2011 - 18:12.




Also tagged with one or more of these keywords: Mgcamd 1.37 -, Openpli 2.01

1 user(s) are reading this topic

0 members, 1 guests, 0 anonymous users