Jump to content


Photo

OpenWebif [E2OpenPlugins]


  • Please log in to reply
1459 replies to this topic

Re: OpenWebif [E2OpenPlugins] #761 tilleke

  • Senior Member
  • 50 posts

+5
Neutral

Posted 20 March 2012 - 17:36

That sounds fine and I am happy you pay some attention to this bug as I noticed this already longer time ago :)


Hmm...with you, do you mean me?

If yes, please note that I am not a developer of OWIF - I am only reporting problems that users of my apps are reporting to me once I have clarified the origin of the problems. In this case, the problem seems to have been introduced after the commit of March 4, 2012 ("Refactored timer dialog code to avoid multiple initializations")

Re: OpenWebif [E2OpenPlugins] #762 Rincewind

  • Member
  • 25 posts

+12
Neutral

Posted 20 March 2012 - 17:53

In this case, the problem seems to have been introduced after the commit of March 4, 2012 ("Refactored timer dialog code to avoid multiple initializations")


Mmmh, that sounds strange: I made that commit (but that's not the reason I'm finding it strange :) ), and it is not touching at all the movies management, only the timers. :huh:

@Tilleke, let me understand, in order to recreate the problem when I'm home and I find a little time: you are saying that if you have set up your default recording directory to somewhere different from /hdd/movie, you call http: //box/movielist?dirname=path and you do not find the movies that are there: is this correct?

@Edgar: Linux/Unix is case sensitive

Re: OpenWebif [E2OpenPlugins] #763 Edgar

  • Senior Member
  • 288 posts

+7
Neutral

Posted 20 March 2012 - 17:53


That sounds fine and I am happy you pay some attention to this bug as I noticed this already longer time ago :)


Hmm...with you, do you mean me?

Ok, both of us :)

If yes, please note that I am not a developer of OWIF - I am only reporting problems that users of my apps are reporting to me

I understood. Sometimes problems need to be more clear and you gave that. Thanks.

VU+ Duo 4K DVB-S2X en DVB-C met Open PLi 7.0


Re: OpenWebif [E2OpenPlugins] #764 Meega

  • Senior Member
  • 2,997 posts

+51
Good

Posted 20 March 2012 - 17:54


That sounds fine and I am happy you pay some attention to this bug as I noticed this already longer time ago :)


Hmm...with you, do you mean me?

If yes, please note that I am not a developer of OWIF


You can be if you want ,more souls more joy :D

ET10000+ Openpli 6.1,1m schotel 4x duo-lnb op vaste opstelling.

Momolights teensy 2.0 met 50 leds op een string ,150 channels
DM8000 Openpli 6.1 Release


Re: OpenWebif [E2OpenPlugins] #765 Edgar

  • Senior Member
  • 288 posts

+7
Neutral

Posted 20 March 2012 - 18:14

@Tilleke, let me understand, in order to recreate the problem when I'm home and I find a little time: you are saying that if you have set up your default recording directory to somewhere different from /hdd/movie, you call http: //box/movielist?dirname=path and you do not find the movies that are there: is this correct?

Sorry I am not Tilleke... You can recreate the problem to use for example an USB stick or USB drive and change the default recording path to that external drive. In e.g. PLi the external harddisks are not mounted as /hdd anymore but as /media/usb (or /media/sdb1 or one person at this forum even /media/sdc1) in case you have two external harddisks. Put a recorded movie in the directory movie and you can see what we mean :)

With http: //box/movielist?dirname=path you mean: http://(ip of the box)/movielist?dirname=/media/usb/movie to put in a webbrowser? I have tried this and I get an error. I do something wrong I guess.

@Edgar: Linux/Unix is case sensitive

I know that. I only meant with that Movies or movies that OWIF only reads the directory movies with small m.

VU+ Duo 4K DVB-S2X en DVB-C met Open PLi 7.0


Re: OpenWebif [E2OpenPlugins] #766 tilleke

  • Senior Member
  • 50 posts

+5
Neutral

Posted 20 March 2012 - 18:32

@Tilleke, let me understand, in order to recreate the problem when I'm home and I find a little time: you are saying that if you have set up your default recording directory to somewhere different from /hdd/movie, you call http: //box/movielist?dirname=path and you do not find the movies that are there: is this correct?


I am still in the office but I will get back later when I am at home.

Re: OpenWebif [E2OpenPlugins] #767 tilleke

  • Senior Member
  • 50 posts

+5
Neutral

Posted 20 March 2012 - 18:37

You can be if you want ,more souls more joy :D


My brain in this moment is full - can't see any space left for learning to write Python :D
Besides, all the developers of OWIF are already doing a great job! Kudos to them!

Re: OpenWebif [E2OpenPlugins] #768 Rincewind

  • Member
  • 25 posts

+12
Neutral

Posted 20 March 2012 - 21:54

OK, I've probably found the problem and I've committed a fix. Please test and let me know.

The strange thing is that, if I did not get it wrong, this issue has always been present in OpenWebif, and possibly in the old web interface! (I did not use the latter, so I'm judging from the code).

Re: OpenWebif [E2OpenPlugins] #769 Edgar

  • Senior Member
  • 288 posts

+7
Neutral

Posted 20 March 2012 - 22:25

Rincewind, it works! I have overwritten movies.py and the list is directly to see in the webbrowser. great job, thanks.
The external USB harddrive users will be happy with that :)

Maybe you know some solution for this:
About automatic updatIng of EPG now-next information in the bouquet list. The automatic refresh after some minutes. In that case the EPG information for now and next will be automatic updated. After an hour we have now outdated EPG info ;)

For the clearance I mean this what's in original webinterface:
Update-Interval for current bouquets EPG (min. 60 sec) [300 sec.]

The 300 seconds is standard, at least I didn't change that.

Thanks,

Edgar

VU+ Duo 4K DVB-S2X en DVB-C met Open PLi 7.0


Re: OpenWebif [E2OpenPlugins] #770 tilleke

  • Senior Member
  • 50 posts

+5
Neutral

Posted 20 March 2012 - 23:51

OK, I've probably found the problem and I've committed a fix. Please test and let me know.

The strange thing is that, if I did not get it wrong, this issue has always been present in OpenWebif, and possibly in the old web interface! (I did not use the latter, so I'm judging from the code).


Thanks Rincewind for your GREAT work. Kudos to you.
I just got a report from app-user saying that everything is now OK. It means that the commit of March 4, 2012 was just coincidental as you rightly suggested.

Re: OpenWebif [E2OpenPlugins] #771 Hejira

  • Member
  • 22 posts

+2
Neutral

Posted 24 March 2012 - 04:25

Is it possible to have EPG n Stream Icons with the Current Channel info please.

Many Thanks

Re: OpenWebif [E2OpenPlugins] #772 pogo1975

  • Member
  • 17 posts

0
Neutral

Posted 24 March 2012 - 22:37

Hi

I have a feature request /patch

this is regarding some problematic channels on 13e or 30e, these channels use shared pmt and when you try to stream them to vlc they are not working i have found a way to make them work but it will be cool to have it implemeted in openwebif.

standard stream.m3u looks like this:
#EXTM3U
#EXTVLCOPT--http-reconnect=true
http://IP:8001/1:0:1:1CB5:1CE8:71:820000:0:0:0:

and working stream m3u for this particular channel should look like this:

#EXTM3U
#EXTVLCOPT--http-reconnect=true
#EXTVLCOPT:program=7349
http://IP:8001/1:0:1:1CB5:1CE8:71:820000:0:0:0:

The difference #EXTVLCOPT:program=7349 where program number is decimal value of 1CB5 from service refference

Is it possible to implement that in stream.m3u generation from openwebif? These should work on other channels too (normal channels that does not use shared pmt)

Thanks in advance.

JArek

Re: OpenWebif [E2OpenPlugins] #773 tilleke

  • Senior Member
  • 50 posts

+5
Neutral

Posted 24 March 2012 - 23:50

@pogo1975

Could you please name some of those channels? I would like to test it as well using VLC. Thanks!

Re: OpenWebif [E2OpenPlugins] #774 tilleke

  • Senior Member
  • 50 posts

+5
Neutral

Posted 24 March 2012 - 23:57

With Android, we normally need an external video-player to play the TV- and Movie-streams from the receiver. Using something called Intents, we pass on the URL to the video-player which then uses it to get the stream from the receiver. While for TV-streams there are no problems whatsoever, I noted however that there is an authentication-request for movie-streams when OpenWebIf-authentication has been enabled in settings. So in order to resolve this, I am passing on the classic user/password prefix in the URL (for example: h*tp://root:mypassword@192.168.1.8:8088/file?file=myfilm.ts) and this, fortunately, works.

Please correct me if I am wrong but I believe the original WebIF does not require this when WebIf-authentication is enabled unless you also enable the separate option in WebIf Plugin-settings which permits you to enable authentication specifically for streaming (which I however believe is disabled by default).

Does this mean that OpenWebIf has enabled this by design? If yes, it would still be nice to distinguish those two options, just like in original WebIf.

Re: OpenWebif [E2OpenPlugins] #775 ouTsiDaz_

  • Member
  • 3 posts

0
Neutral

Posted 25 March 2012 - 01:32

Hi

I have a feature request /patch

this is regarding some problematic channels on 13e or 30e, these channels use shared pmt and when you try to stream them to vlc they are not working i have found a way to make them work but it will be cool to have it implemeted in openwebif.

standard stream.m3u looks like this:

#EXTM3U
#EXTVLCOPT--http-reconnect=true
http://IP:8001/1:0:1:1CB5:1CE8:71:820000:0:0:0:

and working stream m3u for this particular channel should look like this:

#EXTM3U
#EXTVLCOPT--http-reconnect=true
#EXTVLCOPT:program=7349
http://IP:8001/1:0:1:1CB5:1CE8:71:820000:0:0:0:

The difference #EXTVLCOPT:program=7349 where program number is decimal value of 1CB5 from service refference

Is it possible to implement that in stream.m3u generation from openwebif? These should work on other channels too (normal channels that does not use shared pmt)

Thanks in advance.

JArek


I also make this request. Portuguese provider ZON uses shared PMT in all channels.
Adding the PMT makes the channels work on VLC.

#EXTVLCOPT:program=PMT

Thanks

Re: OpenWebif [E2OpenPlugins] #776 pogo1975

  • Member
  • 17 posts

0
Neutral

Posted 25 March 2012 - 09:03

@pogo1975

Could you please name some of those channels? I would like to test it as well using VLC. Thanks!

Hi

For Example: Channels from this transponder: Hot Bird 13e 12188 V

Seriale
AXN Crime Poland

AXN Sci-Fi Poland

Polsat Futbol
Extreme Sports
NatGeo Wild

DISCOVERY
Discovery Channel Polska

AXN Polska
ESPN Classic Sport Europe
Disney XD Polska
Cinemax 2 Europe
TVP 2
Fox Life Poland





They Are All Scrambled but if you have a problem with that pm me.

Edited by pogo1975, 25 March 2012 - 09:07.


Re: OpenWebif [E2OpenPlugins] #777 pogo1975

  • Member
  • 17 posts

0
Neutral

Posted 25 March 2012 - 10:06


I also make this request. Portuguese provider ZON uses shared PMT in all channels.
Adding the PMT makes the channels work on VLC.

#EXTVLCOPT:program=PMT

Thanks


This does not work for me :( i have tested vlc 1.1.9 and 2.0.1

Edited by pogo1975, 25 March 2012 - 10:07.


Re: OpenWebif [E2OpenPlugins] #778 blzr

  • PLi® Core member
  • 2,055 posts

+100
Excellent

Posted 25 March 2012 - 10:43



I also make this request. Portuguese provider ZON uses shared PMT in all channels.
Adding the PMT makes the channels work on VLC.

#EXTVLCOPT:program=PMT

Thanks


This does not work for me :( i have tested vlc 1.1.9 and 2.0.1

I can only confirm, for these (Polsat provided) services with shared PMT pid, an exact SID decimal value has to be added to make it (VLC) streamable...
True sarcasm doesn't need green font...

Re: OpenWebif [E2OpenPlugins] #779 ouTsiDaz_

  • Member
  • 3 posts

0
Neutral

Posted 25 March 2012 - 11:39




I also make this request. Portuguese provider ZON uses shared PMT in all channels.
Adding the PMT makes the channels work on VLC.

#EXTVLCOPT:program=PMT

Thanks


This does not work for me :( i have tested vlc 1.1.9 and 2.0.1

I can only confirm, for these (Polsat provided) services with shared PMT pid, an exact SID decimal value has to be added to make it (VLC) streamable...


Sorry, my bad. You are correct, the value passed should be decimal SID.

PS: I made the changes to the servicesm3u.tmpl and used cheetah to generate the .py, but my box isn't generating the .pyo after restart like it should (I think). I'm using OpenRSI, anybody knows what could be? Or if someone could upload the corrected files would be great.

Edited by ouTsiDaz_, 25 March 2012 - 11:43.


Re: OpenWebif [E2OpenPlugins] #780 mrbeam

  • Senior Member
  • 270 posts

+6
Neutral

Posted 25 March 2012 - 19:24

Bug in remote Control: Volume + is swopped with -.

Wavefrontier T90, Octagon SF4008 (2x DVB-S2x & 1x DVB-T2) Mut@nt HD51 (DVB-S2x & DVB-C), TBS6920 & TBS6925





2 user(s) are reading this topic

0 members, 2 guests, 0 anonymous users