Jump to content


Photo

D-Link DWA-131 wird nicht (vollstaendig) unterstuertzt

d-link wi-fi usb wireless wlan

  • Please log in to reply
2 replies to this topic

#1 inte

  • Member
  • 3 posts

0
Neutral

Posted 9 November 2011 - 10:20

Hallo,

ich habe auf meine et5000 das aktuellste OpenPLI-Image gespielt.
Nun moechte ich gerne mit einem DWA-131 WIFI-Stick ins Netz.
Die Software fuer das Wlan ist installiert, und ich kann auch nach Wlans suchen und finde das Wlan, mit dem ich gerne verbinden moechte.
Leider klappt aber das Verbinden mit dem Netz aber ueberhaupt nicht, auch wenn ich beispielsweise die Verschluesselung komplett deaktiviere.
Laut dmesg wird die Firmware ganz regulaer geladen (also fuer den Stick) und der Stick aktiviert, eine ungewoehnliche Mitteilung find ich da nicht.
Hardware Revision des DWA-131 ist die A1 - sollte damit ja eigentlich gehen.
Da ich mich dunkel an ein aehnliches Verhalten meiner DM8000 mit einem neueren Image erinnern konnte, habe ich mir von dieser die (aktuell mit der internen Karte funktionierenden) wpa-Tools (aus /ust/sbin) kopiert und mal auf die et5000 gespielt, aber auch das hat mich leider nicht weiter gebracht.
Danke fuer Tipps!

Re: D-Link DWA-131 wird nicht (vollstaendig) unterstuertzt #2 Carl

  • Senior Member
  • 367 posts

+8
Neutral

Posted 9 November 2011 - 11:10

Setzen sie die einstellung auf wpa oder wpa2 und nicht auf wpa2.
Box neu starten und es must funktionieren.
XP1000, Clarketech CT9000 and a VU+ duo

Re: D-Link DWA-131 wird nicht (vollstaendig) unterstuertzt #3 inte

  • Member
  • 3 posts

0
Neutral

Posted 9 November 2011 - 14:49

Still doesn't seem to work:(
Maybe this helps to make things clearer:

root@et5x00:~# /etc/init.d/networking restart
Reconfiguring network interfaces... Initializing interface 'wlan0' conf '/etc/wpa_supplicant.wlan0.conf' driver 'wext' ctrl_interface 'N/A' bridge 'N/A'
Configuration file '/etc/wpa_supplicant.wlan0.conf' -> '/etc/wpa_supplicant.wlan0.conf'
Reading configuration file '/etc/wpa_supplicant.wlan0.conf'
ctrl_interface='/var/run/wpa_supplicant'
eapol_version=1
fast_reauth=1
ap_scan=1
Line: 6 - start of a new network block
ssid - hexdump_ascii(len=15):
48 61 6d 62 75 72 67 20 4e 65 74 77 6f 72 6b Hamburg Network
scan_ssid=0 (0x0)
key_mgmt: 0x2
proto: 0x3
pairwise: 0x18
group: 0x18
PSK (ASCII passphrase) - hexdump_ascii(len=8): [REMOVED]
PSK (from passphrase) - hexdump(len=32): [REMOVED]
Priority group 0
id=0 ssid='Hamburg Network'
SIOCGIWRANGE: WE(compiled)=22 WE(source)=16 enc_capa=0xf
capabilities: key_mgmt 0xf enc 0xf flags 0x0
netlink: Operstate: linkmode=1, operstate=5
Own MAC address: 00:26:5a:eb:de:1f
wpa_driver_wext_set_key: alg=0 key_idx=0 set_tx=0 seq_len=0 key_len=0
wpa_driver_wext_set_key: alg=0 key_idx=1 set_tx=0 seq_len=0 key_len=0
wpa_driver_wext_set_key: alg=0 key_idx=2 set_tx=0 seq_len=0 key_len=0
wpa_driver_wext_set_key: alg=0 key_idx=3 set_tx=0 seq_len=0 key_len=0
wpa_driver_wext_set_countermeasures
RSN: flushing PMKID list in the driver
Setting scan request: 0 sec 100000 usec
EAPOL: SUPP_PAE entering state DISCONNECTED
EAPOL: Supplicant port status: Unauthorized
EAPOL: KEY_RX entering state NO_KEY_RECEIVE
EAPOL: SUPP_BE entering state INITIALIZE
EAP: EAP entering state DISABLED
EAPOL: Supplicant port status: Unauthorized
EAPOL: Supplicant port status: Unauthorized
Added interface wlan0
Daemonize..
daemon: No such device
Removing interface wlan0
No keys have been configured - skip key clearing
State: DISCONNECTED -> DISCONNECTED
wpa_driver_wext_set_operstate: operstate 0->0 (DORMANT)
netlink: Operstate: linkmode=-1, operstate=5
EAPOL: External notification - portEnabled=0
EAPOL: Supplicant port status: Unauthorized
EAPOL: External notification - portValid=0
EAPOL: Supplicant port status: Unauthorized
wpa_driver_wext_set_countermeasures
No keys have been configured - skip key clearing
Cancelling scan request
Cancelling authentication timeout
netlink: Operstate: linkmode=0, operstate=6
udhcpc (v1.18.5) started
Sending discover...
Sending discover...
Sending discover...
No lease, forking to background
done.
root@et5x00:~#


Thank you in advance!





Also tagged with one or more of these keywords: d-link, wi-fi, usb, wireless, wlan

1 user(s) are reading this topic

0 members, 1 guests, 0 anonymous users