Jump to content


Photo

af9015 plugin no longer working

usb tuner dvb-t

  • Please log in to reply
32 replies to this topic

#1 erukus

  • Member
  • 3 posts

0
Neutral

Posted 17 November 2011 - 20:18

I flashed my box with open pli from the beginning of the month and then downloaded the above plugin via the feed.
I used a terratec usb dvb-t tuner to receive Irish freeview channels. Yesterday I upgraded the pli image to the latest image
and again downloaded the above plugin. However the usb tuner is no longer recognised. I have tried going back to the older
image but it still no longer sees mu usb tuner? Has the af9015 driver been updated and if so is this the problem?

Re: af9015 plugin no longer working #2 erukus

  • Member
  • 3 posts

0
Neutral

Posted 17 November 2011 - 20:39

Has the af9015 plugin been updated and if so is it possible to get an earlier version such as one from earlier this month?

Re: af9015 plugin no longer working #3 Jag-T

  • Member
  • 20 posts

0
Neutral

Posted 18 November 2011 - 15:15

The driver for dib0700 is also not working anymore with Pli

Re: af9015 plugin no longer working #4 Happysat

  • Senior Member
  • 686 posts

+42
Good

Posted 18 November 2011 - 15:35

Wierd i have both above mentioned DVB-T sticks and both are working fine update from 16 november.

'Wie weet spreekt niet, wie spreekt weet niet'

Sunray Vu Solo2/DM800SE V2 DVB-S2/C/T T-85 (28e,23e,19e,13e,9e,4e,1w,5w)


Re: af9015 plugin no longer working #5 maunti

  • Member
  • 2 posts

0
Neutral

Posted 18 November 2011 - 21:20

I have reflash today, and my AF9015 dosnt work . With an older Kernel was all fine, but now with Kernel 3.1. are nothing. Same is with AF9035 Chipset.

Re: af9015 plugin no longer working #6 erukus

  • Member
  • 3 posts

0
Neutral

Posted 20 November 2011 - 19:24

This has now been solved with the latest image

Re: af9015 plugin no longer working #7 vgi

  • Member
  • 15 posts

0
Neutral

Posted 26 November 2011 - 22:26

My AF9015 stick still not recognized by my DM800. :(
Any ideas?

Re: af9015 plugin no longer working #8 skirmas

  • Member
  • 15 posts

0
Neutral

Posted 1 December 2011 - 17:27

same here 9015 Fatal

Re: af9015 plugin no longer working #9 Happysat

  • Senior Member
  • 686 posts

+42
Good

Posted 1 December 2011 - 17:45

Upgrading enigma2-plugin-drivers-dvb-usb-af9015 on root from 1.0-r2 to 1.0-r3...
Downloading http://downloads.pli-images.org/feeds/openpli-2.1/dm800/mipsel/enigma2-plugin-drivers-dvb-usb-af9015_1.0-r3_mipsel.ipk.
Installing firmware-dvb-usb-af9015 (1.0-r0) to root...
Downloading http://downloads.pli-images.org/feeds/openpli-2.1/dm800/all/firmware-dvb-usb-af9015_1.0-r0_all.ipk.
Collected errors:
* check_data_file_clashes: Package firmware-dvb-usb-af9015 wants to install file /lib/firmware/dvb-usb-af9015.fw
But that file is already provided by package  * v4l-dvb-firmware

I got this error on the afatech and nova dvb-t with online updating..

'Wie weet spreekt niet, wie spreekt weet niet'

Sunray Vu Solo2/DM800SE V2 DVB-S2/C/T T-85 (28e,23e,19e,13e,9e,4e,1w,5w)


Re: af9015 plugin no longer working #10 pieterg

  • PLi® Core member
  • 32,766 posts

+245
Excellent

Posted 1 December 2011 - 20:43

opkg remove v4l-dvb-firmware
(and ignore dependencies if necessary)

Re: af9015 plugin no longer working #11 zork_nl

  • Member
  • 7 posts

0
Neutral

Posted 22 January 2012 - 16:28

When downloading:
http://downloads.pli...-r3_mipsel.ipk. (taken from the post of Happysat)

it seems that the received file is empty. I suppose that is why I encounter problems installing an AF9015?
Does someone who really knows can check this? :-)

Regards,

Erik.

Re: af9015 plugin no longer working #12 javier3034

  • Senior Member
  • 54 posts

+1
Neutral

Posted 23 January 2012 - 12:18

For af-9015:
Menu-Setup-Software-management-Advanced Options-PacketManager, search and install this (the list is in alphabetical ordre:

- firmware-dvb-usb-af9015
- kernel-module-dvb-usb-af9015 (this install all (11) drivers needed modules dependencies,

FTP to /etc/modutils, edit with a unix-linux editor, the file "dvb-usb.af9015" and paste this and like this:

mxl5007t
mxl5005s
mc44s803
mt2060
qt1010
af9013
dvb-pll
tda18271
tda18218
dvb-usb
dvb-usb-af9015


Save this file,


FTP at /etc/ and edit the file "modules", loock if this lines exist:

### update-modules: start processing /etc/modutils/dvb-usb-af9015
dvb-usb-af9015

### update-modules: end processing /etc/modutils/dvb-usb-af9015


If if exist or not, copy or modifi this and like this:

### update-modules: start processing /etc/modutils/dvb-usb-af9015
mxl5007t
mxl5005s
mc44s803
mt2060
qt1010
af9013
dvb-pll
tda18271
tda18218
dvb-usb
dvb-usb-af9015

### update-modules: end processing /etc/modutils/dvb-usb-af9015


Save this file,

Plug your usb-dtt and restart the box.

The usb-dtt af9015 work.

The same steps for needed kernel drivers for others usb-dtt.


@pieterg

this a list of needed drivers for a different usb-dtt chips, all needed are in the repository I say after:

dvb-a867)
dvb-usb.ko
dvb-a867.ko

dvb-as102)
dvb-usb.ko
dvb-as102.ko

b2c2-flexcop-usb)
s5h1420.ko
mt352.ko
itd1000.ko
bcm3510.ko
stv0297.ko
nxt200x.ko
isl6421.ko
cx24113.ko
mt312.ko
cx24123.ko
lgdt330x.ko
stv0299.ko
b2c2-flexcop.ko
tuner-types.ko
tuner-simple.ko
dvb-pll.ko
sleep 2
b2c2-flexcop-usb.ko
;;
dvb-usb-a800)
mt2060.ko
dibx000_common.ko
dib3000mc.ko
dvb-usb.ko
dvb-pll.ko
dvb-usb-dibusb-common.ko
sleep 2
dvb-usb-a800.ko
;;
dvb-usb-af9005)
qt1010.ko
mt2060.ko
dvb-usb.ko
sleep 2
dvb-usb-af9005.ko
;;
dvb-usb-af9015)
mxl5007t.ko
mxl5005s.ko
mc44s803.ko
mt2060.ko
qt1010.ko
af9013.ko
dvb-pll.ko
tda18271.ko
tda18218.ko
dvb-usb.ko
sleep 2
dvb-usb-af9015.ko
;;
dvb-usb-af9035)
mxl5007t.ko
af9033.ko
dvb-pll.ko
tua9001.ko
tda18218.ko
dvb-usb.ko
sleep 2
dvb-usb-af9035.ko
;;
dvb-usb-anysee)
mt352.ko
dvb-pll.ko
tda10023.ko
zl10353.ko
dvb-usb.ko
sleep 2
dvb-usb-anysee.ko
;;
dvb-usb-au6610)
zl10353.ko
qt1010.ko
dvb-usb.ko
sleep 2
dvb-usb-au6610.ko
;;
dvb-usb-az6027)
stb6100.ko
stb0899.ko
dvb-usb.ko
sleep 2
dvb-usb-az6027.ko
;;
dvb-usb-ce6230)
mxl5005s.ko
zl10353.ko
dvb-usb.ko
sleep 2
dvb-usb-ce6230.ko
;;
dvb-usb-cinergyT2)
dvb-usb.ko
sleep 2
dvb-usb-cinergyT2.ko
;;
dvb-usb-cxusb)
atbm8830.ko
lgs8gxx.ko
mt352.ko
dvb-pll.ko
tuner-xc2028.ko
max2165.ko
mxl5005s.ko
zl10353.ko
lgdt330x.ko
cx2270
tuner-types.ko
tuner-simple.ko
dibx000-common.ko
dib0070.ko
dib7000p.ko
dvb-usb.ko
sleep 2
dvb-usb-cxusb.ko
;;
dvb-usb-dib0700)
mt2266.ko
tuner-xc2028.ko
mxl5007t.ko
xc5000.ko
s5h1411.ko
mt2060.ko
lgdt3305.ko
dibx000_common.ko
dib7000p.ko
dib0090.ko
dib7000m.ko
dib0070.ko
dib8000.ko
dib3000mc.ko
dvb-usb.ko
sleep 2
dvb-usb-dib0700.ko
;;
dvb-usb-dibusb-mb)
mt2060.ko
dibx000_common.ko
dib3000mc.ko
dib3000mb.ko
dvb-usb.ko
dvb-pll.ko
dvb-usb-dibusb-common.ko
sleep 2
dvb-usb-dibusb-mb.ko
;;
dvb-usb-dibusb-mc)
mt2060.ko
dibx000_common.ko
dib3000mc.ko
dvb-pll.ko
dvb-usb.ko
dvb-usb-dibusb-common.ko
sleep 2
dvb-usb-dibusb-mc.ko
;;
dvb-usb-digitv)
nxt6000.ko
mt352.ko
dvb-pll.ko
dvb-usb.ko
sleep 2
dvb-usb-digitv.ko
;;
dvb-usb-dtt200u)
dvb-usb.ko
dvb-usb-dtt200u.ko
;;
dvb-usb-dtv5100)
zl10353.ko
qt1010.ko
dvb-usb.ko
sleep 2
dvb-usb-dtv5100.ko
;;
dvb-usb-dw2102)
stv6110.ko
stb6100.ko
cx24116.ko
tda10023.ko
stb6000.ko
ds3000.ko
si21xx.ko
mt312.ko
stv0900.ko
zl10039.ko
st0299.ko
stv0288.ko
dvb-usb.ko
dvb-pll.ko
sleep 2
dvb-usb-dw2102.ko
;;
dvb-usb-ec168)
mxl5005s.ko
ec100.ko
dvb-usb.ko
sleep 2
dvb-usb-ec168.ko
;;
dvb-usb-friio)
dvb-usb.ko
sleep 2
dvb-usb-friio.ko
;;
dvb-usb-gl861)
zl10353.ko
qt1010.ko
dvb-usb.ko
sleep 2
dvb-usb-gl861.ko
;;
dvb-usb-gp8psk)
dvb-usb.ko
sleep 2
dvb-usb-gp8psk.ko
;;
dvb-usb-m920x)
mt352.ko
tda1004x.ko
tda827x.ko
qt1010.ko
tuner-types.ko
tuner-simple.ko
dvb-usb.ko
sleep 2
dvb-usb-m920x.ko
;;
dvb-usb-nova-t-usb2)
mt2060.ko
dibx000_common.ko
dib3000mc.ko
dvb-usb.ko
dvb-pll.ko
dvb-usb-dibusb-common.ko
sleep 2
dvb-usb-nova-t-usb2.ko
;;
dvb-usb-opera)
stv0299.ko
dvb-usb.ko
dvb-pll.ko
sleep 2
dvb-usb-opera2.ko
;;
dvb-usb-ttusb2)
lnbp21.ko
tda826x.ko
tda10086.ko
tda10023.ko
tda827x.ko
dvb-usb.ko
sleep 2
ddvb-usb-ttusb2.ko
;;
dvb-usb-umt-010)
mt352.ko
mt2060.ko
dibx000-common.ko
dib3000mc.ko
dvb-usb.ko
dvb-pll.ko
dvb-usb-dibusb-common.ko
sleep 2
dvb-usb-umt-010.ko
;;
dvb-usb-vp702x)
dvb-usb.ko
sleep 2
dvb-usb-vp702x.ko
;;
dvb-usb-vp7045)
dvb-usb.ko
sleep 2
dvb-usb-vp7045.ko
;;
smsusb)
smsmdtv.ko
sleep 2
smsdvb.ko
smsusb.ko
;;
dvb-ttusb-budget)
lnbp21.ko
ves1820.ko
tda8083.ko
stv0297.ko
tda1004x.ko
cx22700.ko
stv0299.ko
sleep 2
dvb-ttusb-budget.ko
;;
ttusb-dec)
ttusbdecfe.ko
sleep 2
ttusb-dec.ko
;;
em28xx)
tveeprom.ko
videobuf-core.ko
videobuf-vmalloc.ko
v4l1-compat.ko
v4l2-common.ko
videodev.ko
sleep 2
em28xx.ko


and this is the last firmware of af9015 usb-dtt (ver. 5.1), in the repository have ver.4.9:

Attached File  dvb-usb-af9015.rar   7.66KB   237 downloads


Regards

Re: af9015 plugin no longer working #13 javier3034

  • Senior Member
  • 54 posts

+1
Neutral

Posted 23 January 2012 - 12:36

Is not possible edit my last post:

- The "sleep 2" is not needed
- Error of sintax in a name of file to modifi if exist, if not exist create in /etc/modutils, I write "dvb-usb.af9015" and correct name is "dvb-usb-af9015" (whit guion - after "dvb-usb- )

Sorry

Regards

Edited by javier3034, 23 January 2012 - 12:40.


Re: af9015 plugin no longer working #14 Gennar1

  • Senior Member
  • 296 posts

+31
Good

Posted 23 January 2012 - 14:47

Hi javier3034,
thank you very much for your effort in getting the drivers working.
I think the problem of missing dependencies can be solved in the same way it was solved for the ETxx00 family:

http://openpli.org/f...__1#entry233925


the relevant patch, proposed by Skaman, is this one:

etxx00-disable-media-attach.diff
disabling this feature an "hard depency" will be created between the dvb module and the right frontend and tuners. So, when you install a driver (for example kernel-module-dvb-usb-af9035) it will install also af9033 frontend and the tuners modules


Hopefully, this options is available also for the ancient 2.6.18 kernel :P

Pieterg, do you think it may work?

Re: af9015 plugin no longer working #15 pieterg

  • PLi® Core member
  • 32,766 posts

+245
Excellent

Posted 23 January 2012 - 15:25

yes, that will have to be done to make the frontend deps more convenient.
However, the main issue seems to be that old wrapper packages are still requiring v4l-dvb stuff, so looks like we need a clean rebuild on the server.

Edited by pieterg, 23 January 2012 - 15:26.


Re: af9015 plugin no longer working #16 zork_nl

  • Member
  • 7 posts

0
Neutral

Posted 23 January 2012 - 19:29

@javier3034
Thankyou, i'll try this tonight. :-)

Erik.

Re: af9015 plugin no longer working #17 javier3034

  • Senior Member
  • 54 posts

+1
Neutral

Posted 23 January 2012 - 20:26

Thanks at your dear Gennar1, for your explanation.

I think in this case, the problem is that say dear pieterg, the .ipk of the menu-plugins for install the drivers usb-dtt whit all dependencies drivers and he folders ubication, need clean and rebuild becouse the actual .ipk in plugins loock for v4l-dvb-...., and in this momment the new name of drivers don`t have "v4l-".

But in the repositori on manage software, that I write in the post, the .ipk aren good, he iinstall the drivers and all dependencies in the correct folders, but in the etc/modutils, only create de file whit name of bvb-.... and in to this file only the name of driver and not the driver and he drivers dependencies, and not automatic create the lines whit all name of drivers in to the file "modules" in /etc/ and the drivers good installed of manger software, don`t start. Is for this I say the write this manuali.

Another question plis:

I read in another post, the basic closed drivers of bcm..., they create a: /dvb/adapter0/frontend0, denux0,....etc., and /dvb/adapter1/frontend0, demux0, etc., for example for two tuners, one intern and other second extern usb-dtt pluged in the usb, that is true?

Like I say mons ago at dear pieterg in another post, I have a box whit bcm-7325 like VU-solo is a Gigablue-hd-800-solo, like I say have a team working for this box, and in this momment the AAF team make a images for this box and the new Gigablue-hd-800-se.

The first box only have one interior tuner (dvbs2) and in the new box have two tuners dvb-s2 and a second hibrid tuner for dtt/dtc.This Open-AAF image is based in openpli, he structure are the same at opnePli.

If I install the drivers for usb-dtt in the first box (only one interior dvbs2 tuner), when I start the box whit usb-dtt connected, have 2 /dev/misc/vtuner0 and vtuner1, and /dev/dvb/adapter0/ whit all nodes, but in the /dev/dvb/adapter1/ only have one node "frontend0", and usbtunerhelper don´t start becouse don`t have the others nodes "demux0, dvr0",

If I disconnect and connect the usb-dtt, he create all nodes needed in /dev/dvb/adapter1, after this I run manuali the usbtunerhelper and he start good, but not recongice the usb-dtt, if after this I say I restart only de gui, appers the second usb-ddt tuner and have all needed nodes, but when I select a dtt channel, run the spinner and the box stop all time whit the spinner running, need restart the box whit rear electrical swich ON OFF or in telnet whit reboot (the net work).

I have a VU-duo, whit a usb-dtt, I compare the major and minors numbers of nodes and aren the same nunber on the two box,

The image is the same of openpli, but the kernel is 2.6.36, not 3.1.1

Your know watts is the possible problem?

Is the closed bcm-7325 drivers, or is possible the other problem?

Your know a possible test for try plis?

Thank your and regards friends

Re: af9015 plugin no longer working #18 zork_nl

  • Member
  • 7 posts

0
Neutral

Posted 23 January 2012 - 20:56

Ok,

This is not my pizza.
The firmware can be downloaded, but the kernel-module is not available. The only package coming close is v4l-dvb-module etc.... Do i need to have the last one or is the kernel-module package missing? I am using openpli 2.1 3 jan 2012.

Regards and thanks,

Erik.

Re: af9015 plugin no longer working #19 javier3034

  • Senior Member
  • 54 posts

+1
Neutral

Posted 23 January 2012 - 22:09

@zork_nl

whatt box your have?

Re: af9015 plugin no longer working #20 zork_nl

  • Member
  • 7 posts

0
Neutral

Posted 23 January 2012 - 22:19

A DM800

This is where above link is pointing towards a file which is empty when i look at the file (using Windows with 7-Zip)
h**p://downloads.pli-images.org/feeds/openpli-2.1/dm800/mipsel/enigma2-plugin-drivers-dvb-usb-af9015_1.0-r3_mipsel.ipk

regards,


Erik

Edited by zork_nl, 23 January 2012 - 22:23.






Also tagged with one or more of these keywords: usb tuner, dvb-t

1 user(s) are reading this topic

0 members, 1 guests, 0 anonymous users