Jump to content


Photo

Build Script for Openpli Enigma2 on Ubuntu 10.4 32 Bit


  • Please log in to reply
1537 replies to this topic

Re: Build Script for Openpli Enigma2 on Ubuntu 10.4 32 Bit #1521 frankviana

  • Senior Member
  • 340 posts

+2
Neutral

Posted 2 September 2019 - 19:49

I see this error too before press ok

 

[Skin] Processing screen: LanguageWizard
[Skin] Error in screen 'LanguageWizard' widget 'panel': {skin.xml}: Failed to create skincontext (top,8%,*,None) in Context (72,0)+(597,576) : unsupported operand type(s) for -=: 'int' and 'NoneType'. Please contact the skin's author!
[Skin] Error in screen 'LanguageWizard' widget 'panel': {skin.xml}: Failed to create skincontext (bottom,10%,*,None) in Context (72,0)+(597,576) : unsupported operand type(s) for -: 'int' and 'NoneType'. Please contact the skin's author!
warning, skin is missing element wizard in <class 'Screens.LanguageSelection.LanguageWizard'>
selectPic: arrowdown
selectPic: arrowup
[Skin] Processing screen: SimpleSummary
[Skin] Processing screen: Volume
warning, skin is missing element VolumeText in <class 'Screens.Volume.Volume'>
[Skin] Processing screen: Mute
 

 

And this log:

 

Attached File  err.zip   2.47KB   0 downloads


Edited by frankviana, 2 September 2019 - 19:54.

Octagon SX88+, Octagon SX88, Vu Zero (mips) Vu+ Zero 4K (arm), Mecool K1/K2/K3, Azamerica s2010, Nazabox Xgame, TBS 5520se, TBS 5925, TBS 6922se, Openbox X5, Openbox S9, AZBOX TITAN twin, AZBOX Premium+, AZBOX Elite , Raspberry 2/3, Orange pi PC, Coolsat 5000, Dm500s. Motorized dish - 5m (20ºE - 116.8ºW). A lot of plugins...


Re: Build Script for Openpli Enigma2 on Ubuntu 10.4 32 Bit #1522 betacentauri

  • PLi® Core member
  • 5,520 posts

+251
Excellent

Posted 2 September 2019 - 23:45

Seems to be skin issue.
Start with unmodified enigma2. So add no skins and no plugins.
Xtrend ET-9200, ET-8000, ET-10000, OpenPliPC on Ubuntu 12.04

Re: Build Script for Openpli Enigma2 on Ubuntu 10.4 32 Bit #1523 frankviana

  • Senior Member
  • 340 posts

+2
Neutral

Posted 3 September 2019 - 00:09

Seems to be skin issue.
Start with unmodified enigma2. So add no skins and no plugins.

 

How start this way? Any option to choose before start ./enigma ?


Octagon SX88+, Octagon SX88, Vu Zero (mips) Vu+ Zero 4K (arm), Mecool K1/K2/K3, Azamerica s2010, Nazabox Xgame, TBS 5520se, TBS 5925, TBS 6922se, Openbox X5, Openbox S9, AZBOX TITAN twin, AZBOX Premium+, AZBOX Elite , Raspberry 2/3, Orange pi PC, Coolsat 5000, Dm500s. Motorized dish - 5m (20ºE - 116.8ºW). A lot of plugins...


Re: Build Script for Openpli Enigma2 on Ubuntu 10.4 32 Bit #1524 frankviana

  • Senior Member
  • 340 posts

+2
Neutral

Posted 3 September 2019 - 01:31

Now, all ok.

 

I did fresh installation version 7.1 (before, develop version) .

 

 

 

 

 

Thanks

=================

Attached Files


Octagon SX88+, Octagon SX88, Vu Zero (mips) Vu+ Zero 4K (arm), Mecool K1/K2/K3, Azamerica s2010, Nazabox Xgame, TBS 5520se, TBS 5925, TBS 6922se, Openbox X5, Openbox S9, AZBOX TITAN twin, AZBOX Premium+, AZBOX Elite , Raspberry 2/3, Orange pi PC, Coolsat 5000, Dm500s. Motorized dish - 5m (20ºE - 116.8ºW). A lot of plugins...


Re: Build Script for Openpli Enigma2 on Ubuntu 10.4 32 Bit #1525 1455

  • Senior Member
  • 228 posts

+4
Neutral

Posted 3 September 2019 - 08:08

The development version compiles and works without problems also. The scripts do everything right themselves. See compilation logs if any problems exist. Write the logs to the file:

./script_name.sh > LOG 2>&1

Please read README.EN file.



Re: Build Script for Openpli Enigma2 on Ubuntu 10.4 32 Bit #1526 atari

  • Senior Member
  • 27 posts

0
Neutral

Posted 7 September 2019 - 18:11

is it possible to use vtuner in 18.04?

after compiling i get:

XINE_VO_ASPECT_ANAMORPHIC (16:9) !!!!!!!!!!!!!!!!!!!!!!!!!!!!!
Killed
 


Edited by atari, 7 September 2019 - 18:13.


Re: Build Script for Openpli Enigma2 on Ubuntu 10.4 32 Bit #1527 1455

  • Senior Member
  • 228 posts

+4
Neutral

Posted 9 September 2019 - 09:58

Not enough information. There seems to be no difference in the Ubuntu distribution. I don't have vtuner as a physical device. However, searching for "vtuner" on this topic may help. For example, the .ko module may be missing, nim_sockets are not correctly registered.



Re: Build Script for Openpli Enigma2 on Ubuntu 10.4 32 Bit #1528 roxette

  • Senior Member
  • 55 posts

0
Neutral

Posted 5 October 2019 - 00:39

Hi 1455,

 

I have dual tuners connected to enigma2 which creates 2 adapters, the problem is oscam is able to decrypt channels from adapter0.
However, if i want to decrypt channels from adapter1 i just get a black screen.
Any idea?
 
Bdw: enigma2 link in your signature is down.
 


Re: Build Script for Openpli Enigma2 on Ubuntu 10.4 32 Bit #1529 roxette

  • Senior Member
  • 55 posts

0
Neutral

Posted 5 October 2019 - 00:54

vtuner is a virtual tuner which can be used to share your physical tuner over network.
It used to compile in older kernels therefore i don't think you can compile it on 18.04.


Re: Build Script for Openpli Enigma2 on Ubuntu 10.4 32 Bit #1530 1455

  • Senior Member
  • 228 posts

+4
Neutral

Posted 9 October 2019 - 09:08

 

Hi 1455,

 

I have dual tuners connected to enigma2 which creates 2 adapters, the problem is oscam is able to decrypt channels from adapter0.
However, if i want to decrypt channels from adapter1 i just get a black screen.
Any idea?
 
Bdw: enigma2 link in your signature is down.

 

I tried with HVR4000, but there dvb-s2 the first tuner.

Maybe try to trick oscam by swapping in nim_sockets and /dev/dvb?

If it doesn't download, try through vpn. I have no problems with downloading.



Re: Build Script for Openpli Enigma2 on Ubuntu 10.4 32 Bit #1531 1455

  • Senior Member
  • 228 posts

+4
Neutral

Posted 9 October 2019 - 09:17

 

vtuner is a virtual tuner which can be used to share your physical tuner over network.
It used to compile in older kernels therefore i don't think you can compile it on 18.04.

Yes, but that was a long time ago. I will see if there is a driver and whether it can be patched. However, there is a certain device called the same http://www.vtuner.com/ I thought it was a device for PC.

Yes, but that was a long time ago. I will see if there is a driver and whether it can be patched. However there is a certain device called the same: http://www.vtuner.com. I thought it a device for PC.



Re: Build Script for Openpli Enigma2 on Ubuntu 10.4 32 Bit #1532 1455

  • Senior Member
  • 228 posts

+4
Neutral

Posted 9 October 2019 - 09:35

I can transfer the link to Google, but then appears a stuped inscription on this page in the browser "this archive has been uploaded by user from Russia and can be potentially dangerous." :D

That is, I need to make a direct link, which will complicate access to other folders.



Re: Build Script for Openpli Enigma2 on Ubuntu 10.4 32 Bit #1533 roxette

  • Senior Member
  • 55 posts

0
Neutral

Posted 11 October 2019 - 14:24

I tried with HVR4000, but there dvb-s2 the first tuner.

 

 

Maybe try to trick oscam by swapping in nim_sockets and /dev/dvb?

If it doesn't download, try through vpn. I have no problems with downloading.

 

I want to make it work on both adapters not just the 1st adapter

so swapping adapters name in nim_sockets won't solve the problem.  :(

 

Any other thoughts?

 

I already used a vpn to access the download link and it worked.

 

 

 

vtuner is a virtual tuner which can be used to share your physical tuner over network.
It used to compile in older kernels therefore i don't think you can compile it on 18.04.

Yes, but that was a long time ago. I will see if there is a driver and whether it can be patched. However, there is a certain device called the same 

Yes, but that was a long time ago. I will see if there is a driver and whether it can be patched. However there is a certain device called the same: http://www.vtuner.com. I thought it a device for PC.

 

 

Yeah, although vtuner is very old, since nobody9 build script but it's very useful.

I was no interested to compile it at all but i recently did, i want to tell you that you must have it   :D

 

1st you install the server where you have the physical tuner

In my case Raspberry pi 3

 

2nd i installed the driver/client on my pc.

 

post-103976-0-51550500-1570799479_thumb.

 

Original tuner name will be vtuner proxy DVB-2, I changed it to look similar to this video

 

https://www.youtube....h?v=WtDnlOWv3wA

 

I also installed satipclient but it doesn't find any server

 

Have you tried it?

 

 

I can transfer the link to Google, but then appears a stuped inscription on this page in the browser "this archive has been uploaded by user from Russia and can be potentially dangerous." :D

That is, I need to make a direct link, which will complicate access to other folders.

 

Yeah, since you are from Russia so you could be uploading scripts that will be coverted to a spying trojan horse after compilation.  :D

 

Use a vpn to fool Google or just don't care about that stupid notice.

Attached Files


Edited by roxette, 11 October 2019 - 14:25.


Re: Build Script for Openpli Enigma2 on Ubuntu 10.4 32 Bit #1534 1455

  • Senior Member
  • 228 posts

+4
Neutral

Posted 15 October 2019 - 08:29

I need time to understand how this works. I will try later. OK? Just now there is no time.



Re: Build Script for Openpli Enigma2 on Ubuntu 10.4 32 Bit #1535 roxette

  • Senior Member
  • 55 posts

0
Neutral

Posted 16 October 2019 - 00:27

I need time to understand how this works. I will try later. OK? Just now there is no time.

 

No problem, take your time.



Re: Build Script for Openpli Enigma2 on Ubuntu 10.4 32 Bit #1536 roxette

  • Senior Member
  • 55 posts

0
Neutral

Posted 17 October 2019 - 15:28

1455,

Is it possible that dvbsoftwareca is attached to adapter0?

If yes, then it explains why oscam doesn't work on adapter1.

It could some other reason, i'm just not sure.



Re: Build Script for Openpli Enigma2 on Ubuntu 10.4 32 Bit #1537 HARRY15

  • Member
  • 11 posts

0
Neutral

Posted 17 October 2019 - 20:38

THANK YOU FOR EFFORT



Re: Build Script for Openpli Enigma2 on Ubuntu 10.4 32 Bit #1538 1455

  • Senior Member
  • 228 posts

+4
Neutral

Posted 18 October 2019 - 11:01

Guys, I’m leaving for 2 weeks tomorrow. B)  Don't be offended, but there is no time now. Just updated status e2 to current.






8 user(s) are reading this topic

0 members, 7 guests, 0 anonymous users


    Bing (1)