Jump to content


Photo

missing tun.ko in OpenPLi-2.1 beta dm800se ?

tun.ko openvpn

  • Please log in to reply
10 replies to this topic

#1 tohn

  • Member
  • 1 posts

0
Neutral

Posted 12 December 2011 - 01:22

Hi!

I cant get OpenVpn 2.1 package working on OpenPLi-2.1-beta-dm800se.

On OpenPLi-2.1-beta for DM500HD and DM7025 it works.

On DM800SE the OpenVpn 2.1 tells
"
Mon Dec 12 01:12:22 2011 Note: Cannot open TUN/TAP dev /dev/net/tun: No such file or directory (errno=2)
Mon Dec 12 01:12:22 2011 Note: Attempting fallback to kernel 2.2 TUN/TAP interface
Mon Dec 12 01:12:22 2011 Cannot allocate TUN/TAP dev dynamically
"
And I cant find any tun.ko as on DM500HD and DM7025

Is it missing in dm800se or is it somthing I have misst in the configuration ?

/tohn

Re: missing tun.ko in OpenPLi-2.1 beta dm800se ? #2 kleinerjunge

  • Senior Member
  • 167 posts

+1
Neutral

Posted 3 January 2012 - 20:24

Same problem here!

Any news???

cu
KJ

Re: missing tun.ko in OpenPLi-2.1 beta dm800se ? #3 hemispherical1

  • Senior Member
  • 1,596 posts

+49
Good

Posted 3 January 2012 - 22:34

I don't know about 800se, but running "opkg list" on the 800 shows:

kernel-module-tun - 2.6.18-r6+git3+ac6cc9511a5f70eaa584c63fc5c3de33cae1d0e7.1 - tun kernel module; Universal TUN/TAP device driver

... as an available package for install...

--
hemi

Re: missing tun.ko in OpenPLi-2.1 beta dm800se ? #4 kleinerjunge

  • Senior Member
  • 167 posts

+1
Neutral

Posted 4 January 2012 - 02:00

Hi!

Yes, and for DM800se it is missing, unfortunately.

But I got it from elsewhere and installed it in PLI image on my DM800se. Additionally I also got newer OpenVPN-Version and liblzo2-2, which is also needed.

I think we all would appreciate it if PLI Team could integrate those packages in their future releases. Thx.

cu
KJ

Attached Files



Re: missing tun.ko in OpenPLi-2.1 beta dm800se ? #5 nrg17

  • Member
  • 6 posts

0
Neutral

Posted 26 June 2017 - 10:47

I'm searching for tun.ko openpli4 dm800hd. Where i can found it?



Re: missing tun.ko in OpenPLi-2.1 beta dm800se ? #6 mimisiku

  • Senior Member
  • 4,330 posts

+86
Good

Posted 26 June 2017 - 12:16

Really? Replying to a posting from 2012 :) :)
OpenPli 2.1 is obsolete as are the boxes still using them. Fork out €139 / €159 and get a nice fully original DM520/525/525 Combo
Runs on the latest firmware and will do everything OpenPli 2.1 could (and much much more)
Met één been in het graf..... Helaas

Re: missing tun.ko in OpenPLi-2.1 beta dm800se ? #7 nrg17

  • Member
  • 6 posts

0
Neutral

Posted 26 June 2017 - 13:33

... it's a challenge ... and why change if work? :)

it's a challenge



Re: missing tun.ko in OpenPLi-2.1 beta dm800se ? #8 mrvica

  • Senior Member
  • 1,026 posts

+67
Good

Posted 26 June 2017 - 14:02

here you are

Attached Files

  • Attached File  tun.zip   6.65KB   36 downloads


Re: missing tun.ko in OpenPLi-2.1 beta dm800se ? #9 nrg17

  • Member
  • 6 posts

0
Neutral

Posted 26 June 2017 - 14:24

here you are

Thank's, i try it!



Re: missing tun.ko in OpenPLi-2.1 beta dm800se ? #10 nrg17

  • Member
  • 6 posts

0
Neutral

Posted 27 June 2017 - 08:56

here you are

Don't work... when i start openvpn i receive error  ERROR: Cannot open TUN/TAP dev /dev/net/tun: No such device (errno=19) Exiting due to fatal error.

I try

 

root@dm800:~# modprobe tun
modprobe: ERROR: could not insert 'tun': Exec format error
 
and
 
root@dm800:~# insmod /lib/modules/2.6.18-7.4-dm800/kernel/drivers/net/tun.ko
insmod: ERROR: could not insert module /lib/modules/2.6.18-7.4-dm800/kernel/drivers/net/tun.ko: Invalid module format
 

Edited by nrg17, 27 June 2017 - 08:58.


Re: missing tun.ko in OpenPLi-2.1 beta dm800se ? #11 nrg17

  • Member
  • 6 posts

0
Neutral

Posted 27 June 2017 - 09:28

with dmesg 

 

[  317.359000] tun: version magic '2.6.12-5.1-brcmstb-dm800 gcc-4.1' should be '2.6.18-7.4-dm800 mod_unload MIPS32_R1 32BIT gcc-4.9'




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users