Jump to content


Photo

[et9x00] progressbar in EMC and CoolTvGuide with new kernel and new drivers not correct


  • Please log in to reply
23 replies to this topic

#1 Pike_Bishop

  • Senior Member
  • 982 posts

+42
Good

Posted 15 February 2012 - 17:04

Hi Pli Team,

with the new kernel-3.2.2 and the new drivers all users they used emc and/or cool tv guide have a problem with the progressbar
you can ses it in the pictures which i attached.

thanks for reply

regards
Biki3

Attached Files


Receiver: Mutant HD 2400, VU Ultimo 4k

Image: PLI 7.2


Re: [et9x00] progressbar in EMC and CoolTvGuide with new kernel and new drivers not correct #2 pieterg

  • PLi® Core member
  • 32,766 posts

+245
Excellent

Posted 15 February 2012 - 17:07

It is not likely to be related to kernel or driver updates, rather some recent listbox renderer modifications.
What makes you conclude it was caused by the kernel update?

Re: [et9x00] progressbar in EMC and CoolTvGuide with new kernel and new drivers not correct #3 Pike_Bishop

  • Senior Member
  • 982 posts

+42
Good

Posted 15 February 2012 - 19:19

Hi pieterg,

thanks for reply.

What makes you conclude it was caused by the kernel update?

before kernel update and driver update it was all ok with progressbar in EMC and Cool Tv Guide.
maybe it's not caused by kernel or drivers but then it must caused by an other update at the same time
as the new kernel and drivers are coming.


regards
Biki3

Edited by Biki3, 15 February 2012 - 19:21.

Receiver: Mutant HD 2400, VU Ultimo 4k

Image: PLI 7.2


Re: [et9x00] progressbar in EMC and CoolTvGuide with new kernel and new drivers not correct #4 Qu@rk

  • Senior Member
  • 95 posts

+1
Neutral

Posted 16 February 2012 - 09:42

Thanks Biki3 for adressing this problem in PLi forum. Great work, with screenshots etc.

The problem was already caused by an PLi update before kernel 3.2.2.

I did not change anything in my system regarding plugins or skins and after a PLi update at Thursday 9th Feb. or Friday 10th Feb. the progress bar problem occurred. And this was before kernel 3.2.2 that came at the weekend I think.

Many users of Coolman's EMC and CoolTVGuide reported this problem that progress bars (recordings at EMC or broadcasts at CoolTVGuide) always show 100%. If you select the list entry, the progress bar changes its color and shows the correct value.

Edited by Qu@rk, 16 February 2012 - 09:46.


Re: [et9x00] progressbar in EMC and CoolTvGuide with new kernel and new drivers not correct #5 Frogman

  • Senior Member
  • 389 posts

+68
Good

Posted 20 February 2012 - 08:50

Anything new concerning the commit which causes this phenomena?

@pieterg:
You told something about listbox renderer modifications. Which of them do you mean?

Thanks for looking to this :) - this plugins (TVGuide and EMC) are used by a lot of people.
Most problems can be solved simply by a closer look.

Re: [et9x00] progressbar in EMC and CoolTvGuide with new kernel and new drivers not correct #6 littlesat

  • PLi® Core member
  • 53,137 posts

+614
Excellent

Posted 20 February 2012 - 08:55

Why do you need EMC and CoolTVGuide...? Approx. the same functionality is simply included in PLi...

I suggest that these plugins are not compatible with the changes of elistbox.cpp. But is is very rare that this might be related... (then these plugins do rare programming).

http://openpli.git.s...f5b7bada7eef688

Edited by littlesat, 20 February 2012 - 09:01.

WaveFrontier 28.2E | 23.5E | 19.2E | 16E | 13E | 10/9E | 7E | 5E | 1W | 4/5W | 15W


Re: [et9x00] progressbar in EMC and CoolTvGuide with new kernel and new drivers not correct #7 Frogman

  • Senior Member
  • 389 posts

+68
Good

Posted 20 February 2012 - 11:15

It's not a question of need :) - and it doesn't make any difference whether i use it or not.
Enigma2 is very attractive due to it's possibility to integrate functions of plugins. And this means not only new functions but also those which are solved by plugins in a more convenient way - but this is purely a matter of taste.
In this case the plugins do their job in different E2-based images, also in OpenPLi. Unfortunately a change in PLi causes this effect so it would be nice if some experts can have a look at this...

Edited by Steffen, 20 February 2012 - 11:16.

Most problems can be solved simply by a closer look.

Re: [et9x00] progressbar in EMC and CoolTvGuide with new kernel and new drivers not correct #8 littlesat

  • PLi® Core member
  • 53,137 posts

+614
Excellent

Posted 20 February 2012 - 11:21

Do you have sources of these plugins? Without these we're even not able to investigate the reported issue.

Indeed sometimes something could happen that plugins do not work anymore...

I remember I fixed shoutcast plugin last week. It used a strange way to do the menu button... via the timeset function of the graphical EPG.... after we swapped to the blue button with the config in the graphical EPG... Shoutcast has nothing to do with graphical EPG - but because shoutcast did use strange keymappings it had an effect on shoutcast...

Approx. the same could happen now with these two plugins.... Without sources - no fix - and still based on something stupid in the plugin itself....

I would still recommend to report this to the creators of the CoolEPGGuide and EMC so they could make/investigate the fix.

Edited by littlesat, 20 February 2012 - 11:29.

WaveFrontier 28.2E | 23.5E | 19.2E | 16E | 13E | 10/9E | 7E | 5E | 1W | 4/5W | 15W


Re: [et9x00] progressbar in EMC and CoolTvGuide with new kernel and new drivers not correct #9 Pale-Rider

  • Senior Member
  • 126 posts

+6
Neutral

Posted 20 February 2012 - 12:34

These plugins are closed source unfortunatly.

Re: [et9x00] progressbar in EMC and CoolTvGuide with new kernel and new drivers not correct #10 littlesat

  • PLi® Core member
  • 53,137 posts

+614
Excellent

Posted 20 February 2012 - 13:54

:(

WaveFrontier 28.2E | 23.5E | 19.2E | 16E | 13E | 10/9E | 7E | 5E | 1W | 4/5W | 15W


Re: [et9x00] progressbar in EMC and CoolTvGuide with new kernel and new drivers not correct #11 Pr2

  • PLi® Contributor
  • 4,691 posts

+194
Excellent

Posted 20 February 2012 - 17:25

Hi,

Why don't you send an email describing the problem to the e-mail mentioned in the window when you save your settings (paypal account).

Pr2

NO SUPPORT by PM, it is a forum make your question public so everybody can benefit from the question/answer.
If you think that my answer helps you, you can press the up arrow in bottom right of the answer.

Wanna help with OpenPLi Translation? Please read our Wiki Information for translators

Sat: Hotbird 13.0E, Astra 19.2E, Eutelsat5A 5.0W
VU+ Solo 4K: 2*DVB-S2 + 2*DVB-C/T/T2 (used in DVB-C) & Duo 4K: 2*DVB-S2X + DVB-C (FBC)
Edision OS Mio 4K: 1*DVB-S2X + 1*DVB-C/T/T2
 


Re: [et9x00] progressbar in EMC and CoolTvGuide with new kernel and new drivers not correct #12 Frogman

  • Senior Member
  • 389 posts

+68
Good

Posted 20 February 2012 - 19:03

I know the author and i talked to him. He point of view is that he wants to keep the plugin compatible to almost all images - what was realized until the change in PLi. So maybe he holds that it's not his part to change the code... :(
Most problems can be solved simply by a closer look.

Re: [et9x00] progressbar in EMC and CoolTvGuide with new kernel and new drivers not correct #13 littlesat

  • PLi® Core member
  • 53,137 posts

+614
Excellent

Posted 20 February 2012 - 19:58

All other progressbars are working.... so..... and without sources we cannot do a nothing...

Edited by littlesat, 20 February 2012 - 19:59.

WaveFrontier 28.2E | 23.5E | 19.2E | 16E | 13E | 10/9E | 7E | 5E | 1W | 4/5W | 15W


Re: [et9x00] progressbar in EMC and CoolTvGuide with new kernel and new drivers not correct #14 Frogman

  • Senior Member
  • 389 posts

+68
Good

Posted 20 February 2012 - 20:14

ok, i will try - maybe we get the code part for progress bar...
Most problems can be solved simply by a closer look.

Re: [et9x00] progressbar in EMC and CoolTvGuide with new kernel and new drivers not correct #15 Pale-Rider

  • Senior Member
  • 126 posts

+6
Neutral

Posted 20 February 2012 - 20:47

Hi,

Why don't you send an email describing the problem to the e-mail mentioned in the window when you save your settings (paypal account).

Pr2


We already did on behalf of ViX his stance was as far as he was concearned the problem lied with the image ViX / Pli and it was not his to fix.

I know the author and i talked to him. He point of view is that he wants to keep the plugin compatible to almost all images - what was realized until the change in PLi. So maybe he holds that it's not his part to change the code... :(



well i respect that he wants to keep his source closed however if he is unwilling to fix his plugins to work with pli and other images such as ViX we cant very well do any thing about it can we ?.

Edited by pheonix-vix, 20 February 2012 - 20:48.


Re: [et9x00] progressbar in EMC and CoolTvGuide with new kernel and new drivers not correct #16 Pike_Bishop

  • Senior Member
  • 982 posts

+42
Good

Posted 22 February 2012 - 21:03

Hi littlesat,

All other progressbars are working.... so..... and without sources we cannot do a nothing...

thanks for your help, can you tell me other plugins with progressbar -> Coolman need it to compare so maybe this helps to fix the problem
in EMC and Cool TV Guide.

regards
Biki3

Receiver: Mutant HD 2400, VU Ultimo 4k

Image: PLI 7.2


Re: [et9x00] progressbar in EMC and CoolTvGuide with new kernel and new drivers not correct #17 daddelfalk

  • Senior Member
  • 489 posts

+17
Neutral

Posted 23 February 2012 - 08:23

Hi,

issue on EMC ProgressBar should be related on this ones: Author should consider to change his sources to fit for the new declarations and progress_pixmap type

http://openpli.git.s...8a9f9eaa54dd182

http://openpli.git.s...8a9f9eaa54dd182

All:

http://openpli.git.s...be5b822a68c4983


At least attribute foreColorSelected is missing on EMC Code.

Edited by daddelfalk, 23 February 2012 - 08:41.


Re: [et9x00] progressbar in EMC and CoolTvGuide with new kernel and new drivers not correct #18 littlesat

  • PLi® Core member
  • 53,137 posts

+614
Excellent

Posted 23 February 2012 - 08:42

I think you can be right daddelfalk....

WaveFrontier 28.2E | 23.5E | 19.2E | 16E | 13E | 10/9E | 7E | 5E | 1W | 4/5W | 15W


Re: [et9x00] progressbar in EMC and CoolTvGuide with new kernel and new drivers not correct #19 daddelfalk

  • Senior Member
  • 489 posts

+17
Neutral

Posted 23 February 2012 - 08:46

Hi,

yes i think it, too, as the issues descpitions matches to the pli code-changes ;)

Now it's up to the EMC-Author to adjust his code. It's an easy practise so far...

Edited by daddelfalk, 23 February 2012 - 08:47.


Re: [et9x00] progressbar in EMC and CoolTvGuide with new kernel and new drivers not correct #20 Coolman

  • Member
  • 25 posts

+13
Neutral

Posted 23 February 2012 - 23:37

Hi,

here are the Fix...

hope it works :)

Attached Files






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users