Jump to content


Photo

djmount on DM600PVR

dm600 dlna upnp djmount fuse

  • Please log in to reply
1 reply to this topic

#1 tornblad

  • Member
  • 1 posts

0
Neutral

Posted 26 February 2012 - 09:18

Hello!

I've built the openpli image for DM600PVR and installed it on my box, after that I used IPKG to install the extra packages that was created for FUSE, DJMOUNT and LIBUPNP3. The startup scripts does not give any error, but it does not work. If I start DJMOUNT manualy in foreground i got the errors below. Also attached some info that i've seen they asked for when i Googled around. Anyone that have any ideas?


root@dm600pvr ~ # djmount -d -f /mnt/upnp/
[D] Fuse option = -d
[D] Debug options = debug,fuse,leak
[D] Fuse option = /mnt/upnp/
[D] Fuse option = -r
[D] Fuse option = -o
[D] Fuse option = readdir_ino
[I] Charset : successfully initialised charset='ANSI_X3.4-1968'
[D] Fuse option = -f
[D] Intializing UPnP with ipaddress=(null) port=0
[I] UPnP Initialized (192.168.1.73:49152)
[D] Registering Control Point
[D] Control Point Registered
[D] RefreshAll target=urn:schemas-upnp-org:service:ContentDirectory:1
fuse: device not found, try 'modprobe fuse' first
[E] Error in FUSE main loop = 1
[D] Shutting down ...
root@dm600pvr ~ # lsmod
Module Size Used by Tainted: P
fuse 48308 0 - Live 0xc508f000
head 451632 15 - Live 0xc50bc000
root@dm600pvr ~ # modprobe fuse

root@dm600pvr ~ # djmount -d -f /mnt/upnp/
[D] Fuse option = -d
[D] Debug options = debug,fuse,leak
[D] Fuse option = /mnt/upnp/
[D] Fuse option = -r
[D] Fuse option = -o
[D] Fuse option = readdir_ino
[I] Charset : successfully initialised charset='ANSI_X3.4-1968'
[D] Fuse option = -f
[D] Intializing UPnP with ipaddress=(null) port=0
[I] UPnP Initialized (192.168.1.73:49152)
[D] Registering Control Point
[D] Control Point Registered
[D] RefreshAll target=urn:schemas-upnp-org:service:ContentDirectory:1
fuse: device not found, try 'modprobe fuse' first
[E] Error in FUSE main loop = 1
[D] Shutting down ...
root@dm600pvr ~ # cat /proc/fs/
/proc/fs/cifs/ /proc/fs/nfsd/

root@dm600pvr ~ # cat /proc/filesystems
nodev sysfs
nodev rootfs
nodev bdev
nodev proc
nodev sockfs
nodev pipefs
nodev futexfs
nodev tmpfs
nodev eventpollfs
nodev devpts
reiserfs
ext3
nodev ramfs
vfat
iso9660
nodev devfs
nodev nfs
nodev smbfs
nodev cifs
nodev jffs2
nodev rpc_pipefs
nodev fuse
fuseblk
nodev fusectl

root@dm600pvr ~ # cat /proc/mounts
rootfs / rootfs rw 0 0
/dev/root / jffs2 rw,noatime 0 0
none /dev devfs rw 0 0
proc /proc proc rw,nodiratime 0 0
sysfs /sys sysfs rw 0 0
devpts /dev/pts devpts rw 0 0
/dev/mtdblock/2 /boot jffs2 ro,noatime 0 0
tmpfs /var tmpfs rw 0 0
tmpfs /tmp tmpfs rw 0 0
/dev/ide/host0/bus0/target0/lun0/part1 /media/hdd ext3 rw 0 0
192.168.1.5:/nfs /media/nas nfs rw,v3,rsize=32768,wsize=32768,hard,udp,lock,addr=192.168.1.5 0 0
root@dm600pvr ~ # cat /proc/modules
fuse 48308 0 - Live 0xc508f000
head 451632 15 - Live 0xc50bc000
root@dm600pvr ~ # ls /proc/fs
cifs/ nfsd/

Re: djmount on DM600PVR #2 dAF2000

  • Forum Moderator
    PLi® Core member
  • 14,149 posts

+52
Good

Posted 26 February 2012 - 16:13

Welcome on the forum.

Did you install the ipk's from the feed? (so not ipk files downloaded somewhere)
For some reason fuse is not recognized, but I never tried this before.
Many answers to your question can be found in our wiki: http://openpli.org/wiki





Also tagged with one or more of these keywords: dm600, dlna, upnp, djmount, fuse

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users