Jump to content


Photo

New Kernel - Problems mounting ntfs partitons


  • Please log in to reply
24 replies to this topic

#1 kleinerjunge

  • Senior Member
  • 167 posts

+1
Neutral

Posted 8 April 2012 - 15:07

Hi!

After today's update i am not able to mount ntfs partitions (different hdd's) on my et6000.

Giving "init 4" via console an starting enigma2 manually, I noticed that box freezes at message "[Harddisk] enumerating block devices...".

Can someone confirm that issue?

cu
KJ

Re: New Kernel - Problems mounting ntfs partitons #2 kalehrl

  • Senior Member
  • 398 posts

+6
Neutral

Posted 8 April 2012 - 19:10

I can confirm it.
I just tried to attach my 2TB usb hdd with ntfs and fat32 partitions and the box hangs and the spinners appear.
The mount command shows that both partitions were successfully mounted:
/dev/sda2 on /media/sda2 type vfat (rw,relatime,fmask=0000,dmask=0000,allow_utime=0022,codepage=cp437,iocharset=iso8859-1,shortname=mixed,errors=remount-ro)
/dev/sda1 on /media/sda1 type fuseblk (rw,relatime,user_id=0,group_id=0,allow_other,blksize=4096)
But I can't use ftp to go to /media/sda1 or /media/sda2.
Total commander won't connect.
I also had to do init 4 and init 3 to recover.

Re: New Kernel - Problems mounting ntfs partitons #3 MiLo

  • PLi® Core member
  • 13,873 posts

+290
Excellent

Posted 8 April 2012 - 19:37

Seems that ntfs-3g no longer co-operates with the new kernel. No idea what's going on there, tried recompiling it but that didn't help.

As a workaround, you can remove ntfs-3g using
opkg remove --force-depends ntfs-3g

This will fall back on the kernel's built in NTFS support, which is read-only, but appears to work.

You could also remove the "ntfs-3g" line from /etc/filesystems, that would give the built-in driver priority.

Edited by MiLo, 8 April 2012 - 19:38.

Real musicians never die - they just decompose

Re: New Kernel - Problems mounting ntfs partitons #4 kalehrl

  • Senior Member
  • 398 posts

+6
Neutral

Posted 9 April 2012 - 08:11

You could also remove the "ntfs-3g" line from /etc/filesystems, that would give the built-in driver priority.


I did this, rebooted, attached my usb hdd with ntfs and fat32 partitions but only fat32 one is mounted.
Ntfs partition cannot be seen, it is not mounted at all.

Re: New Kernel - Problems mounting ntfs partitons #5 MiLo

  • PLi® Core member
  • 13,873 posts

+290
Excellent

Posted 9 April 2012 - 08:57

Probably the kernel module isn't installed, run:

opkg install kernel-module-ntfs

Real musicians never die - they just decompose

Re: New Kernel - Problems mounting ntfs partitons #6 markerc

  • Member
  • 4 posts

0
Neutral

Posted 9 April 2012 - 16:15

Hey Milo,

the problem persists.

With "opkg install kernel-module-ntfs" HDD folder iss empty....,but it will boot with an attached hard drive NTFS

Re: New Kernel - Problems mounting ntfs partitons #7 kaneguru

  • Senior Member
  • 198 posts

+1
Neutral

Posted 9 April 2012 - 16:24

also by me.

UUID=4df9243e-b5f1-4be0-8a15-aa4e72e37bc8 /media/sdb1 auto defaults 0 0 didn´t work

/dev/sda2 on /media/sdb1 type ext4 (rw,relatime,barrier=1,data=ordered)
/dev/sdb1 on /media/sdb1 type vfat (rw,relatime,fmask=0000,dmask=0000,allow_utim


root@et9x00:~# mount /dev/sdb1 /media/usb
ntfs-3g: Failed to access volume '/dev/sdb1': No such file or directory

ntfs-3g 2012.1.15 integrated FUSE 27 - Third Generation NTFS Driver
Configuration type 1, XATTRS are on, POSIX ACLS are off

Copyright © 2005-2007 Yura Pakhuchiy
Copyright © 2006-2009 Szabolcs Szakacsits
Copyright © 2007-2011 Jean-Pierre Andre
Copyright © 2009 Erik Larsson

Usage: ntfs-3g [-o option[,...]] <device|image_file> <mount_point>

Options: ro (read-only mount), remove_hiberfile, uid=, gid=,
umask=, fmask=, dmask=, streams_interface=.
Please see the details in the manual (type: man ntfs-3g).

Example: ntfs-3g /dev/sda1 /mnt/windows

News, support and information: http://tuxera.com
mount: mounting /dev/sdb1 on /media/usb failed: No such file or directory

Edited by kaneguru, 9 April 2012 - 16:27.

1. VU+ Ultimo VTi5.0 Samsung LCD
2. ET 9000 PLi3.0 Samsung LCD

Wavefrontier 0,8°-4,8°-9°-13°-19,2°-23°-28°

Re: New Kernel - Problems mounting ntfs partitons #8 daddelfalk

  • Senior Member
  • 489 posts

+17
Neutral

Posted 9 April 2012 - 16:48

Hi guys,

for a simple but bulletproof quickfix/workaround

see here:

http://www.et-view.d...-3-3/#post11751

Just install attached IPK and you are fine agin with accessing ntfs hdd with READ-ONLY access trough kernel driver.


Re: New Kernel - Problems mounting ntfs partitons #9 pieterg

  • PLi® Core member
  • 32,766 posts

+245
Excellent

Posted 9 April 2012 - 16:57

care to enlighten us as to what that magical plugin does?

Re: New Kernel - Problems mounting ntfs partitons #10 MiLo

  • PLi® Core member
  • 13,873 posts

+290
Excellent

Posted 9 April 2012 - 18:28

@kaneguru: Your problem is something totally unrelated to this. From your output I gather that /dev/sdb1 is a FAT partition, not NTFS at all.

The NTFS mounting problem with ntfs-3g and the 3.3 kernel is that the mount succeeds without error, but any attempt to access it (e.g. ls /media/ or so) will result in the mount helper causing a hangup (you can kill the mount.ntfs-3g process to get out of it).

The workaround is to use the kernel module instead of ntfs-3g. If it does not work, you've probably forgotten something else.

Edited by MiLo, 9 April 2012 - 18:31.

Real musicians never die - they just decompose

Re: New Kernel - Problems mounting ntfs partitons #11 pieterg

  • PLi® Core member
  • 32,766 posts

+245
Excellent

Posted 9 April 2012 - 20:22

perhaps

(fuse 2.8.7 ChangeLog)

2011-12-09 Miklos Szeredi <miklos@szeredi.hu>

* Fix hang in wait_on_path(). Reported by Ville Silventoinen



Re: New Kernel - Problems mounting ntfs partitons #12 MiLo

  • PLi® Core member
  • 13,873 posts

+290
Excellent

Posted 10 April 2012 - 19:15

fuse 2.8.7 didn't make a difference.
Real musicians never die - they just decompose

Re: New Kernel - Problems mounting ntfs partitons #13 Dimitrij

  • PLi® Core member
  • 6,477 posts

+209
Excellent

Posted 23 April 2012 - 17:33

root@et9000:~# mount
rootfs on / type rootfs (rw)
ubi0:rootfs on / type ubifs (rw,relatime)
proc on /proc type proc (rw,relatime)
sysfs on /sys type sysfs (rw,relatime)
tmpfs on /media type tmpfs (rw,relatime,size=64k)
tmpfs on /dev type tmpfs (rw,relatime,size=64k,mode=755)
devpts on /dev/pts type devpts (rw,relatime,mode=600)
/dev/sda1 on /media/hdd type ext4 (rw,relatime,barrier=1,data=ordered)
/dev/sdb1 on /media/ba type ext4 (rw,relatime,barrier=1,data=ordered)
/dev/sdc1 on /media/usb type ntfs (ro,relatime,uid=0,gid=0,fmask=0177,dmask=077,nls=iso8859-15,errors=continue,mft_zone_multiplier=1)
usbfs on /proc/bus/usb type usbfs (rw,relatime)
tmpfs on /var/volatile type tmpfs (rw,relatime)
/dev/sdc1 on /media/usb type ntfs(ro,relatime,uid=0,gid=0,fmask=0177,dmask=077,nls=iso8859-15,errors=continue,mft_zone_multiplier=1)
Help :)

Formuler1/VU+solo4k(thanks guys to gisclub.tv)


Re: New Kernel - Problems mounting ntfs partitons #14 Dimitrij

  • PLi® Core member
  • 6,477 posts

+209
Excellent

Posted 24 April 2012 - 05:50

What no one knows the solution :wub: ?

Formuler1/VU+solo4k(thanks guys to gisclub.tv)


Re: New Kernel - Problems mounting ntfs partitons #15 pieterg

  • PLi® Core member
  • 32,766 posts

+245
Excellent

Posted 24 April 2012 - 08:35

indeed, no one even seems to know there is a problem (ntfs-3g has not seen any updates since 2009, I doubt it is being actively maintained)

Re: New Kernel - Problems mounting ntfs partitons #16 Sjaaky

  • Senior Member
  • 7,441 posts

+41
Good

Posted 24 April 2012 - 09:42

It is maintained. The version in our image is from januari 2012.
http://www.tuxera.co...rogs-2012-1-15/

There are quite a lot of commits since the last release. I'll try the newest commit tonight.
http://ntfs-3g.git.s...g/ntfs-3g;a=log

Re: New Kernel - Problems mounting ntfs partitons #17 pieterg

  • PLi® Core member
  • 32,766 posts

+245
Excellent

Posted 24 April 2012 - 10:29

You are right, I was just looking at the wrong website:

http://freecode.com/projects/ntfs-3g

Re: New Kernel - Problems mounting ntfs partitons #18 Sjaaky

  • Senior Member
  • 7,441 posts

+41
Good

Posted 24 April 2012 - 18:56

Newest version has the same problem. Mounting the ntfs partition doesn't complete. The new mountpoint (/media/usb in my case) is registered and visible in /proc/mounts. But the mount.ntfs-3g process doesn't complete. According to strace it blocks while reading /dev/fuse.

Re: New Kernel - Problems mounting ntfs partitons #19 theparasol

  • Senior Member
  • 4,141 posts

+196
Excellent

Posted 24 April 2012 - 20:11

Stupid remark maybe but are rights ok for ntfs-3g user on /dev/fuse?

Edited by theparasol, 24 April 2012 - 20:12.


Re: New Kernel - Problems mounting ntfs partitons #20 pieterg

  • PLi® Core member
  • 32,766 posts

+245
Excellent

Posted 24 April 2012 - 21:20

rights will never cause operations to block, just fail.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users