Jump to content


Photo

D-Link dwa-131 nano USB Wifi

et9x00 wifi

  • Please log in to reply
10 replies to this topic

#1 kooleracer

  • Senior Member
  • 130 posts

+1
Neutral

Posted 15 November 2012 - 14:33

Hoe kan ik deze Wifi werkend krijgen op mijn et9000 met pli 3.0? Als ik hem erin steekt en reboot gebeurt er namelijk niets.

««««««««««««««««««««««««««««««««««««««««««« »»»»»»»»»»»»»»»»»»»»»»»»»»»»»»»»»»»»»»»»»»»»»»



Mut@nt / AX HD51 | Linux  4.7.4 | OpenPLi 4.0


Re: D-Link dwa-131 nano USB Wifi #2 kooleracer

  • Senior Member
  • 130 posts

+1
Neutral

Posted 15 November 2012 - 14:47

topic kan dicht.

««««««««««««««««««««««««««««««««««««««««««« »»»»»»»»»»»»»»»»»»»»»»»»»»»»»»»»»»»»»»»»»»»»»»



Mut@nt / AX HD51 | Linux  4.7.4 | OpenPLi 4.0


Re: D-Link dwa-131 nano USB Wifi #3 Erik Slagter

  • PLi® Core member
  • 45,514 posts

+505
Excellent

Posted 15 November 2012 - 14:54

Doet-ie het nu wel dan?
* Wavefrontier T90 with 28E/23E/19E/13E/9E/4.8E/0.8W/5W via SCR switches 2 x 2 x 6 user bands
* Ziggo digital cable TV (FTA)
I don't read PM -> if you have something to ask or to report, do it in the forum so others can benefit. I don't take freelance jobs.
Ik lees geen PM -> als je iets te vragen of te melden hebt, doe het op het forum, zodat anderen er ook wat aan hebben.

Re: D-Link dwa-131 nano USB Wifi #4 kooleracer

  • Senior Member
  • 130 posts

+1
Neutral

Posted 15 November 2012 - 16:33

Doet-ie het nu wel dan?


Hij deed het net wel, maar nadat ik mijn et9x00 reboote werkt hij opeens niet meer. Wat zijn de juiste stappen om een wifi netwerk op te zetten? hij herkende hem als realtek 8.... chip. Toen kon bij network setup kiezen LAN en WLAN adapter. Maar de optie van WLAN komt nu niet meer.

Edited by kooleracer, 15 November 2012 - 16:35.

««««««««««««««««««««««««««««««««««««««««««« »»»»»»»»»»»»»»»»»»»»»»»»»»»»»»»»»»»»»»»»»»»»»»



Mut@nt / AX HD51 | Linux  4.7.4 | OpenPLi 4.0


Re: D-Link dwa-131 nano USB Wifi #5 Erik Slagter

  • PLi® Core member
  • 45,514 posts

+505
Excellent

Posted 15 November 2012 - 16:50

Maar waarom moet het topic dicht dan?

Grote kans dat er wel degelijk een realtek chip in zit!

Begin eens met de relevante regels uit dmesg hier te posten, net nadat je de stick er in gestopt hebt.
* Wavefrontier T90 with 28E/23E/19E/13E/9E/4.8E/0.8W/5W via SCR switches 2 x 2 x 6 user bands
* Ziggo digital cable TV (FTA)
I don't read PM -> if you have something to ask or to report, do it in the forum so others can benefit. I don't take freelance jobs.
Ik lees geen PM -> als je iets te vragen of te melden hebt, doe het op het forum, zodat anderen er ook wat aan hebben.

Re: D-Link dwa-131 nano USB Wifi #6 kooleracer

  • Senior Member
  • 130 posts

+1
Neutral

Posted 15 November 2012 - 17:10

rtw driver version=v3.3.0_2971.20111128
usbcore: registered new interface driver rtl8192cu
r8712u: module is from the staging directory, the quality is unknown, you have b
een warned.
r8712u: Staging version
r8712u: register rtl8712_netdev_ops to netdev_ops
r8712u: USB_SPEED_HIGH with 4 endpoints
r8712u: Boot from EFUSE: Autoload OK
r8712u: CustomerID = 0x0000
r8712u: MAC Address from efuse = 28:10:7b:bd:d5:65
r8712u: Loading firmware from "rtlwifi/rtl8712u.bin"
usbcore: registered new interface driver r8712u
usbcore: registered new interface driver rt2500usb
usbcore: registered new interface driver rt2800usb
usbcore: registered new interface driver rt73usb
usbcore: registered new interface driver rtl8187
usbcore: registered new interface driver zd1211rw
EXT4-fs (sda1): mounted filesystem with ordered data mode. Opts: (null)
Console: switching to colour dummy device 80x25
r8712u: Firmware request failed
usb 1-1: USB disconnect, device number 2
CPU 0 Unable to handle kernel paging request at virtual address 0000322c, epc ==
e185f56c, ra == e185f56c
Oops[#1]:
Cpu 0
$ 0 : 00000000 10008701 00000000 00000000
$ 4 : cfebde20 00000000 00000000 ffffffff
$ 8 : 00000001 00000001 0000000a 00000080
$12 : 0000015e e0ffffff 00000000 2c746365
$16 : 00000000 cfebde20 cfeb8c68 8034e67c
$20 : 00000000 00000000 80700ec0 cfcf5b01
$24 : 00000000 8034cca8
$28 : cfcea000 cfcebd10 00000000 e185f56c
Hi : 00000004
Lo : 0000006c
epc : e185f56c r871xu_dev_remove+0x54/0x198 [r8712u]
Tainted: GF WC O
ra : e185f56c r871xu_dev_remove+0x54/0x198 [r8712u]
Status: 10008703 KERNEL EXL IE
Cause : 00800008
BadVA : 0000322c
PrId : 0002a044 (Brcm4380)
Modules linked in: zd1211rw rtl8187 rt73usb rt2800usb rt2800lib rt2500usb rt2x00
usb rt2x00lib r8712u© 8192cu(O) ipv6 carl9170 ath9k_htc mac80211 ath9k_common
ath9k_hw ath dvb(OF) modloader2(O) modloader(O) tpm(O)
Process khubd (pid: 18, threadinfo=cfcea000, task=cfc7e958, tls=00000000)
Stack : cfeb4b88 80406678 cfcebd18 cfcebd18 00000000 cfebde20 cfeb8c00 e186925c
cfebde00 00000000 00000000 80407e1c cfebde20 80052c98 80725710 8034e6e8
cfebde20 e186925c 80725710 00000001 cfebde00 8034e774 cfebff80 00000000
00000001 cfebde00 00000000 cfebde54 cfebde20 8034e814 cfed14c8 00000000
00000001 00000000 cfcdbcb0 cfcdbcb0 cfebde20 8034e1cc 00000000 804042f8
...
Call Trace:
[<e185f56c>] r871xu_dev_remove+0x54/0x198 [r8712u]
[<80407e1c>] usb_unbind_interface+0x5c/0x150
[<8034e774>] __device_release_driver+0x60/0xd8
[<8034e814>] device_release_driver+0x28/0x40
[<8034e1cc>] bus_remove_device+0xfc/0x138
[<8034b718>] device_del+0x104/0x194
[<80406774>] usb_disable_device+0xc8/0x220
[<803fda48>] usb_disconnect+0x9c/0x154
[<803feb94>] hub_thread+0x4d0/0x1694
[<8004b210>] kthread+0x90/0x98
[<800073d8>] kernel_thread_helper+0x10/0x18


Code: 2673e67c 0260f809 8e520020 <9202322c> 261503c0 14400041 2654ff98 3c02
805e 244267d8
---[ end trace 4eaa2a86a8e2da24 ]---

Edited by kooleracer, 15 November 2012 - 17:13.

««««««««««««««««««««««««««««««««««««««««««« »»»»»»»»»»»»»»»»»»»»»»»»»»»»»»»»»»»»»»»»»»»»»»



Mut@nt / AX HD51 | Linux  4.7.4 | OpenPLi 4.0


Re: D-Link dwa-131 nano USB Wifi #7 Erik Slagter

  • PLi® Core member
  • 45,514 posts

+505
Excellent

Posted 15 November 2012 - 19:15

Ik zie een paar relevante zaken:

r8712u: module is from the staging directory, the quality is unknown, you have been warned.
..
r8712u: Firmware request failed
..
CPU 0 Unable to handle kernel paging request at virtual address 0000322c, epc ==


De eerste regel zegt dat de driver nog in ontwikkeling is, alfa-kwaliteit zeg maar.

De tweede regel zegt dat hij niet de firmware heeft kunnen vinden die geupload moet worden. Volgens mij heeft pieterg daar zeer recent nog het e.e.a. over uitgelegd, even zoeken maar ;)

De derde is gewoon BOEM. Grote chaos in de kernel, zeer waarschijnlijk door een bug in deze driver.

Ik ben bang dat de chip die op de stick zit gewoon nog net even wat te nieuw is, er is nog geen goede support.
* Wavefrontier T90 with 28E/23E/19E/13E/9E/4.8E/0.8W/5W via SCR switches 2 x 2 x 6 user bands
* Ziggo digital cable TV (FTA)
I don't read PM -> if you have something to ask or to report, do it in the forum so others can benefit. I don't take freelance jobs.
Ik lees geen PM -> als je iets te vragen of te melden hebt, doe het op het forum, zodat anderen er ook wat aan hebben.

Re: D-Link dwa-131 nano USB Wifi #8 kooleracer

  • Senior Member
  • 130 posts

+1
Neutral

Posted 15 November 2012 - 19:16

Ik zie een paar relevante zaken:


r8712u: module is from the staging directory, the quality is unknown, you have been warned.
..
r8712u: Firmware request failed
..
CPU 0 Unable to handle kernel paging request at virtual address 0000322c, epc ==


De eerste regel zegt dat de driver nog in ontwikkeling is, alfa-kwaliteit zeg maar.

De tweede regel zegt dat hij niet de firmware heeft kunnen vinden die geupload moet worden. Volgens mij heeft pieterg daar zeer recent nog het e.e.a. over uitgelegd, even zoeken maar ;)

De derde is gewoon BOEM. Grote chaos in de kernel, zeer waarschijnlijk door een bug in deze driver.

Ik ben bang dat de chip die op de stick zit gewoon nog net even wat te nieuw is, er is nog geen goede support.


Maar ik heb hem werkend gekregen voor 1 uur lang, dan kan het toch niet zijn dat hij opeens niet meer werkt?

««««««««««««««««««««««««««««««««««««««««««« »»»»»»»»»»»»»»»»»»»»»»»»»»»»»»»»»»»»»»»»»»»»»»



Mut@nt / AX HD51 | Linux  4.7.4 | OpenPLi 4.0


Re: D-Link dwa-131 nano USB Wifi #9 Erik Slagter

  • PLi® Core member
  • 45,514 posts

+505
Excellent

Posted 15 November 2012 - 19:19

Dat had je eerder niet gezegd ;)

Het kan nog steeds een bug in de driver zijn. Wanneer had je 'm werkend, was dat afgelopen week of al weer een tijdje geleden? Misschien dat er alweer intussen een nieuwe kernel is met nieuwe bugs ;)
* Wavefrontier T90 with 28E/23E/19E/13E/9E/4.8E/0.8W/5W via SCR switches 2 x 2 x 6 user bands
* Ziggo digital cable TV (FTA)
I don't read PM -> if you have something to ask or to report, do it in the forum so others can benefit. I don't take freelance jobs.
Ik lees geen PM -> als je iets te vragen of te melden hebt, doe het op het forum, zodat anderen er ook wat aan hebben.

Re: D-Link dwa-131 nano USB Wifi #10 kooleracer

  • Senior Member
  • 130 posts

+1
Neutral

Posted 15 November 2012 - 19:26

Ik heb hem vandaag binnen gekregen, om 14:00 werkte hij (blauwe lamp aan en WLAN setup menu aanwezig, met signaal kwaliteit etc) om 15:00 deed ik reboot en toen deed hij het niet meer.

««««««««««««««««««««««««««««««««««««««««««« »»»»»»»»»»»»»»»»»»»»»»»»»»»»»»»»»»»»»»»»»»»»»»



Mut@nt / AX HD51 | Linux  4.7.4 | OpenPLi 4.0


Re: D-Link dwa-131 nano USB Wifi #11 kooleracer

  • Senior Member
  • 130 posts

+1
Neutral

Posted 15 November 2012 - 22:03

hem net OpenVix 3.0 OE geïnstalleerd daar werkt het gewoon vlekkeloos.

««««««««««««««««««««««««««««««««««««««««««« »»»»»»»»»»»»»»»»»»»»»»»»»»»»»»»»»»»»»»»»»»»»»»



Mut@nt / AX HD51 | Linux  4.7.4 | OpenPLi 4.0






Also tagged with one or more of these keywords: et9x00, wifi

1 user(s) are reading this topic

0 members, 1 guests, 0 anonymous users