Jump to content


Photo

Today upgrade make my STB not working

CT9100

  • Please log in to reply
14 replies to this topic

#1 ambrosa

  • Senior Member
  • 161 posts

+35
Good

Posted 16 December 2012 - 14:02

Hi guys.

This morning I've made an "opkg update ; opkg upgrade" in my Clarke Teck 9100
Last upgrade was done by me about 1 month ago.
Since 10 minutes before upgrade, my CT was working very fine.


After upgrading (involving new kernel a new E2 image) and rebooting, my system was broken.


Symptons:

1) I've a DTT USB stick Avermedia A867
USB stick is found by kernel and module is correctly loaded

dmesg:

AVerMedia A867 driver module V1.0.27 loaded.
dvb-usb: found a 'AVerMedia A867 DVB-T Recevier' in warm state.
dvb-usb: will pass the complete MPEG2 transport stream to the software demuxer.
DVB: registering new adapter (AVerMedia A867 DVB-T Recevier)
DVB: registering adapter 0 frontend 0 (A867 USB DVB-T)...
dvb-usb: AVerMedia A867 DVB-T Recevier successfully initialized and connected.
usbcore: registered new interface driver dvb-usb-a867



lsmod:

Module Size Used by
ntfs 117802 0
ipv6 351430 12
dvb 4874979 7
modloader2 32661 1 dvb
modloader 22281 0
tpm 6509 3 dvb,modloader2,modloader
dvb_usb_a867 210137 0
dvb_usb 18026 1 dvb_usb_a867



but in Enigma2 there is no the third tuner DTT. It's disappeared !


2) embedded DVB-S2 tuner are found by kernel

DVB: registering new adapter (dvb0)
DVB: registering adapter 1 frontend 0 (DVB-S2)...
DVB: registering adapter 1 frontend 1 (DVB-S2)...


and into E2 they are configured correctly but OSD say to me:

Service unavailable!
Check tuner configuration!

for all channels.


3) there is a minor error in one plugin:

root@et9x00:~# opkg update
Package enigma2-plugin-systemplugins-autobouquetsmaker version git194+b8c7e01-r25 has no valid architecture, ignoring.

Edited by ambrosa, 16 December 2012 - 14:04.

STB: Clarke Tech ET9100
Mass storage: internal SATA-II HDD 1TB WD10EACS GreenPower 5400rpm
Mass storage: external USB pen drive 2GB
Firmware: OpenPLi kernel 3.x.x
Tuner A: AVL2108 (DVB-S2) HotBird 13E
Tuner B: AVL2108 (DVB-S2) HotBird 13E
Tuner C: AverMedia A867 (DVB-T HD) (AF9035 + MXL5007T)
TV: plasma PANASONIC GT30 fullHD
Audio: PCM through HDMI (no Dolby decoder)

Re: Today upgrade make my STB not working #2 ims

  • PLi® Core member
  • 11,135 posts

+168
Excellent

Posted 16 December 2012 - 14:15

Same was today on my 800se - i made update from GUI - after it no signal on both tuners ( S2 and DVB-T usb). I thought, that it was some my tests... After reflash and restore all work well.
Kdo nic nedělá, nic nezkazí!

Re: Today upgrade make my STB not working #3 theparasol

  • Senior Member
  • 4,141 posts

+196
Excellent

Posted 16 December 2012 - 14:54

Could it be that it has something to do with this: http://openpli.git.s...f497aee9f6bf2ec

Its suggested to users to reflash their boxes otherwise the old glib is still installed

Re: Today upgrade make my STB not working #4 ambrosa

  • Senior Member
  • 161 posts

+35
Good

Posted 16 December 2012 - 18:27

NO SUCCESS

I've just reflash from scratch my CT9100 with OpenPLi-3.0-beta-et9x00-20121216_usb.zip

- flash ok
- initial setup ok
- install A867 kernel module ok

Exactly as before: third tuner (DTT A867) is missing (dmesg is ok as before), Tuner A&B (DVB-S2) correctly configured but same error as before.
Full scan not working: search exit immediately

HyperBUG somewhere.....
STB: Clarke Tech ET9100
Mass storage: internal SATA-II HDD 1TB WD10EACS GreenPower 5400rpm
Mass storage: external USB pen drive 2GB
Firmware: OpenPLi kernel 3.x.x
Tuner A: AVL2108 (DVB-S2) HotBird 13E
Tuner B: AVL2108 (DVB-S2) HotBird 13E
Tuner C: AverMedia A867 (DVB-T HD) (AF9035 + MXL5007T)
TV: plasma PANASONIC GT30 fullHD
Audio: PCM through HDMI (no Dolby decoder)

Re: Today upgrade make my STB not working #5 littlesat

  • PLi® Core member
  • 49,224 posts

+527
Excellent

Posted 16 December 2012 - 18:43

I also had to reflash this morning...

WaveFrontier 28.2E | 23.5E | 19.2E | 16E | 13E | 10/9E | 7E | 5E | 1W | 4/5W | 15W


Re: Today upgrade make my STB not working #6 theparasol

  • Senior Member
  • 4,141 posts

+196
Excellent

Posted 16 December 2012 - 18:47

Do you use autobackup? Perhaps delete autobackup settings and try fresh flash again.
That way you can be absolutely sure that no old / incorrect settings are reapplied.

Re: Today upgrade make my STB not working #7 MiLo

  • PLi® Core member
  • 13,881 posts

+290
Excellent

Posted 16 December 2012 - 18:58

Fix is on the way.
Real musicians never die - they just decompose

Re: Today upgrade make my STB not working #8 theparasol

  • Senior Member
  • 4,141 posts

+196
Excellent

Posted 16 December 2012 - 19:10

Milo is referring to this fix (I presume): http://openpli.git.s...57b006cd27adf87

Re: Today upgrade make my STB not working #9 ambrosa

  • Senior Member
  • 161 posts

+35
Good

Posted 16 December 2012 - 19:11

Thanks Milo.

BTW I've just flash with previous image OpenPLi-3.0-beta-et9x00-20121215_usb.zip (yesterday image) and IT WORKS.

Then I've made just now (19:03 CET) an opkg update + upgrade and then reboot.
System IS WORKING again (??)

Then I've installed A867 kernel module 'opkg install kernel-module-dvb-usb-a867' and reboot.
After that system STOP WORKING as before.

All tuners (DVB-S2 and DTT) stop working after loading A867 kernel module.
STB: Clarke Tech ET9100
Mass storage: internal SATA-II HDD 1TB WD10EACS GreenPower 5400rpm
Mass storage: external USB pen drive 2GB
Firmware: OpenPLi kernel 3.x.x
Tuner A: AVL2108 (DVB-S2) HotBird 13E
Tuner B: AVL2108 (DVB-S2) HotBird 13E
Tuner C: AverMedia A867 (DVB-T HD) (AF9035 + MXL5007T)
TV: plasma PANASONIC GT30 fullHD
Audio: PCM through HDMI (no Dolby decoder)

Re: Today upgrade make my STB not working #10 theparasol

  • Senior Member
  • 4,141 posts

+196
Excellent

Posted 16 December 2012 - 19:18

Try and report again tomorrow with image that contains Milo's fix (as its build this night if everything goes ok for your model of box!)

Re: Today upgrade make my STB not working #11 ambrosa

  • Senior Member
  • 161 posts

+35
Good

Posted 16 December 2012 - 19:19

Milo is referring to this fix (I presume): http://openpli.git.s...57b006cd27adf87


Looks to be fine...

Removing USB modules and reboot, system is working again (only with DVB-S2 tuners obviously)

root@et9x00:~# opkg remove kernel-module-dvb-usb-a867
Removing package kernel-module-dvb-usb-a867 from root...
root@et9x00:~# opkg remove kernel-module-dvb-usb
Removing package kernel-module-dvb-usb from root...

STB: Clarke Tech ET9100
Mass storage: internal SATA-II HDD 1TB WD10EACS GreenPower 5400rpm
Mass storage: external USB pen drive 2GB
Firmware: OpenPLi kernel 3.x.x
Tuner A: AVL2108 (DVB-S2) HotBird 13E
Tuner B: AVL2108 (DVB-S2) HotBird 13E
Tuner C: AverMedia A867 (DVB-T HD) (AF9035 + MXL5007T)
TV: plasma PANASONIC GT30 fullHD
Audio: PCM through HDMI (no Dolby decoder)

Re: Today upgrade make my STB not working #12 ims

  • PLi® Core member
  • 11,135 posts

+168
Excellent

Posted 16 December 2012 - 19:28

now it works well (own build with it).

btw - with this "bug", when was tuned to DVB-USB and reboot, then there was GSOD continualy with:
Traceback (most recent call last):
  File "/usr/lib/enigma2/python/Navigation.py", line 51, in dispatchEvent
  File "/usr/lib/enigma2/python/Components/PerServiceDisplay.py", line 17, in event
  File "/usr/lib/enigma2/python/Components/Sources/CurrentService.py", line 26, in serviceEvent
  File "/usr/lib/enigma2/python/Components/Element.py", line 86, in changed
  File "/usr/lib/enigma2/python/Tools/CList.py", line 7, in __call__
  File "/usr/lib/enigma2/python/Components/Converter/PliExtraInfo.py", line 356, in changed
  File "/usr/lib/enigma2/python/Components/Element.py", line 86, in changed
  File "/usr/lib/enigma2/python/Tools/CList.py", line 7, in __call__
  File "/usr/lib/enigma2/python/Components/Renderer/Label.py", line 21, in changed
  File "/usr/lib/enigma2/python/Components/Element.py", line 15, in wrapper
  File "/usr/lib/enigma2/python/Components/Converter/PliExtraInfo.py", line 241, in getText
  File "/usr/lib/enigma2/python/Tools/Transponder.py", line 32, in ConvertToHumanReadable
TypeError: int() argument must be a string or a number, not 'NoneType'
(PyObject_CallObject(<bound method Navigation.dispatchEvent of <Navigation.Navigation instance at 0x2017508>>,(6,)) failed)

may be, ConvertToHumanReadable could be fixed for return...
Kdo nic nedělá, nic nezkazí!

Re: Today upgrade make my STB not working #13 ambrosa

  • Senior Member
  • 161 posts

+35
Good

Posted 16 December 2012 - 20:03

Do you use autobackup? Perhaps delete autobackup settings and try fresh flash again.
That way you can be absolutely sure that no old / incorrect settings are reapplied.


No, I hate autobackup for the same reasons :-)
STB: Clarke Tech ET9100
Mass storage: internal SATA-II HDD 1TB WD10EACS GreenPower 5400rpm
Mass storage: external USB pen drive 2GB
Firmware: OpenPLi kernel 3.x.x
Tuner A: AVL2108 (DVB-S2) HotBird 13E
Tuner B: AVL2108 (DVB-S2) HotBird 13E
Tuner C: AverMedia A867 (DVB-T HD) (AF9035 + MXL5007T)
TV: plasma PANASONIC GT30 fullHD
Audio: PCM through HDMI (no Dolby decoder)

Re: Today upgrade make my STB not working #14 evagelos

  • Member
  • 45 posts

+1
Neutral

Posted 16 December 2012 - 22:07

Some problem here
After remove usbDTT boot ok but with usbDTT does not boot

Re: Today upgrade make my STB not working #15 ambrosa

  • Senior Member
  • 161 posts

+35
Good

Posted 17 December 2012 - 18:23

Problem solved.

I've just flash my STB with today image (et9x00 2012-12-17) , installed a867 kernel module and all works fine.

Now a867 module is loaded AFTER dvb-s2 frontend

DVB: registering new adapter (dvb0)
DVB: registering adapter 0 frontend 0 (DVB-S2)...
DVB: registering adapter 0 frontend 1 (DVB-S2)...
input: front panel as /devices/virtual/input/input2
AVerMedia A867 driver module V1.0.27 loaded.
dvb-usb: found a 'AVerMedia A867 DVB-T Recevier' in warm state.
dvb-usb: will pass the complete MPEG2 transport stream to the software demuxer.
DVB: registering new adapter (AVerMedia A867 DVB-T Recevier)
DVB: registering adapter 1 frontend 0 (A867 USB DVB-T)...
dvb-usb: AVerMedia A867 DVB-T Recevier successfully initialized and connected.
usbcore: registered new interface driver dvb-usb-a867

STB: Clarke Tech ET9100
Mass storage: internal SATA-II HDD 1TB WD10EACS GreenPower 5400rpm
Mass storage: external USB pen drive 2GB
Firmware: OpenPLi kernel 3.x.x
Tuner A: AVL2108 (DVB-S2) HotBird 13E
Tuner B: AVL2108 (DVB-S2) HotBird 13E
Tuner C: AverMedia A867 (DVB-T HD) (AF9035 + MXL5007T)
TV: plasma PANASONIC GT30 fullHD
Audio: PCM through HDMI (no Dolby decoder)





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users