Jump to content


Photo

Bootlogo


  • Please log in to reply
248 replies to this topic

Re: Bootlogo #21 ims

  • PLi® Core member
  • 11,122 posts

+168
Excellent

Posted 26 September 2013 - 17:16

trield flash last original experimental dmm image to my dm800Se and use showiframe with our Pli bootlogo ... there is logo dispayed well ... it seems, it will not be problem there in drivers ;)

 

EDIT: problem is there in our showiframe ... when I am use showiframe binary from original image under PLi, bootlogo is ok


Edited by ims, 26 September 2013 - 18:03.

Kdo nic nedělá, nic nezkazí!

Re: Bootlogo #22 pieterg

  • PLi® Core member
  • 32,766 posts

+245
Excellent

Posted 26 September 2013 - 19:12

The dmm drivers probably need the same data to be written several times, until one of the attempts succeeds to put the entire frame in the videodecoder buffer.

Re: Bootlogo #23 ims

  • PLi® Core member
  • 11,122 posts

+168
Excellent

Posted 26 September 2013 - 19:25

no - in theirs showiframe is nothing wroted in loop, as in our.

It is version 1.8.

Attached Files


Edited by ims, 26 September 2013 - 19:40.

Kdo nic nedělá, nic nezkazí!

Re: Bootlogo #24 pieterg

  • PLi® Core member
  • 32,766 posts

+245
Excellent

Posted 26 September 2013 - 20:05

OK, then it must be the sleep, even worse...

Re: Bootlogo #25 ims

  • PLi® Core member
  • 11,122 posts

+168
Excellent

Posted 26 September 2013 - 20:37

but I do see nothing sleeps there. Only one and it is used in Pli version too.


Kdo nic nedělá, nic nezkazí!

Re: Bootlogo #26 pieterg

  • PLi® Core member
  • 32,766 posts

+245
Excellent

Posted 26 September 2013 - 20:50

Then I see two differences:

1. we provide pts in the pes header
2. we select mpeg4 / mpeg2 (but the detection is wrong, so we end up selecting mpeg2, though the format is mpeg4)

So it must be 1.
(don't know why pts was added, I don't think it would do any good, though it shouldn't cause problems)

Re: Bootlogo #27 ims

  • PLi® Core member
  • 11,122 posts

+168
Excellent

Posted 27 September 2013 - 17:21

In each case loops with usleep was nonsence... This works well (tried on dm800se, xp1000) - i added pts and detecting mpeg2/4 from old file. 

Attached Files


Kdo nic nedělá, nic nezkazí!

Re: Bootlogo #28 pieterg

  • PLi® Core member
  • 32,766 posts

+245
Excellent

Posted 27 September 2013 - 17:36

What is the diff?

Re: Bootlogo #29 ims

  • PLi® Core member
  • 11,122 posts

+168
Excellent

Posted 27 September 2013 - 18:04

into new file added your points 1) 2)


Kdo nic nedělá, nic nezkazí!

Re: Bootlogo #30 pieterg

  • PLi® Core member
  • 32,766 posts

+245
Excellent

Posted 27 September 2013 - 18:21

yes, but what is the difference with our current version?
(in other words, what caused the issue, and what fixes it?)

Re: Bootlogo #31 ims

  • PLi® Core member
  • 11,122 posts

+168
Excellent

Posted 27 September 2013 - 18:25

in our current version we trying wrote it in loop with usleep(8000). Here are no usleep, no loop. Easy write.


Edited by ims, 27 September 2013 - 18:26.

Kdo nic nedělá, nic nezkazí!

Re: Bootlogo #32 pieterg

  • PLi® Core member
  • 32,766 posts

+245
Excellent

Posted 27 September 2013 - 19:08

weird, when I removed the write loop several months ago, I had to revert that because it turned out writing without the loop was causing problems on dreamboxes.

And now the opposite is true...

Re: Bootlogo #33 pieterg

  • PLi® Core member
  • 32,766 posts

+245
Excellent

Posted 27 September 2013 - 19:14

OK, I reverted to the version without the write loop.

Re: Bootlogo #34 theparasol

  • Senior Member
  • 4,141 posts

+196
Excellent

Posted 27 September 2013 - 21:18

Lets hope you dont have to revert it again (e.g. due some specific models dreamboxes still do need the write loop...)

But time will tell!

 

Lets hope that Gutemine initiated something good ;)

 

Too bad the guy is a joker and just gives hints or timebombed proof of concepts to convince himself if some of his brainwaves actually can work.

 

Tnx IMS / PieterG !



Re: Bootlogo #35 ims

  • PLi® Core member
  • 11,122 posts

+168
Excellent

Posted 27 September 2013 - 22:20

OK, I reverted to the version without the write loop.

only for upstream ? I want not use it still...It  added 3-4MB in /dev/root on my dm800se


Kdo nic nedělá, nic nezkazí!

Re: Bootlogo #36 pieterg

  • PLi® Core member
  • 32,766 posts

+245
Excellent

Posted 27 September 2013 - 23:08

Then you probably did not strip the resulting binary. There should be no size difference.

Re: Bootlogo #37 ims

  • PLi® Core member
  • 11,122 posts

+168
Excellent

Posted 27 September 2013 - 23:26

When you see on nighty builds for DM800SE(zipped), 3.0 has cca 41MB and 4.0 has 44MB. It is not stripped too ?? As I saw on images for all boxes, 4.0 adding cca 3MB...


Kdo nic nedělá, nic nezkazí!

Re: Bootlogo #38 pieterg

  • PLi® Core member
  • 32,766 posts

+245
Excellent

Posted 28 September 2013 - 08:19

Ah, you mean 4 is bigger than 3.
(I thought you meant the showiframe binary)

The image is bigger because newer versions of packages are usually larger.
And/or there are dependencies which could be removed.

But if the revert works in 4, I'll backport it to 3.0

Re: Bootlogo #39 johnny0705

  • Senior Member
  • 206 posts

0
Neutral

Posted 28 September 2013 - 08:33

Hello, after update from today there is no boot logo anymore on DM8000.

Gr. Jan

 

ET-10000 + VU+ Solo2 OpenPLI 4

 


Re: Bootlogo #40 ims

  • PLi® Core member
  • 11,122 posts

+168
Excellent

Posted 28 September 2013 - 08:53

could you change /usr/bin/showiframe with this one (unpack, replace and set chmode 755) and could you try it again ? (if processor for dm8000 is same as 800se?)

Attached Files


Kdo nic nedělá, nic nezkazí!




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users