Jump to content


Photo

wi-fi problem on ET9000


  • Please log in to reply
29 replies to this topic

#1 Robinson

  • Senior Member
  • 2,497 posts

+29
Good

Posted 2 March 2013 - 00:09

Hi,
I have just moved from DM800se (2.1) to the latest OpenPLi build for ET9000 and have experienced a problem with my wi-fi TP-Link TL-WN321G V 3.6 (rt73, I think).

This is on DM800se:
Odpowiedź z 192.168.1.102: bajtów=32 czas=1ms TTL=64
Odpowiedź z 192.168.1.102: bajtów=32 czas=1ms TTL=64
Odpowiedź z 192.168.1.102: bajtów=32 czas=1ms TTL=64
Odpowiedź z 192.168.1.102: bajtów=32 czas=1ms TTL=64
Odpowiedź z 192.168.1.102: bajtów=32 czas=1ms TTL=64
Odpowiedź z 192.168.1.102: bajtów=32 czas=1ms TTL=64
Odpowiedź z 192.168.1.102: bajtów=32 czas=2ms TTL=64
Odpowiedź z 192.168.1.102: bajtów=32 czas=1ms TTL=64
Odpowiedź z 192.168.1.102: bajtów=32 czas=1ms TTL=64
Odpowiedź z 192.168.1.102: bajtów=32 czas=1ms TTL=64
Odpowiedź z 192.168.1.102: bajtów=32 czas=1ms TTL=64
Odpowiedź z 192.168.1.102: bajtów=32 czas=1ms TTL=64
Odpowiedź z 192.168.1.102: bajtów=32 czas=1ms TTL=64
Odpowiedź z 192.168.1.102: bajtów=32 czas=1ms TTL=64
Odpowiedź z 192.168.1.102: bajtów=32 czas=1ms TTL=64
Odpowiedź z 192.168.1.102: bajtów=32 czas=2ms TTL=64
Odpowiedź z 192.168.1.102: bajtów=32 czas=1ms TTL=64
Odpowiedź z 192.168.1.102: bajtów=32 czas=1ms TTL=64
Odpowiedź z 192.168.1.102: bajtów=32 czas=1ms TTL=64
Odpowiedź z 192.168.1.102: bajtów=32 czas=1ms TTL=64
Odpowiedź z 192.168.1.102: bajtów=32 czas=1ms TTL=64
Odpowiedź z 192.168.1.102: bajtów=32 czas=1ms TTL=64
Odpowiedź z 192.168.1.102: bajtów=32 czas=1ms TTL=64
Odpowiedź z 192.168.1.102: bajtów=32 czas=1ms TTL=64
Odpowiedź z 192.168.1.102: bajtów=32 czas=1ms TTL=64
Odpowiedź z 192.168.1.102: bajtów=32 czas=1ms TTL=64
Odpowiedź z 192.168.1.102: bajtów=32 czas=1ms TTL=64
Odpowiedź z 192.168.1.102: bajtów=32 czas=1ms TTL=64
Odpowiedź z 192.168.1.102: bajtów=32 czas=1ms TTL=64
Odpowiedź z 192.168.1.102: bajtów=32 czas=1ms TTL=64
Odpowiedź z 192.168.1.102: bajtów=32 czas=1ms TTL=64
Odpowiedź z 192.168.1.102: bajtów=32 czas=5ms TTL=64
Odpowiedź z 192.168.1.102: bajtów=32 czas=1ms TTL=64
Odpowiedź z 192.168.1.102: bajtów=32 czas=1ms TTL=64
Odpowiedź z 192.168.1.102: bajtów=32 czas=1ms TTL=64

And this is on ET9000:
Odpowiedź z 192.168.1.102: bajtów=32 czas=41ms TTL=64
Odpowiedź z 192.168.1.102: bajtów=32 czas=55ms TTL=64
Odpowiedź z 192.168.1.102: bajtów=32 czas=79ms TTL=64
Odpowiedź z 192.168.1.102: bajtów=32 czas=103ms TTL=64
Odpowiedź z 192.168.1.102: bajtów=32 czas=25ms TTL=64
Odpowiedź z 192.168.1.102: bajtów=32 czas=48ms TTL=64
Odpowiedź z 192.168.1.102: bajtów=32 czas=72ms TTL=64
Odpowiedź z 192.168.1.102: bajtów=32 czas=96ms TTL=64
Odpowiedź z 192.168.1.102: bajtów=32 czas=119ms TTL=64
Odpowiedź z 192.168.1.102: bajtów=32 czas=42ms TTL=64
Odpowiedź z 192.168.1.102: bajtów=32 czas=66ms TTL=64
Odpowiedź z 192.168.1.102: bajtów=32 czas=90ms TTL=64
Odpowiedź z 192.168.1.102: bajtów=32 czas=113ms TTL=64
Odpowiedź z 192.168.1.102: bajtów=32 czas=36ms TTL=64
Odpowiedź z 192.168.1.102: bajtów=32 czas=59ms TTL=64
Odpowiedź z 192.168.1.102: bajtów=32 czas=84ms TTL=64
Odpowiedź z 192.168.1.102: bajtów=32 czas=109ms TTL=64
Odpowiedź z 192.168.1.102: bajtów=32 czas=116ms TTL=64
Odpowiedź z 192.168.1.102: bajtów=32 czas=37ms TTL=64
Odpowiedź z 192.168.1.102: bajtów=32 czas=61ms TTL=64
Odpowiedź z 192.168.1.102: bajtów=32 czas=12ms TTL=64
Odpowiedź z 192.168.1.102: bajtów=32 czas=94ms TTL=64
Odpowiedź z 192.168.1.102: bajtów=32 czas=117ms TTL=64
Odpowiedź z 192.168.1.102: bajtów=32 czas=40ms TTL=64
Odpowiedź z 192.168.1.102: bajtów=32 czas=64ms TTL=64
Odpowiedź z 192.168.1.102: bajtów=32 czas=88ms TTL=64
Odpowiedź z 192.168.1.102: bajtów=32 czas=112ms TTL=64
Odpowiedź z 192.168.1.102: bajtów=32 czas=36ms TTL=64

What could be the reason for it?

ET9000, OpenPLi 4.0, 13E, 19E

HD51, OpenPLi 6.2, 75E - 30W


Re: wi-fi problem on ET9000 #2 malakudi

  • PLi® Core member
  • 1,447 posts

+66
Good

Posted 2 March 2013 - 11:28

Your problem is power management.
"iwconfig wlan0 power off" fixes it.
You can put the following script in /etc/network/if-up.d , name it wlanpoweroff or something like that, give it execute permission (755)

#!/bin/sh
# quit if we're called for the loopback
if [ "$IFACE" = wlan0 ]; then
      iwconfig wlan0 power off
      fi
exit 0


Re: wi-fi problem on ET9000 #3 Robinson

  • Senior Member
  • 2,497 posts

+29
Good

Posted 2 March 2013 - 12:41

malakudi, you've been a really great help!
Thanks a lot.

ET9000, OpenPLi 4.0, 13E, 19E

HD51, OpenPLi 6.2, 75E - 30W


Re: wi-fi problem on ET9000 #4 malakudi

  • PLi® Core member
  • 1,447 posts

+66
Good

Posted 2 March 2013 - 12:53

It would be nice to disable this in the kernel driver, I don't see a reason for wifi power management enabled by default on STB. I will take a look in the source code and submit a patch.

Edited by malakudi, 2 March 2013 - 12:54.


Re: wi-fi problem on ET9000 #5 Robinson

  • Senior Member
  • 2,497 posts

+29
Good

Posted 2 March 2013 - 14:43

I seem to have another problem, though.
The red diode on the wi-fi stick seems to be blinking almost all the tijme while it should only blink when CW/DW are passed, I think. Am I right? And regularly, picture freezes for a couple of seconds. Although ping command to the wi-fi stick gives very quick replies all the time after applying your script, malakudi.

ET9000, OpenPLi 4.0, 13E, 19E

HD51, OpenPLi 6.2, 75E - 30W


Re: wi-fi problem on ET9000 #6 Robinson

  • Senior Member
  • 2,497 posts

+29
Good

Posted 2 March 2013 - 16:51

Now it seems to be working more or less all right (no constant blinking) but, interestingly, in Network Setup I see the following:
IP address: N/A
Subnet mask: N/A
Gateway: N/A
However, the connection is OK. I do not quite grasp it.

ET9000, OpenPLi 4.0, 13E, 19E

HD51, OpenPLi 6.2, 75E - 30W


Re: wi-fi problem on ET9000 #7 Robinson

  • Senior Member
  • 2,497 posts

+29
Good

Posted 2 March 2013 - 16:58

Update: It looks like after some time of correct operation (minutes rather than hours), the diode on the wi-fi USB dongle starts blinking more often and, I think, soon glitches will start again.
I wonder if I am the only one experiencing probems with wi-fi on ET9000? If there are more wi-fi users here, what USB dongles do you use?

I'm sorry but there is very little time when I can edit my posts.

Edited by Robinson, 2 March 2013 - 16:59.

ET9000, OpenPLi 4.0, 13E, 19E

HD51, OpenPLi 6.2, 75E - 30W


Re: wi-fi problem on ET9000 #8 malakudi

  • PLi® Core member
  • 1,447 posts

+66
Good

Posted 2 March 2013 - 18:33

A friend of mine has a wifi stick like yours (rt73 - different manufacturer), and after I turned off wifi power management, it worked ok with no issues.

edit: I used static IP in my friend's box, DHCP + WPA2 were having problems in his case.

Edited by malakudi, 2 March 2013 - 18:43.


Re: wi-fi problem on ET9000 #9 Robinson

  • Senior Member
  • 2,497 posts

+29
Good

Posted 2 March 2013 - 19:03

I used static IP in my friend's box, DHCP + WPA2 were having problems in his case.

OK, maybe it is the same here. I will go for static then. Thanks.

ET9000, OpenPLi 4.0, 13E, 19E

HD51, OpenPLi 6.2, 75E - 30W


Re: wi-fi problem on ET9000 #10 Robinson

  • Senior Member
  • 2,497 posts

+29
Good

Posted 2 March 2013 - 20:38

The interesting thing is that when I issue a ping command, I usually get several timeouts and only then do I start getting replies:

C:\Documents and Settings\Rob>ping 192.168.1.102 -t
Badanie 192.168.1.102 z użyciem 32 bajtów danych:
Upłynął limit czasu żądania.
Upłynął limit czasu żądania.
Upłynął limit czasu żądania.
Upłynął limit czasu żądania.
Upłynął limit czasu żądania.
Odpowiedź z 192.168.1.102: bajtów=32 czas=54ms TTL=64
Odpowiedź z 192.168.1.102: bajtów=32 czas=1ms TTL=64
Odpowiedź z 192.168.1.102: bajtów=32 czas=9ms TTL=64
Odpowiedź z 192.168.1.102: bajtów=32 czas=1ms TTL=64
Odpowiedź z 192.168.1.102: bajtów=32 czas=1ms TTL=64
Odpowiedź z 192.168.1.102: bajtów=32 czas=1ms TTL=64
Odpowiedź z 192.168.1.102: bajtów=32 czas=1ms TTL=64
Odpowiedź z 192.168.1.102: bajtów=32 czas=1ms TTL=64

ET9000, OpenPLi 4.0, 13E, 19E

HD51, OpenPLi 6.2, 75E - 30W


Re: wi-fi problem on ET9000 #11 Robinson

  • Senior Member
  • 2,497 posts

+29
Good

Posted 5 March 2013 - 22:13

Following on my post above, I must confirm that this behaviour continues on WLAN. It often takes 5-10 seconds (or more) before WLAN starts replying to incoming requests.
I have observed the same behaviour not only using ping command via telnet (as above) but also using FTP client (Total Commander). I have to try to connect several times before the connection is established. Then, I can disconnect and re-connect immediately. But after some idle time, the situation occurs again.

ET9000, OpenPLi 4.0, 13E, 19E

HD51, OpenPLi 6.2, 75E - 30W


Re: wi-fi problem on ET9000 #12 malakudi

  • PLi® Core member
  • 1,447 posts

+66
Good

Posted 5 March 2013 - 23:28

As a workaround, try to put a cron job to ping your router every 1 minute.

Re: wi-fi problem on ET9000 #13 Robinson

  • Senior Member
  • 2,497 posts

+29
Good

Posted 31 March 2019 - 10:55

It would be nice to disable this in the kernel driver, I don't see a reason for wifi power management enabled by default on STB. I will take a look in the source code and submit a patch.

 

I am forced to use my old wi-fi dongle again because there is no Ethernet cable in the room.

Is this patch included or do I still have to use the script you posted above?

By the way, does a dongle using RT73 driver require some axtra packets to be installed or does it work out-of-the-box with OpenPLi 6 or 7?


ET9000, OpenPLi 4.0, 13E, 19E

HD51, OpenPLi 6.2, 75E - 30W


Re: wi-fi problem on ET9000 #14 WanWizard

  • Forum Moderator
    PLi® Core member
  • 48,430 posts

+823
Excellent

Posted 31 March 2019 - 11:00

The only USB devices that work out-of-the-box are the devices the manufacturer supports, with is usually only their own brand USB tuner or wifi stick.

 

For all others, you need to install the driver, and some require firmware as well. For the RT73, you need both.


Currently in use: VU+Duo 4K (2xFBC S2), Amiko Viper T2C (T2), SAB Alpha Triple HD (S2+T2), Zgemma H3.T2C (T/C), Zgemma H6 (fallback), VU+Zero (fallback)

Many answers to your question can be found in our new and improved wiki.

note: I do not provide support via PM !

 


Re: wi-fi problem on ET9000 #15 Robinson

  • Senior Member
  • 2,497 posts

+29
Good

Posted 31 March 2019 - 12:55

Do you knoiw what telnet commands to use to install both driver and firmware for RT73?


ET9000, OpenPLi 4.0, 13E, 19E

HD51, OpenPLi 6.2, 75E - 30W


Re: wi-fi problem on ET9000 #16 WanWizard

  • Forum Moderator
    PLi® Core member
  • 48,430 posts

+823
Excellent

Posted 31 March 2019 - 14:27

Can't check now, but I'd say:

opkg install kernel-module-rt73usb
opkg install firmware-rt73

you should be able to find them in software management, advanced options, package management too, if you don't fancy a commandline.


Currently in use: VU+Duo 4K (2xFBC S2), Amiko Viper T2C (T2), SAB Alpha Triple HD (S2+T2), Zgemma H3.T2C (T/C), Zgemma H6 (fallback), VU+Zero (fallback)

Many answers to your question can be found in our new and improved wiki.

note: I do not provide support via PM !

 


Re: wi-fi problem on ET9000 #17 Robinson

  • Senior Member
  • 2,497 posts

+29
Good

Posted 21 April 2019 - 12:16

It looks like RT73 is installed by default in OpenPLi 7.0, at least for ET9000.

Wi-fi works but only with WEP or WPA switched off. :(

Is there a way to remedy it? I am using a TP-LINK router - TL-MR3420.

Now I cannot use WEP/WPA/WPA2. Luckily I use MAC filtering but I am not sure if it is safe.


ET9000, OpenPLi 4.0, 13E, 19E

HD51, OpenPLi 6.2, 75E - 30W


Re: wi-fi problem on ET9000 #18 WanWizard

  • Forum Moderator
    PLi® Core member
  • 48,430 posts

+823
Excellent

Posted 21 April 2019 - 12:30

I wouldn't know why that wouldn't work. Encryption is the function of the WPA supplicant, and afaik that works fine (for most people appearently).

 

Is the firmware (firmware-rt73) installed too?


Currently in use: VU+Duo 4K (2xFBC S2), Amiko Viper T2C (T2), SAB Alpha Triple HD (S2+T2), Zgemma H3.T2C (T/C), Zgemma H6 (fallback), VU+Zero (fallback)

Many answers to your question can be found in our new and improved wiki.

note: I do not provide support via PM !

 


Re: wi-fi problem on ET9000 #19 Robinson

  • Senior Member
  • 2,497 posts

+29
Good

Posted 21 April 2019 - 16:13

root@et9x00:~# opkg list *rt73*
firmware-rt73 - 1.1+git292+25f936b-r0.0 - firmware-rt73 version 1.1+gitAUTOINC+2
5f936b80e-r0
 Firmware for RT73
kernel-module-rt73usb-3.8.7 - 3.8.7-r6.13.1 - rt73usb kernel module
 rt73usb kernel module; Ralink RT73 USB Wireless LAN driver.

 

Looks like things are installed correctly.

I used "opkg list" command.


ET9000, OpenPLi 4.0, 13E, 19E

HD51, OpenPLi 6.2, 75E - 30W


Re: wi-fi problem on ET9000 #20 WanWizard

  • Forum Moderator
    PLi® Core member
  • 48,430 posts

+823
Excellent

Posted 22 April 2019 - 01:18

"list" shows available packages, not installed packages, you need to use "list-installed" for that.


Currently in use: VU+Duo 4K (2xFBC S2), Amiko Viper T2C (T2), SAB Alpha Triple HD (S2+T2), Zgemma H3.T2C (T/C), Zgemma H6 (fallback), VU+Zero (fallback)

Many answers to your question can be found in our new and improved wiki.

note: I do not provide support via PM !

 





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users