Jump to content


Photo

Installing the OnDemand plugin (BBC/ITV/C4)


  • Please log in to reply
266 replies to this topic

#1 Anzo

  • Senior Member
  • 284 posts

+5
Neutral

Posted 20 March 2013 - 13:53

I succesfully installed the OnDemand plugin and rebooted my DM8000 with an up to date OpenPli 3. When accessing Applications from the main menu I got the message "Extensions/OnDemand (cannot import name SCOPE_ACTIVE_SKIN). I tried it with the standard Pli HD skin and the Metrix HD skin (mod for Pli), but the same error message. Is this purely a problem with the plugin or am I missing a python or so?

Groet, André

apparatuur: Gigablue Quad Plus, Gigablue Ultra UE, Gigablue X3, Dreambox 8000, Opticum X406, Humax Freesat

ontvangst: 5 west, 1 west, 5 oost, 7 oost, 9 oost, 13 oost, 19 oost, 23 oost, 28 oost via o.a. Big Bisat

smartcards: Sky UK FTV, MTV Unlimited, HD+ Deutschland, Ziggo TV Royaal (via OScam)


Re: Installing the OnDemand plugin (BBC/ITV/C4) #2 adri

  • Senior Member
  • 368 posts

+5
Neutral

Posted 20 March 2013 - 15:20

Did you manually install the required python plugins:

python-lxml
python-beautifulsoup
python-dnspython

These plugins may not exist in the OpenPli feed, in which case you'll need to get them elsewhere.

Edited by adri, 20 March 2013 - 15:20.


Re: Installing the OnDemand plugin (BBC/ITV/C4) #3 Anzo

  • Senior Member
  • 284 posts

+5
Neutral

Posted 20 March 2013 - 15:29

Yes, I did install the additional python plugins as provided with the thread on another board.

Groet, André

apparatuur: Gigablue Quad Plus, Gigablue Ultra UE, Gigablue X3, Dreambox 8000, Opticum X406, Humax Freesat

ontvangst: 5 west, 1 west, 5 oost, 7 oost, 9 oost, 13 oost, 19 oost, 23 oost, 28 oost via o.a. Big Bisat

smartcards: Sky UK FTV, MTV Unlimited, HD+ Deutschland, Ziggo TV Royaal (via OScam)


Re: Installing the OnDemand plugin (BBC/ITV/C4) #4 ims

  • PLi® Core member
  • 9,729 posts

+157
Excellent

Posted 20 March 2013 - 15:32

as I read about it, it is for VIX image.

But for me it works on Vu+ultimo (installed this package -all dependencies included in .ipk)

Attached Files


Edited by ims, 20 March 2013 - 15:44.

Kdo nic nedělá, nic nezkazí!

Re: Installing the OnDemand plugin (BBC/ITV/C4) #5 Anzo

  • Senior Member
  • 284 posts

+5
Neutral

Posted 20 March 2013 - 15:42

At first yes, but now they made it available for all Open Alliance images. To my knowledge, OpenPli is one of them.

Groet, André

apparatuur: Gigablue Quad Plus, Gigablue Ultra UE, Gigablue X3, Dreambox 8000, Opticum X406, Humax Freesat

ontvangst: 5 west, 1 west, 5 oost, 7 oost, 9 oost, 13 oost, 19 oost, 23 oost, 28 oost via o.a. Big Bisat

smartcards: Sky UK FTV, MTV Unlimited, HD+ Deutschland, Ziggo TV Royaal (via OScam)


Re: Installing the OnDemand plugin (BBC/ITV/C4) #6 Anzo

  • Senior Member
  • 284 posts

+5
Neutral

Posted 20 March 2013 - 15:45

github: https://github.com/o...master/OnDemand

Groet, André

apparatuur: Gigablue Quad Plus, Gigablue Ultra UE, Gigablue X3, Dreambox 8000, Opticum X406, Humax Freesat

ontvangst: 5 west, 1 west, 5 oost, 7 oost, 9 oost, 13 oost, 19 oost, 23 oost, 28 oost via o.a. Big Bisat

smartcards: Sky UK FTV, MTV Unlimited, HD+ Deutschland, Ziggo TV Royaal (via OScam)


Re: Installing the OnDemand plugin (BBC/ITV/C4) #7 ims

  • PLi® Core member
  • 9,729 posts

+157
Excellent

Posted 20 March 2013 - 15:46

tried on vu ultimo now (but only via webif) - and without this error. I can try it on dm800se later.

I install plugin with all dependencies ( in my last post), try it too

Edited by ims, 20 March 2013 - 15:50.

Kdo nic nedělá, nic nezkazí!

Re: Installing the OnDemand plugin (BBC/ITV/C4) #8 Anzo

  • Senior Member
  • 284 posts

+5
Neutral

Posted 20 March 2013 - 16:04

Wow, it works on my DM8000. I had some trouble with just the command "opkg install" and then I added the command "force overwrite". After that I restarted the Dreambox and I have tested the ITV player. I chose the program Celebirty Juice in resolution 1200. It started right away. So it works outside the UK! Thanks so much for helping me!

Groet, André

apparatuur: Gigablue Quad Plus, Gigablue Ultra UE, Gigablue X3, Dreambox 8000, Opticum X406, Humax Freesat

ontvangst: 5 west, 1 west, 5 oost, 7 oost, 9 oost, 13 oost, 19 oost, 23 oost, 28 oost via o.a. Big Bisat

smartcards: Sky UK FTV, MTV Unlimited, HD+ Deutschland, Ziggo TV Royaal (via OScam)


Re: Installing the OnDemand plugin (BBC/ITV/C4) #9 Anzo

  • Senior Member
  • 284 posts

+5
Neutral

Posted 20 March 2013 - 16:11

Just an example of RTE On Demand (Irish with restricted IP, but available with this plugin in other countries).

Attached Files


Groet, André

apparatuur: Gigablue Quad Plus, Gigablue Ultra UE, Gigablue X3, Dreambox 8000, Opticum X406, Humax Freesat

ontvangst: 5 west, 1 west, 5 oost, 7 oost, 9 oost, 13 oost, 19 oost, 23 oost, 28 oost via o.a. Big Bisat

smartcards: Sky UK FTV, MTV Unlimited, HD+ Deutschland, Ziggo TV Royaal (via OScam)


Re: Installing the OnDemand plugin (BBC/ITV/C4) #10 Anzo

  • Senior Member
  • 284 posts

+5
Neutral

Posted 20 March 2013 - 16:22

In the newer version of the maker is also Channel 4 added :-)

Groet, André

apparatuur: Gigablue Quad Plus, Gigablue Ultra UE, Gigablue X3, Dreambox 8000, Opticum X406, Humax Freesat

ontvangst: 5 west, 1 west, 5 oost, 7 oost, 9 oost, 13 oost, 19 oost, 23 oost, 28 oost via o.a. Big Bisat

smartcards: Sky UK FTV, MTV Unlimited, HD+ Deutschland, Ziggo TV Royaal (via OScam)


Re: Installing the OnDemand plugin (BBC/ITV/C4) #11 ims

  • PLi® Core member
  • 9,729 posts

+157
Excellent

Posted 20 March 2013 - 16:25

BBCi - Sport - third item, 1500:

Vu ultimo - ok
xp1000 - ok
dm800se - works, but sound jerky :(

when I actualised .py file on dm800se from plugin's sources - cannot import name SCOPE_ACTIVE_SKIN

Edited by ims, 20 March 2013 - 16:25.

Kdo nic nedělá, nic nezkazí!

Re: Installing the OnDemand plugin (BBC/ITV/C4) #12 Anzo

  • Senior Member
  • 284 posts

+5
Neutral

Posted 20 March 2013 - 16:33

I've asked my friend mvdb also to test on his DM8000. I tested 3/ITV/BBC/RTE with divers programs in the highest resolutions available. Alle were great, video AND sound.

Groet, André

apparatuur: Gigablue Quad Plus, Gigablue Ultra UE, Gigablue X3, Dreambox 8000, Opticum X406, Humax Freesat

ontvangst: 5 west, 1 west, 5 oost, 7 oost, 9 oost, 13 oost, 19 oost, 23 oost, 28 oost via o.a. Big Bisat

smartcards: Sky UK FTV, MTV Unlimited, HD+ Deutschland, Ziggo TV Royaal (via OScam)


Re: Installing the OnDemand plugin (BBC/ITV/C4) #13 Anzo

  • Senior Member
  • 284 posts

+5
Neutral

Posted 20 March 2013 - 16:34

cannot import name SCOPE_ACTIVE_SKIN


Sounds like back to square one ;-)

Groet, André

apparatuur: Gigablue Quad Plus, Gigablue Ultra UE, Gigablue X3, Dreambox 8000, Opticum X406, Humax Freesat

ontvangst: 5 west, 1 west, 5 oost, 7 oost, 9 oost, 13 oost, 19 oost, 23 oost, 28 oost via o.a. Big Bisat

smartcards: Sky UK FTV, MTV Unlimited, HD+ Deutschland, Ziggo TV Royaal (via OScam)


Re: Installing the OnDemand plugin (BBC/ITV/C4) #14 metoo

  • Senior Member
  • 1,528 posts

+33
Good

Posted 20 March 2013 - 16:40

works here too, very nice

ET10000 C C C C/T  2TB HDD ET7000 + ET6000 dvb-S  OpenPli 4.0 Triax 88 multifeed quad LNBs 


Re: Installing the OnDemand plugin (BBC/ITV/C4) #15 matt56

  • Member
  • 7 posts

+3
Neutral

Posted 20 March 2013 - 16:47

For me the same experiences as Anzo. The ITV, BBC and RTE player works well even with high bitrates.

Attached Files


Dreambox 8000 HD PVR S/T/C Open Pli4 / Opticum HD x406p / NOXON DAB+ stick

Visiosat Big Bisat / Technisat Digidish


Re: Installing the OnDemand plugin (BBC/ITV/C4) #16 ims

  • PLi® Core member
  • 9,729 posts

+157
Excellent

Posted 20 March 2013 - 17:00

an I think, it is in conflict with Foreca, pzmail etc
Kdo nic nedělá, nic nezkazí!

Re: Installing the OnDemand plugin (BBC/ITV/C4) #17 Pale-Rider

  • Senior Member
  • 126 posts

+6
Neutral

Posted 20 March 2013 - 18:22

At first yes, but now they made it available for all Open Alliance images. To my knowledge, OpenPli is one of them.


no mate, While The OE-Alliance is originally based on and takes updates from Pli, Pli it self is not a Member of the OE-Alliance and on the whole does not repatriate fixes from the OE-Alliance back into it's own OE., I believe this error is as a result in the different skin engines used between the OE-Alliance and Pli although i could be wrong about that. for now use the modified version by Mickd, that should work fine for you.


For me the same experiences as Anzo. The ITV, BBC and RTE player works well even with high bitrates.


There was recently a update that allows HD streaming of content from the BBC iplayer and ITV player plugins.

Edited by pheonix-vix, 20 March 2013 - 18:23.


Re: Installing the OnDemand plugin (BBC/ITV/C4) #18 Robinson

  • Senior Member
  • 2,371 posts

+26
Good

Posted 20 March 2013 - 18:45

as I read about it, it is for VIX image.
But for me it works on Vu+ultimo (installed this package -all dependencies included in .ipk)

I have an ET9000. Can I use this ipk too? What would the exact command be? Or can I just upload the the ipk to my box and install it from /tmp wihtout any additional parameters possible to be used via telnet?
Also, does it work for Channel 4?

ET9000, OpenPLi 4.0, 75E - 30W

HD51, OpenPLi 6.1, 13E, 19E


Re: Installing the OnDemand plugin (BBC/ITV/C4) #19 Anzo

  • Senior Member
  • 284 posts

+5
Neutral

Posted 21 March 2013 - 23:09

BBCi - Sport - third item, 1500:

Vu ultimo - ok
xp1000 - ok
dm800se - works, but sound jerky :(

when I actualised .py file on dm800se from plugin's sources - cannot import name SCOPE_ACTIVE_SKIN


Have you found anything on the error as mentioned above, maybe?

Groet, André

apparatuur: Gigablue Quad Plus, Gigablue Ultra UE, Gigablue X3, Dreambox 8000, Opticum X406, Humax Freesat

ontvangst: 5 west, 1 west, 5 oost, 7 oost, 9 oost, 13 oost, 19 oost, 23 oost, 28 oost via o.a. Big Bisat

smartcards: Sky UK FTV, MTV Unlimited, HD+ Deutschland, Ziggo TV Royaal (via OScam)


Re: Installing the OnDemand plugin (BBC/ITV/C4) #20 ims

  • PLi® Core member
  • 9,729 posts

+157
Excellent

Posted 22 March 2013 - 10:56

You must see into vix's /Tools/Directories.py and then add lines for SCOPE_ACTIVE_SKIN.
Kdo nic nedělá, nic nezkazí!




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users