Jump to content


Photo

OpenPLi 4.0 FTP username/password?


  • Please log in to reply
42 replies to this topic

#1 fihi

  • Member
  • 1 posts

0
Neutral

Posted 12 August 2013 - 19:50

I installed OpenPLi 4.0 in VUplus Solo2 and FTP does not work. Username: root, password: blank does not work. What's the password? Thank you.



Re: OpenPLi 4.0 FTP username/password? #2 betacentauri

  • PLi® Core member
  • 5,596 posts

+254
Excellent

Posted 12 August 2013 - 19:53

Workaround: Set a password via telnet. Then ftp works.


Xtrend ET-9200, ET-8000, ET-10000, OpenPliPC on Ubuntu 12.04

Re: OpenPLi 4.0 FTP username/password? #3 nautilus7

  • Senior Member
  • 147 posts

+1
Neutral

Posted 5 September 2013 - 11:44

Hi, I just bought an xtrend 4000 and installed openpli 4.0, latest nightly build. What is the username and password for ftp? I tried root/dreambox, root/-, dreambox/- with no result. Also telnet is asking for a password. Thanks.



Re: OpenPLi 4.0 FTP username/password? #4 WanWizard

  • Forum Moderator
    PLi® Core member
  • 49,460 posts

+871
Excellent

Posted 5 September 2013 - 11:50

It should be empty (no password, just enter).

 

You first have to login using telnet and set a password before you can use the other services.


Currently in use: VU+Duo 4K (2xFBC S2), Amiko Viper T2C (T2), SAB Alpha Triple HD (S2+T2), Zgemma H3.T2C (T/C), Zgemma H6 (fallback), VU+Zero (fallback)

Many answers to your question can be found in our new and improved wiki.

note: I do not provide support via PM !

 


Re: OpenPLi 4.0 FTP username/password? #5 nautilus7

  • Senior Member
  • 147 posts

+1
Neutral

Posted 5 September 2013 - 13:47

what is the telnet login username and password?



Re: OpenPLi 4.0 FTP username/password? #6 fairsats

  • Member
  • 31 posts

+1
Neutral

Posted 5 September 2013 - 14:10

It should be empty (no password, just enter).

 

You first have to login using telnet and set a password before you can use the other services.

Logged into telnet...set a pw...left uname as root and used the pw...i created in telnet...still will not open dm enigma 2

 

Also dreamedit wil not work  error no services or lamedb found in %dir on dm

 

Why are suddenly these images getting complicated?


Edited by fairsats, 5 September 2013 - 14:13.


Re: OpenPLi 4.0 FTP username/password? #7 adri

  • Senior Member
  • 368 posts

+5
Neutral

Posted 5 September 2013 - 14:16

Why is there a required password in the first place?

Every enigma2 image, except the new PLI 4.0, uses the default of no root password.

Wouldn't it be better to just remove the required password restriction and instantly be compatible again with all utilities and other images?



Re: OpenPLi 4.0 FTP username/password? #8 WanWizard

  • Forum Moderator
    PLi® Core member
  • 49,460 posts

+871
Excellent

Posted 5 September 2013 - 14:18

Sigh.... Does nobody read?

 

OpenPLi 4.0 is a work-in-progress. It is not a finished product, and if you're not prepared to test, deal with problems you encounter, follow the bug reports, and report new bugs, DO NOT INSTALL IT!

 

As mentioned in thousands of other posts, the password and the dreamboxedit problem have nothing to do with each other. The last one is related to tests we're currently doing with a different ftp daemon, which appearantly lacks a few commands required by that tool. So we will (or already have) reverted that change, and will look for an alternative.


@adri,

 

There is no required password, OpenPLi 4.0  comes out of the box without one. The issue was that the vsftpd daemon we were using didn't want to accept accounts with no password. And the busybox ftp daemon that we've been testing over the last few days lacks required functionality.

 

So we're back to vsftpd, and looking for a solution to have it accept accounts without password. It will be solved, but it needs time. Like any other development project.


Currently in use: VU+Duo 4K (2xFBC S2), Amiko Viper T2C (T2), SAB Alpha Triple HD (S2+T2), Zgemma H3.T2C (T/C), Zgemma H6 (fallback), VU+Zero (fallback)

Many answers to your question can be found in our new and improved wiki.

note: I do not provide support via PM !

 


Re: OpenPLi 4.0 FTP username/password? #9 nautilus7

  • Senior Member
  • 147 posts

+1
Neutral

Posted 5 September 2013 - 18:41

OK, thanks for the explanation. Where can I find a changelog, so I can tell if the issue has been fixed?



Re: OpenPLi 4.0 FTP username/password? #10 WanWizard

  • Forum Moderator
    PLi® Core member
  • 49,460 posts

+871
Excellent

Posted 5 September 2013 - 19:23

Via twitter: @OpenPLi

Via the commit mailinglists: https://lists.source...pli-git-commits

VIa http://sourceforge.n...npli/_list/git, select a repository, choose for "browse commits"


Currently in use: VU+Duo 4K (2xFBC S2), Amiko Viper T2C (T2), SAB Alpha Triple HD (S2+T2), Zgemma H3.T2C (T/C), Zgemma H6 (fallback), VU+Zero (fallback)

Many answers to your question can be found in our new and improved wiki.

note: I do not provide support via PM !

 


Re: OpenPLi 4.0 FTP username/password? #11 dummer

  • Senior Member
  • 55 posts

+4
Neutral

Posted 5 September 2013 - 20:50

The easiest way is to use a application called PUTTY and just make/input a new

I had the same problem and was done in 10 seconds.



Re: OpenPLi 4.0 FTP username/password? #12 fairsats

  • Member
  • 31 posts

+1
Neutral

Posted 7 September 2013 - 09:44

Updated to latest version PLi4.....problems with log in

 

 

Have done this...

telnet....Passwd

Change  ....Entered new PW

Confirm    Entered PW again.

 

Message,,PW Changed..

 

in DCC     Left u/n     root

P/W          As new

 

Message   log in incorrect

 

All that I am asking ......Is this the latest state of affairs?

 

Was ok in the first version of PLi 4



Re: OpenPLi 4.0 FTP username/password? #13 rodak

  • Member
  • 29 posts

0
Neutral

Posted 7 September 2013 - 09:58

If this is the same what some other people are getting, the old configuration file of a preious version of vsftpd is still there. This file contains settings that aren't correct for the new version.

The correct solution is to just re-flash the box, or run:

mv -f /etc/vsftpd.conf-opkg /etc/vsftpd.conf

(please please please send exact error messages, then I can help. Just saying "it doesn't work" leaves me no clue as to what the cause may be).


Edited by rodak, 7 September 2013 - 09:59.


Re: OpenPLi 4.0 FTP username/password? #14 fairsats

  • Member
  • 31 posts

+1
Neutral

Posted 7 September 2013 - 10:24

If this is the same what some other people are getting, the old configuration file of a preious version of vsftpd is still there. This file contains settings that aren't correct for the new version.

The correct solution is to just re-flash the box, or run:

mv -f /etc/vsftpd.conf-opkg /etc/vsftpd.conf

(please please please send exact error messages, then I can help. Just saying "it doesn't work" leaves me no clue as to what the cause may be).



Re: OpenPLi 4.0 FTP username/password? #15 fairsats

  • Member
  • 31 posts

+1
Neutral

Posted 7 September 2013 - 10:26

 Reflashed latest version....Thank you....ok now..... :)



Re: OpenPLi 4.0 FTP username/password? #16 rodak

  • Member
  • 29 posts

0
Neutral

Posted 7 September 2013 - 13:09

 Reflashed latest version....Thank you....ok now..... :)



You didn't have to, you can run this as mentioned by MiLo in another post and here above:
mv -f /etc/vsftpd.conf-opkg /etc/vsftpd.conf
But now it's too late, glad you sorted it. But for other users it may be useful info if they don't want to reflash :-)

Re: OpenPLi 4.0 FTP username/password? #17 SpaceRat

  • Senior Member
  • 1,000 posts

+62
Good

Posted 8 September 2013 - 02:00

Please:
Do not make any attempts to make E2 even more insecure.

While it is true that it's a bad idea to open the ftpd on the E2 box to the net, some people will ...
1st box: Vu+ Ultimo 4k 4xDVB-S2 FBC / 2xDVB-C / 1.8 TB HDD / OpenATV 6.2
2nd box: Gigablue Quad 4k 2xDVB-S2 FBC / 2xDVB-C / 1.8 TB HDD / OpenATV 6.2
testing boxes: Vu+ Duo² + AX Quadbox HD2400 + 2x Vu+ Solo² + Octagon SF4008
Sats & Pay-TV: Astra 19.2°E + Hotbird 13°E with Redlight / SCT HD / SES Astra HD- / Sky V14 / 4th empire propaganda TV
Card-Server: Raspberry Pi + IPv6-capable oscam
Router: Linksys WRT1900ACS w/ LEDE + Fritz!Box 7390

Re: OpenPLi 4.0 FTP username/password? #18 WanWizard

  • Forum Moderator
    PLi® Core member
  • 49,460 posts

+871
Excellent

Posted 8 September 2013 - 08:34

We're not.

 

A blank default password is actually a better solution then just a default password, since with the blank password services like ftp don't work, you are forced to set a password. With a default password, most people don't change it.


Currently in use: VU+Duo 4K (2xFBC S2), Amiko Viper T2C (T2), SAB Alpha Triple HD (S2+T2), Zgemma H3.T2C (T/C), Zgemma H6 (fallback), VU+Zero (fallback)

Many answers to your question can be found in our new and improved wiki.

note: I do not provide support via PM !

 


Re: OpenPLi 4.0 FTP username/password? #19 SpaceRat

  • Senior Member
  • 1,000 posts

+62
Good

Posted 8 September 2013 - 14:29

We're not.
 
A blank default password is actually a better solution then just a default password, since with the blank password services like ftp don't work, you are forced to set a password. With a default password, most people don't change it.

If the ftpd won't accept connections without a password, it's not a blank default password anymore because it cannot be used for login :)

But why not simply generate one on installation and show it on the TV screen?

"Installation generated default password: gs8kjgn93"
"This password will be used for ftp/telnet/ssh and web logins until you change it via telnet/ssh."

"Während der Installation erzeugtes Password: gs8kjgn93"
"Dieses Passwort wird für den Login via FTP/Telnet/SSH und Web Browser benutzt, bis Sie es über Telnet/SSH ändern."

This would prevent people from opening their web interface to everybody and his grandma ...
1st box: Vu+ Ultimo 4k 4xDVB-S2 FBC / 2xDVB-C / 1.8 TB HDD / OpenATV 6.2
2nd box: Gigablue Quad 4k 2xDVB-S2 FBC / 2xDVB-C / 1.8 TB HDD / OpenATV 6.2
testing boxes: Vu+ Duo² + AX Quadbox HD2400 + 2x Vu+ Solo² + Octagon SF4008
Sats & Pay-TV: Astra 19.2°E + Hotbird 13°E with Redlight / SCT HD / SES Astra HD- / Sky V14 / 4th empire propaganda TV
Card-Server: Raspberry Pi + IPv6-capable oscam
Router: Linksys WRT1900ACS w/ LEDE + Fritz!Box 7390

Re: OpenPLi 4.0 FTP username/password? #20 MiLo

  • PLi® Core member
  • 13,895 posts

+291
Excellent

Posted 8 September 2013 - 14:56

Even with a 32 character long password, it is STILL a bad idea to forward the webinterface, ftp or telnet to the outside world. Just don't do it. It's a really really bad idea.

 

As for an explanation, well YOU may not understand how one could mis-use those, but I know a few methods and real criminals will probably know a few more. So don't. Please.

 

What you CAN do safely is to forward the SSH port (22). That is the only one that's safe.


Real musicians never die - they just decompose




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users