Jump to content


Photo

Custom Image

image bitbake

  • Please log in to reply
10 replies to this topic

#1 athoik

  • PLi® Core member
  • 8,342 posts

+314
Excellent

Posted 13 September 2013 - 20:59

Hello,

 

 

I would like to guide/help me with the building of custom images using recipes-local.

 

When you want to put something extra into the image (my-image.bb) you simply appending this to IMAGE_INSTALL.

 

 

IMAGE_INSTALL += "enigma2-plugin-my-custom-plugin"

 

Above is clear and wors like a charm.

 

 

When you want to remove something from the image (eg ppanels) how can you do that?

 

 

IMAGE_INSTALL -= "enigma2-plugin-extensions-ppanel"

 

Above probably is not valid, so the simpler way is to copy openpli-enigma2-image.bb, make changes and save it as my-image.bb?

 

 

When you want to add a modified version of pliHD skin you need to use my-pliHD and use RPROVIDES,RREPLACES? Or just adding modified pliHD into local-recipes will use the modified version over the original one?

 

Sorry for making all those questions, but i don't want to reinvent the wheel and done things by the hard way.

 

Thanks,


Edited by athoik, 13 September 2013 - 21:01.

Wavefield T90: 0.8W - 1.9E - 4.8E - 13E - 16E - 19.2E - 23.5E - 26E - 33E - 39E - 42E - 45E on EMP Centauri DiseqC 16/1
Unamed: 13E Quattro - 9E Quattro on IKUSI MS-0916

Re: Custom Image #2 Erik Slagter

  • PLi® Core member
  • 46,251 posts

+514
Excellent

Posted 14 September 2013 - 07:57

Sorry for making all those questions, but i don't want to reinvent the wheel and done things by the hard way.

Not at all, I am very interested in the answer as well  :). I think you have very good points.


* Wavefrontier T90 with 28E/23E/19E/13E/9E/4.8E/0.8W/5W via SCR switches 2 x 2 x 6 user bands
* Ziggo digital cable TV (FTA)
I don't read PM -> if you have something to ask or to report, do it in the forum so others can benefit. I don't take freelance jobs.
Ik lees geen PM -> als je iets te vragen of te melden hebt, doe het op het forum, zodat anderen er ook wat aan hebben.

Re: Custom Image #3 MiLo

  • PLi® Core member
  • 13,975 posts

+295
Excellent

Posted 14 September 2013 - 13:25

You can create a .bbappend for any script you like, and then overwrite things.

An example of how to "delete" things is in ntfs-3g-ntfsprogs_2013.1.13.bbappend:

RDEPENDS_ntfs-3g := "${@bb.data.getVar('RDEPENDS_ntfs-3g',d,1).replace('util-linux-mount', '')}"

(The ":=" is important, it forces bitbake to evaluate it "now" instead of later, when used, like make does)
Real musicians never die - they just decompose

Re: Custom Image #4 athoik

  • PLi® Core member
  • 8,342 posts

+314
Excellent

Posted 15 September 2013 - 13:35

Million thanks MiLo,

This is what i did on my-image.bb

IMAGE_INSTALL := "${@bb.data.getVar('IMAGE_INSTALL',d,1).replace('openpli-bootlogo', '')}"
IMAGE_INSTALL := "${@bb.data.getVar('IMAGE_INSTALL',d,1).replace('enigma2-plugin-skins-pli-hd', '')}"
IMAGE_INSTALL := "${@bb.data.getVar('IMAGE_INSTALL',d,1).replace('enigma2-plugin-extensions-ppanel', ' ')}"


But when i was trying to build vusolo2 i was getting "vuplus-initrd-vusolo2vuplus-initrd-vusolo2vuplus-initrd-vusolo2" missing RDEPENDS.

So i change it like this and build workd on vusolo2 too.

IMAGE_INSTALL := "${@bb.data.getVar('IMAGE_INSTALL',d,1).replace('openpli-bootlogo', '').replace('enigma2-plugin-skins-pli-hd', '').replace('enigma2-plugin-extensions-ppanel','')}"



Now i am trying to change also the spinner but i think the code do_openpli_branding needs change in order to support changing spinner too.

if [ -n "${BRANDINGDIR}" -a -d "${BRANDINGDIR}/enigma2" ] ; then
- cp -p ${BRANDINGDIR}/enigma2/* ${S}/data/.
+ cp -rp ${BRANDINGDIR}/enigma2/* ${S}/data/ 
fi


Using "cp -p ${BRANDINGDIR}/enigma2/* ${S}/data/." you cannot copy subfolders.

cp: omitting directory `/.../enigma2/skin_default'


PS. In order to use BRANDINGDIR you must run bitbake like this MACHINE=XXX BRANDINGDIR=YYY bitbake my-image correct?


Edited by athoik, 15 September 2013 - 13:37.

Wavefield T90: 0.8W - 1.9E - 4.8E - 13E - 16E - 19.2E - 23.5E - 26E - 33E - 39E - 42E - 45E on EMP Centauri DiseqC 16/1
Unamed: 13E Quattro - 9E Quattro on IKUSI MS-0916

Re: Custom Image #5 athoik

  • PLi® Core member
  • 8,342 posts

+314
Excellent

Posted 15 September 2013 - 16:17

Here is the exact message appears when trying to build vusolo2:

 

ERROR: Nothing RPROVIDES 'vuplus-initrd-vusolo2vuplus-initrd-vusolo2vuplus-initrd-vusolo2' (but /opt/openpli/openpli4/meta-local/recipes-local/images/my-image.bb RDEPENDS on or otherwise requires it)

 

Something is wrong on vuplus-initrd-vuduo2.bb (or vuplus-initrd.inc)?


Edited by athoik, 15 September 2013 - 16:17.

Wavefield T90: 0.8W - 1.9E - 4.8E - 13E - 16E - 19.2E - 23.5E - 26E - 33E - 39E - 42E - 45E on EMP Centauri DiseqC 16/1
Unamed: 13E Quattro - 9E Quattro on IKUSI MS-0916

Re: Custom Image #6 Erik Slagter

  • PLi® Core member
  • 46,251 posts

+514
Excellent

Posted 15 September 2013 - 16:18

Interesting, I don't see this.


Since when is this?


* Wavefrontier T90 with 28E/23E/19E/13E/9E/4.8E/0.8W/5W via SCR switches 2 x 2 x 6 user bands
* Ziggo digital cable TV (FTA)
I don't read PM -> if you have something to ask or to report, do it in the forum so others can benefit. I don't take freelance jobs.
Ik lees geen PM -> als je iets te vragen of te melden hebt, doe het op het forum, zodat anderen er ook wat aan hebben.

Re: Custom Image #7 athoik

  • PLi® Core member
  • 8,342 posts

+314
Excellent

Posted 15 September 2013 - 16:51

When using my-image.bb where the following exists:

 

 

IMAGE_INSTALL := "${@bb.data.getVar('IMAGE_INSTALL',d,1).replace('openpli-bootlogo', '')}"
IMAGE_INSTALL := "${@bb.data.getVar('IMAGE_INSTALL',d,1).replace('enigma2-plugin-skins-pli-hd', '')}"
IMAGE_INSTALL := "${@bb.data.getVar('IMAGE_INSTALL',d,1).replace('enigma2-plugin-extensions-ppanel', ' ')}"

 

This happens only on solo2 (and i think on duo2).


Edited by athoik, 15 September 2013 - 16:53.

Wavefield T90: 0.8W - 1.9E - 4.8E - 13E - 16E - 19.2E - 23.5E - 26E - 33E - 39E - 42E - 45E on EMP Centauri DiseqC 16/1
Unamed: 13E Quattro - 9E Quattro on IKUSI MS-0916

Re: Custom Image #8 MiLo

  • PLi® Core member
  • 13,975 posts

+295
Excellent

Posted 15 September 2013 - 18:50

Don't use ":="


Real musicians never die - they just decompose

Re: Custom Image #9 athoik

  • PLi® Core member
  • 8,342 posts

+314
Excellent

Posted 15 September 2013 - 19:14

I will try without ":="

 

What about the spinner?

 

Now i am trying to change also the spinner but i think the code do_openpli_branding needs change in order to support changing spinner too.

if [ -n "${BRANDINGDIR}" -a -d "${BRANDINGDIR}/enigma2" ] ; then
- cp -p ${BRANDINGDIR}/enigma2/* ${S}/data/.
+ cp -rp ${BRANDINGDIR}/enigma2/* ${S}/data/ 
fi

Using "cp -p ${BRANDINGDIR}/enigma2/* ${S}/data/." you cannot copy subfolders.

cp: omitting directory `/.../enigma2/skin_default'

PS. In order to use BRANDINGDIR you must run bitbake like this MACHINE=XXX BRANDINGDIR=YYY bitbake my-image correct?

 

Thanks again.


Wavefield T90: 0.8W - 1.9E - 4.8E - 13E - 16E - 19.2E - 23.5E - 26E - 33E - 39E - 42E - 45E on EMP Centauri DiseqC 16/1
Unamed: 13E Quattro - 9E Quattro on IKUSI MS-0916

Re: Custom Image #10 athoik

  • PLi® Core member
  • 8,342 posts

+314
Excellent

Posted 17 September 2013 - 13:33

Recursive add contents of BRANDINGDIR to enigma2 data directory.

 

Attached File  0001-Recursive-add-contents-of-BRANDINGDIR-to-enigma2-dat.patch.txt   938bytes   36 downloads

 

Using this patch you can customize also files under subfolders, eg the spinner.

 

Patch is for upstream.


Wavefield T90: 0.8W - 1.9E - 4.8E - 13E - 16E - 19.2E - 23.5E - 26E - 33E - 39E - 42E - 45E on EMP Centauri DiseqC 16/1
Unamed: 13E Quattro - 9E Quattro on IKUSI MS-0916

Re: Custom Image #11 athoik

  • PLi® Core member
  • 8,342 posts

+314
Excellent

Posted 25 September 2013 - 20:06

Hello,

 

Maybe a silly question, is it possible to add 3rd-party plugin on image when you are building it?

 

There is no bitbake to add in IMAGE_INSTALL, so what is the best way to do that, create custom bitbake in meta-local?

 

Thanks once again.


Wavefield T90: 0.8W - 1.9E - 4.8E - 13E - 16E - 19.2E - 23.5E - 26E - 33E - 39E - 42E - 45E on EMP Centauri DiseqC 16/1
Unamed: 13E Quattro - 9E Quattro on IKUSI MS-0916





Also tagged with one or more of these keywords: image, bitbake

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users