Jump to content


Photo

Radio Streaming - VLC : regression in recent nightly build ?

vlc radio streaming

  • Please log in to reply
6 replies to this topic

#1 sebsto

  • Senior Member
  • 52 posts

0
Neutral

Posted 20 October 2013 - 07:34

Hello,

 

To correctly stream some radio channel to VLC, it is required to include the programID in the m3u file.

This modification has been made to openpli months ago.  But when testing recent builds, it does not work anymore.

 

Original topic on VLC trac : https://trac.videola...vlc/ticket/4264

Original Topic on OpenPli Forum : http://openpli.org/f...-39#entry265968

GitHub Commit with original fix : https://github.com/E...b7fdb0f56838e2b

 

Can someone explain why this is not working anymore ? How can we fix this ?

 

I just downloaded the M3U for one of the CSAT radio channel and I did receive :

 

#EXTM3U 
#EXTVLCOPT--http-reconnect=true 
http://192.168.0.96:8001/1:0:2:2151:400:1:C00000:0:0:0:
 

 

 
Thanks for your help
 
Seb


Re: Radio Streaming - VLC : regression in recent nightly build ? #2 blzr

  • PLi® Core member
  • 2,036 posts

+99
Good

Posted 20 October 2013 - 08:51

looks that a special setting has been added for this, with this comit:

https://github.com/E...00066fe3955866b

so, you need to set in openwebif config 'Add service name to stream information' to 'yes'

and everything should work as before...


True sarcasm doesn't need green font...

Re: Radio Streaming - VLC : regression in recent nightly build ? #3 sebsto

  • Senior Member
  • 52 posts

0
Neutral

Posted 20 October 2013 - 10:20

Thank you I missed that one

 

Seb



Re: Radio Streaming - VLC : regression in recent nightly build ? #4 sebsto

  • Senior Member
  • 52 posts

0
Neutral

Posted 20 October 2013 - 10:27

Short side question : are you pushing these changes back to Enigma2 and OpenWebIf trunk ?  Or are these specific to OpenPli ?

 

Thanks

 

Seb



Re: Radio Streaming - VLC : regression in recent nightly build ? #5 Robinson

  • Senior Member
  • 2,494 posts

+29
Good

Posted 29 October 2013 - 18:22

looks that a special setting has been added for this, with this comit:

https://github.com/E...00066fe3955866b

so, you need to set in openwebif config 'Add service name to stream information' to 'yes'

and everything should work as before...

 

I understand that setting Add service name to stream information to YES is necessary to stream some channels but does this setting have any bad side effects?

In other words, if it stays to YES all the time, would I experience any other problems?


ET9000, OpenPLi 4.0, 13E, 19E

HD51, OpenPLi 6.2, 75E - 30W


Re: Radio Streaming - VLC : regression in recent nightly build ? #6 blzr

  • PLi® Core member
  • 2,036 posts

+99
Good

Posted 29 October 2013 - 22:40

...

In other words, if it stays to YES all the time, would I experience any other problems?

 

well, I've never encountered  a n y ...

 

but, considering this (rather unexpected) change from the 'default' to 'optional', it could be, that this SID addition in m3u been messing up something in non-vlc streams /?/, or some plugins /?/
possibly someone else could tell more on this...


True sarcasm doesn't need green font...

Re: Radio Streaming - VLC : regression in recent nightly build ? #7 Robinson

  • Senior Member
  • 2,494 posts

+29
Good

Posted 30 October 2013 - 13:44

blzr, if I understand it correctly, this line has some side effects for transcoded streams (Solo2, Duo2).

See here: http://openpli.org/f...ndpost&p=372765

Am I right?


ET9000, OpenPLi 4.0, 13E, 19E

HD51, OpenPLi 6.2, 75E - 30W






1 user(s) are reading this topic

0 members, 1 guests, 0 anonymous users