Jump to content


Photo

New Zealand EPG


  • Please log in to reply
23 replies to this topic

Re: New Zealand EPG #21 doglover

  • Rytec EPG Team
  • 13,034 posts

+394
Excellent

Posted 19 July 2019 - 08:21

At first sight, I could not see anything wrong.

But I copied them to one of my receivers (Although, I cannot import it -but I can see in the log if there are mistakes).  And sure enough 2 errors.

 

Log:

[EPGImport] failed to open /etc/epgimport/nz.sources.xml Error: mismatched tag: line 8, column 2
sourcesDone():  False None
[EPGImport] WakeUpTime now set to 1563520941 (now=1563519960)
[EPGImport] WakeUpTime now set to 1563520941 (now=1563519985)
[EPGImport] Selected source:  ['Matt Huisman NZ EPG ']
sourcesDone():  False None
[EPGImport] nextImport, source= Matt Huisman NZ EPG
[EPGImport] Downloading: http://i.mjh.nz/nz/epg.xml.gz to local path: /tmp/epgimport.gz
[EPGImport] checkValidServer serverurl http://i.mjh.nz/nz/epg.xml.gz
[EPGImport] checkValidServer rejected server download error for: http://i.mjh.nz/nz
[EPGImport] download failed: checkValidServer reject the server
[EPGImport] imported 0 events
[EPGImport] Save last import date and count event
[EPGImport] Run check deep standby after import
[EPGImport] #### Finished ####

The first error is tag mismatch.  The sourcecat closing tag is missing.

 

The second error is an oversight of me.  A nocheck value has to be added.  The EPGimport routine checks if the file on a remote server is not outdated.  It needs a LastUpdate.txt file on the server.

This file is not present on the server you are using, and so EPGimport rejects the server.  This is not needed for local files.  But this is a remote server, which I did not take into account.

The solution is adding a nocheck parameter to the source.

 

The sources file should be this:

<?xml version="1.0" encoding="utf-8"?>
<sources>
<sourcecat sourcecatname="NZ XMLTV">
<source type="gen_xmltv" nocheck="1" channels="nz.channels.xml">
<description>Matt Huisman NZ EPG </description>
<url>http://i.mjh.nz/nz/epg.xml.gz</url>
</source>
</sourcecat>
</sources>

The log now looks this:

[EPGImport] Selected source:  ['Matt Huisman NZ EPG ']
sourcesDone():  False None
[EPGImport] nextImport, source= Matt Huisman NZ EPG
[EPGImport] Downloading: http://i.mjh.nz/nz/epg.xml.gz to local path: /tmp/epgimport.gz
[EPGImport] Not cheching the server since nocheck is set for it: http://i.mjh.nz/nz/epg.xml.gz
[EPGImport] afterDownload /tmp/epgimport.gz
[EPGImport] unlink /tmp/epgimport.gz
[EPGImport] afterChannelDownload None
[EPGImport] Using twisted thread
[EPGImport] Parsing channels from '/etc/epgimport/custom.channels.xml'
[EPGImport] Parsing channels from '/etc/epgimport/nz.channels.xml'
[EPGImport] Parsing channels from '/etc/epgimport/nz.channels.xml'
[XMLTVConverter] Enumerating event information
Unknown channel:  tv.redbull.tv
Unknown channel:  tv.9
Unknown channel:  tv.10
Unknown channel:  tv.11
Unknown channel:  tv.12
Unknown channel:  tv.13
Unknown channel:  tv.38
Unknown channel:  tv.14
Unknown channel:  tv.27
Unknown channel:  tv.30
Unknown channel:  tv.28
Unknown channel:  tv.65
Unknown channel:  tv.37
Unknown channel:  tv.55
Unknown channel:  tv.67
Unknown channel:  tv.20
Unknown channel:  tv.46
Unknown channel:  tv.58
Unknown channel:  tv.45
Unknown channel:  tv.7
Unknown channel:  tv.39
Unknown channel:  tv.56
Unknown channel:  tv.21
Unknown channel:  tv.36
Unknown channel:  tv.18
Unknown channel:  tv.63
Unknown channel:  tv.41
Unknown channel:  tv.60
Unknown channel:  tv.23
Unknown channel:  tv.24
Unknown channel:  tv.26
Unknown channel:  tv.51
[EPGImport] ### thread is ready ### Events: 0
[EPGImport] imported 0 events
[EPGImport] Save last import date and count event
[EPGImport] Run check deep standby after import
[EPGImport] #### Finished ####

It still imports nothing on my receiver, since I do not have these channels on the receiver, and therefore the entries in the log - Unknown channel

But the import is running.

 

Willy

 

PS:  To obtain the log.  Open EPGimport.  Press Menu.  Choose 1 to see the log.

Now you can save the log.  The log is stored in /tmp/


Edited by doglover, 19 July 2019 - 08:27.

~~Rytec Team~~
Xtrend ET6000 OpenPli (used as mediaplayer)
Mutant HD2400 OpenPli
Vu+ Duo OpenPli (backup)

Synology NAS

Sat: 13E, 19.2E, 23.5E and 28.2E
*Pli/Rytec EPG POWERED*


Re: New Zealand EPG #22 NZNinja

  • Member
  • 6 posts

0
Neutral

Posted 20 July 2019 - 04:51

Perfect.  Thank you.

 

Still no joy with the logs though, maybe it's a Vu+ / Blackhole issue?



Re: New Zealand EPG #23 doglover

  • Rytec EPG Team
  • 13,034 posts

+394
Excellent

Posted 20 July 2019 - 06:21

A Blackhole issue maybe.  VU+ machine with other software do not have a problem.

 

Willy


~~Rytec Team~~
Xtrend ET6000 OpenPli (used as mediaplayer)
Mutant HD2400 OpenPli
Vu+ Duo OpenPli (backup)

Synology NAS

Sat: 13E, 19.2E, 23.5E and 28.2E
*Pli/Rytec EPG POWERED*


Re: New Zealand EPG #24 NZNinja

  • Member
  • 6 posts

0
Neutral

Posted 21 July 2019 - 04:54

Funnily enough, when I successfully managed to run an import, it offers you the opportunity to save the logs (which isn't when you really need it)

 

Maybe because I hadn't closed the sourcecat tag the importer crashed and was unable to save the log file.






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users