Jump to content


Photo

DM800se hangs after a while playing 1080 mkv


  • Please log in to reply
22 replies to this topic

#1 kermith

  • Senior Member
  • 176 posts

+2
Neutral

Posted 25 November 2013 - 01:26

Hi,I use 800se for playing 1080 mkv files. Most of them have dts sound but it's down mixed because I only use my Samsung TV as the sound source. It down mixes great but after about 15 to 25 minutes the subtitles start to unsynch and right after that the picture itself freezes and jumps 1 frame forward unless I hit the stop button wait a minute or two and then stops the video. 

 

At this point if I start the video again it will freeze the picture right away so the only solution is to reboot the box. Then the video file will play again and if I'm luck it'll play for more than next 15 minutes. Then the freezing starts all over again and I have to reboot the box. 

 

This happens so often during watching watching a movie it's just pure pain. 

 

I used both OpenPli 3.0 as well as 4.0.

Is there anything I can do to be able to get rid of this problem? 

Please advise what I can do. 

 

/kerm


Edited by kermith, 25 November 2013 - 01:27.


Re: DM800se hangs after a while playing 1080 mkv #2 betacentauri

  • PLi® Core member
  • 6,115 posts

+271
Excellent

Posted 25 November 2013 - 01:41

Does the mkv contain many subtitles? If yes, remove all unnecessary subtitles. It's a known bug in gstreamer and no fix is available yet.
Xtrend ET-9200, ET-8000, ET-10000, OpenPliPC on Ubuntu 12.04

Re: DM800se hangs after a while playing 1080 mkv #3 Erik Slagter

  • PLi® Core member
  • 45,733 posts

+512
Excellent

Posted 25 November 2013 - 10:22

I create mkv's with more than one subtitle every now and then, it that's no problem (anymore - it just to be).

 

I'd rather suspect the DTS sound. Can't you remove the DTS sound? DTS sound is always a pain on STBes.


* Wavefrontier T90 with 28E/23E/19E/13E/9E/4.8E/0.8W/5W via SCR switches 2 x 2 x 6 user bands
* Ziggo digital cable TV (FTA)
I don't read PM -> if you have something to ask or to report, do it in the forum so others can benefit. I don't take freelance jobs.
Ik lees geen PM -> als je iets te vragen of te melden hebt, doe het op het forum, zodat anderen er ook wat aan hebben.

Re: DM800se hangs after a while playing 1080 mkv #4 betacentauri

  • PLi® Core member
  • 6,115 posts

+271
Excellent

Posted 25 November 2013 - 10:35

Here's the thread:
http://openpli.org/f...ndpost&p=365508

Read post before and after that specific post. And I only say it can be the problem.


Xtrend ET-9200, ET-8000, ET-10000, OpenPliPC on Ubuntu 12.04

Re: DM800se hangs after a while playing 1080 mkv #5 Erik Slagter

  • PLi® Core member
  • 45,733 posts

+512
Excellent

Posted 25 November 2013 - 10:42

Yes I am aware of the many gstreamer bugs ;) Including this one.

 

I am only saying I suspect the DTS track. So that's two possibilities to try, not?


* Wavefrontier T90 with 28E/23E/19E/13E/9E/4.8E/0.8W/5W via SCR switches 2 x 2 x 6 user bands
* Ziggo digital cable TV (FTA)
I don't read PM -> if you have something to ask or to report, do it in the forum so others can benefit. I don't take freelance jobs.
Ik lees geen PM -> als je iets te vragen of te melden hebt, doe het op het forum, zodat anderen er ook wat aan hebben.

Re: DM800se hangs after a while playing 1080 mkv #6 betacentauri

  • PLi® Core member
  • 6,115 posts

+271
Excellent

Posted 25 November 2013 - 10:45

Yes, 2 tries and you also might be right  ;)  Let's wait for user feedback...


Xtrend ET-9200, ET-8000, ET-10000, OpenPliPC on Ubuntu 12.04

Re: DM800se hangs after a while playing 1080 mkv #7 kermith

  • Senior Member
  • 176 posts

+2
Neutral

Posted 25 November 2013 - 13:04

Wow, 

Guys thanks for the answers! Well I've read through the posts and the links. I guess then I will have to use mkvmerge and see if this will work better.

I will try that and get back to you asap!

 

/kerm



Re: DM800se hangs after a while playing 1080 mkv #8 Erik Slagter

  • PLi® Core member
  • 45,733 posts

+512
Excellent

Posted 25 November 2013 - 13:04

Yes that would be very interesting to know.


* Wavefrontier T90 with 28E/23E/19E/13E/9E/4.8E/0.8W/5W via SCR switches 2 x 2 x 6 user bands
* Ziggo digital cable TV (FTA)
I don't read PM -> if you have something to ask or to report, do it in the forum so others can benefit. I don't take freelance jobs.
Ik lees geen PM -> als je iets te vragen of te melden hebt, doe het op het forum, zodat anderen er ook wat aan hebben.

Re: DM800se hangs after a while playing 1080 mkv #9 kermith

  • Senior Member
  • 176 posts

+2
Neutral

Posted 26 November 2013 - 00:50

OK, 

Here's what I did. Since I had a feeling that this wasn't caused by DTS I went with the suggestions betacentauri gave. 
Meaning that this would be caused by internal subtitles of the mkv. So I went ahead and surfed to http://www.fosshub.com/MKVToolNix.html and installed MKVToolNix for windows. 

 

The program is pretty easy to use, just install it and fire it up. Clicking "add" in the upper right corner brings you up an explorer window where you choose your .mkv file. Then in the middle of the window all you do is un-check the subtitles (or in this case all subtitles) that you don't need. Then all the way down just click "Start muxing" and it will output an untouched new muxed .mkv file, without the subtitles of course. The whole procedure took between 4-5 on my laptop with an i5 processor and 8 GB of RAM.

 

I do of course have an external .srt file.

 

Well, the next thing was for me to copy the file to my external drive and connect it to my DM800SE. 

And Boy, it was playing fluently like a colibree  ;) . No freezes no hiccups and even fast forward and backward worked like a charm! 

 

Fortunately MKVToolNix has also a batch option, which I haven't tried yet, but which means just doing a batch during the night and BAM all your files are ready to rock on Pli 4.0!!

 

Huge thanks to all you guys coming with suggestions on this! And I'm happy to say that it works at last!  :D

 

/kerm


Edited by kermith, 26 November 2013 - 00:52.


Re: DM800se hangs after a while playing 1080 mkv #10 betacentauri

  • PLi® Core member
  • 6,115 posts

+271
Excellent

Posted 26 November 2013 - 08:16

Does it took 4-5 minutes or hours? If hours, use another program. There are programs which can remove subtitles without processing the video.
Xtrend ET-9200, ET-8000, ET-10000, OpenPliPC on Ubuntu 12.04

Re: DM800se hangs after a while playing 1080 mkv #11 kermith

  • Senior Member
  • 176 posts

+2
Neutral

Posted 26 November 2013 - 12:46

It took 4-5 minutes and it doesn't process the video.  ;)



Re: DM800se hangs after a while playing 1080 mkv #12 Erik Slagter

  • PLi® Core member
  • 45,733 posts

+512
Excellent

Posted 26 November 2013 - 13:05

MKVmerge is smart.

 

Can you do me a favour an also try with the DTS track removed?


* Wavefrontier T90 with 28E/23E/19E/13E/9E/4.8E/0.8W/5W via SCR switches 2 x 2 x 6 user bands
* Ziggo digital cable TV (FTA)
I don't read PM -> if you have something to ask or to report, do it in the forum so others can benefit. I don't take freelance jobs.
Ik lees geen PM -> als je iets te vragen of te melden hebt, doe het op het forum, zodat anderen er ook wat aan hebben.

Re: DM800se hangs after a while playing 1080 mkv #13 kermith

  • Senior Member
  • 176 posts

+2
Neutral

Posted 26 November 2013 - 13:13

Do you mean remove the DTS track and keep the subtitles tracks?



Re: DM800se hangs after a while playing 1080 mkv #14 Erik Slagter

  • PLi® Core member
  • 45,733 posts

+512
Excellent

Posted 26 November 2013 - 13:20

Yep. I guess there is also an AC3 or MP2 track?


* Wavefrontier T90 with 28E/23E/19E/13E/9E/4.8E/0.8W/5W via SCR switches 2 x 2 x 6 user bands
* Ziggo digital cable TV (FTA)
I don't read PM -> if you have something to ask or to report, do it in the forum so others can benefit. I don't take freelance jobs.
Ik lees geen PM -> als je iets te vragen of te melden hebt, doe het op het forum, zodat anderen er ook wat aan hebben.

Re: DM800se hangs after a while playing 1080 mkv #15 ims

  • PLi® Core member
  • 11,574 posts

+172
Excellent

Posted 26 November 2013 - 15:02

yesterday I must remove subtitles and DTS from mkv, because enigma2 was restarted on DM800SE each 6 minut and XP1000 had problems on start yet.


Kdo nic nedělá, nic nezkazí!

Re: DM800se hangs after a while playing 1080 mkv #16 kermith

  • Senior Member
  • 176 posts

+2
Neutral

Posted 27 November 2013 - 10:11

Yep. I guess there is also an AC3 or MP2 track?

 

Nope, there's no other tracks than DTS.



Re: DM800se hangs after a while playing 1080 mkv #17 kermith

  • Senior Member
  • 176 posts

+2
Neutral

Posted 27 November 2013 - 10:12

yesterday I must remove subtitles and DTS from mkv, because enigma2 was restarted on DM800SE each 6 minut and XP1000 had problems on start yet.

 

Never had that problem. DTS works fine for me. The subtitles was the culprit so far...



Re: DM800se hangs after a while playing 1080 mkv #18 Erik Slagter

  • PLi® Core member
  • 45,733 posts

+512
Excellent

Posted 27 November 2013 - 12:07

Yep. I guess there is also an AC3 or MP2 track?

 

Nope, there's no other tracks than DTS.

Oh dear, usually they leave the non-DTS-track (which is mandatory) intact iirc.

 

Then to test you´d have to transcode the audio track.


* Wavefrontier T90 with 28E/23E/19E/13E/9E/4.8E/0.8W/5W via SCR switches 2 x 2 x 6 user bands
* Ziggo digital cable TV (FTA)
I don't read PM -> if you have something to ask or to report, do it in the forum so others can benefit. I don't take freelance jobs.
Ik lees geen PM -> als je iets te vragen of te melden hebt, doe het op het forum, zodat anderen er ook wat aan hebben.

Re: DM800se hangs after a while playing 1080 mkv #19 kermith

  • Senior Member
  • 176 posts

+2
Neutral

Posted 27 November 2013 - 16:26

 

Yep. I guess there is also an AC3 or MP2 track?

 

Nope, there's no other tracks than DTS.

Oh dear, usually they leave the non-DTS-track (which is mandatory) intact iirc.

 

Then to test you´d have to transcode the audio track.

 

Sure I'll transcode, give a New York minute ;)



Re: DM800se hangs after a while playing 1080 mkv #20 kermith

  • Senior Member
  • 176 posts

+2
Neutral

Posted 30 November 2013 - 02:28

So I transcoded the DTS to Dolby and .mkv ran smooth as well with the subtitles tracks in the video.
This actually means that one of the two has to be done, either delete the subtitles or transcode the DTS to make the .mkv run smoothly.

 

I prefer deleting the subtitles because it's faster and doesn't congest your PC which transcoding does.

Anyway any trick of the two will work, and lastly I just wish it could be somehow fixed in the future... or maybe that's to much to hope for :)

 

/kerm


Edited by kermith, 30 November 2013 - 02:28.





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users