Jump to content


Photo

Automatic Subtitle selection does not work properly.

Subtitle Automatic

  • Please log in to reply
12 replies to this topic

#1 Erfeniuses

  • Senior Member
  • 43 posts

0
Neutral

Posted 5 January 2014 - 18:43

Hi there.

Using OpenPLI v4 on VU+ Duo2. Kernel 3.3.8 / Enigma 2013-12-22 / update 2013-12-26.

 

There seems to be problem with automatic language selection, has been a long time.

When channel has many DVB / TTX languages, system selects always the one with ID Zero or similar, despite that language desired.

Attached File  subtitle_selections.jpg   31.3KB   46 downloads

 

Automatic selection for subtitles are here Finland (Suomi).

Attached File  subtitle_auto_settings.jpg   87.33KB   37 downloads

Can this be fixed?

Thank you.



Re: Automatic Subtitle selection does not work properly. #2 hemertje

  • Forum Moderator
    PLi® Core member
  • 33,244 posts

+118
Excellent

Posted 5 January 2014 - 18:52

which channel on which satellite position?

 

can you create a enigma2 log via Telnet?

 

stop enigma: init 4

start and log enigma in the telnet screen: enigma2


on the Glassfibre 1GB DVB-C...


Re: Automatic Subtitle selection does not work properly. #3 Erfeniuses

  • Senior Member
  • 43 posts

0
Neutral

Posted 5 January 2014 - 21:51

problems occure on Thor 0.8W mostly.

It seems that for the 1st time there is subtitles with PID 0 and it gets selected automatically, but after I have manually selected Finnish DVB subtitle, that Zero one has gone..

Attached File  zero_subtitle.jpg   24.42KB   16 downloads


Edited by Erfeniuses, 5 January 2014 - 21:56.


Re: Automatic Subtitle selection does not work properly. #4 Erfeniuses

  • Senior Member
  • 43 posts

0
Neutral

Posted 5 January 2014 - 22:01

I'm sorry I do not know how to produce log. Can you give me the commands. I'll post it to pastebin.



Re: Automatic Subtitle selection does not work properly. #5 betacentauri

  • PLi® Core member
  • 7,096 posts

+319
Excellent

Posted 5 January 2014 - 22:21

Hemertje already did that. Use telnet to login on your box. Then execute
init 4
This stops enigma2 and all recordings stop!!

Then at best execute
enigma2 > /tmp/e2.txt 2>&1

E2 starts then. Reproduce the problem. When you have finished, press Ctrl+c in telnet window. This stops e2. Then execute
init 3
to start the box normal.

In /tmp you find the file e2.txt. Post it here.
Xtrend ET-9200, ET-8000, ET-10000, OpenPliPC on Ubuntu 12.04

Re: Automatic Subtitle selection does not work properly. #6 Erfeniuses

  • Senior Member
  • 43 posts

0
Neutral

Posted 5 January 2014 - 23:17

Here it is

http://pastebin.com/9zv7k4Bm

 

I changed to channel "playing 1:0:1:CEB:21:46:E080000:0:0:0:" and there went to subtitles part where the TTX PID 0 was selected, not Finnish one.

Attached File  1_0_1_CEB_21_46_E080000_0_0_0.jpg   46.2KB   19 downloads


Edited by Erfeniuses, 5 January 2014 - 23:20.


Re: Automatic Subtitle selection does not work properly. #7 janejak

  • Senior Member
  • 284 posts

+11
Neutral

Posted 6 January 2014 - 00:17

I have checked at home i have same scannel but ok

Attached Files



Re: Automatic Subtitle selection does not work properly. #8 littlesat

  • PLi® Core member
  • 53,313 posts

+621
Excellent

Posted 6 January 2014 - 00:57

It could be cached that incorrect subtitle... Disable select subtitle stored by channel. I suggest the settings you use are somehow corrupted as the channel should not have dvb subs.

WaveFrontier 28.2E | 23.5E | 19.2E | 16E | 13E | 10/9E | 7E | 5E | 1W | 4/5W | 15W


Re: Automatic Subtitle selection does not work properly. #9 Erfeniuses

  • Senior Member
  • 43 posts

0
Neutral

Posted 6 January 2014 - 10:43

I had "prefere subtitle stored by service" disabled all the time and still subtile selection does not work.

This is my language settings.

Attached File  automatic_language_selections.jpg   105.15KB   12 downloads

 

I rebooted the device to English language, tuned to 4.8E ViasatExplorerHD and DVB pid 0 was selected.

Attached File  viasat_explorerHD_Subs.jpg   39.65KB   13 downloads.

When I manually select Finnish subs, that 0 sub vanishes.

 

I use Dreamset Settings Editor 2.39 to read / restore channels to my VU.



Re: Automatic Subtitle selection does not work properly. #10 Erfeniuses

  • Senior Member
  • 43 posts

0
Neutral

Posted 6 January 2014 - 17:45

littlesat You are corrent. Somehow Dreamset Settings Editor Corrupts the database and every channel gets DVB pid 0 sub that messes system up.

 

I Rescanned everything and rebooted. Now database is suppose to be clean and every channel has correct subtitle selections and automation works great!

Al Read the channels to "DreamBoxEdit v3.0" PC App and fed them back to VU. After reboot all channel sub selections were correct.

So Do  not Use Dreamset Settings Editor, use DreamBoxEdit instead!

 

Thank you all for helping.



Re: Automatic Subtitle selection does not work properly. #11 littlesat

  • PLi® Core member
  • 53,313 posts

+621
Excellent

Posted 6 January 2014 - 17:48

I know... this issue exist for a longer period.... please notify the auther of Dreamset Settings Editor... They are adding the subtitles that do not exist in the cache...


WaveFrontier 28.2E | 23.5E | 19.2E | 16E | 13E | 10/9E | 7E | 5E | 1W | 4/5W | 15W


Re: Automatic Subtitle selection does not work properly. #12 Erfeniuses

  • Senior Member
  • 43 posts

0
Neutral

Posted 6 January 2014 - 17:57

I just did file a bug report. :) I'm sorry for all the trouble I caused..



Re: Automatic Subtitle selection does not work properly. #13 littlesat

  • PLi® Core member
  • 53,313 posts

+621
Excellent

Posted 6 January 2014 - 18:08

Thanks.... and sorry it took a while before I did recognise the issue...


WaveFrontier 28.2E | 23.5E | 19.2E | 16E | 13E | 10/9E | 7E | 5E | 1W | 4/5W | 15W




Also tagged with one or more of these keywords: Subtitle, Automatic

1 user(s) are reading this topic

0 members, 1 guests, 0 anonymous users