Jump to content


Photo

Vu+ Solo2 DLNA / FUSE not available

dlna solo2 fuse

  • Please log in to reply
16 replies to this topic

#1 snake.bite

  • Member
  • 9 posts

+1
Neutral

Posted 10 January 2014 - 09:13

Hi,

I'm new to OpenPLI and Enigma. I have a fresh install of OpenPLI 4 on a brand new VU+ Solo2 and tried to install a DLNA browser. However, it complains about an unsatisfyable dependency to kernel-module-fuse:

 

root@vusolo2:~# opkg install enigma2-plugin-extensions-dlnabrowser
Installing enigma2-plugin-extensions-dlnabrowser (experimental-git8427+8d6204f-r0) to root...
Downloading http://downloads.pli...r0_vusolo2.ipk.
Collected errors:
 * satisfy_dependencies_for: Cannot satisfy the following dependencies for enigma2-plugin-extensions-dlnabrowser:
 *     kernel-module-fuse *

 * opkg_install_cmd: Cannot install package enigma2-plugin-extensions-dlnabrowser.

 

Using opkg list | grep fuse I cannot locate such a package. Which is probably correct, as

 

root@vusolo2:~# cat /proc/filesystems
nodev    sysfs

...

nodev    autofs
    fuseblk
nodev    fuse
nodev    fusectl

    udf
...

 

shows that it is compiled into the kernel.

 

How to proceed from here?

TIA,

Chris.



Re: Vu+ Solo2 DLNA / FUSE not available #2 Erik Slagter

  • PLi® Core member
  • 45,947 posts

+513
Excellent

Posted 10 January 2014 - 10:14

Actually there is no problem. If you install the package with dependencies forced, it will probably work.


* Wavefrontier T90 with 28E/23E/19E/13E/9E/4.8E/0.8W/5W via SCR switches 2 x 2 x 6 user bands
* Ziggo digital cable TV (FTA)
I don't read PM -> if you have something to ask or to report, do it in the forum so others can benefit. I don't take freelance jobs.
Ik lees geen PM -> als je iets te vragen of te melden hebt, doe het op het forum, zodat anderen er ook wat aan hebben.

Re: Vu+ Solo2 DLNA / FUSE not available #3 MiLo

  • PLi® Core member
  • 13,964 posts

+294
Excellent

Posted 10 January 2014 - 10:22

How to proceed from here?

Ask the plugin author to change the "depends" into a "recommends".
Real musicians never die - they just decompose

Re: Vu+ Solo2 DLNA / FUSE not available #4 snake.bite

  • Member
  • 9 posts

+1
Neutral

Posted 10 January 2014 - 13:51

Thanks for the heads up. Indeed, the plugin works when installed with --force-depends.

Will contact OE core (opkg indicates OE core mailing list as author) about this.



Re: Vu+ Solo2 DLNA / FUSE not available #5 MiLo

  • PLi® Core member
  • 13,964 posts

+294
Excellent

Posted 10 January 2014 - 14:49

I don't think that something called "enigma2-plugin-extensions-dlnabrowser" would REALLY have OE-core as its maintainer.
Real musicians never die - they just decompose

Re: Vu+ Solo2 DLNA / FUSE not available #6 macnuts

  • Senior Member
  • 420 posts

+14
Neutral

Posted 10 January 2014 - 17:45

From opkg info enigma2-plugin-extensions-dlnabrowser:

Maintainer: Felix Domke <tmbinc "at" elitedvb "dot" net>


Edited by macnuts, 10 January 2014 - 17:47.


Re: Vu+ Solo2 DLNA / FUSE not available #7 snake.bite

  • Member
  • 9 posts

+1
Neutral

Posted 10 January 2014 - 21:16

@macnuts: where did you find that? Mine shows:

 

root@vusolo2:~# opkg info enigma2-plugin-extensions-dlnabrowser - experimental-git8427+8d6204f-r0
Package: enigma2-plugin-extensions-dlnabrowser
Version: 1.0-r0

Depends: enigma2, djmount, fuse-utils, libfuse2, libupnp3, gst-plugins-bad-neonhttpsrc
Status: unknown ok not-installed
Architecture: mips32el
Maintainer: kos
MD5Sum: 3d6ef531ba50504d4ef5bc9589fa42bb
Size: 8978
Filename: enigma2-plugin-extensions-dlnabrowser_1.0-r0_mips32el.ipk
Description: this is dlna/upnp browser using djmount

Package: enigma2-plugin-extensions-dlnabrowser
Version: experimental-git8427+8d6204f-r0

Depends: libfuse2, kernel-module-fuse, fuse-utils, djmount, libupnp3
Status: install user installed
Section: base
Architecture: vusolo2
Maintainer: OE-Core Developers <openembedded-core@lists.openembedded.org>
MD5Sum: 0b55d887b87e463f5a93cd78cdc57b79
Size: 21714
Filename: enigma2-plugin-extensions-dlnabrowser_experimental-git8427+8d6204f-r0_vusolo2.ipk
Source: git://code.vuplus.com/git/dvbapp.git;protocol=http;branch=vuplus_experimental;tag=8d6204fa8ce5d67ebc0d5dbae5c77cce481b503d file://enigma2-plugin-systemplugins-dlnabrowser_20130723.patch;striplevel=1;apply=yes
Description: enigma2-plugin-extensions-dlnabrowser version experimental-
 gitAUTOINC+8d6204fa8c-r0  VU+ DLNA Browser plugin
Installed-Time: 1389349034
 



Re: Vu+ Solo2 DLNA / FUSE not available #8 macnuts

  • Senior Member
  • 420 posts

+14
Neutral

Posted 10 January 2014 - 21:39

Sorry for that.

 

I've just realized that at the time of writing last post latest image from vu+ was flashed. The maintainer output is from the same-named plugin in their feeds. I was working in console for some time and I forgot it is another image :wacko:  :wacko:  :wacko: I am sure about the plugin name as I copied it from Milo post above.

 

On openpli, I have the same output as yours.



Re: Vu+ Solo2 DLNA / FUSE not available #9 rytec

  • Rytec EPG Team
  • 1,082 posts

+22
Neutral

Posted 16 July 2014 - 10:52

Even with the --force-depends option I cannot install this package : opkg install --force-depends enigma2-plugin-extensions-dlnabrowser Installing enigma2-plugin-extensions-dlnabrowser (git8495+bbc3238-r0) to root... Downloading http://downloads.pli...0_mips32el.ipk. Configuring enigma2-plugin-extensions-dlnabrowser. Collected errors: * satisfy_dependencies_for: Cannot satisfy the following dependencies for enigma2-plugin-extensions-dlnabrowser: * kernel-module-fuse *
~~Rytec Team~~ VU Ultimo / VU Uno / VU Solo / Panasonic TH42-PV700 *Pli/Rytec EPG POWERED*

Re: Vu+ Solo2 DLNA / FUSE not available #10 MiLo

  • PLi® Core member
  • 13,964 posts

+294
Excellent

Posted 16 July 2014 - 19:13

fuse is built into the kernel. Hence there is no such package.

Edited by MiLo, 16 July 2014 - 19:13.

Real musicians never die - they just decompose

Re: Vu+ Solo2 DLNA / FUSE not available #11 Erik Slagter

  • PLi® Core member
  • 45,947 posts

+513
Excellent

Posted 24 July 2014 - 17:52

I will check the plugin.


* Wavefrontier T90 with 28E/23E/19E/13E/9E/4.8E/0.8W/5W via SCR switches 2 x 2 x 6 user bands
* Ziggo digital cable TV (FTA)
I don't read PM -> if you have something to ask or to report, do it in the forum so others can benefit. I don't take freelance jobs.
Ik lees geen PM -> als je iets te vragen of te melden hebt, doe het op het forum, zodat anderen er ook wat aan hebben.

Re: Vu+ Solo2 DLNA / FUSE not available #12 Erik Slagter

  • PLi® Core member
  • 45,947 posts

+513
Excellent

Posted 26 July 2014 - 18:37

Fixed (fingers crossed...), removed the dependency from the plugin.


* Wavefrontier T90 with 28E/23E/19E/13E/9E/4.8E/0.8W/5W via SCR switches 2 x 2 x 6 user bands
* Ziggo digital cable TV (FTA)
I don't read PM -> if you have something to ask or to report, do it in the forum so others can benefit. I don't take freelance jobs.
Ik lees geen PM -> als je iets te vragen of te melden hebt, doe het op het forum, zodat anderen er ook wat aan hebben.

Re: Vu+ Solo2 DLNA / FUSE not available #13 athoik

  • PLi® Core member
  • 8,296 posts

+310
Excellent

Posted 26 July 2014 - 19:29

Why not add?

KERNEL_BUILTIN_MODULES = "\
kernel-module-fuse \
"

This way the dependency will be correct.
Wavefield T90: 0.8W - 1.9E - 4.8E - 13E - 16E - 19.2E - 23.5E - 26E - 33E - 39E - 42E - 45E on EMP Centauri DiseqC 16/1
Unamed: 13E Quattro - 9E Quattro on IKUSI MS-0916

Re: Vu+ Solo2 DLNA / FUSE not available #14 Erik Slagter

  • PLi® Core member
  • 45,947 posts

+513
Excellent

Posted 27 July 2014 - 10:00

Because I didn't know ;)

Where to change this? Kernel recipe I guess?

Edited by Erik Slagter, 27 July 2014 - 10:01.

* Wavefrontier T90 with 28E/23E/19E/13E/9E/4.8E/0.8W/5W via SCR switches 2 x 2 x 6 user bands
* Ziggo digital cable TV (FTA)
I don't read PM -> if you have something to ask or to report, do it in the forum so others can benefit. I don't take freelance jobs.
Ik lees geen PM -> als je iets te vragen of te melden hebt, doe het op het forum, zodat anderen er ook wat aan hebben.

Re: Vu+ Solo2 DLNA / FUSE not available #15 MiLo

  • PLi® Core member
  • 13,964 posts

+294
Excellent

Posted 27 July 2014 - 10:04

Use RRECOMMENDS instead of RDEPENDS. That way, the install won't fail if the module isn't available.
Real musicians never die - they just decompose

Re: Vu+ Solo2 DLNA / FUSE not available #16 athoik

  • PLi® Core member
  • 8,296 posts

+310
Excellent

Posted 27 July 2014 - 12:23

KERNEL_BUILTIN_MODULES = "\
kernel-module-fuse \
"

 
 

Where to change this? Kernel recipe I guess?

 
Correct! This goes inside kernel recipe, eg for meta-dream is inside linux-dreambox.inc (http://sf.net/p/open...03c1d699178f174)

Another location could be the machine.conf, when you can specify modules builded into kernel for this machine.

Use RRECOMMENDS instead of RDEPENDS. That way, the install won't fail if the module isn't available.

That is also correct and much simpler ;)

Edited by athoik, 27 July 2014 - 12:24.

Wavefield T90: 0.8W - 1.9E - 4.8E - 13E - 16E - 19.2E - 23.5E - 26E - 33E - 39E - 42E - 45E on EMP Centauri DiseqC 16/1
Unamed: 13E Quattro - 9E Quattro on IKUSI MS-0916

Re: Vu+ Solo2 DLNA / FUSE not available #17 Erik Slagter

  • PLi® Core member
  • 45,947 posts

+513
Excellent

Posted 28 July 2014 - 18:25

I like the approach from athoik though, I am afraid though it will be a lot of work though:

- check all model's kernel if they all have fuse builtin

- change all model's+versions kernel bb files to include the directive


* Wavefrontier T90 with 28E/23E/19E/13E/9E/4.8E/0.8W/5W via SCR switches 2 x 2 x 6 user bands
* Ziggo digital cable TV (FTA)
I don't read PM -> if you have something to ask or to report, do it in the forum so others can benefit. I don't take freelance jobs.
Ik lees geen PM -> als je iets te vragen of te melden hebt, doe het op het forum, zodat anderen er ook wat aan hebben.





Also tagged with one or more of these keywords: dlna, solo2, fuse

1 user(s) are reading this topic

0 members, 1 guests, 0 anonymous users