Jump to content


Photo

OpenPLI 4 no recognize my r8712u WiFi Card


  • Please log in to reply
36 replies to this topic

#1 toxstoxs

  • Member
  • 33 posts

0
Neutral

Posted 10 January 2014 - 22:40

Hi to everyone.

 

I'm pretty new here and expecially with my new 800se

 

I've been running since 2 days ago the OpenPLi 3 image without any issue using my WiFi onboard. (recognized as r8712u

 

Once moved to OpenPLi 4 it's only available the LAN card.

 

Can someone be so kind to give some clear tips or ipk package to make it work on the new Image?

 

thank's a lot in advance for kind answers.

 

Alessandro



Re: OpenPLI 4 no recognize my r8712u WiFi Card #2 athoik

  • PLi® Core member
  • 8,395 posts

+321
Excellent

Posted 10 January 2014 - 22:45

Maybe we need to define correct machine features after MiLo changes (kernelwifi)


See http://sourceforge.n...d1bcf0d9f5191d/
Wavefield T90: 0.8W - 1.9E - 4.8E - 13E - 16E - 19.2E - 23.5E - 26E - 33E - 39E - 42E - 45E on EMP Centauri DiseqC 16/1
Unamed: 13E Quattro - 9E Quattro on IKUSI MS-0916

Re: OpenPLI 4 no recognize my r8712u WiFi Card #3 toxstoxs

  • Member
  • 33 posts

0
Neutral

Posted 10 January 2014 - 22:51

the wifi patch sound like a solution...

 

just... i really have no idea how to do it and where to start from.. :D

 

help!!!! :)



Re: OpenPLI 4 no recognize my r8712u WiFi Card #4 athoik

  • PLi® Core member
  • 8,395 posts

+321
Excellent

Posted 11 January 2014 - 08:21

Look here: http://sourceforge.n...reambox.inc#l23

 

The following change is required:

 

-MACHINE_FEATURES += "alsa usbhost 3dtv switchoff tpm dreambox"
+MACHINE_FEATURES += "alsa usbhost wlan kernelwifi externalwifi 3dtv switchoff tpm dreambox"

Wavefield T90: 0.8W - 1.9E - 4.8E - 13E - 16E - 19.2E - 23.5E - 26E - 33E - 39E - 42E - 45E on EMP Centauri DiseqC 16/1
Unamed: 13E Quattro - 9E Quattro on IKUSI MS-0916

Re: OpenPLI 4 no recognize my r8712u WiFi Card #5 toxstoxs

  • Member
  • 33 posts

0
Neutral

Posted 11 January 2014 - 10:01

So you are basically telling me that i need to replace the dreambox.inc file 

with the one posted in your link and edit it as below before to copy it into my box?

 

# dreambox.inc
include conf/machine/include/openpli.inc
 
EXTRA_IMAGEDEPENDS += "dreambox-secondstage-${MACHINE}"
 
GLIBC_EXTRA_OECONF = "--with-tls --with-__thread"
 
MACHINE_ESSENTIAL_EXTRA_RDEPENDS += "dreambox-dvb-modules-${MACHINE}"
 
include conf/machine/include/autoload-filesystems.inc
 
MACHINE_EXTRA_RRECOMMENDS = " \
gst-plugin-dreambox-dvbmediasink \
gst-plugin-dtsdownmix \
ntfs-3g \
kernel-module-cifs \
kernel-module-hmac \
kernel-module-md4 \
kernel-module-ecb \
dreambox-boot-progress \
"
 
#MACHINE_FEATURES += "alsa usbhost 3dtv switchoff tpm dreambox"
MACHINE_FEATURES += "alsa usbhost wlan kernelwifi externalwifi 3dtv switchoff tpm dreambox"
# Add "dreambox" override for recipes
MACHINEOVERRIDES .= ":dreambox"
 
PREFERRED_PROVIDER_virtual/bootloader = "dreambox-secondstage-${MACHINE}"
PREFERRED_PROVIDER_virtual/kernel = "linux-dreambox"
 
PREFERRED_PROVIDER_virtual/blindscan-dvbs = "dreambox-blindscan-utils"
PREFERRED_PROVIDER_virtual/blindscan-dvbc = "dreambox-blindscan-utils"
 
# Dreamboxes need old kernel headers to work
LINUX_LIBC_HEADERS_VERSION = "3.1"
PREFERRED_VERSION_linux-libc-headers = "${LINUX_LIBC_HEADERS_VERSION}"
PREFERRED_VERSION_linux-libc-headers-native = "${LINUX_LIBC_HEADERS_VERSION}"
PREFERRED_VERSION_nativesdk-linux-libc-headers = "${LINUX_LIBC_HEADERS_VERSION}"
 
PREFERRED_VERSION_linux-dreambox = "3.2"
 
KERNEL_IMAGETYPE = "vmlinux"
KERNEL_OUTPUT = "${KERNEL_IMAGETYPE}"
KERNEL_CONSOLE = "${@base_contains('OPENPLI_FEATURES', 'usbconsole', 'ttyS0,115200', 'null', d)}"
 
DREAMBOX_BUILDIMAGE = "buildimage --arch ${MACHINE} ${EXTRA_BUILDCMD} \
--erase-block-size ${DREAMBOX_ERASE_BLOCK_SIZE} \
--flash-size ${DREAMBOX_FLASH_SIZE} \
--sector-size ${DREAMBOX_SECTOR_SIZE}"
 
 
Is it correct the modified RED part?
 
where that file is located once connected to box with ftp?
Thanks


Re: OpenPLI 4 no recognize my r8712u WiFi Card #6 MiLo

  • PLi® Core member
  • 14,010 posts

+295
Excellent

Posted 11 January 2014 - 10:08

Pushed the fix:

https://sourceforge....b4a5c050004a6e/
Real musicians never die - they just decompose

Re: OpenPLI 4 no recognize my r8712u WiFi Card #7 athoik

  • PLi® Core member
  • 8,395 posts

+321
Excellent

Posted 11 January 2014 - 10:23

Thanks i am trying build now.
 
I posted the same paramaters as vuxxo.inc (vu has kernel 3.1 and dreambox has 3.2 so it should be ok)
 
BTW, why not making change on dreambox.inc like other boxes?


Wavefield T90: 0.8W - 1.9E - 4.8E - 13E - 16E - 19.2E - 23.5E - 26E - 33E - 39E - 42E - 45E on EMP Centauri DiseqC 16/1
Unamed: 13E Quattro - 9E Quattro on IKUSI MS-0916

Re: OpenPLI 4 no recognize my r8712u WiFi Card #8 toxstoxs

  • Member
  • 33 posts

0
Neutral

Posted 11 January 2014 - 11:53

What should i do then?

 

it has been released a new OpenPLi 4 image fixed .. dated 11-01-2014 ?

 

OpenPLi-4.0-beta-dm800se-20140111.zip

 

does contain the fix already?


Edited by toxstoxs, 11 January 2014 - 11:54.


Re: OpenPLI 4 no recognize my r8712u WiFi Card #9 MiLo

  • PLi® Core member
  • 14,010 posts

+295
Excellent

Posted 11 January 2014 - 12:00

Wait till tomorrow.
Real musicians never die - they just decompose

Re: OpenPLI 4 no recognize my r8712u WiFi Card #10 toxstoxs

  • Member
  • 33 posts

0
Neutral

Posted 11 January 2014 - 12:19

Wait till tomorrow.

thank's

 

can you gently report and confirm here if , once released the 12-01-2014 build .. will it include the fix?

Just in order to don't flash it and go crazy once more.. :D



Re: OpenPLI 4 no recognize my r8712u WiFi Card #11 athoik

  • PLi® Core member
  • 8,395 posts

+321
Excellent

Posted 11 January 2014 - 12:25

The fix will install by default wifi drivers into the image. So that users don't have to install manually kernel modules,firmware etc.

 

I guess if you run the following (via telnet/ssh) will install the missing drivers.

 

opkg update
opkg install firmware-rtl8712u
opkg install kernel-module-r8712u

Wavefield T90: 0.8W - 1.9E - 4.8E - 13E - 16E - 19.2E - 23.5E - 26E - 33E - 39E - 42E - 45E on EMP Centauri DiseqC 16/1
Unamed: 13E Quattro - 9E Quattro on IKUSI MS-0916

Re: OpenPLI 4 no recognize my r8712u WiFi Card #12 pieterg

  • PLi® Core member
  • 32,766 posts

+245
Excellent

Posted 11 January 2014 - 12:48

indeed, there is no need to reflash

Re: OpenPLI 4 no recognize my r8712u WiFi Card #13 toxstoxs

  • Member
  • 33 posts

0
Neutral

Posted 11 January 2014 - 13:01

telnet command are possible to be sent with PUTTY?

 

i'm new on this so... forgive if i ask maybe too simple things.



Re: OpenPLI 4 no recognize my r8712u WiFi Card #14 WanWizard

  • PLi® Core member
  • 58,470 posts

+1,276
Excellent

Posted 11 January 2014 - 13:06

Yes.


Currently in use: VU+Duo 4K (2xFBC S2), Amiko Viper T2C (T2+fallback), Octagon SF8008 (S2+T2), Zgemma H9.2H (T2+fallback)

Many answers to your question can be found in our new and improved wiki.

Because to health reasons, I will not be active online very often anymore.


Re: OpenPLI 4 no recognize my r8712u WiFi Card #15 toxstoxs

  • Member
  • 33 posts

0
Neutral

Posted 11 January 2014 - 13:11

wich are the default login and psw for openpli4 telnet connection?

 

243r24324343.png1313342.png


Edited by toxstoxs, 11 January 2014 - 13:14.


Re: OpenPLI 4 no recognize my r8712u WiFi Card #16 dirocca

  • Senior Member
  • 1,667 posts

+59
Good

Posted 11 January 2014 - 13:13

telnet command are possible to be sent with PUTTY?

 

i'm new on this so... forgive if i ask maybe too simple things.

you could also use DCC, it gives you the possibility to connect to the box with telnet and ftp(it´s very handy and user vriendly) ;)

 

Attached File  dcce2_150.zip   5.37MB   32 downloads

 

grtz Philip


vuduo2 openpli6.1 1TB HDD 2xdualS2tuner

av receiver denon - samsung 4k hdr+ 65inch UE65MU7000 - bose accoustimas 7.1 :rolleyes:

tvv kaart & schotel(64cm), duo lnb, OSCAM

logitech harmony ultimate

 

 

 


Re: OpenPLI 4 no recognize my r8712u WiFi Card #17 dirocca

  • Senior Member
  • 1,667 posts

+59
Good

Posted 11 January 2014 - 13:15

login; root

passwd empty

 

grtz Philip


vuduo2 openpli6.1 1TB HDD 2xdualS2tuner

av receiver denon - samsung 4k hdr+ 65inch UE65MU7000 - bose accoustimas 7.1 :rolleyes:

tvv kaart & schotel(64cm), duo lnb, OSCAM

logitech harmony ultimate

 

 

 


Re: OpenPLI 4 no recognize my r8712u WiFi Card #18 toxstoxs

  • Member
  • 33 posts

0
Neutral

Posted 11 January 2014 - 13:21

after telnet commands is necessary a hard reboot yes?



Re: OpenPLI 4 no recognize my r8712u WiFi Card #19 WanWizard

  • PLi® Core member
  • 58,470 posts

+1,276
Excellent

Posted 11 January 2014 - 13:23

Always restart the box from the menu using the remote, never from the commandline using 'reboot' or 'shutdown'.

 

Enigma needs to be shutdown correctly, in order to flush runtime data in memory (EPG, changed channel list settings, config, etc).


Currently in use: VU+Duo 4K (2xFBC S2), Amiko Viper T2C (T2+fallback), Octagon SF8008 (S2+T2), Zgemma H9.2H (T2+fallback)

Many answers to your question can be found in our new and improved wiki.

Because to health reasons, I will not be active online very often anymore.


Re: OpenPLI 4 no recognize my r8712u WiFi Card #20 toxstoxs

  • Member
  • 33 posts

0
Neutral

Posted 11 January 2014 - 13:27

ok.. now once inside the NETWORK System menu it show both adapter LAN and r8712u but...

 

once inside the WiFi panel and entering the Configuration of it.. it report  : Wireless Plugin not installed

 

I execuded succesfull those 3 telnet commands and made a hard reboot.

 

 

opkg update
opkg install firmware
-rtl8712u
opkg install kernel
-module-r8712u

 

Something else is missing or to be enabled somewhere?


Edited by toxstoxs, 11 January 2014 - 13:27.



1 user(s) are reading this topic

0 members, 1 guests, 0 anonymous users