Jump to content


Photo

Unable to compile gst-1.0 branch


  • Please log in to reply
249 replies to this topic

#1 theparasol

  • Senior Member
  • 4,148 posts

+196
Excellent

Posted 25 January 2014 - 11:44

The master git clone and compile works fine :)

 

I can clone the gst-1.0 branch too but I'm unable to compile the gst-1.0 branch. If you ask me this branch is broken.

 

 

Attached Files


@Camping: ZGemma H.2S, Technisat Multytenne 4-in-1 @Home: Edision Mini 4K, Wave Frontier T55, EMP Centauri EMP DiSEqC 8/1 switch, 4x Inverto Ultra Black single LNB


Re: Unable to compile gst-1.0 branch #2 Erik Slagter

  • PLi® Core member
  • 46,759 posts

+536
Excellent

Posted 25 January 2014 - 11:52

I think it's safest to remove your tmp directory first. And indeed it may be possible the branch has become outdated. Did you do a git submodule update?


* Wavefrontier T90 with 28E/23E/19E/13E/9E/4.8E/0.8W/5W via SCR switches 2 x 2 x 6 user bands
* Ziggo digital cable TV (FTA)
I don't read PM -> if you have something to ask or to report, do it in the forum so others can benefit. I don't take freelance jobs.
Ik lees geen PM -> als je iets te vragen of te melden hebt, doe het op het forum, zodat anderen er ook wat aan hebben.

Re: Unable to compile gst-1.0 branch #3 theparasol

  • Senior Member
  • 4,148 posts

+196
Excellent

Posted 25 January 2014 - 12:00

tmp is clean, after doing a submodule update this happens:

 

Attached Files


@Camping: ZGemma H.2S, Technisat Multytenne 4-in-1 @Home: Edision Mini 4K, Wave Frontier T55, EMP Centauri EMP DiSEqC 8/1 switch, 4x Inverto Ultra Black single LNB


Re: Unable to compile gst-1.0 branch #4 betacentauri

  • PLi® Core member
  • 7,158 posts

+321
Excellent

Posted 25 January 2014 - 12:00

It will take much effort to make it working. The old openpli core uses still old git urls:

SRC_URI = "git://openpli.git.sourceforge.net/gitroot/openpli/enigma2;protocol=git;branch=${ENIGMA2_BRANCH}"

 

http://sourceforge.n...gma2/enigma2.bb


Xtrend ET-9200, ET-8000, ET-10000, OpenPliPC on Ubuntu 12.04

Re: Unable to compile gst-1.0 branch #5 Erik Slagter

  • PLi® Core member
  • 46,759 posts

+536
Excellent

Posted 25 January 2014 - 12:03

IIRC the gst-1 branch is based on OpenPLi 2.1 which in turn is based on OE 2.0. I can think of reasons why that won't work ;)

 

I think the best approach is, like MiLo said, is to NOT use this branch, do a clean checkout of master, make your own branch locally, and then remove the gst overrides we do in meta-openpli, which will cause the mainstream gst (1.0) to be used.


* Wavefrontier T90 with 28E/23E/19E/13E/9E/4.8E/0.8W/5W via SCR switches 2 x 2 x 6 user bands
* Ziggo digital cable TV (FTA)
I don't read PM -> if you have something to ask or to report, do it in the forum so others can benefit. I don't take freelance jobs.
Ik lees geen PM -> als je iets te vragen of te melden hebt, doe het op het forum, zodat anderen er ook wat aan hebben.

Re: Unable to compile gst-1.0 branch #6 betacentauri

  • PLi® Core member
  • 7,158 posts

+321
Excellent

Posted 25 January 2014 - 12:03

I think it's a better idea to use current openpli core and edit the receipts. Means move gstreamer 1.x receipts to openpli core. Change branch for dvbmediasink and gstsubsink.


Xtrend ET-9200, ET-8000, ET-10000, OpenPliPC on Ubuntu 12.04

Re: Unable to compile gst-1.0 branch #7 Erik Slagter

  • PLi® Core member
  • 46,759 posts

+536
Excellent

Posted 25 January 2014 - 12:05

LOL we agree ;)


* Wavefrontier T90 with 28E/23E/19E/13E/9E/4.8E/0.8W/5W via SCR switches 2 x 2 x 6 user bands
* Ziggo digital cable TV (FTA)
I don't read PM -> if you have something to ask or to report, do it in the forum so others can benefit. I don't take freelance jobs.
Ik lees geen PM -> als je iets te vragen of te melden hebt, doe het op het forum, zodat anderen er ook wat aan hebben.

Re: Unable to compile gst-1.0 branch #8 theparasol

  • Senior Member
  • 4,148 posts

+196
Excellent

Posted 25 January 2014 - 12:10

Very nice, you are all experienced git users, unlike me :)

 

Tnx for pointers, now its up to me to discover and experiment how to do this... small slow steps before I can even start to test and code on gstreamer changes ;)


@Camping: ZGemma H.2S, Technisat Multytenne 4-in-1 @Home: Edision Mini 4K, Wave Frontier T55, EMP Centauri EMP DiSEqC 8/1 switch, 4x Inverto Ultra Black single LNB


Re: Unable to compile gst-1.0 branch #9 betacentauri

  • PLi® Core member
  • 7,158 posts

+321
Excellent

Posted 25 January 2014 - 12:18

Not really. I'm learning by doing...
 

Try to delete this folder: meta-openpli/recipes-multimedia/gstreamer

Then I guess this folder is used: openembedded-core/meta/recipes-multimedia/gstreamer

And so gstreamer version 1.2.2

 

Then you need to change the branch for dvbmediasink and gstsubsink (the gst-1.0 branch should still work, I hope)....

 

Take a look at the commits what they have changed for gst-1.0 branch:

http://sourceforge.n...f614/log/?path=


Xtrend ET-9200, ET-8000, ET-10000, OpenPliPC on Ubuntu 12.04

Re: Unable to compile gst-1.0 branch #10 Erik Slagter

  • PLi® Core member
  • 46,759 posts

+536
Excellent

Posted 25 January 2014 - 12:31

Very nice, you are all experienced git users, unlike me :)

Experience comes with doing ;) Also, I find there are many very good articles on specific tasks in git on internet, they've proven to be very instructive.

 

Unlike bitbake and OE, where you really have to learn by doing.


Edited by Erik Slagter, 25 January 2014 - 12:31.

* Wavefrontier T90 with 28E/23E/19E/13E/9E/4.8E/0.8W/5W via SCR switches 2 x 2 x 6 user bands
* Ziggo digital cable TV (FTA)
I don't read PM -> if you have something to ask or to report, do it in the forum so others can benefit. I don't take freelance jobs.
Ik lees geen PM -> als je iets te vragen of te melden hebt, doe het op het forum, zodat anderen er ook wat aan hebben.

Re: Unable to compile gst-1.0 branch #11 theparasol

  • Senior Member
  • 4,148 posts

+196
Excellent

Posted 25 January 2014 - 12:45

I'm just a bit annoyed and disappointed to must first master git and then i can attempt the coding.
Coding i like... Not git ;)

Elah happened before with cisco configs... Now i even like does devices!

@Camping: ZGemma H.2S, Technisat Multytenne 4-in-1 @Home: Edision Mini 4K, Wave Frontier T55, EMP Centauri EMP DiSEqC 8/1 switch, 4x Inverto Ultra Black single LNB


Re: Unable to compile gst-1.0 branch #12 Erik Slagter

  • PLi® Core member
  • 46,759 posts

+536
Excellent

Posted 25 January 2014 - 12:54

Take it from me, you'll learn to appreciate git. First you get the steep hill of "I only want... in svn that's all far more simple..." and then at some point one gets to see what's possible and what svn can't do. E.g. afaik there is no way in svn to prepare a commit and review it, edit it, review it again, etc. before you send it to upstream. Or to re-organise some commits you made locally.


* Wavefrontier T90 with 28E/23E/19E/13E/9E/4.8E/0.8W/5W via SCR switches 2 x 2 x 6 user bands
* Ziggo digital cable TV (FTA)
I don't read PM -> if you have something to ask or to report, do it in the forum so others can benefit. I don't take freelance jobs.
Ik lees geen PM -> als je iets te vragen of te melden hebt, doe het op het forum, zodat anderen er ook wat aan hebben.

Re: Unable to compile gst-1.0 branch #13 littlesat

  • PLi® Core member
  • 53,493 posts

+630
Excellent

Posted 25 January 2014 - 12:56

Just an idea... Merge master into the gstreamer branch first...

WaveFrontier 28.2E | 23.5E | 19.2E | 16E | 13E | 10/9E | 7E | 5E | 1W | 4/5W | 15W


Re: Unable to compile gst-1.0 branch #14 Erik Slagter

  • PLi® Core member
  • 46,759 posts

+536
Excellent

Posted 25 January 2014 - 13:00

????


* Wavefrontier T90 with 28E/23E/19E/13E/9E/4.8E/0.8W/5W via SCR switches 2 x 2 x 6 user bands
* Ziggo digital cable TV (FTA)
I don't read PM -> if you have something to ask or to report, do it in the forum so others can benefit. I don't take freelance jobs.
Ik lees geen PM -> als je iets te vragen of te melden hebt, doe het op het forum, zodat anderen er ook wat aan hebben.

Re: Unable to compile gst-1.0 branch #15 christophecvr

  • Senior Member
  • 3,131 posts

+140
Excellent

Posted 25 January 2014 - 13:22

Just an idea... Merge master into the gstreamer branch first...

I do not think that will work out

 

What I saw is that the gst-1.0 branch is still openpli 3.0 .

 

Removing the gstreamer out off ./met-openpli/recipes-multimedia is not enough.

 

Enigma2.bb dvbmediasink gstsubsink and ...must be changed as well. But even when build will succeed, I guess many applications will not work quite ok, just cause they ass well need to be modified.



Re: Unable to compile gst-1.0 branch #16 Erik Slagter

  • PLi® Core member
  • 46,759 posts

+536
Excellent

Posted 25 January 2014 - 13:26

I guess the way to is

 

1) make clean compiling image with gst-1, by removing our 0.1-overrides. The resulting image probably won't work, but that's ok

2) port the current patches on the dvbsink to gst-1. this may be as easy as applying them and maybe only a few offsets have changed, and then make a new patch, but more probable is find out what the patches do and re-implement them on gst-1...


* Wavefrontier T90 with 28E/23E/19E/13E/9E/4.8E/0.8W/5W via SCR switches 2 x 2 x 6 user bands
* Ziggo digital cable TV (FTA)
I don't read PM -> if you have something to ask or to report, do it in the forum so others can benefit. I don't take freelance jobs.
Ik lees geen PM -> als je iets te vragen of te melden hebt, doe het op het forum, zodat anderen er ook wat aan hebben.

Re: Unable to compile gst-1.0 branch #17 christophecvr

  • Senior Member
  • 3,131 posts

+140
Excellent

Posted 25 January 2014 - 13:57

I'm just for trie making a build with gst-1.0

 

First removed the gstreamer map out of meta-openpli/recipes-multimedia

 

Then changed the file enigma2.bb 

and the file gstsubsink.

 

It's now building 

 

but I could not find dvbsink



Re: Unable to compile gst-1.0 branch #18 betacentauri

  • PLi® Core member
  • 7,158 posts

+321
Excellent

Posted 25 January 2014 - 14:03

Sorry, you may not remove the hole folder. The dvbmediasink bitbake file is in the folder. See here
http://sourceforge.n...edia/gstreamer/
Xtrend ET-9200, ET-8000, ET-10000, OpenPliPC on Ubuntu 12.04

Re: Unable to compile gst-1.0 branch #19 christophecvr

  • Senior Member
  • 3,131 posts

+140
Excellent

Posted 25 January 2014 - 14:20

Sorry, you may not remove the hole folder. The dvbmediasink bitbake file is in the folder. See here
http://sourceforge.n...edia/gstreamer/

ok I' stop my build.

 

Now that have all changes I first wil create another branch then it's easy to produce I git patch (just for info whit all changes combined)



Re: Unable to compile gst-1.0 branch #20 christophecvr

  • Senior Member
  • 3,131 posts

+140
Excellent

Posted 25 January 2014 - 14:50

Here already a couple changes done to master to have GST-1.0 . I just made a git patch (its two patches in one as I needed to correct a typo)

 

I just trying a build now (for vuduo2). Do not know if it's ok

 

But then there is already a first resumé

Attached Files




1 user(s) are reading this topic

0 members, 1 guests, 0 anonymous users