Jump to content


Photo

Argolis Smargo Smartreader V2 update problem

argolis smargo smartreader v2 update problem

  • Please log in to reply
16 replies to this topic

#1 Andreas

  • Member
  • 7 posts

0
Neutral

Posted 6 February 2014 - 10:13

Hi, I'm posting here on advise from Argolis sales and support, I'm having problems with updating the Smargo Smartreader V2 that I purchased/received this week.

 

I've downloaded the smartreader2update and smartreader2tool both for windows and linux, and ran it on several machines (windows 7 all updates/ubuntu 12.04 all updates).

 

On both platforms the device starts blinking blue (LED) upon insertion, but update attempts fail.. below is some information for each platform - if anyone can offer help/suggestion/insight it's appreciated.

 

 

This is the output of "dmesg" in ubuntu:

 

[63464.696069] usb 3-1: new full-speed USB device number 2 using uhci_hcd

[63464.867132] usb 3-1: New USB device found, idVendor=0403, idProduct=6001

[63464.867142] usb 3-1: New USB device strings: Mfr=1, Product=2, SerialNumber=3

[63464.867149] usb 3-1: Product: Smartreader2 plus

[63464.867155] usb 3-1: Manufacturer: Argolis BV

[63464.867160] usb 3-1: SerialNumber:         

[63464.943006] usbcore: registered new interface driver usbserial

[63464.943022] usbcore: registered new interface driver usbserial_generic

[63464.943032] usbserial: USB Serial support registered for generic

[63464.954879] usbcore: registered new interface driver ftdi_sio

[63464.954891] usbserial: USB Serial support registered for FTDI USB Serial Device

[63464.954969] ftdi_sio 3-1:1.0: FTDI USB Serial Device converter detected

[63464.954989] usb 3-1: Detected FT232BM

[63464.954991] usb 3-1: Number of endpoints 2

[63464.954992] usb 3-1: Endpoint 1 MaxPacketSize 64

[63464.954994] usb 3-1: Endpoint 2 MaxPacketSize 64

[63464.954996] usb 3-1: Setting MaxPacketSize 64

[63464.958168] usb 3-1: FTDI USB Serial Device converter now attached to ttyUSB0

 

But still I get this error when running the update:

 

./smartreader2update 

 

COM_ERROR (/dev/ttyUSB0)

 

 

 

And in Windows 7 no drivers are installed, the device is simply listed as "Smartreader plus" - and the update executable just keeps asking me to insert the device.. please see attached pic of the device manager

 

 

 

Anyone had this problem? I've contacted the selling site, the argolis sales/support - and they pointed me here(?)

 

 

 

//Br, Andreas

Attached Files



Re: Argolis Smargo Smartreader V2 update problem #2 Kosh

  • Senior Member
  • 424 posts

+5
Neutral

Posted 6 February 2014 - 12:01

Since you are installing the device on the PC and it does not work as expected, they should be the ones helping you.

This is primarily an STB-forum, not for PC support. If you can't get it to run on an STB you might try and ask again here.


ET10K user i.c.w. Samsung UE40B6000 LED HDTV. ET9K alas not functioning anymore.


Re: Argolis Smargo Smartreader V2 update problem #3 Andreas

  • Member
  • 7 posts

0
Neutral

Posted 6 February 2014 - 12:21

Since you are installing the device on the PC and it does not work as expected, they should be the ones helping you.

This is primarily an STB-forum, not for PC support. If you can't get it to run on an STB you might try and ask again here.

 

 

Yeah, I thought so as well, and included a question on that in my reply to sales/support at argolis:

 

openpli is a forum for the openpli-firmware? I'm not using a box/openpli.. I don't intend to either, why post there? what's the connection to argolis/smargo?

 

 

I have however been using openpli on a dreambox previously, worked perfectly (: I posted this question as they asked/directed me to do so.

 

 

As I stated previously, any insight/thoughts/help is appreciated - but if a moderator/admin thinks this topic should be closed that's of course okay.



Re: Argolis Smargo Smartreader V2 update problem #4 waterpas

  • Senior Member
  • 68 posts

+2
Neutral

Posted 6 February 2014 - 13:22

Is it really necessary to update your device? I got it working on an E2 STB, how ever up untill now all 3 readers won't read my Conax-card, Seca3-card works well! Maybe you need some extra plugins to get it working. See below (OScam werkt niet) if you need any translations....



Re: Argolis Smargo Smartreader V2 update problem #5 Andreas

  • Member
  • 7 posts

0
Neutral

Posted 6 February 2014 - 14:06

Is it really necessary to update your device? I got it working on an E2 STB, how ever up untill now all 3 readers won't read my Conax-card, Seca3-card works well! Maybe you need some extra plugins to get it working. See below (OScam werkt niet) if you need any translations....

 

I see your point, but as it is now I don't seem to be able to open communication to the device in any case, that kinda throws a wrench in the system.. and also I'd like to be able to assign the "id" to the device as the product advertises );



Re: Argolis Smargo Smartreader V2 update problem #6 radxnl

  • Senior Member
  • 1,527 posts

+57
Good

Posted 6 February 2014 - 14:24

on your linux system start with:

 

cat /dev/ttyUSB0 to see if your access rights are setup correctly ( default distro installation sometimes requires root only access ( = bad ) to serial ports )



Re: Argolis Smargo Smartreader V2 update problem #7 Andreas

  • Member
  • 7 posts

0
Neutral

Posted 7 February 2014 - 08:11

on your linux system start with:

 

cat /dev/ttyUSB0 to see if your access rights are setup correctly ( default distro installation sometimes requires root only access ( = bad ) to serial ports )

 

Thank you radxnl - that's the ticket (: and I should have thought of that myself (or the manufacturer). I modified my users groups and gained access, and the smartreader2-tools worked as supposed.

 

That enables me to use the product with Ubuntu - but it's still not recognized/installed correctly in Windows (7 in my case) - any thoughts on that?

 

 

EDIT: is there a "thank you"/rep-system? if so I'd like to +1 radxnl for this (:


Edited by Andreas, 7 February 2014 - 08:13.


Re: Argolis Smargo Smartreader V2 update problem #8 Frenske

  • Forum Moderator
    PLi® Core member
  • 23,519 posts

+219
Excellent

Posted 7 February 2014 - 09:11


 EDIT: is there a "thank you"/rep-system? if so I'd like to +1 radxnl for this (:


Try the green thumb on the right bottom in the posting from Radxnl. ;)
Mijn schotel is een T90 met 10 LNB's. Daarnaast voor de fun nog een draaibaar systeem met een Triax TD 78.

Dreamboxen heb ik niet meer. Verder nog een een VU+ duo2 met 500Gb harddisk + een VU+ Uno, Zero, Solo 4K, Ultimo 4K, Zero 4K, Uno 4Kse. + ook nog een Xtrend ET4000. Daarnaast heb ik ook nog diverse andere modellen w.o. een Formuler F4, ET8500, ET7500, Mut@nt 2400HD, Xsarius Fusion HD se en verder nog wel het e.e.a. waarmee op verzoek vanalles wordt getest. Iemand moet het tenslotte doen. ;) :)

Voor centrale opslag van media gebruik ik een Qnap 219P met tweemaal 2 Tb harddisks.

-------------------------------------------------------------------------------------------
Many answers to your question can be found in our wiki: Just one click away from this "solutioncentre".

Als ik alles al wist hoefde ik ook niets te vragen. If I had all the knowledge I had no questions at all.

Re: Argolis Smargo Smartreader V2 update problem #9 Andreas

  • Member
  • 7 posts

0
Neutral

Posted 7 February 2014 - 11:48


 EDIT: is there a "thank you"/rep-system? if so I'd like to +1 radxnl for this (:


Try the green thumb on the right bottom in the posting from Radxnl. ;)

 

I don't see it.. not on your post either, do you?

 

2eeflm1.png



Re: Argolis Smargo Smartreader V2 update problem #10 WanWizard

  • Forum Moderator
    PLi® Core member
  • 52,532 posts

+1,021
Excellent

Posted 7 February 2014 - 12:05

It's use is restricted to senior members of this forum. This was done to prevent mis-use (users creating dummy accounts, then giving themselfs a lot of thumbs-up).


Currently in use: VU+Duo 4K (2xFBC S2), Amiko Viper T2C (T2), Octagon SF8008 (S2+T2), SAB Alpha Triple HD (S2+T2), Zgemma H9.2H (T2+fallback)

Many answers to your question can be found in our new and improved wiki.

note: I do not provide support via PM !

 


Re: Argolis Smargo Smartreader V2 update problem #11 Andreas

  • Member
  • 7 posts

0
Neutral

Posted 7 February 2014 - 12:14

It's use is restricted to senior members of this forum. This was done to prevent mis-use (users creating dummy accounts, then giving themselfs a lot of thumbs-up).

 

Makes sense (: sad to have to go out of the way to avoid semi-idiotic behavior (; virtual bragging rights abused to the max

 

A big thanks to radxnl from me instead then (:

 

 

Any thoughts on why the smartreader isn't correctly detected/installed in Windows 7 is appreciated - although you guys already helped a lot! (manufacturer, take notes)



Re: Argolis Smargo Smartreader V2 update problem #12 WanWizard

  • Forum Moderator
    PLi® Core member
  • 52,532 posts

+1,021
Excellent

Posted 7 February 2014 - 12:31

Yeah, unfortunately there are people like that...

 

I'll click the "thumbs up" for you. ;)

 

And I can't help you with your question, don't use those readers, and haven't seen Windows in years...


Currently in use: VU+Duo 4K (2xFBC S2), Amiko Viper T2C (T2), Octagon SF8008 (S2+T2), SAB Alpha Triple HD (S2+T2), Zgemma H9.2H (T2+fallback)

Many answers to your question can be found in our new and improved wiki.

note: I do not provide support via PM !

 


Re: Argolis Smargo Smartreader V2 update problem #13 Andreas

  • Member
  • 7 posts

0
Neutral

Posted 7 February 2014 - 12:45

Yeah, unfortunately there are people like that...

 

I'll click the "thumbs up" for you. ;)

 

And I can't help you with your question, don't use those readers, and haven't seen Windows in years...

 

Thanks (: On any given day (well, work days at least) I see most OS's (; win, *nix, osx, android, ios.. whatever works



Re: Argolis Smargo Smartreader V2 update problem #14 radxnl

  • Senior Member
  • 1,527 posts

+57
Good

Posted 7 February 2014 - 12:48

regarding windows7, de-install the 'new' ftdi drivers and install the old ones ( as provided for the 'old' smartreaders )

 

( if you cannot manange i will try to find a download link for you somewhere )



Re: Argolis Smargo Smartreader V2 update problem #15 tedy58

  • Member
  • 3 posts

0
Neutral

Posted 28 January 2018 - 20:01

Hi to all,
Today I have issue with this smartreader too. May be it is little complicated when I drive it but anyway I will explain it and you decide if it worth to do it my way.
 
First of all I use Ubuntu 16.04-2 as system to check if my card works.
2. I add the reader in /etc/udev/rules.d/44-persistent-usb.rules (with correct permissions) if don't have create such a file.

    it contain similar staff inside:


# This file was automatically generated by the /lib/udev/write_cd_rules
# program, run by the cd-aliases-generator.rules rules file.
#
# You can modify it, as long as you keep each rule on a single
# line, and set the $GENERATED variable.

# USB readers //////////
# Bus 002 Device 011: ID 0403:6001 Future Technology Devices International, Ltd FT232 USB-Serial (UART) IC
#  idProduct          0x6001 FT232 USB-Serial (UART) IC
# lsusb -v # will give you the device info

SUBSYSTEMS=="usb", KERNEL=="ttyUSB*", ATTRS{idVendor}=="0403", ATTRS{idProduct}=="6001", ATTRS{serial}=="reader16",  SYMLINK+="rdrnew"

   here ATTRS{serial}=="reader16" contain the serial name that is find by the

 #lsusb -v 

command where you must find which is your reader.

 

3. restart udev rules with following command:

 #sudo udevadm control --reload-rules && sudo udevadm trigger

4. Then make a reader with similar values:

[reader]
label                         = rdr
description                   = Smargo /dev/rdrnew
protocol                      = smargo
device                        = /dev/rdrnew
smargopatch                   = 1
cacheex_allow_request         = 1
caid                          = CAIDhere
detect                        = cd
mhz                           = 534
cardmhz                       = 369
ident                         = CAIDhere:000000
group                         = 1
emmcache                      = 1,1,2,0

   here you have to change the correct values for you t.e.:

 

device = /dev/rdrnew set here the value that you set in persistent_usb.rules file 

CAIDhere set correct caid,

mhz set correct mhz

 

for me this value works

 

then start your oscam and try it.



Re: Argolis Smargo Smartreader V2 update problem #16 tedy58

  • Member
  • 3 posts

0
Neutral

Posted 28 January 2018 - 20:15

I try to edit my post above and add some more details, but seems forum rules doesn't allow it to members with few post.



Re: Argolis Smargo Smartreader V2 update problem #17 Pr2

  • PLi® Contributor
  • 4,118 posts

+169
Excellent

Posted 30 January 2018 - 19:15

Hi,

 

Or use your smargo in smartreader protocol and forgot about those udev rules.

 

http://www.streamboa...?threadid=42226

 

Pr2


NO SUPPORT by PM, it is a forum make your question public so everybody can benefit from the question/answer.
If you think that my answer helps you, you can press the up arrow in bottom right of the answer.

Wanna help with OpenPLi Translation? Please read our Wiki Information for translators

Sat: Hotbird 13.0E, Astra 19.2E, Eutelsat5A 5.0W
VU+ Solo 4K: 2*DVB-S2 + 2*DVB-C/T/T2 (used in DVB-C) & Duo 4K: 2*DVB-S2X + DVB-C (FBC)
Edision OS Mio 4K: 1*DVB-S2X + 1*DVB-C/T/T2
 






Also tagged with one or more of these keywords: argolis, smargo, smartreader v2, update, problem

1 user(s) are reading this topic

0 members, 1 guests, 0 anonymous users