Jump to content


Photo

PIMP my PLiHD by talbs

skin PLiHD SHD PICONS weather

  • Please log in to reply
110 replies to this topic

Re: PIMP my PLiHD by talbs #41 isson

  • Senior Member
  • 37 posts

+1
Neutral

Posted 18 March 2014 - 10:08

Even after an online update (enigma version stucked at 2014-03-10)

Even with default PLiHD skin.

...

I had to do a fresh flash to get it back on default PLiHD and my skin.

++

same here..


WeTek Play


Re: PIMP my PLiHD by talbs #42 XtrendET

  • Senior Member
  • 61 posts

0
Neutral

Posted 18 March 2014 - 11:04

Interesting, I simply installed the 2.6 version, stored in the pimp-plugin my settings again and after restart everything works fine, including number-zap. I make the pli updates every day.



Re: PIMP my PLiHD by talbs #43 talbs

  • Senior Member
  • 101 posts

+9
Neutral

Posted 18 March 2014 - 11:41

Maybe the box type, I am on DM800Hdse

Take a look at this thread --> http://openpli.org/f...-up-left-on-tv/


PIMP my PLiHD skin on GitHub: https://github.com/talbss/PIMP-my-PLiHD-by-talbs

My skin_user_PLi-HD1.xml on GitHub: https://github.com/t...in_user_PLi-HD1


Re: PIMP my PLiHD by talbs #44 talbs

  • Senior Member
  • 101 posts

+9
Neutral

Posted 26 March 2014 - 18:29

Hi here is an update of my skin:

 

main change:

 

- now the plugin scans the folder: \usr\share\enigma2\PIMP-my-PLiHD-by-talbs\fonts when you want to select your font.

 

Then if you want to add your own font, just sent it to above folder  :wub:

font extension must be .ttf

 

- other updates are cosmetics 


Edited by WanWizard, 28 March 2014 - 08:22.
removed corrupt attachment

PIMP my PLiHD skin on GitHub: https://github.com/talbss/PIMP-my-PLiHD-by-talbs

My skin_user_PLi-HD1.xml on GitHub: https://github.com/t...in_user_PLi-HD1


Re: PIMP my PLiHD by talbs #45 talbs

  • Senior Member
  • 101 posts

+9
Neutral

Posted 26 March 2014 - 18:41

EDIT:

 

- you can also delete undersired embedded fonts in above folder to save space (don't delete your selected font or GSOD !!!)

- weather forcast now/today/2 days can be selected by the plugin.

- weather widget has been moved and resized to be in harmony with SNR/AGC/BER bar/information.

 

all skin history can be found on my github, see my signature.

 

Enjoy or not  :D


PIMP my PLiHD skin on GitHub: https://github.com/talbss/PIMP-my-PLiHD-by-talbs

My skin_user_PLi-HD1.xml on GitHub: https://github.com/t...in_user_PLi-HD1


Re: PIMP my PLiHD by talbs #46 talbs

  • Senior Member
  • 101 posts

+9
Neutral

Posted 27 March 2014 - 22:16

Hi, maybe above attachment is corrupted during upload.

 

Here is the new uplaod.

 

 

Attached File  enigma2-plugin-skins-pimp-my-pli-hd-by-talbs_2.73_all.ipk   1.42MB   223 downloads

 

 


PIMP my PLiHD skin on GitHub: https://github.com/talbss/PIMP-my-PLiHD-by-talbs

My skin_user_PLi-HD1.xml on GitHub: https://github.com/t...in_user_PLi-HD1


Re: PIMP my PLiHD by talbs #47 bulllet

  • Member
  • 2 posts

0
Neutral

Posted 28 March 2014 - 16:29

very nice skin :)

i need information about font size in

i wont make  big size of fonts


Edited by bulllet, 28 March 2014 - 16:30.


Re: PIMP my PLiHD by talbs #48 onujack

  • Member
  • 4 posts

0
Neutral

Posted 28 March 2014 - 18:54

It is a nice skin indeed.But i have problem 2.73.When i applaing skin settings my box boot have away and stucks tahat way.No problem 2.6 version.My box is DM800SE latest PLI4 :(



Re: PIMP my PLiHD by talbs #49 kojoot

  • Member
  • 22 posts

+1
Neutral

Posted 28 March 2014 - 20:07

It is a nice skin indeed.But i have problem 2.73.When i applaing skin settings my box boot have away and stucks tahat way.No problem 2.6 version.My box is DM800SE latest PLI4 :(

 

I have the same problem on vu+ duo2 with the version 2.73



Re: PIMP my PLiHD by talbs #50 kojoot

  • Member
  • 22 posts

+1
Neutral

Posted 28 March 2014 - 20:38

It is a nice skin indeed.But i have problem 2.73.When i applaing skin settings my box boot have away and stucks tahat way.No problem 2.6 version.My box is DM800SE latest PLI4 :(

 

I have the same problem on vu+ duo2 with the version 2.73

During installation I got this:

 

Installing enigma2-plugin-skins-pimp-my-pli-hd-by-talbs (2.6) to root...       
Configuring enigma2-plugin-skins-pimp-my-pli-hd-by-talbs.                      
Collected errors:                                                              
 * parse_from_stream_nomalloc: Missing new line character at end of file!      
root@vuduo2:~#        


Re: PIMP my PLiHD by talbs #51 kojoot

  • Member
  • 22 posts

+1
Neutral

Posted 29 March 2014 - 09:14

I solved the problem. It was in loading font nmsbd (default PLiHD font). 



Re: PIMP my PLiHD by talbs #52 jase41

  • Member
  • 24 posts

+1
Neutral

Posted 29 March 2014 - 09:59

Does the skin work in vu plus duo 2 ?



Re: PIMP my PLiHD by talbs #53 talbs

  • Senior Member
  • 101 posts

+9
Neutral

Posted 29 March 2014 - 23:37

I solved the problem. It was in loading font nmsbd (default PLiHD font).

Hi
My skin expects that nmsbd.ttf is in /usr/share/enigma2/font folder.
Do you have it?
Do you have default pliHD skin installed?

Thank you

@Jase

Yes

Edited by talbs, 29 March 2014 - 23:37.

PIMP my PLiHD skin on GitHub: https://github.com/talbss/PIMP-my-PLiHD-by-talbs

My skin_user_PLi-HD1.xml on GitHub: https://github.com/t...in_user_PLi-HD1


Re: PIMP my PLiHD by talbs #54 talbs

  • Senior Member
  • 101 posts

+9
Neutral

Posted 29 March 2014 - 23:39

It is a nice skin indeed.But i have problem 2.73.When i applaing skin settings my box boot have away and stucks tahat way.No problem 2.6 version.My box is DM800SE latest PLI4 :(


Thank for reporting
Can you post telnet messages while installing the skin?

Thank you

PIMP my PLiHD skin on GitHub: https://github.com/talbss/PIMP-my-PLiHD-by-talbs

My skin_user_PLi-HD1.xml on GitHub: https://github.com/t...in_user_PLi-HD1


Re: PIMP my PLiHD by talbs #55 kojoot

  • Member
  • 22 posts

+1
Neutral

Posted 30 March 2014 - 08:56

I solved the problem. It was in loading font nmsbd (default PLiHD font).

Hi
My skin expects that nmsbd.ttf is in /usr/share/enigma2/font folder.
Do you have it?
Do you have default pliHD skin installed?

Thank you

@Jase

Yes

yes I have default pliHD skin, and font nmsbd.ttf and I saw in crash log that loading that font causes crash. I simply changed font (direfent then default pliHD) in plugin and then when the skin was loaded, a replaced font to default pliHD because I like it.

 

Now it works prefectly.



Re: PIMP my PLiHD by talbs #56 talbs

  • Senior Member
  • 101 posts

+9
Neutral

Posted 30 March 2014 - 10:02

Thank you i will check that

PIMP my PLiHD skin on GitHub: https://github.com/talbss/PIMP-my-PLiHD-by-talbs

My skin_user_PLi-HD1.xml on GitHub: https://github.com/t...in_user_PLi-HD1


Re: PIMP my PLiHD by talbs #57 mika-nl

  • Senior Member
  • 454 posts

+10
Neutral

Posted 30 March 2014 - 12:12

Enigma2 output :

 

loading bouquet... /etc/enigma2/userbouquet.favourites.radio 5536
0 entries in Bouquet userbouquet.favourites.radio
67 entries in Bouquet bouquets.radio
[FONT] adding font /usr/share/fonts/nmsbd.ttf...OK (Regular)
[FONT] adding font /usr/share/fonts/andale.ttf...OK (Fixed)
[FONT] adding font /usr/share/fonts/tuxtxt.ttf...OK (Console)
[FONT] adding font /usr/share/fonts/ae_AlMateen.ttf...OK (Replacement)
[SKIN] loading include: /usr/share/enigma2/PIMP-my-PLiHD-by-talbs/skin_templates.xml
[SKIN] loading include: /usr/share/enigma2/PIMP-my-PLiHD-by-talbs/skin_plugins.xml
[SKIN] loading include: /usr/share/enigma2/PIMP-my-PLiHD-by-talbs/skin_templates_talbs.xml
[FONT] adding font /usr/share/fonts/nmsbd (default PLiHD font)...FATAL:  failed: Operation not permitted
Killed
root@xp1000:~# find / -name nmsbd.ttf
/usr/share/fonts/nmsbd.ttf
root@xp1000:~# 



Re: PIMP my PLiHD by talbs #58 talbs

  • Senior Member
  • 101 posts

+9
Neutral

Posted 30 March 2014 - 15:46

thank you very much.

 

again a bad copy/paste :ph34r:

 

 

I think that it can be corrected by replacing:

 

in usr/lib/enigma2/python/Plugins/Extensions/PIMPmyPLiHD/plugin.py

 

line 166

config.plugins.PIMPmyPLiHD.FontSelection = ConfigSelection(default="nmsbd (default PLiHD font)",choices=fontlist)

must be replaced by

config.plugins.PIMPmyPLiHD.FontSelection = ConfigSelection(default="nmsbd.ttf",choices=fontlist)

Sorry but i can't test now as i am out of home.

 

Will check that tonight.

 

PS: i don't use this font and it is the only one which is managed in a different manner as i assume that it is by default present in the image (default enigma2/font folder).


PIMP my PLiHD skin on GitHub: https://github.com/talbss/PIMP-my-PLiHD-by-talbs

My skin_user_PLi-HD1.xml on GitHub: https://github.com/t...in_user_PLi-HD1


Re: PIMP my PLiHD by talbs #59 talbs

  • Senior Member
  • 101 posts

+9
Neutral

Posted 30 March 2014 - 21:27

Issue solved:

Here is the updated version:

 

Attached File  enigma2-plugin-skins-pimp-my-pli-hd-by-talbs_2.74_all.ipk   1.4MB   685 downloads

 

changelog:

 

- correct typo in plugin.py as reported above (thank you guys).

- check if /usr/share/fonts/nmsbd.ttf exists before adding it to font selection list.

- remove skin.xml file from skin installation, then user must generate skin using the plugin after first skin installation and/or skin upgrade.

 

 this has been done mainly for 2 reasons:

 - avoid issue if  /usr/share/fonts/nmsbd.ttf does not exist.

- after skin upgrade, having a skin different from saved skin settings (from previous skin generation).

 

Your comments are welcome.


PIMP my PLiHD skin on GitHub: https://github.com/talbss/PIMP-my-PLiHD-by-talbs

My skin_user_PLi-HD1.xml on GitHub: https://github.com/t...in_user_PLi-HD1


Re: PIMP my PLiHD by talbs #60 mika-nl

  • Senior Member
  • 454 posts

+10
Neutral

Posted 30 March 2014 - 21:39

Thx alot for the nice skin update :)


Edited by mika-nl, 30 March 2014 - 21:39.






Also tagged with one or more of these keywords: skin, PLiHD, SHD PICONS, weather

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users