Jump to content


Photo

2014-03-06 vu+duo2 image: please correct transcoding & LCD4Linux setup

vu+duo2 transcoding LCD4Linux

  • Please log in to reply
11 replies to this topic

#1 macnuts

  • Senior Member
  • 420 posts

+14
Neutral

Posted 6 March 2014 - 18:31

I've just flashed a newest image 2013-03-06, vu+duo2, and found two problems:

 

1.

That one is not a real problem, but transcoding is not installed by default anymore. Please correct and install vuplus-transcoding by default.

 

2.

LCD4Linux mess after latest cleanup ;)

LCD4Linux is not installed by default anymore on duo2, which is not good.

What is worse, it is hard to deduct openpli's INTENDED LCD4Linux package(s) to be installed. Please help me choose the right one(s) out of:

 

Spoiler

 

 Many thanks.



Re: 2014-03-06 vu+duo2 image: please correct transcoding & LCD4Linux setup #2 WanWizard

  • Forum Moderator
    PLi® Core member
  • 47,897 posts

+803
Excellent

Posted 6 March 2014 - 18:40

The transcoding (for the Duo2 and Solo2) is a work in progress. It is reworked at the moment, so you'll have to be patient until it is properly fixed.


Currently in use: VU+Duo 4K (2xFBC S2), Amiko Viper T2C (T2), SAB Alpha Triple HD (S2+T2), Zgemma H3.T2C (T/C), Zgemma H6 (fallback), VU+Zero (fallback)

Many answers to your question can be found in our new and improved wiki.

note: I do not provide support via PM !

 


Re: 2014-03-06 vu+duo2 image: please correct transcoding & LCD4Linux setup #3 Erik Slagter

  • PLi® Core member
  • 45,327 posts

+497
Excellent

Posted 6 March 2014 - 18:57

1. That one is not a real problem, but transcoding is not installed by default anymore. Please correct and install vuplus-transcoding by default.

It's not a question of "correction". If we were to decide to not include transcoding support in the image, the user would only have to install one package. I cannot see that as a major deal breaker.

But anyway, the transcoding is being reworked (see commit logs) and it will come together just fine, probably already in tomorrow's build.

2.
LCD4Linux mess after latest cleanup ;)
LCD4Linux is not installed by default anymore on duo2, which is not good.
What is worse, it is hard to deduct openpli's INTENDED LCD4Linux package(s) to be installed.

Not true. It is NOT a mess and whether it's inside the image, see my previous comment. In the commit logs, one can read that formerly there where two versions of the plugin, one of them I removed a few days ago, exactly to resolve "the mess". This leaves the 3rd-party version (which is much newer and has much more features), which we cannot include in the image for various reasons.


* Wavefrontier T90 with 28E/23E/19E/13E/9E/4.8E/0.8W/5W via SCR switches 2 x 2 x 6 user bands
* Ziggo digital cable TV (FTA)
I don't read PM -> if you have something to ask or to report, do it in the forum so others can benefit. I don't take freelance jobs.
Ik lees geen PM -> als je iets te vragen of te melden hebt, doe het op het forum, zodat anderen er ook wat aan hebben.

Re: 2014-03-06 vu+duo2 image: please correct transcoding & LCD4Linux setup #4 macnuts

  • Senior Member
  • 420 posts

+14
Neutral

Posted 6 March 2014 - 19:08

When I do now opkg update then opkg list *lcd4linux* I can see nothing now. Is this intended or someone is working on it now?



Re: 2014-03-06 vu+duo2 image: please correct transcoding & LCD4Linux setup #5 macnuts

  • Senior Member
  • 420 posts

+14
Neutral

Posted 6 March 2014 - 19:12

 Not true. It is NOT a mess and whether it's inside the image, see my previous comment. In the commit logs, one can read that formerly there where two versions of the plugin, one of them I removed a few days ago, exactly to resolve "the mess". This leaves the 3rd-party version (which is much newer and has much more features), which we cannot include in the image for various reasons.

 

 I know that one plugin was removed to cleanup "the mess" as you said. That's why I was astonished that there were so many to choose from. Now none is available.

 

Does it mean that there is no lcd4linux support in the image (feeds) and I need googling for it?


Edited by macnuts, 6 March 2014 - 19:16.


Re: 2014-03-06 vu+duo2 image: please correct transcoding & LCD4Linux setup #6 Erik Slagter

  • PLi® Core member
  • 45,327 posts

+497
Excellent

Posted 6 March 2014 - 19:59

I see there is still some work to do, but other than you say. The original, native version, which has been removed, is still in the feed because it has changed ARCH at some time (and the person who changed it, didn't remove the old location). So this still needs to be cleaned up.

 

Besides that issue, it's all there:

 

root@duo:/var/lib/opkg# opkg update
Downloading http://downloads.pli...ty/Packages.gz.
Inflating http://downloads.pli...ty/Packages.gz.
Updated list of available packages in /var/lib/opkg/openpli-3rd-party.
Downloading http://downloads.pli...o2/Packages.gz.
Inflating http://downloads.pli...o2/Packages.gz.
Updated list of available packages in /var/lib/opkg/openpli-3rd-party-vuduo2.
Downloading http://downloads.pli...ll/Packages.gz.
Inflating http://downloads.pli...ll/Packages.gz.
Updated list of available packages in /var/lib/opkg/openpli-all.
Downloading http://downloads.pli...el/Packages.gz.
Inflating http://downloads.pli...el/Packages.gz.
Updated list of available packages in /var/lib/opkg/openpli-mips32el.
Downloading http://downloads.pli...o2/Packages.gz.
Inflating http://downloads.pli...o2/Packages.gz.
Updated list of available packages in /var/lib/opkg/openpli-vuduo2.
root@duo:/var/lib/opkg# opkg list | fgrep lcd4linux
enigma2-plugin-extensions-lcd4linux - 3.8-r3 - Web/DPF/Samsung LCD Ansteuerung
enigma2-plugin-extensions-lcd4linux - 1.0-20130723_p0_r0 - enigma2-plugin-extensions-lcd4linux version 1.0-20130723_p0_r0  Vu+
enigma2-plugin-extensions-lcd4linux-dev - 1.0-20130723_p0_r0 - enigma2-plugin-extensions-lcd4linux version 1.0-20130723_p0_r0 -
enigma2-plugin-extensions-lcd4linuxsupport - 1.0-20130723_p0_r0 - enigma2-plugin-extensions-lcd4linuxsupport version 1.0-20130723_p0_r0
enigma2-plugin-extensions-lcd4linuxsupport-dev - 1.0-20130723_p0_r0 - enigma2-plugin-extensions-lcd4linuxsupport version 1.0-20130723_p0_r0 -
lcd4linux - 0.11.0-SVN-r3 - lcd4linux version 0.11.0-SVN-r3  LCD4Linux is a small program that grabs
lcd4linux-dev - 0.11.0-SVN-r3 - lcd4linux version 0.11.0-SVN-r3 - Development files  LCD4Linux is a small


* Wavefrontier T90 with 28E/23E/19E/13E/9E/4.8E/0.8W/5W via SCR switches 2 x 2 x 6 user bands
* Ziggo digital cable TV (FTA)
I don't read PM -> if you have something to ask or to report, do it in the forum so others can benefit. I don't take freelance jobs.
Ik lees geen PM -> als je iets te vragen of te melden hebt, doe het op het forum, zodat anderen er ook wat aan hebben.

Re: 2014-03-06 vu+duo2 image: please correct transcoding & LCD4Linux setup #7 macnuts

  • Senior Member
  • 420 posts

+14
Neutral

Posted 6 March 2014 - 20:31

Thank you very much!!! Installing those three solved the problem.

 

The packages are still in the feed; it occurred that opkg lost wildcard functionality somehow, so opkg list *lcd4* stopped working for me (does not produce any results any more).



Re: 2014-03-06 vu+duo2 image: please correct transcoding & LCD4Linux setup #8 Erik Slagter

  • PLi® Core member
  • 45,327 posts

+497
Excellent

Posted 6 March 2014 - 20:37

If you use asterisks on a linux command line, you should really escape them with ' or " or \ because the shell will try to expand them.


* Wavefrontier T90 with 28E/23E/19E/13E/9E/4.8E/0.8W/5W via SCR switches 2 x 2 x 6 user bands
* Ziggo digital cable TV (FTA)
I don't read PM -> if you have something to ask or to report, do it in the forum so others can benefit. I don't take freelance jobs.
Ik lees geen PM -> als je iets te vragen of te melden hebt, doe het op het forum, zodat anderen er ook wat aan hebben.

Re: 2014-03-06 vu+duo2 image: please correct transcoding & LCD4Linux setup #9 macnuts

  • Senior Member
  • 420 posts

+14
Neutral

Posted 6 March 2014 - 20:40

Thank you again. You are right of course, shell does expand, I forgot about it (as it was somehow working in the past). All back to normal, now waiting for transcoding to be finished. No hurry take your time.

 

Many thanks.



Re: 2014-03-06 vu+duo2 image: please correct transcoding & LCD4Linux setup #10 littlesat

  • PLi® Core member
  • 48,972 posts

+523
Excellent

Posted 6 March 2014 - 21:29

Lcd was in full capital... That was your issue....

WaveFrontier 28.2E | 23.5E | 19.2E | 16E | 13E | 10/9E | 7E | 5E | 1W | 4/5W | 15W


Re: 2014-03-06 vu+duo2 image: please correct transcoding & LCD4Linux setup #11 macnuts

  • Senior Member
  • 420 posts

+14
Neutral

Posted 6 March 2014 - 21:56

No my issue is that I changed to folder where I had a copy of lcd4linux settings ;) (lcd4config file) and shell expanded wildcard. Small things hurt badly.

Regards.



Re: 2014-03-06 vu+duo2 image: please correct transcoding & LCD4Linux setup #12 Erik Slagter

  • PLi® Core member
  • 45,327 posts

+497
Excellent

Posted 7 March 2014 - 09:03

Thank you again. You are right of course, shell does expand, I forgot about it (as it was somehow working in the past). All back to normal, now waiting for transcoding to be finished. No hurry take your time.

So the emotional storm has died out in the meantime :D Never mind, we all have these every now and then ;)


* Wavefrontier T90 with 28E/23E/19E/13E/9E/4.8E/0.8W/5W via SCR switches 2 x 2 x 6 user bands
* Ziggo digital cable TV (FTA)
I don't read PM -> if you have something to ask or to report, do it in the forum so others can benefit. I don't take freelance jobs.
Ik lees geen PM -> als je iets te vragen of te melden hebt, doe het op het forum, zodat anderen er ook wat aan hebben.





Also tagged with one or more of these keywords: vu+duo2, transcoding, LCD4Linux

1 user(s) are reading this topic

0 members, 1 guests, 0 anonymous users