Jump to content


Photo

Green screen after software upgrade to march 2014 version

green screen software upgrade components plugins

  • Please log in to reply
7 replies to this topic

#1 pablogiganti

  • Member
  • 9 posts

0
Neutral

Posted 24 March 2014 - 22:32

Hi,

On the 23/03/2014 I did a software upgrade using my box´s GUI from my autumn (sorry, don´t remember the version number but the wallpaper had a picture taken in autumn) version of Openpli to the latest release (winter wallpaper). I have done this process in the past without any problem but this time I get a Green screen of death which says the following and the box restarts itself over and over again in a loop...

 

We are sorry. Your STB encountered a software problem, and needs to be restarted. Please send the logfile to forum www.openpli.org. Your STB restarts in 10 seconds!

 

Component: enigma2

 

File "/usr/lib/enigma2/python/Components/Network.py", line 682, in msgPlugins
File "/usr/lib/enigma2/python/Plugins/Extensions/OpenWebif/plugin.py", line 121, in IfUpIfDown
    HttpdStart(global_session)
  File "/usr/lib/enigma2/python/Plugins/Extensions/OpenWebif/httpserver.py", line 127, in HttpdStart
    BJregisterService('https',httpsPort)
File "/usr/lib/enigma2/python/Plugins/Extensions/OpenWebif/httpserver.py", line 278, in HttpdStart
    BJregisterService('https',httpsPort)
File "/usr/lib/enigma2/python/Plugins/Extensions/Bonjour/Bonjour.py", line 196, in <module>
    bonjour = Bonjour()
File "/usr/lib/enigma2/python/Plugins/Extensions/Bonjour/Bonjour.py", line 196, in <module>
    bonjour = Bonjour()
  File "/usr/lib/enigma2/python/Plugins/Extensions/Bonjour/Bonjour.py", line 14, in __init__
    self.reloadConfig()
  File "/usr/lib/enigma2/python/Plugins/Extensions/Bonjour/Bonjour.py", line 99, in reloadConfig
    self.__parse(file)
  File "/usr/lib/enigma2/python/Plugins/Extensions/Bonjour/Bonjour.py", line 64, in __parse
    config = cet_parse(self.AVAHI_SERVICES_DIR + file).getroot()
  File "<string>", line 56, in parse
  File "<string>", line 35, in parse
cElementTree.ParseError: no element found: line 1, column 0
(PyObject_CallObject(<Tools.BoundFunction.boundFunction instance at 0x20d7058>,(1,)) failed)

 

I looked for error logs files and I found a bunch created that day so I´m posting the latest 2.

 

I tried flashing the box with earlier versions of Pli (the latest 3 versions available to download from the Pli site) but the box gets into the loop again.

I then tried to flash it with the original Dreambox 7020HD image and the box came alive. Then I tried to flash it again with Pli but the box gets into the green screen loop yet again.

I also tried another unofficial image (don´t remember which one it was…Peter Pan or something and the box goes back to normal.

One time I had the original firmware installed, I could access the box via FTP so I deleted most of /usr/lib/enigma2/python/ content (especially all the files and dirs found in Components and plugins folder content), flash it again with Pli but yet the problem persisted.

By the way, I flashed the box using the web interface but process seems to finish as it should.

 

I´m stuck and I don´t really know what to do apart of installing an alternative image but I love Openpli, I´m used to it and no other image compares to it.

Can anyone think of any solution?

Thanks in advance for your help.

Pablo

Attached Files


Dreambox 7020HD + HDD 1TB


Re: Green screen after software upgrade to march 2014 version #2 dirocca

  • Senior Member
  • 1,667 posts

+59
Good

Posted 24 March 2014 - 23:14

Deinstall plugin " bonjour "

Grtz Philip

vuduo2 openpli6.1 1TB HDD 2xdualS2tuner

av receiver denon - samsung 4k hdr+ 65inch UE65MU7000 - bose accoustimas 7.1 :rolleyes:

tvv kaart & schotel(64cm), duo lnb, OSCAM

logitech harmony ultimate

 

 

 


Re: Green screen after software upgrade to march 2014 version #3 pablogiganti

  • Member
  • 9 posts

0
Neutral

Posted 24 March 2014 - 23:46

Thank you Dirocca but I can´t because the box reboots immediately after it boots up so it doesn´t give me enough time to get to the menu.

If I access the plugin menu when running the original image (which works fine and allows me to access the plugins menu) the plugin appear as uninstalled.

Is there any other way to delete Bonjour or completely delete all information (inc Bonjour) before reinstalling Pli?

Thanks!


Dreambox 7020HD + HDD 1TB


Re: Green screen after software upgrade to march 2014 version #4 WanWizard

  • Forum Moderator
    PLi® Core member
  • 55,450 posts

+1,126
Excellent

Posted 25 March 2014 - 00:04

telnet into the box as soon as it boots up, and type "opkg remove enigma2-plugin-extensions-bonjour".


Currently in use: VU+Duo 4K (2xFBC S2), Amiko Viper T2C (T2+fallback), Octagon SF8008 (S2+T2), Zgemma H9.2H (T2+fallback)

Many answers to your question can be found in our new and improved wiki.

note: I do not provide support via PM !

 


Re: Green screen after software upgrade to march 2014 version #5 pablogiganti

  • Member
  • 9 posts

0
Neutral

Posted 25 March 2014 - 01:12

Yeah yeah yeah, three times yeah!

Thanks WanWizard, the telnet trick worked perfectly.


Dreambox 7020HD + HDD 1TB


Re: Green screen after software upgrade to march 2014 version #6 WanWizard

  • Forum Moderator
    PLi® Core member
  • 55,450 posts

+1,126
Excellent

Posted 25 March 2014 - 08:14

Glad you got it sorted!


Currently in use: VU+Duo 4K (2xFBC S2), Amiko Viper T2C (T2+fallback), Octagon SF8008 (S2+T2), Zgemma H9.2H (T2+fallback)

Many answers to your question can be found in our new and improved wiki.

note: I do not provide support via PM !

 


Re: Green screen after software upgrade to march 2014 version #7 SpaceRat

  • Senior Member
  • 1,021 posts

+64
Good

Posted 15 April 2014 - 23:21

Does this error occur always and for everyone when Bonjour is installed?
Or has this been fixed in later versions of the Bonjour plugin?
1st box: Vu+ Ultimo 4k 4xDVB-S2 FBC / 2xDVB-C / 1.8 TB HDD / OpenATV 6.2
2nd box: Gigablue Quad 4k 2xDVB-S2 FBC / 2xDVB-C / 1.8 TB HDD / OpenATV 6.2
testing boxes: Vu+ Duo² + AX Quadbox HD2400 + 2x Vu+ Solo² + Octagon SF4008
Sats & Pay-TV: Astra 19.2°E + Hotbird 13°E with Redlight / SCT HD / SES Astra HD- / Sky V14 / 4th empire propaganda TV
Card-Server: Raspberry Pi + IPv6-capable oscam
Router: Linksys WRT1900ACS w/ LEDE + Fritz!Box 7390

Re: Green screen after software upgrade to march 2014 version #8 kunopli

  • Member
  • 1 posts

0
Neutral

Posted 10 May 2014 - 06:09

It happened to me also, as son i rebooted after the bonjour install, then it started to reboot itself over and over again.







Also tagged with one or more of these keywords: green screen, software upgrade, components, plugins

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users