Jump to content


Photo

openpli 4 time sync ! NTP


  • Please log in to reply
73 replies to this topic

#1 ajeeb

  • Senior Member
  • 385 posts

0
Neutral

Posted 29 July 2014 - 04:38

recently my box don't get any NTP !!

so I install ntpdate via telnet and execute manually 

 

any idea?

BR


ET9000,DM500s+usbTTdvb-3600 ,DVB2000,Humax5400, MACbook PRO retina 13", MAC pro 2 x Quad XEON-2.8GB , 8GB ECC, 4TB+FusionDrive(SSD) , LG-24FHD, HD6870,Debian server

"Since the dawn of our species, Man has been blessed with curiosity"


Re: openpli 4 time sync ! NTP #2 mimisiku

  • Senior Member
  • 3,329 posts

+58
Good

Posted 29 July 2014 - 05:29

Normally the system time is taken from the selected DVB Stream from the tuner. No signal and the date reverts to 01-01-1970 upon boot. Setting the time from NTP is therefore a temporary solution. Upon booting time will be reset again.

 

Check your tuner and signal... Same problems seems to occur with clone boxes having "non standard" tuners build-in


Met één been in het graf..... Helaas

Re: openpli 4 time sync ! NTP #3 ajeeb

  • Senior Member
  • 385 posts

0
Neutral

Posted 29 July 2014 - 06:11

 actually the box get tuner signal ! and date change from 01-01-1970 to current date with none exact time ! according to my area or time zone 

I remember an option to customize NTP pool !! etc

yes your right next reboot system will cause the problem again !

am looking for permanent solution

 

br


ET9000,DM500s+usbTTdvb-3600 ,DVB2000,Humax5400, MACbook PRO retina 13", MAC pro 2 x Quad XEON-2.8GB , 8GB ECC, 4TB+FusionDrive(SSD) , LG-24FHD, HD6870,Debian server

"Since the dawn of our species, Man has been blessed with curiosity"


Re: openpli 4 time sync ! NTP #4 Jan Gruuthuse

  • Senior Member
  • 984 posts

+20
Neutral

Posted 29 July 2014 - 16:10

On my fritz!box (192.168.178.1) I did enable timeserver, getting its time from a public time lab NTP server with an utmost precision of a few milliseconds (10-3 seconds) when the synchronization is done in optimal conditions. ;)

On the stb (openpli 4.0) run these lines to install ntpdate:

opkg update
opkg install ntpdate

edit/create file /etc/cron/root:

30 * * * *    ntpdate -b -s -u 192.168.178.1

 

This keeps my two xp1000 good in timesync.


Edited by Jan Gruuthuse, 29 July 2014 - 16:13.

3 * xp1000 OpenPli 4.0 + usb 3.0 stick 64 GB, fixed lnb 28.2E, 23.5E ,19.2E ,16E, 13E, 9E, 4.8E, n4100pro 12 TB


Re: openpli 4 time sync ! NTP #5 ajeeb

  • Senior Member
  • 385 posts

0
Neutral

Posted 31 July 2014 - 03:20

well, that solve problem,

 

 

30 * * * * ntpdate -b -s -u 0.pool.ntp.org
 

 


BR


Edited by ajeeb, 31 July 2014 - 03:22.

ET9000,DM500s+usbTTdvb-3600 ,DVB2000,Humax5400, MACbook PRO retina 13", MAC pro 2 x Quad XEON-2.8GB , 8GB ECC, 4TB+FusionDrive(SSD) , LG-24FHD, HD6870,Debian server

"Since the dawn of our species, Man has been blessed with curiosity"


Re: openpli 4 time sync ! NTP #6 Jan Gruuthuse

  • Senior Member
  • 984 posts

+20
Neutral

Posted 31 July 2014 - 16:29

Keep in mind this is a every 30 minute call to the timeserver.

# * * * * *  command to execute
# ┬ ┬ ┬ ┬ ┬
# │ │ │ │ │
# │ │ │ │ │
# │ │ │ │ └───── day of week (0 - 6) (0 to 6 are Sunday to Saturday, or use names; 7 is Sunday, the same as 0)
# │ │ │ └────────── month (1 - 12)
# │ │ └─────────────── day of month (1 - 31)
# │ └──────────────────── hour (0 - 23)
# └───────────────────────── min (0 - 59)

Source: http://en.wikipedia....ing_definitions

 

While I'm using the fritz!box as timeserver, this is an inhouse call. Have no idea if every 1/2 hour call to NTP pool would be appreciated by the volunteers running this pool.

If no internal timeserver available perhaps you could use this:

@reboot ntpdate -b -s -u 0.pool.ntp.org

test if this is working as it should.


Edited by Jan Gruuthuse, 31 July 2014 - 16:29.

3 * xp1000 OpenPli 4.0 + usb 3.0 stick 64 GB, fixed lnb 28.2E, 23.5E ,19.2E ,16E, 13E, 9E, 4.8E, n4100pro 12 TB


Re: openpli 4 time sync ! NTP #7 adri

  • Senior Member
  • 369 posts

+5
Neutral

Posted 31 July 2014 - 20:11

Normal NTP servers assume you'll be making a call once every 1024 seconds (17 minutes), once time has stabelised.

So they should not object to once every 1/2 hour.



Re: openpli 4 time sync ! NTP #8 Jan Gruuthuse

  • Senior Member
  • 984 posts

+20
Neutral

Posted 1 August 2014 - 07:04

It is usually considered poor manners to regularly hit even a server pool more than a few times in a 24 hour period. If you're one of those many who are in the habit of synching every clock on your LAN against a single public server, every few seconds, your IP may end up on the clock-master's list of Folks We Don't Like, and your network's time of reckoning will eventually arrive - or worse, you will contribute to stopping these vital services.

 

line just before Auto-starting ntpd:

source: http://www.freebsdwi...P_pool_servers 


Edited by Jan Gruuthuse, 1 August 2014 - 07:06.

3 * xp1000 OpenPli 4.0 + usb 3.0 stick 64 GB, fixed lnb 28.2E, 23.5E ,19.2E ,16E, 13E, 9E, 4.8E, n4100pro 12 TB


Re: openpli 4 time sync ! NTP #9 ajeeb

  • Senior Member
  • 385 posts

0
Neutral

Posted 4 August 2014 - 03:27

you can attach the line to softcam auto start !!

ET9000,DM500s+usbTTdvb-3600 ,DVB2000,Humax5400, MACbook PRO retina 13", MAC pro 2 x Quad XEON-2.8GB , 8GB ECC, 4TB+FusionDrive(SSD) , LG-24FHD, HD6870,Debian server

"Since the dawn of our species, Man has been blessed with curiosity"


Re: openpli 4 time sync ! NTP #10 MiLo

  • PLi® Core member
  • 14,001 posts

+295
Excellent

Posted 4 August 2014 - 09:34

You don't need the ntpdate package, it's already included in busybox.
Real musicians never die - they just decompose

Re: openpli 4 time sync ! NTP #11 Jan Gruuthuse

  • Senior Member
  • 984 posts

+20
Neutral

Posted 5 August 2014 - 08:10

So ntpdate command should work like mentioned above without installing the real ntpdate but using busybox-ntpd? I'm a little confused as opkg install installs the ntpdate package and is not mentioning some form of ntpdate is present.


3 * xp1000 OpenPli 4.0 + usb 3.0 stick 64 GB, fixed lnb 28.2E, 23.5E ,19.2E ,16E, 13E, 9E, 4.8E, n4100pro 12 TB


Re: openpli 4 time sync ! NTP #12 MiLo

  • PLi® Core member
  • 14,001 posts

+295
Excellent

Posted 5 August 2014 - 10:40

To grab the time, a command like this should do:
ntpd -q -p pool.ntp.org
 
See the manpage for ntpd.
Real musicians never die - they just decompose

Re: openpli 4 time sync ! NTP #13 MiLo

  • PLi® Core member
  • 14,001 posts

+295
Excellent

Posted 5 August 2014 - 10:44

So ntpdate command should work like mentioned above without installing the real ntpdate but using busybox-ntpd? I'm a little confused as opkg install installs the ntpdate package and is not mentioning some form of ntpdate is present.

That's because like most tools on posix systems (like Linux) they do as you ask, not as you intend.

If you type "opkg install ntpdate" it will install ntpdate for you. It will not complain that there might be a better option. It will not go out on google and consult the openpli forum about the best alternative for that package. Those things, you'll have to do yourself.
Real musicians never die - they just decompose

Re: openpli 4 time sync ! NTP #14 ajeeb

  • Senior Member
  • 385 posts

0
Neutral

Posted 17 November 2014 - 18:02

ntpdate not update ! current time !?

I use local server and remote server 

latest package updated


ET9000,DM500s+usbTTdvb-3600 ,DVB2000,Humax5400, MACbook PRO retina 13", MAC pro 2 x Quad XEON-2.8GB , 8GB ECC, 4TB+FusionDrive(SSD) , LG-24FHD, HD6870,Debian server

"Since the dawn of our species, Man has been blessed with curiosity"


Re: openpli 4 time sync ! NTP #15 Satpal

  • Senior Member
  • 291 posts

+4
Neutral

Posted 17 November 2014 - 21:27

Normally the system time is taken from the selected DVB Stream from the tuner. No signal and the date reverts to 01-01-1970 upon boot. Setting the time from NTP is therefore a temporary solution.

This is part of the problem as there are plenty of transponders out there giving a wrong time. I wonder why it therefore hasn't become standard practice as I have seen in e.g. the PowerBoard image to just set the transponder with the service after boot-up as the one which time is taken and won't be affected by others with wrong times.



Re: openpli 4 time sync ! NTP #16 Erik Slagter

  • PLi® Core member
  • 46,561 posts

+530
Excellent

Posted 18 November 2014 - 12:51

Reasoning from "our" situation, in Western Europe, almost all providers/transponders broadcast more or less correct time. So that is why it doesn't get much attention.

 

So for the why, try to reason from the provider. I guess they lend/sell receivers that don't use the transponder time, so they don't care. It's as simple as that. Providers don't care whether they're adhering to standards and norm, they care about doing the least to make it work on their own hardware. Sad but true.

 

Having said that, yes you will need to run ntp then, if you need to have a proper clock all of the time, I'd suggest using ntp instead of ntpdate (which works only once). Also you should disable fetching the time from the transponder.


* Wavefrontier T90 with 28E/23E/19E/13E/9E/4.8E/0.8W/5W via SCR switches 2 x 2 x 6 user bands
* Ziggo digital cable TV (FTA)
I don't read PM -> if you have something to ask or to report, do it in the forum so others can benefit. I don't take freelance jobs.
Ik lees geen PM -> als je iets te vragen of te melden hebt, doe het op het forum, zodat anderen er ook wat aan hebben.

Re: openpli 4 time sync ! NTP #17 MiLo

  • PLi® Core member
  • 14,001 posts

+295
Excellent

Posted 18 November 2014 - 16:13

"ntpd" is built in (busybox) and runs as deamon.
Real musicians never die - they just decompose

Re: openpli 4 time sync ! NTP #18 ajeeb

  • Senior Member
  • 385 posts

0
Neutral

Posted 20 November 2014 - 23:58

How to disable fetching time from the transponder? Pli , I can't find such an option!!

Best regards

ET9000,DM500s+usbTTdvb-3600 ,DVB2000,Humax5400, MACbook PRO retina 13", MAC pro 2 x Quad XEON-2.8GB , 8GB ECC, 4TB+FusionDrive(SSD) , LG-24FHD, HD6870,Debian server

"Since the dawn of our species, Man has been blessed with curiosity"


Re: openpli 4 time sync ! NTP #19 WanWizard

  • PLi® Core member
  • 56,543 posts

+1,175
Excellent

Posted 21 November 2014 - 08:21

I'm not sure there is a standard setting for it, if you don't use the systemtime plugin.

 

You can add it to the config manually.

 

Telnet to the box, stop Enigma using 'init 3', edit /etc/enigma2/settings, and add "config.misc.useTransponderTime=false", restart enigma using 'init 4'.


Currently in use: VU+Duo 4K (2xFBC S2), Amiko Viper T2C (T2+fallback), Octagon SF8008 (S2+T2), Zgemma H9.2H (T2+fallback)

Many answers to your question can be found in our new and improved wiki.

Because to health reasons, I will not be active very often anymore.


Re: openpli 4 time sync ! NTP #20 jackassnl

  • Senior Member
  • 92 posts

+3
Neutral

Posted 21 November 2014 - 12:37

First init 4, when you're finished init 3.

Edited by jackassnl, 21 November 2014 - 12:39.





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users