Jump to content


Photo

VU+DUO 2 Transcode crash (API)

Transcode API VU+DUO2 crash

  • Please log in to reply
10 replies to this topic

#1 Hawkz

  • Senior Member
  • 27 posts

0
Neutral

Posted 27 September 2014 - 20:34

Ik heb een VU+ DUO 2 met 2x DVB-S2 tuners en de laatste PLI (van vandaag).

Als ik naar mijn Android tablet wil streamen werkt dat.

Helaas kan ik niet 'transcode' kiezen in de stream opties, want dit werkt niet.

Als ik de 'Transcode' plugin installeer (op de satelliet tuner) en deze wil openen crasht mijn satelliet tuner.

Hierbij de log file, hopenlijk kunnen jullie het probleem vinden/ oplossen. b.v.d.

Attached Files



Re: VU+DUO 2 Transcode crash (API) #2 WanWizard

  • Forum Moderator
    PLi® Core member
  • 46,740 posts

+767
Excellent

Posted 28 September 2014 - 01:21

Er is geen plugin voor OpenPLi die je kunt installeren. Wat je hebt geinstalleert is niet compatible, het crasht.


Currently in use: VU+Duo 4K (2xFBC S2), Amiko Viper T2C (T2), SAB Alpha Triple HD (S2+T2), Zgemma H3.T2C (T/C), Zgemma H6 (fallback), VU+Zero (fallback)

Many answers to your question can be found in our new and improved wiki.

note: I do not provide support via PM !

 


Re: VU+DUO 2 Transcode crash (API) #3 Erik Slagter

  • PLi® Core member
  • 45,168 posts

+495
Excellent

Posted 28 September 2014 - 08:39

Mee eens, maar ik zie nog iets:

IOError: [Errno 2] No such file or directory: '/etc/enigma2/streamproxy.conf'

Dat betekent:

- de plugin is wel van ons, die heb ik gemaakt om instellingen in de config file vanaf de rc te kunnen doen (in plaats van met een editor)

- deze config file mist, de plugin zou er eigenlijk niet op mogen crashen, maar aande andere kant, de image komt al met de streamproxy er in, dus zou de config file er ook moeten zijn

- er klopt dus zowiezo iets niet.

 

Heb je deze file toevallig zelf verwijderd of verplaatst? Of het streamproxy package verwijderd?

 

Ik heb toevallig eergisteren nog een schone flash gedaan op mijn duo2 en daar werkt in ieder geval transcoding gewoon, dus de file /etc/enigma2/streamproxy.conf is er ook.

 

Dit probleem kun je overigens waarschijnlijk heel simpel oplossen door even in te loggen in te toetsen: "touch /etc/enigma2/streamproxy.conf" dan zal het waarschijnlijk werken.


* Wavefrontier T90 with 28E/23E/19E/13E/9E/4.8E/0.8W/5W via SCR switches 2 x 2 x 6 user bands
* Ziggo digital cable TV (FTA)
I don't read PM -> if you have something to ask or to report, do it in the forum so others can benefit. I don't take freelance jobs.
Ik lees geen PM -> als je iets te vragen of te melden hebt, doe het op het forum, zodat anderen er ook wat aan hebben.

Re: VU+DUO 2 Transcode crash (API) #4 Hawkz

  • Senior Member
  • 27 posts

0
Neutral

Posted 28 September 2014 - 14:28

Erik, bedankt voor je reactie.

Opnieuw het image van OpenPli 'OpenPLi-4.0-beta-vuduo2-20140928_usb' geinstalleerd.

Meteen in de directory /etc/enigma2/ gekeken, helaas geen streamproxy.conf

Daarna plugin geinstalleerd "Transcoding-setup" (zie bijlage)

Helaas nog geen streamproxy.conf, dus met Telnet "touch /etc/enigma2/streamproxy.conf" gedaan.

Plugin crashed niet meer, ik kan nu resolutie en bitrade instellen, helaas blijft het bestandje streamproxy.conf wel leeg, vreemd genoeg.

Ik gebruik de VU+ player Android App, als ik hier bij Advanced settings iets wil aanpassen krijg ik een foutmelding over de Transcoding API, zie bijlage.

Streamen werkt dus, maar de HD kanalen blokken en storen, dus wil ik transcoden, maar dat krijg ik niet aan de gang helaas...

Attached Files



Re: VU+DUO 2 Transcode crash (API) #5 Hawkz

  • Senior Member
  • 27 posts

0
Neutral

Posted 28 September 2014 - 14:44

correctie: "Plugin crasht niet meer, ik kan nu de resolutie en bitrate wel instellen, helaas blijft het bestandje streamproxy.conf wel leeg, vreemd genoeg?"

 

Kijk jij ook via deze VU+ Android App of met OpenWebif?



Re: VU+DUO 2 Transcode crash (API) #6 Erik Slagter

  • PLi® Core member
  • 45,168 posts

+495
Excellent

Posted 29 September 2014 - 14:30

Als er na een verse flash op de VU+ Duo2 of Solo2 geen file /etc/enigma2/streamproxy.conf file staat, dan gaat er iets fout, die zou er wel moeten zijn. Ik zal daar binnenkort eens naar kijken.

 

De VU+ Player kun je prima gebruiken en er zal inderdaad een foutmelding komen, maar die kun je negeren, heeft te maken met dat het instellen van bitrate etc. "onder water" op andere images anders gaat. Die plugin heb je op zich niet nodig, of je moet onafhankelijk van de client (VU+ player, Dreamdroid, Timote, etc.) de bitrate e.d. "default" kunnen aanpassen.

 

Grote kans dat het ondertussen wel gewoon werkt. Ik kom er nog op terug.


* Wavefrontier T90 with 28E/23E/19E/13E/9E/4.8E/0.8W/5W via SCR switches 2 x 2 x 6 user bands
* Ziggo digital cable TV (FTA)
I don't read PM -> if you have something to ask or to report, do it in the forum so others can benefit. I don't take freelance jobs.
Ik lees geen PM -> als je iets te vragen of te melden hebt, doe het op het forum, zodat anderen er ook wat aan hebben.

Re: VU+DUO 2 Transcode crash (API) #7 Hawkz

  • Senior Member
  • 27 posts

0
Neutral

Posted 30 September 2014 - 00:19

Dus voor de duidelijkheid... jij installeerd niet de plugin "Transcoding-setup", dus gewoon out of the box werkt het transcoden al bij jou?

 

1. Installeer PLI-image via USB

2. Loop de setup procedure van Pli door

3. zorg dat je smartcard/ cam werkt

4. Laat een kanalen lijst. (Henksat b.v.)

4. Stel je client (APP) op je smartphone/ tablet in op het juiste IP adres en de default poorten (verschillend voor streamen [8001] en transcoden [8002])

5. Transcoden werkt :-) ??

 

p.s. Heb jij een iOS of een Android tablet/phone en welke player gebruik jij? de interne/ MX player /VLC...?

p.s.2. de VU+ App is dus niet 100% compatible met PLi vanwege een andere API/ implementatie?



Re: VU+DUO 2 Transcode crash (API) #8 Hawkz

  • Senior Member
  • 27 posts

0
Neutral

Posted 30 September 2014 - 00:43

 

 

De VU+ Player kun je prima gebruiken en er zal inderdaad een foutmelding komen, maar die kun je negeren, heeft te maken met dat het instellen van bitrate etc. "onder water" op andere images anders gaat. Die plugin heb je op zich niet nodig, of je moet onafhankelijk van de client (VU+ player, Dreamdroid, Timote, etc.) de bitrate e.d. "default" kunnen aanpassen.

Helaas begrijp ik je hier niet helemaal.

Streamen = originele stream

Transcode = opnieuw een stream met een lagere bitrate/ framerate.

 

Hoe pas jij de bitrate/ framerate dan aan?

Die is natuurlijk afhankelijk van je internet verbinding die je op dat moment ter beschikking hebt. (Ik maak buitenhuis overigens een VPN verbinding naar mijn router) aangezien het niet op je satelliet tuner gebeurd (geen plugin installeren/ is ook niet handig want liever doe je dat remote op je client) en ook niet in je client (smartphone/ tablet APP), want dat wordt niet ondersteund begrijp ik? Ik neem aan dat het compatible maken van de API niet in jullie To-do list staat ;-) ?



Re: VU+DUO 2 Transcode crash (API) #9 metoo

  • Senior Member
  • 1,560 posts

+33
Good

Posted 30 September 2014 - 08:13

tiMote op android kun je ook de bitrate instellen


ET10000 C C C C/T  2TB HDD ET7000 + ET6000 dvb-S  OpenPli Triax 88 multifeed quad LNBs VU Uno4K SE C+2TB HDD Mutant HD60


Re: VU+DUO 2 Transcode crash (API) #10 Erik Slagter

  • PLi® Core member
  • 45,168 posts

+495
Excellent

Posted 30 September 2014 - 11:58

Het aanpassen van de bitrate werkt in de VU+ player uiteindelijk gewoon, ondanks dat er een foutmelding komt.


* Wavefrontier T90 with 28E/23E/19E/13E/9E/4.8E/0.8W/5W via SCR switches 2 x 2 x 6 user bands
* Ziggo digital cable TV (FTA)
I don't read PM -> if you have something to ask or to report, do it in the forum so others can benefit. I don't take freelance jobs.
Ik lees geen PM -> als je iets te vragen of te melden hebt, doe het op het forum, zodat anderen er ook wat aan hebben.

Re: VU+DUO 2 Transcode crash (API) #11 Erik Slagter

  • PLi® Core member
  • 45,168 posts

+495
Excellent

Posted 30 September 2014 - 15:45

Ik heb het even geprobeerd te reproduceren en dat lukt niet. Ik heb een solo2 (maakt in dit geval niet uit) van een flash van een paar dagen geleden voorzien, GEEN BACKUP. De config file staat er en streamproxy wordt gestart (hiervoor moet je wel, na alle wizards doorlopen te hebben, eenmalig de ontvanger herstarten). Daarna heb ik de config plugin geinstalleerd, beide parameters aangepast en dan gaat ook gewoon fluitend.


* Wavefrontier T90 with 28E/23E/19E/13E/9E/4.8E/0.8W/5W via SCR switches 2 x 2 x 6 user bands
* Ziggo digital cable TV (FTA)
I don't read PM -> if you have something to ask or to report, do it in the forum so others can benefit. I don't take freelance jobs.
Ik lees geen PM -> als je iets te vragen of te melden hebt, doe het op het forum, zodat anderen er ook wat aan hebben.





Also tagged with one or more of these keywords: Transcode, API, VU+DUO2, crash

1 user(s) are reading this topic

0 members, 1 guests, 0 anonymous users