Jump to content


Photo

Beeld en geluid niet sync bij IPTV

Algemeen

  • Please log in to reply
10 replies to this topic

#1 Loui (PD1LOI)

  • Senior Member
  • 3,704 posts

+105
Excellent

Posted 9 February 2015 - 11:04

Misschien is er al eens over geschreven,maar toch heb ik niet de juiste info kunnen vinden. Het is namelijk zo,als BNR Nieuwsradio via de webcam bekijk loopt het geluid zeker 1 tot 1½ seconde achter het beeld aan. En dat is ook met TV Flevoland zo wat is hier aan te doe zodat dit wat gelijk loopt.


Mijn handtekening is zoals gewoonlijk niet te lezen.
PD1LOI
Mut@nt-HD51-PVR en Wavefrontier T90.
En alles draait op OpenPli.xx 

Bereikbaar op BM 204 NL TS-1 Lokaal 9 TS-2-DMR http://www.pi1fld.nl


Re: Beeld en geluid niet sync bij IPTV #2 Erik Slagter

  • PLi® Core member
  • 46,690 posts

+534
Excellent

Posted 9 February 2015 - 15:20

Lipsync plugin?

 

Maar dit soort problemen kun je inderdaad wel verwachten met ip streams.


* Wavefrontier T90 with 28E/23E/19E/13E/9E/4.8E/0.8W/5W via SCR switches 2 x 2 x 6 user bands
* Ziggo digital cable TV (FTA)
I don't read PM -> if you have something to ask or to report, do it in the forum so others can benefit. I don't take freelance jobs.
Ik lees geen PM -> als je iets te vragen of te melden hebt, doe het op het forum, zodat anderen er ook wat aan hebben.

Re: Beeld en geluid niet sync bij IPTV #3 Loui (PD1LOI)

  • Senior Member
  • 3,704 posts

+105
Excellent

Posted 10 February 2015 - 11:21

Oke dus niet echt een oplossing in de image zelf.Laten we het maar zo voorlopig.


Mijn handtekening is zoals gewoonlijk niet te lezen.
PD1LOI
Mut@nt-HD51-PVR en Wavefrontier T90.
En alles draait op OpenPli.xx 

Bereikbaar op BM 204 NL TS-1 Lokaal 9 TS-2-DMR http://www.pi1fld.nl


Re: Beeld en geluid niet sync bij IPTV #4 Erik Slagter

  • PLi® Core member
  • 46,690 posts

+534
Excellent

Posted 10 February 2015 - 12:45

Wat ik zeg, het is een inherent probleem met ip streams. Het is dus geen bug in de image, en het is lastig te workarounden.


* Wavefrontier T90 with 28E/23E/19E/13E/9E/4.8E/0.8W/5W via SCR switches 2 x 2 x 6 user bands
* Ziggo digital cable TV (FTA)
I don't read PM -> if you have something to ask or to report, do it in the forum so others can benefit. I don't take freelance jobs.
Ik lees geen PM -> als je iets te vragen of te melden hebt, doe het op het forum, zodat anderen er ook wat aan hebben.

Re: Beeld en geluid niet sync bij IPTV #5 adri

  • Senior Member
  • 369 posts

+5
Neutral

Posted 10 February 2015 - 12:58

Erik,

 

Ik heb vaak gemerkt, dat bij rtmp streams vaak eerst een of meerdere seconden video gestuurd wordt en pas daarna de audio stream.

Waarschijnlijk gebeurd dit voor de 'buffering' op de client.

 

Een rtmp stream heeft ook embedded timestamps, zodat audio en video gesynchroniseerd afgespeeld kunnen worden.

Als ik een stream in een browser met flash pluguin bekijk, dan zie ik ook aan het begin een stilstaand beeld en na enige tijd begint de stream synchroon af te spelen.

 

Ik denk dat er bij GStreamer of enigma geen gebruik gemaakt wordt van de rtmp timestamps, waardoor beeld en geluid vaak niet synchroon lopen.



Re: Beeld en geluid niet sync bij IPTV #6 Erik Slagter

  • PLi® Core member
  • 46,690 posts

+534
Excellent

Posted 10 February 2015 - 13:35

Het zou best kunnen dat er binnen gstreamer op dat gebied een bug zit, daar kunnen wij helaas alleen nie zoveel aan doen.


* Wavefrontier T90 with 28E/23E/19E/13E/9E/4.8E/0.8W/5W via SCR switches 2 x 2 x 6 user bands
* Ziggo digital cable TV (FTA)
I don't read PM -> if you have something to ask or to report, do it in the forum so others can benefit. I don't take freelance jobs.
Ik lees geen PM -> als je iets te vragen of te melden hebt, doe het op het forum, zodat anderen er ook wat aan hebben.

Re: Beeld en geluid niet sync bij IPTV #7 adri

  • Senior Member
  • 369 posts

+5
Neutral

Posted 10 February 2015 - 16:17

Misschien is het correct gebruiken of controleren van timestamps/timecodes een uitdaging voor de nieuwe GST 1.x branch/versie?



Re: Beeld en geluid niet sync bij IPTV #8 Erik Slagter

  • PLi® Core member
  • 46,690 posts

+534
Excellent

Posted 11 February 2015 - 14:29

Er is wel het e.e.a. gefixed in versie 1, maar het is niet zo dat opeens alles perfect werkt. Wat dat betreft zijn de verwachtingen bij sommige mensen toch echt te hooggespannen.


* Wavefrontier T90 with 28E/23E/19E/13E/9E/4.8E/0.8W/5W via SCR switches 2 x 2 x 6 user bands
* Ziggo digital cable TV (FTA)
I don't read PM -> if you have something to ask or to report, do it in the forum so others can benefit. I don't take freelance jobs.
Ik lees geen PM -> als je iets te vragen of te melden hebt, doe het op het forum, zodat anderen er ook wat aan hebben.

Re: Beeld en geluid niet sync bij IPTV #9 adri

  • Senior Member
  • 369 posts

+5
Neutral

Posted 16 February 2015 - 23:24

Erik,

 

Misschien dat de volgende gstreamer patch een verbetering geeft, indien deze nog niet 'applied' is:

 

http://lists.freedes...une/042538.html

 

De zou verbetering in de 'timestamp handling' geven.

 

Adri,


Edited by adri, 16 February 2015 - 23:25.


Re: Beeld en geluid niet sync bij IPTV #10 theparasol

  • Senior Member
  • 4,145 posts

+196
Excellent

Posted 16 February 2015 - 23:58

Dat voorstel komt uit 2010... als die er nu nog niet inzit komt die er nooit meer in ;)


@Camping: ZGemma H.2S, Technisat Multytenne 4-in-1 @Home: Edision Mini 4K, Wave Frontier T55, EMP Centauri EMP DiSEqC 8/1 switch, 4x Inverto Ultra Black single LNB


Re: Beeld en geluid niet sync bij IPTV #11 Erik Slagter

  • PLi® Core member
  • 46,690 posts

+534
Excellent

Posted 17 February 2015 - 16:09

Die zal in gstreamer > 0.10 waarschijnlijk wel zitten.


* Wavefrontier T90 with 28E/23E/19E/13E/9E/4.8E/0.8W/5W via SCR switches 2 x 2 x 6 user bands
* Ziggo digital cable TV (FTA)
I don't read PM -> if you have something to ask or to report, do it in the forum so others can benefit. I don't take freelance jobs.
Ik lees geen PM -> als je iets te vragen of te melden hebt, doe het op het forum, zodat anderen er ook wat aan hebben.



Also tagged with one or more of these keywords: Algemeen

1 user(s) are reading this topic

0 members, 1 guests, 0 anonymous users