Jump to content


Photo

DB transcoder


  • Please log in to reply
60 replies to this topic

Re: DB transcoder #21 spameris

  • Senior Member
  • 49 posts

+1
Neutral

Posted 17 October 2015 - 21:30

Hello!

I would like to inform that first unstable version of E2 transcoder for Raspberry PI2 is available in public. There is a lot of things which need to do to make this transcoder perfect, but if you wold like to test it you can do this.

Basically this is a rasbpian wheezy image with some modifications to make possible to run this app.

 

What you need to do, to install this app?

1. download image with torrent http://e2transcoder....nstable.torrent

 

2. Install on SD card this image, there should be a lot of instructions how to do this in insternet. I suspect you need at least 8GB SD card, not because all software is so big but because i took this image from my 8GB SD card.

 

3. If you want a transcode SD channels you need a MPEG2 license. MPEG2 license is necessary  to PI2 could decode in HW mode mpeg2 streams.  http://www.raspberry...-2-license-key/

 

4. run command in pi2 console

sudo chmod 666 /var/www/admin/db/dbtranscode.db

5. edit file /var/www/config.php for you needs, E2 receiver IP, username etc...

 

6. Open link http://yourpi2ipaddress

 

Ah, almoust forgot, PI2 linux username and password is

user: pi

password: raspberry


Edited by spameris, 17 October 2015 - 21:33.

Enigma2 Transcoder win/lin: http://e2transcoder....nscoder_070.zip


Re: DB transcoder #22 airwave

  • Member
  • 3 posts

0
Neutral

Posted 29 October 2015 - 00:09

Hi,

 

having issues running it on Windows 10 64-bit.

Installed and started as explained, VC framework is installed, server started as administrator and listening on port 8888.

When trying to log in, I get to the admin interface, but then in the shell window I get three 404 errors. After clicking Login, nothing else happens (I am still at the start page). The errors are strange, as the corresponding files are in place in C:\DB\...

 

[Thu Oct 29 00:08:11 2015] 192.168.1.22:50987 [200]: /admin?
[Thu Oct 29 00:08:11 2015] 192.168.1.22:50991 [404]: /css/slider.css - No such file or directory
[Thu Oct 29 00:08:11 2015] 192.168.1.22:50992 [404]: /js/bootstrap-slider.js - No such file or directory
[Thu Oct 29 00:08:11 2015] 192.168.1.22:50993 [404]: /js/modernizr.js - No such file or directory
[Thu Oct 29 00:08:11 2015] 192.168.1.22:50994 [404]: /js/tr.js - No such file or directory


Re: DB transcoder #23 airwave

  • Member
  • 3 posts

0
Neutral

Posted 29 October 2015 - 23:26

Ok after enabling the error logging, turns out there's an error even prior to that:

[Thu Oct 29 23:09:40 2015] 192.168.1.22:59089 [200]: /admin - Class 'SQLite3' not found in C:\DB\web\admin\functions.php on line 5



Re: DB transcoder #24 airwave

  • Member
  • 3 posts

0
Neutral

Posted 30 October 2015 - 18:54

Making some slow progress.

By enabling error logging in web/admin/index.php, I get the following error:

php Undefined index: authenticated in index.php line 24

 

Turns out the variable has some issue here. If I set it manually ($_SESSION["authenticated"]='true';) I get logged in, but cannot see anything useful (the channel list is the default one, refresh playlist has no effect etc.)



Re: DB transcoder #25 spameris

  • Senior Member
  • 49 posts

+1
Neutral

Posted 30 October 2015 - 21:22

If you are runing this app on windows, try please run this bat file as administrator, (right click "run as administrator"), than let me know about results. Check please also is this app extracted path c:\DB\

 

 

 

Hi,

 

having issues running it on Windows 10 64-bit.

Installed and started as explained, VC framework is installed, server started as administrator and listening on port 8888.

When trying to log in, I get to the admin interface, but then in the shell window I get three 404 errors. After clicking Login, nothing else happens (I am still at the start page). The errors are strange, as the corresponding files are in place in C:\DB\...

 

[Thu Oct 29 00:08:11 2015] 192.168.1.22:50987 [200]: /admin?
[Thu Oct 29 00:08:11 2015] 192.168.1.22:50991 [404]: /css/slider.css - No such file or directory
[Thu Oct 29 00:08:11 2015] 192.168.1.22:50992 [404]: /js/bootstrap-slider.js - No such file or directory
[Thu Oct 29 00:08:11 2015] 192.168.1.22:50993 [404]: /js/modernizr.js - No such file or directory
[Thu Oct 29 00:08:11 2015] 192.168.1.22:50994 [404]: /js/tr.js - No such file or directory

 


Edited by spameris, 30 October 2015 - 21:23.

Enigma2 Transcoder win/lin: http://e2transcoder....nscoder_070.zip


Re: DB transcoder #26 spameris

  • Senior Member
  • 49 posts

+1
Neutral

Posted 30 October 2015 - 21:50

sorry i didnt read carefully as this is standard error if there is no permissions, i will check to launch app on W10 and let you know about results.


Enigma2 Transcoder win/lin: http://e2transcoder....nscoder_070.zip


Re: DB transcoder #27 spameris

  • Senior Member
  • 49 posts

+1
Neutral

Posted 30 October 2015 - 22:54

OK i think solution is quite simple, please try to open link

 

http://yourip:8888/admin/index.php

or

http://yourip:8888/admin/

 

i can reproduce error if link is opened with

 

http://yourip:8888/admin (without slash)

 

i will fix this problem, but please let me know if this solve your problem.

 

P.S.

 

e2 website is down, some problems with internet on web server.


Enigma2 Transcoder win/lin: http://e2transcoder....nscoder_070.zip


Re: DB transcoder #28 dEeds

  • Member
  • 1 posts

0
Neutral

Posted 9 November 2015 - 14:13

Hello,

 

I've installed the latest SD Card Image to a Raspberry PI2 Version B and I always get this error in stream.log:

 

Could not create pipeline: could not link omxh264enc-omxh264enc0 to h264parse0

 

Is there something missin on the SD card image?



Re: DB transcoder #29 spameris

  • Senior Member
  • 49 posts

+1
Neutral

Posted 9 November 2015 - 19:09

Hi,

 

1. in config php is it line 

 

$conf["parameters"] = "{stream_url} {width} {audio_id} {stream_dir} {crf} -v";
 
exactly like this ? also with this -v option

 

2.you can try manually launch transcoder binary with following command, ofc replace receiver stream url with your own. And than check is it in /var/www/stream/ folder appearing files.
 
 /opt/e2enc/enc http://192.168.1.120...55:300000:0:0:0: 400 1 /var/www/stream/ 4000000 -v
 
seems that for some reason to encoder is sent malformed parameters.

Edited by spameris, 9 November 2015 - 19:09.

Enigma2 Transcoder win/lin: http://e2transcoder....nscoder_070.zip


Re: DB transcoder #30 johanedlund

  • Member
  • 4 posts

0
Neutral

Posted 10 November 2015 - 18:34

Hi,

I just bought a Raspberry PI to use this SW but I get the same error as post #28. I have done what you suggested in post #29 and checked that the file looks correct and it does, I also tried to manually launch the transcoder but with the same result "Could not create pipeline: could not link omxh264enc-omxh264enc0 to h264parse0"

 

What to do next?

 

/Johan

 

PS. It works really good on a Win-machine ;-)



Re: DB transcoder #31 spameris

  • Senior Member
  • 49 posts

+1
Neutral

Posted 10 November 2015 - 18:58

Could please record approx 20seconds of tv channel with receiver and share this file in some cloud like dropbox and give link to me.

For this pi2 this e2transcoder is still very young and bugs can be expected ;)

Enigma2 Transcoder win/lin: http://e2transcoder....nscoder_070.zip


Re: DB transcoder #32 spameris

  • Senior Member
  • 49 posts

+1
Neutral

Posted 10 November 2015 - 21:26

OK, i think i reproduced this error. I think you missed point 3 in installation decription.

 

  1. If you want a transcode SD channels you need a MPEG2 license. MPEG2 license is necessary  to PI2 could decode in HW mode mpeg2 streams.  http://www.raspberry...-2-license-key/

I think you want to transcode mpeg2 channels, but to do this on PI2 in HW assisted mode you need to buy this license. http://www.raspberry...-2-license-key/ and when you receive key , you should enter it in /boot/config.txt than this feature will be activated for your PI2. This money is not going to me im not a lawyer i dont know  who and why is getting this money.

 

To double check is this realy issue you can just try to transcode some HD channels or SD channels which are broadcasted in MPEG4 format.


Edited by spameris, 10 November 2015 - 21:30.

Enigma2 Transcoder win/lin: http://e2transcoder....nscoder_070.zip


Re: DB transcoder #33 johanedlund

  • Member
  • 4 posts

0
Neutral

Posted 10 November 2015 - 23:49

Hi again,

I am only trying to transcode HD-channels and the error message that I got was when try to encode SVT1 HD which is in MPEG4.

 

So there's something else that's causing the error.



Re: DB transcoder #34 spameris

  • Senior Member
  • 49 posts

+1
Neutral

Posted 12 November 2015 - 22:29

on my receiver i transcoded SVT1 HD  (0.8W) without any problems. I restored clean image to SD card and it transcoded without any problems, so im noto sure to i can help without this short video file.


Enigma2 Transcoder win/lin: http://e2transcoder....nscoder_070.zip


Re: DB transcoder #35 spameris

  • Senior Member
  • 49 posts

+1
Neutral

Posted 26 November 2015 - 09:37

to fix this 

 

Could not create pipeline: could not link omxh264enc-omxh264enc0 to h264parse0

 

please disable "Include ECM in http streams" receiver settings.


Enigma2 Transcoder win/lin: http://e2transcoder....nscoder_070.zip


Re: DB transcoder #36 johanedlund

  • Member
  • 4 posts

0
Neutral

Posted 1 December 2015 - 01:28

Hi, 

Now I have tried to switch off "Include ECM in http streams" but getting the same error.

 

In the beginning of the error it says:

 

** (enc:2825): WARNING **: Cannot autolaunch D-Bus without X11 $DISPLAY

** (enc:2825): WARNING **: Cannot autolaunch D-Bus without X11 $DISPLAY

** (enc:2825): WARNING **: Cannot autolaunch D-Bus without X11 $DISPLAY

** (enc:2825): WARNING **: Cannot autolaunch D-Bus without X11 $DISPLAY

** (enc:2825): WARNING **: Cannot autolaunch D-Bus without X11 $DISPLAY

 

 

----

 

Could not create pipeline: could not link omxh264enc-omxh264enc0 to h264parse0

 

What can I do to help you find this error?

 

/Johan



Re: DB transcoder #37 johanedlund

  • Member
  • 4 posts

0
Neutral

Posted 1 December 2015 - 02:18

The full error message:

 

 

sudo /opt/e2enc/enc http://192.168.2.144...6:E080000:0:0:0: 400 1 /var/www/stream/ 4000000 -v
 
** (enc:2783): WARNING **: Cannot autolaunch D-Bus without X11 $DISPLAY
 
** (enc:2783): WARNING **: Cannot autolaunch D-Bus without X11 $DISPLAY
 
** (enc:2783): WARNING **: Cannot autolaunch D-Bus without X11 $DISPLAY
 
** (enc:2783): WARNING **: Cannot autolaunch D-Bus without X11 $DISPLAY
 
** (enc:2783): WARNING **: Cannot autolaunch D-Bus without X11 $DISPLAY
Analyzing URI timed out
 
souphttpsrc location=http://192.168.2.144...6:E080000:0:0:0: is-live=true ! decodebin name=demux demux.src_1 ! queue !  audioresample ! audioconvert dithering=0 ! audio/x-raw,channels=2 ! avenc_aac compliance=experimental ! mux. mpegtsmux name=mux ! hlssink max-files=4 location=/var/www/stream/stream%05d.ts playlist-location=/var/www/stream/ystream.m3u8 target-duration=10 demux. ! queue deinterlace method=greedyl ! videoscale method=1 ! videorate ! videoconvert ! omxh264enc target-bitrate=4000000 control-rate=variable inlin             e-header=true periodicty-idr=1 interval-intraframes=50 ! video/x-h264,framerate=24/1,profile=high,width=400,height=0 ! h264parse config-interval=5 ! mux.
0
0
400
400
1
/var/www/stream/
4000000
0
souphttpsrc location=http://192.168.2.144...6:E080000:0:0:0: is-live=true ! decodebin name=demux demux.src_1 ! queue ! audioresample ! audioconvert dithering=0 ! audio/x-raw,channels=2 ! avenc_aac compliance=experimental ! mux. mpegtsmux name=mux ! hlssink max-files=4 location=/var/www/stream/stream%05d.ts playlist-location=/var/www/stream/ystream.m3u8 target-duration=10 demux. ! queue ! deinterlace method=greedyl ! videoscale method=1 ! videorate ! videoconvert ! omxh264enc target-bitrate=4000000 control-rate=variable inline-header=true periodicty-idr=1 interval-intraframes=50 ! video/x-h264,framerate=24/1,profile=high,width=400,height=0 ! h264parse config-interval=5 ! mux.
Could not create pipeline: could not link omxh264enc-omxh264enc0 to h264parse0


Re: DB transcoder #38 kareltjevdh

  • Member
  • 15 posts

0
Neutral

Posted 4 January 2016 - 14:57

I've tried to use the transcoder but after starting it on a windows 7 machine with admin rights  i get the following errors:

 

[Mon Jan 04 14:53:56 2016] 127.0.0.1:51570 [200]: /admin
[Mon Jan 04 14:53:56 2016] 127.0.0.1:51602 [404]: /css/slider.css - No such file or directory
[Mon Jan 04 14:53:56 2016] 127.0.0.1:51603 [404]: /js/bootstrap-slider.js - No such file or directory
[Mon Jan 04 14:53:56 2016] 127.0.0.1:51604 [404]: /js/tr.js - No such file or directory
[Mon Jan 04 14:53:56 2016] 127.0.0.1:51606 [404]: /js/modernizr.js - No such file or directory
[Mon Jan 04 14:53:56 2016] 127.0.0.1:51605 [404]: /favicon.ico - No such file or directory
[Mon Jan 04 14:55:11 2016] 127.0.0.1:51867 [200]: /admin/index.php
[Mon Jan 04 14:55:11 2016] 127.0.0.1:51868 [200]: /admin/css/slider.css
[Mon Jan 04 14:55:11 2016] 127.0.0.1:51869 [200]: /admin/js/bootstrap-slider.js
[Mon Jan 04 14:55:11 2016] 127.0.0.1:51870 [200]: /admin/js/modernizr.js
[Mon Jan 04 14:55:11 2016] 127.0.0.1:51871 [200]: /admin/js/tr.js

 

Best regards,

 

Karel



Re: DB transcoder #39 spameris

  • Senior Member
  • 49 posts

+1
Neutral

Posted 4 January 2016 - 19:50

Hi Karel,

 

try please open link http://yourip:8888/admin/   (with slash at end)

 

do you entering correct username and password ?


Enigma2 Transcoder win/lin: http://e2transcoder....nscoder_070.zip


Re: DB transcoder #40 spameris

  • Senior Member
  • 49 posts

+1
Neutral

Posted 18 March 2016 - 13:06

Hi,

 

just wanted to inform that recently moved to another domain, where you can download transcoder.

 

how this is http://e2transcoder.sharetext.net


Enigma2 Transcoder win/lin: http://e2transcoder....nscoder_070.zip





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users