Jump to content


Photo

Cron job werkt niet


  • Please log in to reply
64 replies to this topic

Re: Cron job werkt niet #21 doglover

  • Rytec EPG Team
  • 15,245 posts

+536
Excellent

Posted 3 April 2015 - 14:39

root@et9x00:~# crontab -l                                         
*/5 echo "hallo" > /tmp/test.log                                  
55 15 * * * ntpdate time.nist.gov > /tmp/ntpdate.log              
52 5 * * * rm /media/hdd/epg.dat                                  
53 5 * * * rebootroot@et9x00:~#              

Willy

                    
                                                                


~~Rytec Team~~
Maxytec Multibox SE OpenPli (used as mediaplayer)
Mutant HD2400 OpenPli
Vu+ Duo OpenPli (backup)

Synology NAS

Sat: 13E, 19.2E, 23.5E and 28.2E
*Pli/Rytec EPG POWERED*


Re: Cron job werkt niet #22 ims

  • PLi® Core member
  • 12,739 posts

+194
Excellent

Posted 3 April 2015 - 14:40

note in englisg - sorry:

 

for me did not work crontab, then I used: opkg install busybox-cron --force-reinstall

only after it was created /etc/cron/crontabs directory with root file and then cron work  (crontab -c and crontab -l too )


Kdo nic nedělá, nic nezkazí!

Re: Cron job werkt niet #23 Jan Gruuthuse

  • Senior Member
  • 984 posts

+20
Neutral

Posted 3 April 2015 - 14:54

Ik zie hem de log file aan maken 7 B. Dus veronderstel ik dat cronjob werkt met /etc/cron/crontabs/root. Echter krijg geen toegang tot de log. Kan dus niet nagaan of de instructies wel correct werken. Log blijft 7 B  groot.


3 * xp1000 OpenPli 4.0 + usb 3.0 stick 64 GB, fixed lnb 28.2E, 23.5E ,19.2E ,16E, 13E, 9E, 4.8E, n4100pro 12 TB


Re: Cron job werkt niet #24 Jan Gruuthuse

  • Senior Member
  • 984 posts

+20
Neutral

Posted 3 April 2015 - 15:08

De log (usb stick) op computer bekeken: de "hallo" stond dus 1 keer in de log file.


3 * xp1000 OpenPli 4.0 + usb 3.0 stick 64 GB, fixed lnb 28.2E, 23.5E ,19.2E ,16E, 13E, 9E, 4.8E, n4100pro 12 TB


Re: Cron job werkt niet #25 doglover

  • Rytec EPG Team
  • 15,245 posts

+536
Excellent

Posted 3 April 2015 - 15:14

Als je wil appenden aan een bestaande file moet je >> gebruiken.

Als je > gebruikt wordt iedere keer de file overschreven.

 

Willy

 

PS bij mij wil ie nog niet echt.


~~Rytec Team~~
Maxytec Multibox SE OpenPli (used as mediaplayer)
Mutant HD2400 OpenPli
Vu+ Duo OpenPli (backup)

Synology NAS

Sat: 13E, 19.2E, 23.5E and 28.2E
*Pli/Rytec EPG POWERED*


Re: Cron job werkt niet #26 Jan Gruuthuse

  • Senior Member
  • 984 posts

+20
Neutral

Posted 3 April 2015 - 15:27

opkg list | grep busybox-cron
busybox-cron - 1.22.1-r32.3 - Tiny versions of many common UNIX utilities in a single small executable
opkg list-installed | grep busybox-cron
busybox-cron - 1.22.1-r32.3

 

 

eventueel zoals ims voorsteld met herstart van de box.

opkg install busybox-cron --force-reinstall
System OE: 	        PLi-OE
Distro: 	        openpli
Firmware version: 	4.0
Driver date: 	        3.12.1+20140103-r1.4
Kernel version: 	3.12.1
Gui version: 	        2015-04-03

Edited by Jan Gruuthuse, 3 April 2015 - 15:29.

3 * xp1000 OpenPli 4.0 + usb 3.0 stick 64 GB, fixed lnb 28.2E, 23.5E ,19.2E ,16E, 13E, 9E, 4.8E, n4100pro 12 TB


Re: Cron job werkt niet #27 doglover

  • Rytec EPG Team
  • 15,245 posts

+536
Excellent

Posted 3 April 2015 - 15:28

Cron heeft éénmaal zij job uitgevoerd nadat ik dit gedaan hebt:  opkg install busybox-cron --force-reinstall

 

Hierna wil ie niet meer.

Momenteel staat er dit in:

 

 

 

# dummy line
*/2 * * * * echo "hallo" >> /tmp/test.log
25 16 * * * date >> /tmp/ntpdate.log
52 5 * * * rm /media/hdd/epg.dat
53 5 * * * reboot

Willy


~~Rytec Team~~
Maxytec Multibox SE OpenPli (used as mediaplayer)
Mutant HD2400 OpenPli
Vu+ Duo OpenPli (backup)

Synology NAS

Sat: 13E, 19.2E, 23.5E and 28.2E
*Pli/Rytec EPG POWERED*


Re: Cron job werkt niet #28 doglover

  • Rytec EPG Team
  • 15,245 posts

+536
Excellent

Posted 3 April 2015 - 15:30

root@et9x00:~# opkg list | grep busybox-cron                                   
busybox-cron - 1.22.1-r32.12 - Tiny versions of many common UNIX utilities in a
single small executable                                                        
root@et9x00:~#                                                                 
root@et9x00:~# opkg list-installed | grep busybox-cron                         
busybox-cron - 1.22.1-r32.12                                              

Willy


~~Rytec Team~~
Maxytec Multibox SE OpenPli (used as mediaplayer)
Mutant HD2400 OpenPli
Vu+ Duo OpenPli (backup)

Synology NAS

Sat: 13E, 19.2E, 23.5E and 28.2E
*Pli/Rytec EPG POWERED*


Re: Cron job werkt niet #29 doglover

  • Rytec EPG Team
  • 15,245 posts

+536
Excellent

Posted 3 April 2015 - 15:33

Nog eens dit gedaan:

root@et9x00:~#                                                                 
root@et9x00:~# opkg install busybox-cron --force-reinstall                     
Downloading http://downloads.pli-images.org/feeds/openpli-4/mips32el/busybox-cr
n_1.22.1-r32.12_mips32el.ipk.                                                  
Reinstalling busybox-cron (1.22.1-r32.12) on root.                             
stopping Busybox Periodic Command Scheduler: crond... stopped crond (pid 18847)
done.                                                                          
update-rc.d: /etc/init.d/busybox-cron exists during rc.d purge (continuing)    
 Removing any system startup links for busybox-cron ...                        
  /etc/rc0.d/K20busybox-cron                                                   
  /etc/rc1.d/K20busybox-cron                                                   
  /etc/rc2.d/S20busybox-cron                                                   
  /etc/rc3.d/S20busybox-cron                                                   
  /etc/rc4.d/S20busybox-cron                                                   
  /etc/rc5.d/S20busybox-cron                                                   
  /etc/rc6.d/K20busybox-cron                                                   
Configuring busybox-cron.                                                      
 Adding system startup for /etc/init.d/busybox-cron.                           
starting Busybox Periodic Command Scheduler: crond... done.      

En hij een test.log file geschreven met één hallo in.

Binnen twee minuten weten we meer.

 

Willy


~~Rytec Team~~
Maxytec Multibox SE OpenPli (used as mediaplayer)
Mutant HD2400 OpenPli
Vu+ Duo OpenPli (backup)

Synology NAS

Sat: 13E, 19.2E, 23.5E and 28.2E
*Pli/Rytec EPG POWERED*


Re: Cron job werkt niet #30 doglover

  • Rytec EPG Team
  • 15,245 posts

+536
Excellent

Posted 3 April 2015 - 15:37

Nu schijnt ie te werken.

Er staan al drie hallo's in de file nu.

 

Rest morgenochtend.

 

Willy


~~Rytec Team~~
Maxytec Multibox SE OpenPli (used as mediaplayer)
Mutant HD2400 OpenPli
Vu+ Duo OpenPli (backup)

Synology NAS

Sat: 13E, 19.2E, 23.5E and 28.2E
*Pli/Rytec EPG POWERED*


Re: Cron job werkt niet #31 Jan Gruuthuse

  • Senior Member
  • 984 posts

+20
Neutral

Posted 3 April 2015 - 15:40

blijkbaar op de goede weg.


3 * xp1000 OpenPli 4.0 + usb 3.0 stick 64 GB, fixed lnb 28.2E, 23.5E ,19.2E ,16E, 13E, 9E, 4.8E, n4100pro 12 TB


Re: Cron job werkt niet #32 Erik Slagter

  • PLi® Core member
  • 46,759 posts

+536
Excellent

Posted 3 April 2015 - 16:05

Ik heb ook wel eens ruzie gehad met de crond van busybox. Volgens mij is er (ook) een probleem met detecteren dat je een aanpassing heb gedaan in de crontab, dat werkt niet (altijd). Je moet dan de crond daemon herstarten voordat er wat gebeurt. De "echte" crond ziet dat altijd vanzelf.


* Wavefrontier T90 with 28E/23E/19E/13E/9E/4.8E/0.8W/5W via SCR switches 2 x 2 x 6 user bands
* Ziggo digital cable TV (FTA)
I don't read PM -> if you have something to ask or to report, do it in the forum so others can benefit. I don't take freelance jobs.
Ik lees geen PM -> als je iets te vragen of te melden hebt, doe het op het forum, zodat anderen er ook wat aan hebben.

Re: Cron job werkt niet #33 doglover

  • Rytec EPG Team
  • 15,245 posts

+536
Excellent

Posted 3 April 2015 - 16:23

En hoe herstart je hem?

Heb hem nu geherinstalleerd (heb het tweemaal moeten doen).  Ik zal zien morgenochtend of ie zijjn job behoorlijk vervuld.

 

Willy


~~Rytec Team~~
Maxytec Multibox SE OpenPli (used as mediaplayer)
Mutant HD2400 OpenPli
Vu+ Duo OpenPli (backup)

Synology NAS

Sat: 13E, 19.2E, 23.5E and 28.2E
*Pli/Rytec EPG POWERED*


Re: Cron job werkt niet #34 Erik Slagter

  • PLi® Core member
  • 46,759 posts

+536
Excellent

Posted 3 April 2015 - 16:45

Volgens het boekje door kill -HUP ernaartoe te sturen, maar of dat werkt? Zoniet, afschieten met kill (zonder -HUP), kijken naar de command line en precies weer zo opstarten... Hier staat "/usr/sbin/crond -c /etc/cron/crontabs"


* Wavefrontier T90 with 28E/23E/19E/13E/9E/4.8E/0.8W/5W via SCR switches 2 x 2 x 6 user bands
* Ziggo digital cable TV (FTA)
I don't read PM -> if you have something to ask or to report, do it in the forum so others can benefit. I don't take freelance jobs.
Ik lees geen PM -> als je iets te vragen of te melden hebt, doe het op het forum, zodat anderen er ook wat aan hebben.

Re: Cron job werkt niet #35 doglover

  • Rytec EPG Team
  • 15,245 posts

+536
Excellent

Posted 4 April 2015 - 11:16

Cron heeft zijn taak vervuld deze ochtend.

 

Conclusie:  Cron zat vast op de een of andere manier.

 

Willy


~~Rytec Team~~
Maxytec Multibox SE OpenPli (used as mediaplayer)
Mutant HD2400 OpenPli
Vu+ Duo OpenPli (backup)

Synology NAS

Sat: 13E, 19.2E, 23.5E and 28.2E
*Pli/Rytec EPG POWERED*


Re: Cron job werkt niet #36 MiLo

  • PLi® Core member
  • 14,020 posts

+296
Excellent

Posted 4 April 2015 - 13:48

Waarschijnlijk als je cron een taak laat starten die hangt bij opstarten (bijvoorbeeld NFS access nodig) dan hangt de cron deamon ook.
Real musicians never die - they just decompose

Re: Cron job werkt niet #37 Erik Slagter

  • PLi® Core member
  • 46,759 posts

+536
Excellent

Posted 4 April 2015 - 14:01

Klinkt ook wel plausibel. Dan zou de crond in disk wait moeten staan ('D' status in ps).


* Wavefrontier T90 with 28E/23E/19E/13E/9E/4.8E/0.8W/5W via SCR switches 2 x 2 x 6 user bands
* Ziggo digital cable TV (FTA)
I don't read PM -> if you have something to ask or to report, do it in the forum so others can benefit. I don't take freelance jobs.
Ik lees geen PM -> als je iets te vragen of te melden hebt, doe het op het forum, zodat anderen er ook wat aan hebben.

Re: Cron job werkt niet #38 doglover

  • Rytec EPG Team
  • 15,245 posts

+536
Excellent

Posted 20 April 2015 - 10:05

Heb deze ochtend weer een probleem gehad met cron.

Toegegeven ik had een klein tikfoutje gemaakt in the crontabs.  (was een * vergeten)

 

Maar cron zat wel muurvast.  Wou niets meer uitvoeren.

Kreeg cron ook niet afgeschoten met het kill commando.

 

Nadat ik het typefoutje gecorrigeerd had, en de box met het commando reboot herstart had.  Werkte cron weer en voerde ie de commando's uit.

 

Besluit:  deze versie van cron loopt gemakkelijk vast.

 

Willy

 

PS: is er geen programma'tje dat de crontabs edit en deze perfect opslaat.  En ik bedoel niet crontabs -e want hierin moet je alles manueel intikken


Edited by doglover, 20 April 2015 - 10:07.

~~Rytec Team~~
Maxytec Multibox SE OpenPli (used as mediaplayer)
Mutant HD2400 OpenPli
Vu+ Duo OpenPli (backup)

Synology NAS

Sat: 13E, 19.2E, 23.5E and 28.2E
*Pli/Rytec EPG POWERED*


Re: Cron job werkt niet #39 Erik Slagter

  • PLi® Core member
  • 46,759 posts

+536
Excellent

Posted 20 April 2015 - 18:00

PS: is er geen programma'tje dat de crontabs edit en deze perfect opslaat.  En ik bedoel niet crontabs -e want hierin moet je alles manueel intikken

Ehhh, wat wil je dan, een gui met een muis?

 

Heb je 'm ook geprobeerd met kill -9 te killen? Dan MOET hij weggaan. Zoniet, dan is je linux kernel niet lekker, dan is meer aan de hand.


* Wavefrontier T90 with 28E/23E/19E/13E/9E/4.8E/0.8W/5W via SCR switches 2 x 2 x 6 user bands
* Ziggo digital cable TV (FTA)
I don't read PM -> if you have something to ask or to report, do it in the forum so others can benefit. I don't take freelance jobs.
Ik lees geen PM -> als je iets te vragen of te melden hebt, doe het op het forum, zodat anderen er ook wat aan hebben.

Re: Cron job werkt niet #40 doglover

  • Rytec EPG Team
  • 15,245 posts

+536
Excellent

Posted 20 April 2015 - 18:05

Ehhh, wat wil je dan, een gui met een muis?

 

 

Ja.  Iets waar ik de juiste dingen kan invullen en die het dan goed wegschrijft.

(Heb reeds teveel kleine foutjes gemaakt - die wel nefast waren)

Als het niet bestaat dan doe ik zo wel verder, geen erg.  Nog beter opletten dan.

 

Mag ook een GUI op de box zelf zijn.  Ik heb een draadloos toetsenbord.  Heb vroeger nog zoiets gezien toen ik nog met verschillende images aan het spelen was.  (OpenVIX of OpenATV denk ik)

 

Nee ik heb niet geprobeerd met kill -9

 

Willy


~~Rytec Team~~
Maxytec Multibox SE OpenPli (used as mediaplayer)
Mutant HD2400 OpenPli
Vu+ Duo OpenPli (backup)

Synology NAS

Sat: 13E, 19.2E, 23.5E and 28.2E
*Pli/Rytec EPG POWERED*



0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users