Jump to content


Photo

Kodi 15.2 for vusolose, vusolo2 and vuduo2

kodi vuplus

  • Please log in to reply
238 replies to this topic

Re: Kodi 15.2 for vusolose, vusolo2 and vuduo2 #221 danny187

  • Member
  • 14 posts

0
Neutral

Posted 19 January 2017 - 01:57

Quick question

Latest compile with Kodi 0.5 I think it is, struggles with most Kodi addons which use HLS streams, just blank screen via media player as external, rtmp streams are fine within Kodi also.

Anything I can change once compiled it or during making it so all formats work bang on.

As I had an image from December think different gstreamer and Kodi 0.3. And all formats in Kodi was fine.

But as now making my own, wondering if any ideas what it could be?

Re: Kodi 15.2 for vusolose, vusolo2 and vuduo2 #222 danny187

  • Member
  • 14 posts

0
Neutral

Posted 19 January 2017 - 02:23

Not overly fussed, just wondering if any come across the same and if so what they did.

Re: Kodi 15.2 for vusolose, vusolo2 and vuduo2 #223 danny187

  • Member
  • 14 posts

0
Neutral

Posted 19 January 2017 - 11:03

You do not have this file: kernel-add-support-for-gcc-6.patch.Add this file in /meta-vuplus-bsp/recipes-bsp/linux/files/

Do you have this file? as I have same error.

edit - Found file, will see if this sorts.

Thanks


Edited by danny187, 19 January 2017 - 11:07.


Re: Kodi 15.2 for vusolose, vusolo2 and vuduo2 #224 mman

  • Senior Member
  • 218 posts

0
Neutral

Posted 22 January 2017 - 15:49

I've been looking into this topic, but probably can't find it, how can I install Kodi on Vu+ solo 4K, the entire process.

Thank you to everyone.



Re: Kodi 15.2 for vusolose, vusolo2 and vuduo2 #225 danny187

  • Member
  • 14 posts

0
Neutral

Posted 16 February 2017 - 11:18

has anyone managed to build Kodi 16.1 on the Vu+ Uno 4k?

If so, does anyone have the recipes/info on how I can add it in.

As I can't find anywhere.

thanks.



Re: Kodi 15.2 for vusolose, vusolo2 and vuduo2 #226 foxbob

  • Senior Member
  • 598 posts

+18
Neutral

Posted 17 February 2017 - 20:59

I am build kodi 17 in my solo2.

https://cloud.mail.r.../2PTc/SwW2N6DZK



Re: Kodi 15.2 for vusolose, vusolo2 and vuduo2 #227 littlesat

  • PLi® Core member
  • 54,867 posts

+663
Excellent

Posted 18 February 2017 - 08:32

Why not make it good.... And put changes on the bsp layer here....?

WaveFrontier 28.2E | 23.5E | 19.2E | 16E | 13E | 10/9E | 7E | 5E | 1W | 4/5W | 15W


Re: Kodi 15.2 for vusolose, vusolo2 and vuduo2 #228 bogdanm

  • Senior Member
  • 59 posts

+1
Neutral

Posted 18 February 2017 - 09:31

@mx3L ;

- will be possible run kodi 17 on OE-A images ?

- im see was update on OPENSPA image but im no see file to run on other ?



Re: Kodi 15.2 for vusolose, vusolo2 and vuduo2 #229 ostende

  • Senior Member
  • 69 posts

0
Neutral

Posted 18 February 2017 - 09:44

this is the depends and recommends for can build it 

 

Depends: 
libgcc1 (>= 5.3.0), 
vuplus-libgles-vusolo2 (>= 15.1), 
libpython2.7-1.0 (>= 2.7.11), 
libmysqlclient18 (>= 5.5.49), 
libplist1, 
python-threading, 
python-distutils, 
libpcrecpp0 (>= 8.38), 
libavahi-common3 (>= 0.6.32), 
libz1 (>= 1.2.8), 
libudev1 (>= 3.1.5), 
librtmp1, 
libavahi-client3 (>= 0.6.32), 
xz, python-pkgutil, 
libtag1 (>= 1.9.1), 
python-compression,
libasound2 (>= 1.1.0), 
libxslt (>= 1.1.28),
python-xmlrpc, 
libmicrohttpd12 (>= 0.9.48),
libshairplay0, 
glibc-gconv-utf-32, 
python-email, 
libshairport0, 
python-mechanize, 
alsa-lib, 
python-json, 
python-misc, 
python-difflib, 
libcap2 (>= 2.24), 
libsqlite3-0 (>= 3.11.0), 
libtiff5, 
python-textutils, 
nfs-utils-client, 
python-numbers, 
python-pprint, 
python-netserver, 
python-compiler, 
python-pygobject, 
python, 
liblzma5 (>= 5.2.2), 
libtinyxml2.6.2 (>= 2.6.2), 
libnfs1, libpcre1 (>= 8.38), 
python-subprocess, 
alsa-plugins, 
libfribidi0 (>= 0.19.2), 
python-simplejson, 
libbluray, 
libc6 (>= 2.23), 
python-xml, 
libfreetype6 (>= 2.6.3), 
libupnp3, 
python-robotparser, 
libpyglib-2.0-python0,
python-compile, 
libstdc++6 (>= 5.3.0), 
python-html, 
libsmbclient0 (>= 3.6.25), 
libxml2 (>= 2.9.3), 
python-shell, 
liblzo2-2 (>= 2.09), 
bluez5 (>= 5.37), 
python-zlib, 
python-sqlite3, 
libexpat1 (>= 2.1.0), 
libuuid1 (>= 2.27.1), 
libbz2-0 (>= 1.0.6), 
libyajl2 (>= 2.1.0)
 
 
Recommends: 
glibc-gconv-unicode, 
glibc-charmap-ibm850, 
glibc-gconv-utf-32, 
lsb, 
glibc-localedata-en-us, 
libcec, 
python, 
glibc-charmap-utf-8, 
glibc-gconv-ibm850, 
os-release, 
libcurl4, 
python-re, 
python-lang, 
python-netclient
 
 
Provides: virtual/kodi, kodi
 
 
and the kodi files are attached 
 
 
 
i don't know if their is some change on bb files of kodi but i tried to build it with oealliance image but not succeded
 


Re: Kodi 15.2 for vusolose, vusolo2 and vuduo2 #230 danny187

  • Member
  • 14 posts

0
Neutral

Posted 18 February 2017 - 17:20

 

this is the depends and recommends for can build it 

 

Depends: 
libgcc1 (>= 5.3.0), 
vuplus-libgles-vusolo2 (>= 15.1), 
libpython2.7-1.0 (>= 2.7.11), 
libmysqlclient18 (>= 5.5.49), 
libplist1, 
python-threading, 
python-distutils, 
libpcrecpp0 (>= 8.38), 
libavahi-common3 (>= 0.6.32), 
libz1 (>= 1.2.8), 
libudev1 (>= 3.1.5), 
librtmp1, 
libavahi-client3 (>= 0.6.32), 
xz, python-pkgutil, 
libtag1 (>= 1.9.1), 
python-compression,
libasound2 (>= 1.1.0), 
libxslt (>= 1.1.28),
python-xmlrpc, 
libmicrohttpd12 (>= 0.9.48),
libshairplay0, 
glibc-gconv-utf-32, 
python-email, 
libshairport0, 
python-mechanize, 
alsa-lib, 
python-json, 
python-misc, 
python-difflib, 
libcap2 (>= 2.24), 
libsqlite3-0 (>= 3.11.0), 
libtiff5, 
python-textutils, 
nfs-utils-client, 
python-numbers, 
python-pprint, 
python-netserver, 
python-compiler, 
python-pygobject, 
python, 
liblzma5 (>= 5.2.2), 
libtinyxml2.6.2 (>= 2.6.2), 
libnfs1, libpcre1 (>= 8.38), 
python-subprocess, 
alsa-plugins, 
libfribidi0 (>= 0.19.2), 
python-simplejson, 
libbluray, 
libc6 (>= 2.23), 
python-xml, 
libfreetype6 (>= 2.6.3), 
libupnp3, 
python-robotparser, 
libpyglib-2.0-python0,
python-compile, 
libstdc++6 (>= 5.3.0), 
python-html, 
libsmbclient0 (>= 3.6.25), 
libxml2 (>= 2.9.3), 
python-shell, 
liblzo2-2 (>= 2.09), 
bluez5 (>= 5.37), 
python-zlib, 
python-sqlite3, 
libexpat1 (>= 2.1.0), 
libuuid1 (>= 2.27.1), 
libbz2-0 (>= 1.0.6), 
libyajl2 (>= 2.1.0)
 
 
Recommends: 
glibc-gconv-unicode, 
glibc-charmap-ibm850, 
glibc-gconv-utf-32, 
lsb, 
glibc-localedata-en-us, 
libcec, 
python, 
glibc-charmap-utf-8, 
glibc-gconv-ibm850, 
os-release, 
libcurl4, 
python-re, 
python-lang, 
python-netclient
 
 
Provides: virtual/kodi, kodi
 
 
and the kodi files are attached 
 
 
 
i don't know if their is some change on bb files of kodi but i tried to build it with oealliance image but not succeded

 

Not sure what do with this file on OpenPLi., normally bb files, recipes and kodi.inc?

Have you managed to build Kodi 16.1 or Kodi 16.1RC at all on Vu Uno 4k?

I built vuplus-kodi in Uno 4k it opened but never worked as remote would move tabs inside kodi.

As cant find any proper recipes for Kodi on OpenPli for Vu Uno 4k.

 



Re: Kodi 15.2 for vusolose, vusolo2 and vuduo2 #231 gonzolo

  • Member
  • 2 posts

0
Neutral

Posted 20 February 2017 - 14:22

Kodi 16.1,gstreamer-1.11.0 for vuuno4k,vuultimo4k,vusolo4k

 

Only tested on vusolo4k

Test images:

 

https://files.fm/u/8gzav4hz

 

 

 



Re: Kodi 15.2 for vusolose, vusolo2 and vuduo2 #232 danny187

  • Member
  • 14 posts

0
Neutral

Posted 20 February 2017 - 15:47

Kodi 16.1,gstreamer-1.11.0 for vuuno4k,vuultimo4k,vusolo4k

 

Only tested on vusolo4k

Test images:

 

https://files.fm/u/8gzav4hz

 

 

 

Any idea who made them? or if they have the bitbake/recipes for the vuuno4k Kodi 16.1?

 



Re: Kodi 15.2 for vusolose, vusolo2 and vuduo2 #233 gonzolo

  • Member
  • 2 posts

0
Neutral

Posted 20 February 2017 - 18:49

 

Kodi 16.1,gstreamer-1.11.0 for vuuno4k,vuultimo4k,vusolo4k

 

Only tested on vusolo4k

Test images:

 

https://files.fm/u/8gzav4hz

 

 

 

Any idea who made them? or if they have the bitbake/recipes for the vuuno4k Kodi 16.1?

 

 

ad the missing file for vuuno4k in meta-vuplus/recipes-bsp/kodi

kodi-vuuno4k.bb.

require kodi.inc

COMPATIBLE_MACHINE = "^(vuuno4k)$"

BUILD_PR = "r0"
GLPR = "20161206_r1"

EXTRA_OECONF += " --with-platform=vuplus-arm --with-ffmpeg=force_vuplus_arm "

SRC_URI[xbmc-support.md5sum] = "b0f62cb425b0f5bc5dc6ebcbe76f0890"
SRC_URI[xbmc-support.sha256sum] = "b2b91ec85cc7edfef86218906a8743868e372fb5f2736fa1ce066335a23c6bb1"
 



Re: Kodi 15.2 for vusolose, vusolo2 and vuduo2 #234 puc

  • Senior Member
  • 47 posts

0
Neutral

Posted 21 February 2017 - 18:24

can this work on vu zero if not why



Re: Kodi 15.2 for vusolose, vusolo2 and vuduo2 #235 danny187

  • Member
  • 14 posts

0
Neutral

Posted 21 February 2017 - 23:12

Heads up the image link above for Vu+ Uno 4k made box stick on boot and didn't work.


Finally after days of fucking my build environment up, I now have OpenPli 5.0 on gstreamer 1.11.1 and Kodi 16.1 working on my Vu Uno 4k.

 



Re: Kodi 15.2 for vusolose, vusolo2 and vuduo2 #236 pepinoogorino

  • Senior Member
  • 65 posts

+2
Neutral

Posted 24 February 2017 - 15:52

@danny187 I compile master-next with serviceapp recipes without any major problems for Solo4k. Could you share a recipe for generating image with kodi? I tried recipes from mx3L, but they have been updated over time and probably I missed some stage...


Edited by pepinoogorino, 24 February 2017 - 15:54.


Re: Kodi 15.2 for vusolose, vusolo2 and vuduo2 #237 littlesat

  • PLi® Core member
  • 54,867 posts

+663
Excellent

Posted 24 February 2017 - 16:03

https://github.com/O...b6df24bcd3642e6


WaveFrontier 28.2E | 23.5E | 19.2E | 16E | 13E | 10/9E | 7E | 5E | 1W | 4/5W | 15W


Re: Kodi 15.2 for vusolose, vusolo2 and vuduo2 #238 foxbob

  • Senior Member
  • 598 posts

+18
Neutral

Posted 18 March 2017 - 20:42

Need help.I am build kodi in my solo2.Build and work ok.I use https://github.com/o...163a3b4f33a98(2 months ago).

When i use last openembedded-core build error.

| checking for mipsel-oe-linux-pkg-config... no
| checking for pkg-config... /home/boris/test/vuplus-fulan-openpli-oe-core/build/tmp/work/vusolo2-oe-linux/kodi-vusolo2/17.1rc1-r11/recipe-sysroot-native/usr/bin/pkg-config
| checking pkg-config is at least version 0.9.0... yes
| checking for size_t... yes
| checking for working alloca.h... yes
| checking for alloca... yes
| checking for uid_t in sys/types.h... (cached) {ac_cv_type_uid_t=yes}
| checking for unistd.h... (cached) yes
| checking for working chown... no
| checking for dirent.h that defines DIR... yes
| checking for library containing opendir... none required
| checking whether closedir returns void... yes
| checking for error_at_line... yes
| checking for _LARGEFILE_SOURCE value needed for large files... no
| checking whether mipsel-oe-linux-gcc  -mel -mabi=32 -mhard-float -march=mips32 --sysroot=/home/boris/test/vuplus-fulan-openpli-oe-core/build/tmp/work/vusolo2-oe-linux/kodi-vusolo2/17.1rc1-r11/recipe-sysroot needs -traditional... no
| checking whether lstat correctly handles trailing slash... no
| checking whether lstat accepts an empty string... yes
| checking whether lstat correctly handles trailing slash... (cached) no
| checking for working memcmp... (cached) yes
| checking whether time.h and sys/time.h may both be included... yes
| checking for sys/time.h... yes
| checking for unistd.h... (cached) yes
| checking for stdlib.h... (cached) yes
| checking for sys/param.h... yes
| checking for utime.h... yes
| checking for alarm... yes
| checking for working mktime... no
| checking for getpagesize... (cached) yes
| checking for working mmap... (cached) yes
| checking sys/select.h usability... yes
...
| checking for python... (cached) /home/boris/test/vuplus-fulan-openpli-oe-core/build/tmp/work/vusolo2-oe-linux/kodi-vusolo2/17.1rc1-r11/recipe-sysroot-native/usr/bin/python-native/python
| checking for a version of Python >= '2.1.0'... ./configure: line 22292: /home/boris/test/vuplus-fulan-openpli-oe-core/build/tmp/work/vusolo2-oe-linux/kodi-vusolo2/17.1rc1-r11/recipe-sysroot-native/usr/bin/python-native/python: No such file or directory
| no
| configure: error: in `/home/boris/test/vuplus-fulan-openpli-oe-core/build/tmp/work/vusolo2-oe-linux/kodi-vusolo2/17.1rc1-r11/git':
| configure: error:
| This version of the AC_PYTHON_DEVEL macro
| doesn't work properly with versions of Python before
| 2.1.0. You may need to re-run configure, setting the
| variables PYTHON_CPPFLAGS, PYTHON_LDFLAGS, PYTHON_SITE_PKG,
| PYTHON_EXTRA_LIBS and PYTHON_EXTRA_LDFLAGS by hand.
| Moreover, to disable this check, set PYTHON_NOVERSIONCHECK
| to something else than an empty string.
 
In my recipes:CACHED_CONFIGUREVARS += " \
 ac_cv_path_PYTHON="${STAGING_BINDIR_NATIVE}/python-native/python" \


Re: Kodi 15.2 for vusolose, vusolo2 and vuduo2 #239 nyakec

  • Senior Member
  • 30 posts

0
Neutral

Posted 26 March 2017 - 10:53

@ Mx3L.  Please You may download mx3L kodi 17?  Thanks Díkec-nyakec





Also tagged with one or more of these keywords: kodi, vuplus

1 user(s) are reading this topic

0 members, 1 guests, 0 anonymous users