Jump to content


Photo

[Enigma2][hungary] half of EPG is missing


  • Please log in to reply
18 replies to this topic

#1 adriankoooo

  • Senior Member
  • 29 posts

0
Neutral

Posted 17 January 2016 - 19:41

Hi,

 

 

I am trying to use CrossEPG with Hungarian channels (UPC).

 

-CrossEPG installed with blue panel

- update rytec list...

-I choosed Rytec Hungary from the list 

-Yellow button: download

 

When it is finished I pressed Force epg reload.

 

Done.

 

The result? Nothing. EPG on the half of channels are missing:

 

Attached File  screenshot.png   48.88KB   7 downloads

Attached File  screenshot-2.png   25.81KB   6 downloads

 

What I tried already:

 

-reboot

-download again + force reload epg

 



Re: [Enigma2][hungary] half of EPG is missing #2 Robinson

  • Senior Member
  • 2,481 posts

+28
Good

Posted 17 January 2016 - 20:23

Yoy will get little help on this forum if you use CrossEPG.

Use EPGImport instead.


ET9000, OpenPLi 4.0, 13E, 19E

HD51, OpenPLi 6.2, 75E - 30W


Re: [Enigma2][hungary] half of EPG is missing #3 fabiandaniel

  • Senior Member
  • 28 posts

0
Neutral

Posted 17 January 2016 - 20:51

Hi,

 

 

I am trying to use CrossEPG with Hungarian channels (UPC).

 

-CrossEPG installed with blue panel

- update rytec list...

-I choosed Rytec Hungary from the list 

-Yellow button: download

 

When it is finished I pressed Force epg reload.

 

Done.

 

The result? Nothing. EPG on the half of channels are missing:

 

attachicon.gifscreenshot.png

attachicon.gifscreenshot-2.png

 

What I tried already:

 

-reboot

-download again + force reload epg

I have also this problem



Re: [Enigma2][hungary] half of EPG is missing #4 adriankoooo

  • Senior Member
  • 29 posts

0
Neutral

Posted 17 January 2016 - 21:36

The biggest problem that there is no EPGImport plugin in Newnigma, only CrossEPG. Maybe someone reads this topic who uses Newnigma2 and can help us.



Re: [Enigma2][hungary] half of EPG is missing #5 doglover

  • Rytec EPG Team
  • 12,576 posts

+381
Excellent

Posted 18 January 2016 - 08:06

Use an image which has XMLTVimport included (OpenPLi, OpenATV, OpenVIX)

 

or

 

request Newnigma they support XMLTVimport.  If Crossepg works, there is no reason why XMLTVimport should not work.

 

Willy


~~Rytec Team~~
Xtrend ET6000 OpenPli (used as mediaplayer)
Mutant HD2400 OpenPli
Vu+ Duo OpenPli (backup)

Synology NAS

Sat: 13E, 19.2E, 23.5E and 28.2E
*Pli/Rytec EPG POWERED*


Re: [Enigma2][hungary] half of EPG is missing #6 adriankoooo

  • Senior Member
  • 29 posts

0
Neutral

Posted 20 January 2016 - 16:49

There is some problem with closed source Enigma2 code? I thought that Open***, Newnigma2 and other image developers works from the same codebase (CVS).

 

http://board.newnigm...8906#post228906



Re: [Enigma2][hungary] half of EPG is missing #7 doglover

  • Rytec EPG Team
  • 12,576 posts

+381
Excellent

Posted 20 January 2016 - 17:19

If you believe the gutemine explanations, good luck.

All Open*** images can load the epg.dat files created by XMLTVimport.

 

Willy


Edited by doglover, 20 January 2016 - 17:21.

~~Rytec Team~~
Xtrend ET6000 OpenPli (used as mediaplayer)
Mutant HD2400 OpenPli
Vu+ Duo OpenPli (backup)

Synology NAS

Sat: 13E, 19.2E, 23.5E and 28.2E
*Pli/Rytec EPG POWERED*


Re: [Enigma2][hungary] half of EPG is missing #8 adriankoooo

  • Senior Member
  • 29 posts

0
Neutral

Posted 20 January 2016 - 17:31

Doglover, I am just asking this as a regular user who can't understand why this plugin not working on all Enigma2 images.

 

Is there any patch missing from Newnigma2? Since XMLTVImport/Crossepg creates the epg.dat, just the image won't recognize it?! In this case I can't do anything, the team must first patch the image.

 

 

I feel there little conflict between the two teams.  :D



Re: [Enigma2][hungary] half of EPG is missing #9 WanWizard

  • Forum Moderator
    PLi® Core member
  • 46,428 posts

+751
Excellent

Posted 20 January 2016 - 17:50

As to your first remark, it is a common misconception that "all" enigma2 codebases are the same, this is absolutely not the case.

 

All public ones (i.e. the open source ones) have code derived from the last DMM version that was GPLv2 licensed. Some, like VU+, stuck to this codebase, and derivatives like OpenVIX worked with that code. OpenPLi went their own direction as soon as DMM left the open source scene, and went their own way. We also have our own Open Embedded version. Some other images use our code, some don't, some cherry-pick some changes and leave others.

 

As a result, there are differences, sometimes significant.

 

As for OpenPLi, we like to innovate, and find that plugin creators have to be compatible with OpenPLi, not that we have to stay compatible with (sometimes very old) plugins.

 

So, there may be many reasons why a plugin you get from the internet somewhere works on image A and not on image B...


Currently in use: VU+Duo 4K (2xFBC S2), Amiko Viper T2C (T2), SAB Alpha Triple HD (S2+T2), Zgemma H3.T2C (T/C), Zgemma H6 (fallback), VU+Zero (fallback)

Many answers to your question can be found in our new and improved wiki.

note: I do not provide support via PM !

 


Re: [Enigma2][hungary] half of EPG is missing #10 adriankoooo

  • Senior Member
  • 29 posts

0
Neutral

Posted 20 January 2016 - 17:58

Nice, thanks for clarification. It is clear now.

 

One more question: I would like to read more about OpenPli innovations (how/what is it different from other images). Is there any comparison like this?

 

In short time I am going to switch to Vu+ so I definitely going to try OpenPLI.



Re: [Enigma2][hungary] half of EPG is missing #11 WanWizard

  • Forum Moderator
    PLi® Core member
  • 46,428 posts

+751
Excellent

Posted 20 January 2016 - 18:00

Most of our innovations are "under the hood". There is no "end-user" definition of modifications, technical people can follow our twitter account. We leave the "dressing up" of the image, like plugins and skins, to other people.


Currently in use: VU+Duo 4K (2xFBC S2), Amiko Viper T2C (T2), SAB Alpha Triple HD (S2+T2), Zgemma H3.T2C (T/C), Zgemma H6 (fallback), VU+Zero (fallback)

Many answers to your question can be found in our new and improved wiki.

note: I do not provide support via PM !

 


Re: [Enigma2][hungary] half of EPG is missing #12 gutemine

  • Senior Member
  • 841 posts

+64
Good

Posted 20 January 2016 - 23:10

It is not about believing - try it out and you will see what happens.

 

PLI or any other recent XMLTV ipk installs nicely on a DMM OE2.0  Image. When loading is executing it doesn't find the necessary patches, therefore the code fallback creates an epg.dat and then e2 starts crashing when it tries to load it (bzw. due to version mismatch. Your git still supports old ones for the crappy epg.dat distributors which seem do die hard, but DMM abandoned that when they switched from OE 1.6 to 2.0. The epg.dat that the Cossepg C code and the resulting binary produce is loading, the one created with the python code of the XMLTV Plugin is NOT.

 

And your are wrong, hardly any other box ist still loading the epg.dat, I think the last time this was actually really used was PLI 2.x. In the meantime allmost all OpenXYZ Images use the patch to load epg per events - which DMM rejected years ago to avoid crashes from corrupt data loads. What they DID implement is a patch to load epg.dat without restarting, which now CrossEPF uses and which would be only a handfull of codelines to use also in XMLTV Plugin as I use the same calls in DreamOS to oad the epg.db intead, but if the epg.dat is not valid this doesnÄt help at all.

 

But I think we had a similar discussion before and I will not repeat my answers all over again.

 

Ciao

gutemine


Edited by gutemine, 20 January 2016 - 23:15.


Re: [Enigma2][hungary] half of EPG is missing #13 doglover

  • Rytec EPG Team
  • 12,576 posts

+381
Excellent

Posted 21 January 2016 - 08:20

gutemine you seem to have all the answers all the time.

 

The plug-in (XMLTVimport) is opensource, why not contribute to it, and fix things.  So it can be used on more images.

Use as a start this Github:  https://github.com/o...nce/XMTV-Import

Since this version uses a build in option to update the sources. (As a programmer you will easily find where to find the sources.)  It has the advantage the user never has to worry about updating the sources again.

(The OpenPli version uses a different method for this, which I believe is better, but when the sources are updated the user has to update its configuration file.  Which can be a disadvantage)

For the actually importing of the EPG both the OE-Alliance and Open PLi version of XMLTVimport are identical.

 

Be positive, and contribute.

We can disagree about things, but you have the knowledge about programming these things.  I do not have this knowledge.  (I can contribute in a different way)

 

Willy


Edited by doglover, 21 January 2016 - 08:31.

~~Rytec Team~~
Xtrend ET6000 OpenPli (used as mediaplayer)
Mutant HD2400 OpenPli
Vu+ Duo OpenPli (backup)

Synology NAS

Sat: 13E, 19.2E, 23.5E and 28.2E
*Pli/Rytec EPG POWERED*


Re: [Enigma2][hungary] half of EPG is missing #14 gutemine

  • Senior Member
  • 841 posts

+64
Good

Posted 21 January 2016 - 19:59

Look the Plugin is very badly programmed, tons of try:/except: just to keep it going, idiotic things like checking if a Channel exists by creating a dummy recordings, not handling multi EPG Languages, etc. which I already explained here I think 1-2x

 

I had to fix some of these things to make it run on DreamOS and the deb shipps with all these changes. It even still includes the epg_dat.py so that the same code works on OpenATV with my 7080 just to proove that I didn't ruin it. if you diff them you would already get a better Plugin.

 

BUT I did all this NOT to make XMLTV work on DreamOS, I did it to proove how simply the DreamOS epg.db is to use and integrate and the purpose was to stop comments like this Plugin can't work with DreamOS because they use a closed source e2, etc.

 

THEN the complaints started why OpenTV loading of EPG is not working, why CrossEPG is not working on DreamOS.  So I looked into the CrossEPG code and when I saw how badly THIS is coded I decided to stop, just take the 2 binaries needed and produce my own OpenEPG Plugin. BTW it would be only a 1h job to make this run with old epg.dat just by using a third CrossEPG binary which produces correct epg.dat.

 

But to close the case - I already spent TOO much on this EPG business to prove other people wrong.

 

XMLTV would need me days to clean up a mess which I didn't cause and CrossEPG would need to be completely rewritten to be honest which would be weeks.

 

I'm simply sorry to say that I'm not interested anymore in spending further time on EPG loading, because my time and interest is limited.

 

It was fun to reverse engineer or invent a python SQL Interface to DMM's epg.db, but the other things are just boring and I preferen to join the crowd complaining how bad it is - with the only difference that I know why and on some things even how easy they could be fixed. Which then even is more frustrating when people ask me to do it instead of spending their own time and ask only for advice - which I normally give quite freely, except when I feel to be exploited.

 

Over the last 12 years since I'*m active in this community I've contributed already around 200 Plugins and around 65.0000 Forum entries at various places, so if you ask me to contribute more ... nice try,

 

And yes, I see this as a positive comment from my side btw ...

 

gutemine


Edited by gutemine, 21 January 2016 - 20:03.


Re: [Enigma2][hungary] half of EPG is missing #15 fabiandaniel

  • Senior Member
  • 28 posts

0
Neutral

Posted 7 February 2016 - 14:03

The fault is with the XMLTV import as well because Rytec Hungary datas are incomplete. 

 

Hi,

 

 

I am trying to use CrossEPG with Hungarian channels (UPC).

 

-CrossEPG installed with blue panel

- update rytec list...

-I choosed Rytec Hungary from the list 

-Yellow button: download

 

When it is finished I pressed Force epg reload.

 

Done.

 

The result? Nothing. EPG on the half of channels are missing:

 

attachicon.gifscreenshot.png

attachicon.gifscreenshot-2.png

 

What I tried already:

 

-reboot

-download again + force reload epg



Re: [Enigma2][hungary] half of EPG is missing #16 doglover

  • Rytec EPG Team
  • 12,576 posts

+381
Excellent

Posted 7 February 2016 - 15:26

See here.

 

File needs maintenance.  Doing it at the moment.

 

Willy


~~Rytec Team~~
Xtrend ET6000 OpenPli (used as mediaplayer)
Mutant HD2400 OpenPli
Vu+ Duo OpenPli (backup)

Synology NAS

Sat: 13E, 19.2E, 23.5E and 28.2E
*Pli/Rytec EPG POWERED*


Re: [Enigma2][hungary] half of EPG is missing #17 benkej

  • Member
  • 2 posts

0
Neutral

Posted 19 February 2016 - 14:42

Please send me working hungarian xmltv source. Today after reboot my dm800 the sources is missing and I don't find working.

 

thank you



Re: [Enigma2][hungary] half of EPG is missing #18 doglover

  • Rytec EPG Team
  • 12,576 posts

+381
Excellent

Posted 19 February 2016 - 14:55

Just install (in OpenPLi) the XMLTVimport-rytec  plug-in.

This contains the sources.

 

Willy


~~Rytec Team~~
Xtrend ET6000 OpenPli (used as mediaplayer)
Mutant HD2400 OpenPli
Vu+ Duo OpenPli (backup)

Synology NAS

Sat: 13E, 19.2E, 23.5E and 28.2E
*Pli/Rytec EPG POWERED*


Re: [Enigma2][hungary] half of EPG is missing #19 benkej

  • Member
  • 2 posts

0
Neutral

Posted 19 February 2016 - 16:50

Thank you! I'll try






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users