Jump to content


Photo

Bluray Player plugin


  • Please log in to reply
120 replies to this topic

#1 Taapat

  • PLi® Core member
  • 1,796 posts

+72
Good

Posted 5 March 2016 - 17:22

The first test version of the simple plugin to play blu-ray discs.
 
Github: enigma2-plugin-blurayplayer
 
Attached File  BlurayPlayerMovieSelection.jpg   63.47KB   55 downloads

 

Attached File  BlurayPlayerMain.jpg   59.14KB   45 downloads

Requires libbluray library (attached).

 

Plugin can play bluray folders and local iso images.
Iso image plugin mount, therefore I disabled iso mount from network. In my opinion it takes too much time, and it is impossible to normal use.

 

Create this plugins I was inspired by nikolasi. I'm in my image for 7111 already in 2014 made automatically bluray play using libbluray library and ffmpeg. But openpli used gstreamer, and this option does not suit. After I read about the nikolasi plugin, I again became interested in the bluray. But I decided to do a little bit differently.

 

I created library that works with enigma python code.
The plugin is integrated in the MovieSelection screen and does not have its own interface to run. Therefore do not be surprised that after installation it can not be found.

Just press ok in MovieSelection screen on bluray folder or iso file to open titles selection. The first title is the longest.

 

While the plugin only reads the file length from the titles and play the corresponding m2ts file.
It does not support chapters and angels.

I have own build system, newest, therefore by my request for openpli-4 packages build MastaG. Many thanks to him for that!



Re: Bluray Player plugin #2 Taapat

  • PLi® Core member
  • 1,796 posts

+72
Good

Posted 5 March 2016 - 17:26

If someone wants to build this plugin himself then here are my bb files for plugin and libbluray from git:

 

enigma2-plugin-extensions-blurayplayer.bb

 

recipes-support/libbluray/libbluray_git.bb



Re: Bluray Player plugin #3 Trial

  • Senior Member
  • 983 posts

+29
Good

Posted 5 March 2016 - 19:27

Hi,

first Test worked perfect. Nice work.

 

Ralf



Re: Bluray Player plugin #4 littlesat

  • PLi® Core member
  • 49,205 posts

+527
Excellent

Posted 5 March 2016 - 20:28

What is the difference between the nf and non nf ipk's?

WaveFrontier 28.2E | 23.5E | 19.2E | 16E | 13E | 10/9E | 7E | 5E | 1W | 4/5W | 15W


Re: Bluray Player plugin #5 Taapat

  • PLi® Core member
  • 1,796 posts

+72
Good

Posted 5 March 2016 - 21:12

It's a question which I also asked MastaG, after he build for me this package.
Here's his answer:

The following receivers are mips32el-nf: DM800 (not supported by PLi), Xtrend ET4x00, XP1000, Mutant HD1100, Zgemma Star sh1 and a few others.
 

However the first gen Zgemma Star (S, H1, H2 and 2S) with sh1 machine comes in two flavors:
They're original BSP used in PLi4 uses soft-float:

 

But oe-alliance uses hard-float for sh1:

 

So in PLi-4 you'll get mips32el-nf for these older Zgemma Star receivers.
But in OpenATV you'll simply get mips32el.



Re: Bluray Player plugin #6 athoik

  • PLi® Core member
  • 7,922 posts

+294
Excellent

Posted 5 March 2016 - 21:28

I guess there is an "inherit allarch" missing from blueray plugin, this is what littlesat says.
Wavefield T90: 0.8W - 1.9E - 4.8E - 13E - 16E - 19.2E - 23.5E - 26E - 33E - 39E - 42E - 45E on EMP Centauri DiseqC 16/1
Unamed: 13E Quattro - 9E Quattro on IKUSI MS-0916

Re: Bluray Player plugin #7 MastaG

  • PLi® Core member
  • 1,514 posts

+115
Excellent

Posted 5 March 2016 - 21:56

There is some c-compiled code in the plugin ipk.
Thats why its not allarch.
If it were python-only then it should be for all.

Re: Bluray Player plugin #8 Taapat

  • PLi® Core member
  • 1,796 posts

+72
Good

Posted 5 March 2016 - 22:02

Yes, in the plugin is used small c library that works between libbluray and plugin python code, so the package can not be with all architecture.


Edited by Taapat, 5 March 2016 - 22:04.


Re: Bluray Player plugin #9 athoik

  • PLi® Core member
  • 7,922 posts

+294
Excellent

Posted 5 March 2016 - 22:09

It can but it requires more efford.

Move this to enigma2 or create another package with c/c++ code and depend on this.

Using shared feeds has great gain when done right. (Less bandwidth, less compile tine).

Even though as long as plugin is not machine specific it is not so big problem ;)
Wavefield T90: 0.8W - 1.9E - 4.8E - 13E - 16E - 19.2E - 23.5E - 26E - 33E - 39E - 42E - 45E on EMP Centauri DiseqC 16/1
Unamed: 13E Quattro - 9E Quattro on IKUSI MS-0916

Re: Bluray Player plugin #10 Erik Slagter

  • PLi® Core member
  • 45,353 posts

+498
Excellent

Posted 6 March 2016 - 12:38

Yes, split the packages.

What's in the binary? Maybe it can be added to enigma2 itself.

 

Does this play encrypted BluRay disks?


* Wavefrontier T90 with 28E/23E/19E/13E/9E/4.8E/0.8W/5W via SCR switches 2 x 2 x 6 user bands
* Ziggo digital cable TV (FTA)
I don't read PM -> if you have something to ask or to report, do it in the forum so others can benefit. I don't take freelance jobs.
Ik lees geen PM -> als je iets te vragen of te melden hebt, doe het op het forum, zodat anderen er ook wat aan hebben.

Re: Bluray Player plugin #11 Taapat

  • PLi® Core member
  • 1,796 posts

+72
Good

Posted 6 March 2016 - 14:07

Of course, if you want, I can split packages.

Binary simply connects plugin python code with libbluray library.
It takes the path to the bluray folder from plugin, and returns the title list.
For this binary has nothing to do with the enigma.

 

But c and python code is so small that the resources and time of its compilation is thousands of times smaller than for the compilation preperate or create package.
The benefit would only in the case, when change the python code. Then should not rebuild packages for architectures, but should rebuild only one package for all arch.

 

But how much architectures is supported on openpli, 2-3? Is it really better to spend resources to build, maintain and update a separate package for 6,8kiB library?

 

This is a very simple plugin. It just reading the titles and give for enigma2 player relevant m2ts file. Do not expect too much from it.

 

I think that for a normal bluray support (3d, menus, etc...) need implement libluray in enigma as it is done in xbmc, ffmpeg, or in the dreambox.
But I think that for me, for it will not be the knowledge and the patience.


Edited by Taapat, 6 March 2016 - 14:11.


Re: Bluray Player plugin #12 Taapat

  • PLi® Core member
  • 1,796 posts

+72
Good

Posted 6 March 2016 - 18:53

Libbluray library from actual git.

Small cosmetic changes.

Improving main title selection:

-prefer playlists with more chapters
-prefer HD over SD, H.264/VC1 over MPEG1/2

Attached Files



Re: Bluray Player plugin #13 thawtes

  • Senior Member
  • 79 posts

+1
Neutral

Posted 7 March 2016 - 04:31

thank you @Taapat

 

good job, i traying...



Re: Bluray Player plugin #14 thawtes

  • Senior Member
  • 79 posts

+1
Neutral

Posted 7 March 2016 - 07:47

not work on vu+ duo2  :(

 

installed enigma2-plugin-extensions-blurayplayer_1+git33+0f16229-r0_mips32el.ipk

installed libbluray_v0.9.2+git2270+cf90e6d-r0_mips32el.ipk

 

but not work... how to work and usage ? (using image openatv 5.1 image)

 

thanks...



Re: Bluray Player plugin #15 littlesat

  • PLi® Core member
  • 49,205 posts

+527
Excellent

Posted 7 March 2016 - 08:00

Try first openpli.... ;)

WaveFrontier 28.2E | 23.5E | 19.2E | 16E | 13E | 10/9E | 7E | 5E | 1W | 4/5W | 15W


Re: Bluray Player plugin #16 nikolasi

  • Member
  • 22 posts

+7
Neutral

Posted 7 March 2016 - 08:30

not work on vu+ duo2  :(

 

installed enigma2-plugin-extensions-blurayplayer_1+git33+0f16229-r0_mips32el.ipk

installed libbluray_v0.9.2+git2270+cf90e6d-r0_mips32el.ipk

 

but not work... how to work and usage ? (using image openatv 5.1 image)

 

thanks...

You can try this it should work on all versions of e2  https://yadi.sk/d/gnu-WsekpxYNu



Re: Bluray Player plugin #17 Trial

  • Senior Member
  • 983 posts

+29
Good

Posted 7 March 2016 - 08:36

Hi,


but not work... how to work and usage ? (using image openatv 5.1 image)

 

 

perhaps answer was in 1st post. You will not see any new plugin. Use the normal mediaplayer and then press OK on an ISO file.

 

ciao



Re: Bluray Player plugin #18 thawtes

  • Senior Member
  • 79 posts

+1
Neutral

Posted 7 March 2016 - 16:03

Hi,


but not work... how to work and usage ? (using image openatv 5.1 image)

 

 

perhaps answer was in 1st post. You will not see any new plugin. Use the normal mediaplayer and then press OK on an ISO file.

 

ciao

 

yes, I know, but somehow it did not work..



Re: Bluray Player plugin #19 thawtes

  • Senior Member
  • 79 posts

+1
Neutral

Posted 7 March 2016 - 16:04

 

not work on vu+ duo2  :(

 

installed enigma2-plugin-extensions-blurayplayer_1+git33+0f16229-r0_mips32el.ipk

installed libbluray_v0.9.2+git2270+cf90e6d-r0_mips32el.ipk

 

but not work... how to work and usage ? (using image openatv 5.1 image)

 

thanks...

You can try this it should work on all versions of e2  https://yadi.sk/d/gnu-WsekpxYNu

 

 

 

thanks, I'm trying now..
 


Re: Bluray Player plugin #20 Trial

  • Senior Member
  • 983 posts

+29
Good

Posted 7 March 2016 - 16:05

Hi,

I tried on OpenViX with self created ISO and no problem. Perhaps you need recent version 5.2.

 

ciao






1 user(s) are reading this topic

0 members, 1 guests, 0 anonymous users