Jump to content


Photo

DM8000 opkg error

DM8000

  • Please log in to reply
11 replies to this topic

#1 pryggi

  • Senior Member
  • 48 posts

0
Neutral

Posted 24 October 2016 - 22:00

DM8000 OpenPLI 4 was last updated in July. Ran the software update from menu and enigma2 package failed to update, 88 other packages were successfully updated.

 

Tested on terminal:
 

root@dm8000:~# opkg update
Downloading http://downloads.pli-images.org/feeds/openpli-4/3rd-party-dm8000/Packages.gz.
Updated list of available packages in /var/lib/opkg/openpli-3rd-party-dm8000.
Downloading http://downloads.pli-images.org/feeds/openpli-4/3rd-party/Packages.gz.
Updated list of available packages in /var/lib/opkg/openpli-3rd-party.
Downloading http://downloads.pli-images.org/feeds/openpli-4/all/Packages.gz.
Updated list of available packages in /var/lib/opkg/openpli-all.
Downloading http://downloads.pli-images.org/feeds/openpli-4/dm8000/Packages.gz.
Updated list of available packages in /var/lib/opkg/openpli-dm8000.
Downloading http://downloads.pli-images.org/feeds/openpli-4/mips32el/Packages.gz.
Updated list of available packages in /var/lib/opkg/openpli-mips32el.


root@dm8000:~# opkg upgrade
Not selecting libdvdread4 5.0.1+git247+4507900 as installing it would break existing dependencies.
Not selecting libdvdnav4 5.0.2+git784+0a0b2ff as installing it would break existing dependencies.
Upgrading enigma2 from 2.7+git14018+cc837df-r0.0 to 2.7+git14329+52ed70a-r0.0 on root.
Downloading http://downloads.pli-images.org/feeds/openpli-4/dm8000/enigma2_2.7+git14329+52ed70a-r0.0_dm8000.ipk.
Installing glibc-gconv-iso8859-15 (2.20-r0.10) on root.
Not selecting libtuxtxt32bpp0 2.0+git63+96a3708 as installing it would break existing dependencies.
Not selecting libtuxtxt32bpp0 2.0+git60+b6c8d5a as installing it would break existing dependencies.
Not selecting libtuxtxt0 2.0+git63+96a3708 as installing it would break existing dependencies.
Not selecting libtuxtxt0 2.0+git60+b6c8d5a as installing it would break existing dependencies.
Collected errors:
 * opkg_download_pkg: Package glibc-gconv-iso8859-15 is not available from any configured src.
 * opkg_install_pkg: Failed to download glibc-gconv-iso8859-15. Perhaps you need to run 'opkg update'?


root@dm8000:~# opkg list_installed | grep glibc-gconv-iso8859-15
eglibc-gconv-iso8859-15 - 2.19-r0


root@dm8000:~# opkg list | grep glibc-gconv-iso8859-1
eglibc-gconv-iso8859-15 - 2.19-r0
glibc-gconv-iso8859-1 - 2.20-r0.0 - gconv module for character set iso8859-1  gconv module for character set
glibc-gconv-iso8859-10 - 2.20-r0.0 - gconv module for character set iso8859-10  gconv module for character set
glibc-gconv-iso8859-11 - 2.20-r0.0 - gconv module for character set iso8859-11  gconv module for character set
glibc-gconv-iso8859-13 - 2.20-r0.0 - gconv module for character set iso8859-13  gconv module for character set
glibc-gconv-iso8859-14 - 2.20-r0.0 - gconv module for character set iso8859-14  gconv module for character set
glibc-gconv-iso8859-15 - 2.20-r0.0 - gconv module for character set iso8859-15  gconv module for character set
glibc-gconv-iso8859-15 - 2.20-r0.10
glibc-gconv-iso8859-16 - 2.20-r0.0 - gconv module for character set iso8859-16  gconv module for character set


root@dm8000:~# opkg install glibc-gconv-iso8859-15
Installing glibc-gconv-iso8859-15 (2.20-r0.10) on root.
Collected errors:
 * opkg_download_pkg: Package glibc-gconv-iso8859-15 is not available from any configured src.
 * opkg_install_pkg: Failed to download glibc-gconv-iso8859-15. Perhaps you need to run 'opkg update'?
 * opkg_install_cmd: Cannot install package glibc-gconv-iso8859-15.

What else can I do to fix this?

Thanks in advance.



Re: DM8000 opkg error #2 WanWizard

  • PLi® Core member
  • 56,543 posts

+1,175
Excellent

Posted 25 October 2016 - 10:31

I don't know why your box wants to install r10, the current feed contains 2.20-r0.0.

 

The packages file also references this file. Have you installed something manually that lists this as an external dependency?


Currently in use: VU+Duo 4K (2xFBC S2), Amiko Viper T2C (T2+fallback), Octagon SF8008 (S2+T2), Zgemma H9.2H (T2+fallback)

Many answers to your question can be found in our new and improved wiki.

Because to health reasons, I will not be active very often anymore.


Re: DM8000 opkg error #3 pryggi

  • Senior Member
  • 48 posts

0
Neutral

Posted 25 October 2016 - 15:16

Thanks for your reply, yes I have manually installed stuff, and also stuff from opkg streams. How can I check the external dependencies of the manually installed stuff?

With opkg status, I could only find that:

root@dm8000:~# opkg status enigma2
Package: enigma2
Version: 2.7+git14018+cc837df-r0.0
Depends: libgcc1 (>= 4.9.1), libgomp1 (>= 4.9.1), libpython2.7-1.0 (>= 2.7.3), python-utf8-hack, python-threading, libtuxtxt0 (>= 2.0+git64+a1b4255), libxml2 (>= 2.9.2), python-codecs, libfreetype6 (>= 2.5.4), python-core, python-twisted-core, libdvbsi++1 (>= 0.3.7), glibc-gconv-iso8859-15, python-re, enigma2-fonts, font-valis-enigma, libstdc++6 (>= 4.9.1), libglib-2.0-0 (>= 2.42.1), libsigc-1.2-5 (>= 1.2.5), python-fcntl, python-netclient, ethtool, python-netserver, libfribidi0 (>= 0.19.2), python-zopeinterface, libc6 (>= 2.20), python-xml, libtuxtxt32bpp0 (>= 2.0+git64+a1b4255), virtual/blindscan-dvbc, python-pickle, libgstpbutils-0.10-0 (>= 0.10.36.1+git10186+bdb3316), libpng16-16 (>= 1.6.16), python-shell, gstreamer (>= 0.10.36.1+git12092+1bcabb9), libgif4 (>= 4.1.6), python-numbers, libdreamdvd0 (>= 1.0+git215+93f5820), python-twisted-web, libjpeg8 (>= 8d), python-zlib, python-crypt, python-lang, alsa-conf
Recommends: gst-plugins-base-app, gst-plugins-base-typefindfunctions, gst-plugins-good-isomp4, gst-plugins-base-vorbis, gst-plugins-base-decodebin, gst-plugins-good-souphttpsrc, gst-plugins-ugly-amrnb, gst-plugins-bad-faad, gst-plugins-good-matroska, gst-plugins-base-playbin, enigma2-plugin-skins-pli-hd, gst-plugins-good-flac, glib-networking, gst-plugins-good-wavparse, gst-plugins-bad-rtmp, hotplug-e2-helper, gst-plugin-subsink, gst-plugins-bad-vcdsrc, gst-plugins-good-flv, gst-plugins-good-autodetect, gst-plugins-ugly-mpegaudioparse, gst-plugins-ugly-amrwbdec, libdvdcss2, gst-plugins-base-audioresample, gst-plugins-base-decodebin2, gst-plugins-good-rtpmanager, gst-plugins-good-audioparsers, gst-plugins-good-udp, gst-plugins-base-subparse, gst-plugins-ugly-asf, gst-plugins-ugly-mpegstream, gst-plugins-bad-cdxaparse, gst-plugins-ugly-cdio, gst-plugins-base-audioconvert, gst-plugins-good-icydemux, gst-plugins-base-ogg, gst-plugins-good-rtsp, gst-plugins-bad-fragmented, gst-plugins-ugly-mad, gst-plugins-ugly-dvdsub, gst-plugins-base-alsa, gst-plugins-good-id3demux, gst-plugins-bad-mpegdemux, gst-plugins-good-avi, gst-plugins-good-apetag, gst-plugins-good-rtp, gst-plugins-bad-mms
Status: install user installed
Architecture: dm8000
Installed-Time: 1468167961


root@dm8000:~# opkg status eglibc-gconv-iso8859-15
Package: eglibc-gconv-iso8859-15
Version: 2.19-r0
Depends: eglibc-gconv, libc6 (>= 2.19)
Provides: glibc-gconv-iso8859-15
Status: install user installed
Architecture: mips32el
Installed-Time: 1401614595

No other references to glibc-gconv-iso8859-15 pop up with 
opkg status | grep glibc-gconv-iso8859-15

command.

I tried also with opkg depends and whatdepends commands but these yielded also no additional results. 



Re: DM8000 opkg error #4 WanWizard

  • PLi® Core member
  • 56,543 posts

+1,175
Excellent

Posted 25 October 2016 - 18:36

what does

opkg update && opkg info glibc-gconv-iso8859-15

tell you?


Currently in use: VU+Duo 4K (2xFBC S2), Amiko Viper T2C (T2+fallback), Octagon SF8008 (S2+T2), Zgemma H9.2H (T2+fallback)

Many answers to your question can be found in our new and improved wiki.

Because to health reasons, I will not be active very often anymore.


Re: DM8000 opkg error #5 pryggi

  • Senior Member
  • 48 posts

0
Neutral

Posted 25 October 2016 - 23:26

root@dm8000:~# opkg update && opkg info glibc-gconv-iso8859-15
Downloading http://downloads.pli-images.org/feeds/openpli-4/3rd-party-dm8000/Packages.gz.
Updated list of available packages in /var/lib/opkg/openpli-3rd-party-dm8000.
Downloading http://downloads.pli-images.org/feeds/openpli-4/3rd-party/Packages.gz.
Updated list of available packages in /var/lib/opkg/openpli-3rd-party.
Downloading http://downloads.pli-images.org/feeds/openpli-4/all/Packages.gz.
Updated list of available packages in /var/lib/opkg/openpli-all.
Downloading http://downloads.pli-images.org/feeds/openpli-4/dm8000/Packages.gz.
Updated list of available packages in /var/lib/opkg/openpli-dm8000.
Downloading http://downloads.pli-images.org/feeds/openpli-4/mips32el/Packages.gz                                                                                        .
Updated list of available packages in /var/lib/opkg/openpli-mips32el.
Package: glibc-gconv-iso8859-15
Version: 2.20-r0.0
Depends: glibc-gconv, libc6 (>= 2.20)
Status: unknown ok not-installed
Section: base
Architecture: mips32el
Maintainer: OE-Core Developers <openembedded-core@lists.openembedded.org>
MD5Sum: b3ecc210ce4bbe3b559feebc7a357eee
Size: 5172
Filename: glibc-gconv-iso8859-15_2.20-r0.0_mips32el.ipk
Source: None
Description: gconv module for character set iso8859-15  gconv module for character set
 iso8859-15

Package: glibc-gconv-iso8859-15
Version: 2.20-r0.10
Depends: glibc-gconv, libc6 (>= 2.20)
Status: install ok half-installed
Architecture: mips32el


I hope there was sth meaningful here... (me clueless) TIA



Re: DM8000 opkg error #6 WanWizard

  • PLi® Core member
  • 56,543 posts

+1,175
Excellent

Posted 26 October 2016 - 09:48

It shows you the package from the feed, the correct one:

Package: glibc-gconv-iso8859-15
Version: 2.20-r0.0
Depends: glibc-gconv, libc6 (>= 2.20)
Status: unknown ok not-installed
Section: base
Architecture: mips32el
Maintainer: OE-Core Developers <openembedded-core@lists.openembedded.org>
MD5Sum: b3ecc210ce4bbe3b559feebc7a357eee
Size: 5172
Filename: glibc-gconv-iso8859-15_2.20-r0.0_mips32el.ipk
Source: None
Description: gconv module for character set iso8859-15 gconv module for character set
iso8859-15

And then it says there is a second package, which is the wrong version, doesn't have a proper control file (so lots of info missing) and with install problems:

Package: glibc-gconv-iso8859-15
Version: 2.20-r0.10
Depends: glibc-gconv, libc6 (>= 2.20)
Status: install ok half-installed
Architecture: mips32el

This one doesn't come from our feeds.

 

Can you try to remove it, then reinstall it?

opkg remove glibc-gconv-iso8859-15
opkg install glibc-gconv-iso8859-15

Currently in use: VU+Duo 4K (2xFBC S2), Amiko Viper T2C (T2+fallback), Octagon SF8008 (S2+T2), Zgemma H9.2H (T2+fallback)

Many answers to your question can be found in our new and improved wiki.

Because to health reasons, I will not be active very often anymore.


Re: DM8000 opkg error #7 pryggi

  • Senior Member
  • 48 posts

0
Neutral

Posted 26 October 2016 - 20:10

After some whiskeys, I think I screwed up, and removed everything:
 

root@dm8000:~# opkg remove glibc-gconv-iso8859-15
No packages removed.

root@dm8000:~# opkg remove eglibc-gconv-iso8859-15
No packages removed.
Collected errors:
 * print_dependents_warning: Package eglibc-gconv-iso8859-15 is depended upon by packages:
 * print_dependents_warning:    enigma2
 * print_dependents_warning: These might cease to work if package eglibc-gconv-iso8859-15 is removed.

 * print_dependents_warning: Force removal of this package with --force-depends.
 * print_dependents_warning: Force removal of this package and its dependents
 * print_dependents_warning: with --force-removal-of-dependent-packages.


root@dm8000:~# opkg remove eglibc-gconv-iso8859-15 --force-removal-of-dependent-packages
Removing package enigma2-plugin-extensions-graphmultiepg from root...
Removing package enigma2-plugin-systemplugins-satfinder from root...
Removing package enigma2-plugin-systemplugins-videotune from root...
Removing package enigma2 from root...
Removing package eglibc-gconv-iso8859-15 from root...


root@dm8000:~# opkg install glibc-gconv-iso8859-15
Installing glibc-gconv-iso8859-15 (2.20-r0.10) on root.
Collected errors:
 * opkg_download_pkg: Package glibc-gconv-iso8859-15 is not available from any configured src.
 * opkg_install_pkg: Failed to download glibc-gconv-iso8859-15. Perhaps you need to run 'opkg update'?
 * opkg_install_cmd: Cannot install package glibc-gconv-iso8859-15.


root@dm8000:~# opkg install eglibc-gconv-iso8859-15
Unknown package 'eglibc-gconv-iso8859-15'.
Collected errors:
 * opkg_install_cmd: Cannot install package eglibc-gconv-iso8859-15.


root@dm8000:~# opkg install enigma2-plugin-extensions-graphmultiepg
Installing enigma2-plugin-extensions-graphmultiepg (2.7+git14335+2b5dbaa-r0.0) on root.
Downloading http://downloads.pli-images.org/feeds/openpli-4/dm8000/enigma2-plugin-extensions-graphmultiepg_2.7+git14335+2b5dbaa-r0.0_dm8000.ipk.
Configuring enigma2-plugin-extensions-graphmultiepg.


root@dm8000:~# opkg install enigma2-plugin-systemplugins-satfinder
Installing enigma2-plugin-systemplugins-satfinder (2.7+git14335+2b5dbaa-r0.0) on root.
Downloading http://downloads.pli-images.org/feeds/openpli-4/dm8000/enigma2-plugin-systemplugins-satfinder_2.7+git14335+2b5dbaa-r0.0_dm8000.ipk.
Configuring enigma2-plugin-systemplugins-satfinder.


root@dm8000:~# opkg install enigma2-plugin-systemplugins-videotune
Installing enigma2-plugin-systemplugins-videotune (2.7+git14335+2b5dbaa-r0.0) on root.
Downloading http://downloads.pli-images.org/feeds/openpli-4/dm8000/enigma2-plugin-systemplugins-videotune_2.7+git14335+2b5dbaa-r0.0_dm8000.ipk.
Configuring enigma2-plugin-systemplugins-videotune.

root@dm8000:~# opkg install eglibc-gconv
Package eglibc-gconv (2.19-r0) installed in root is up to date.


root@dm8000:~# opkg install enigma2 --nodeps
Installing enigma2 (2.7+git14335+2b5dbaa-r0.0) on root.
Downloading http://downloads.pli-images.org/feeds/openpli-4/dm8000/enigma2_2.7+git14335+2b5dbaa-r0.0_dm8000.ipk.
Configuring enigma2.

But I stilll dont have this glibc-gconv-iso8859-15_2.20-r0.0_mips32el

So this new enigma2 probably fails to load due to this failed dependency. Do you have an url for this glibc-gconv-iso8859-15_2.20-r0.0_mips32el.ipk. Google is not my friend in regards to this file...



Re: DM8000 opkg error #8 WanWizard

  • PLi® Core member
  • 56,543 posts

+1,175
Excellent

Posted 26 October 2016 - 21:28

You are sure you did an opkg update before all this?

 

Because it something seriously wrong with your package indexes. Because glibc-gconv-iso8859-15_2.20-r0.0 is available in the standard mips32el feed, so I don't know why it doesn't install.

 

Which files are in /var/lib/opkg/lists? There should be an "openpli-mips32el" file there. What date does it have? If you search in it for "glibc-gconv-iso8859-15", can you find it, and what version does it have there?

 

What I also don't understand: enigma2 loads glibc-gconv-iso8859-15 as a dependency. You couldn't install it manually, but I also don't see an error message in your output that it can't be found or installed?


Currently in use: VU+Duo 4K (2xFBC S2), Amiko Viper T2C (T2+fallback), Octagon SF8008 (S2+T2), Zgemma H9.2H (T2+fallback)

Many answers to your question can be found in our new and improved wiki.

Because to health reasons, I will not be active very often anymore.


Re: DM8000 opkg error #9 pryggi

  • Senior Member
  • 48 posts

0
Neutral

Posted 26 October 2016 - 21:56

Thanks for bearing with me. It is indeed an old installation, probably from early days of OpenPLI4, so I don't remember everything that I have done there.

Yes. I did opkg uopdate. 
 

/var/lib/opkg/lists folder is empty.

 

openpli-mips32el file is in /var/lib/opkg folder. It is 5339109 bytes, it is modified today at the time that I did the opkg update.

These are the sections from it that contain glibc-gconv-iso8859-15

 

Package: glibc-gconv-iso8859-15
Version: 2.20-r0.0
Depends: glibc-gconv, libc6 (>= 2.20)
Section: base
Architecture: mips32el
Maintainer: OE-Core Developers <openembedded-core@lists.openembedded.org>
MD5Sum: b3ecc210ce4bbe3b559feebc7a357eee
Size: 5172
Filename: glibc-gconv-iso8859-15_2.20-r0.0_mips32el.ipk
Source: None
Description:  gconv module for character set iso8859-15  gconv module for character set
 iso8859-15
OE: glibc-locale
License: GPLv2 & LGPLv2.1
Priority: optional
 

 

 

Package: glibc-gconvs
Version: 2.20-r0.0
Recommends: glibc-gconv-ebcdic-at-de-a, glibc-gconv-euc-cn, glibc-gconv-ibm855, glibc-gconv-ibm857, glibc-gconv-ibm856, glibc-gconv-ibm918, glibc-gconv-ibm850, glibc-gc
onv-ibm852, glibc-gconv-hp-thai8, glibc-gconv-ibm297, glibc-gconv-euc-kr, glibc-gconv-ibm290, glibc-gconv-ibm9448, glibc-gconv-ebcdic-dk-no, glibc-gconv-ebcdic-is-friss
, glibc-gconv-iso8859-9, glibc-gconv-iso8859-8, glibc-gconv-inis-8, glibc-gconv-greek7-old, glibc-gconv-iso8859-5, glibc-gconv-iso8859-4, glibc-gconv-iso8859-7, glibc-g
conv-iso8859-6, glibc-gconv-iso8859-1, glibc-gconv-iso8859-3, glibc-gconv-iso8859-2, glibc-gconv-johab, glibc-gconv-cp1258, glibc-gconv-ibm903, glibc-gconv-cp1256, glib
c-gconv-ibm1046, glibc-gconv-ibm1047, glibc-gconv-cp1253, glibc-gconv-cp1252, glibc-gconv-ibm905, glibc-gconv-cp1250, glibc-gconv-ibm860, glibc-gconv-ibm861, glibc-gcon
v-ibm4971, glibc-gconv-ibm863, glibc-gconv-ibm864, glibc-gconv-ibm865, glibc-gconv-ibm866, glibc-gconv-ibm868, glibc-gconv-ibm869, glibc-gconv-koi-8, glibc-gconv-ibm111
2, glibc-gconv-gbk, glibc-gconv-latin-greek, glibc-gconv-iso-10367-box, glibc-gconv-mac-uk, glibc-gconv-utf-16, glibc-gconv-big5hkscs, glibc-gconv-ibm4909, glibc-gconv-
t.61, glibc-gconv-ibm4517, glibc-gconv-ecma-cyrillic, glibc-gconv-uhc, glibc-gconv-iso-2022-jp-3, glibc-gconv-libgb, glibc-gconv-cwi, glibc-gconv-iso-ir-197, glibc-gcon
v-ibm1163, glibc-gconv-ebcdic-fi-se, glibc-gconv-ibm1161, glibc-gconv-ibm1160, glibc-gconv-ibm1167, glibc-gconv-ibm1166, glibc-gconv-ibm1164, glibc-gconv-ibm1008, glibc
-gconv-latin-greek-1, glibc-gconv-ibm875, glibc-gconv-ibm874, glibc-gconv-utf-7, glibc-gconv-ibm871, glibc-gconv-ibm870, glibc-gconv-gbgbk, glibc-gconv-iso8859-14, glib
c-gconv-sami-ws2, glibc-gconv-iso8859-11, glibc-gconv-ibm1364, glibc-gconv-iso8859-13, glibc-gconv-ibm278, glibc-gconv-viscii, glibc-gconv-iso-ir-209, glibc-gconv, glib
c-gconv-nats-dano, glibc-gconv-ibm275, glibc-gconv-ibm274, glibc-gconv-ibm277, glibc-gconv-iso646, glibc-gconv-ibm866nav, glibc-gconv-koi8-t, glibc-gconv-koi8-u, glibc-
gconv-gb18030, glibc-gconv-ibm901, glibc-gconv-ansi-x3.110, glibc-gconv-ibm803, glibc-gconv-tcvn5712-1, glibc-gconv-armscii-8, glibc-gconv-unicode, glibc-gconv-euc-jisx
0213, glibc-gconv-ebcdic-dk-no-a, glibc-gconv-ibm880, glibc-gconv-ebcdic-it, glibc-gconv-mac-sami, glibc-gconv-ibm1371, glibc-gconv-iso8859-9e, glibc-gconv-libksc, glib
c-gconv-koi8-r, glibc-gconv-gbbig5, glibc-gconv-libjis, glibc-gconv-shift-jisx0213, glibc-gconv-ibm5347, glibc-gconv-ebcdic-es-s, glibc-gconv-ibm1008-420, glibc-gconv-c
p770, glibc-gconv-cp771, glibc-gconv-ebcdic-fr, glibc-gconv-cp775, glibc-gconv-ibm9066, glibc-gconv-euc-tw, glibc-gconv-nats-sefi, glibc-gconv-mik, glibc-gconv-ibm1149,
 glibc-gconv-ibm1148, glibc-gconv-ibm1145, glibc-gconv-ibm1144, glibc-gconv-ibm1147, glibc-gconv-ibm1146, glibc-gconv-ibm1141, glibc-gconv-ibm1140, glibc-gconv-ibm1143,
 glibc-gconv-ibm1142, glibc-gconv-libisoir165, glibc-gconv-ibm891, glibc-gconv-inis, glibc-gconv-ibm1097, glibc-gconv-isiri-3342, glibc-gconv-hp-roman9, glibc-gconv-hp-
roman8, glibc-gconv-ebcdic-pt, glibc-gconv-cp1125, glibc-gconv-ibm420, glibc-gconv-ibm423, glibc-gconv-ibm424, glibc-gconv-ibm256, glibc-gconv-cp1251, glibc-gconv-ibm11
62, glibc-gconvs, glibc-gconv-ibm273, glibc-gconv-ibm1388, glibc-gconv-ibm4899, glibc-gconv-macintosh, glibc-gconv-ibm1004, glibc-gconv-iso-11548-1, glibc-gconv-ibm500,
 glibc-gconv-inis-cyrillic, glibc-gconv-euc-jp-ms, glibc-gconv-ibm1153, glibc-gconv-ibm943, glibc-gconv-ibm1157, glibc-gconv-ibm1154, glibc-gconv-ibm16804, glibc-gconv-
iso-5427, glibc-gconv-ibm1158, glibc-gconv-brf, glibc-gconv-iso-2022-kr, glibc-gconv-iso-2022-jp, glibc-gconv-ibm922, glibc-gconv-mac-centraleurope, glibc-gconv-ebcdic-
fi-se-a, glibc-gconv-mac-is, glibc-gconv-ebcdic-es-a, glibc-gconv-iso-2022-cn-ext, glibc-gconv-iso-6937-2, glibc-gconv-libcns, glibc-gconv-ibm1390, glibc-gconv-georgian
-ps, glibc-gconv-ibm1155, glibc-gconv-ebcdic-at-de, glibc-gconv-greek-ccitt, glibc-gconv-greek7, glibc-gconv-ibm1399, glibc-gconv-gost-19768-74, glibc-gconv-ibm851, gli
bc-gconv-ibm932, glibc-gconv-ibm933, glibc-gconv-ibm930, glibc-gconv-ibm937, glibc-gconv-ibm935, glibc-gconv-sjis, glibc-gconv-cp772, glibc-gconv-ibm939, glibc-gconv-cp
10007, glibc-gconv-iso8859-15, glibc-gconv-ibm1124, glibc-gconv-ibm1123, glibc-gconv-ibm1122, glibc-gconv-asmo-449, glibc-gconv-euc-jp, glibc-gconv-ibm1129, glibc-gconv
-hp-turkish8, glibc-gconv-ibm437, glibc-gconv-hp-greek8, glibc-gconv-iso8859-16, glibc-gconv-cp932, glibc-gconv-cp773, glibc-gconv-ibm12712, glibc-gconv-tis-620, glibc-
gconv-ibm9030, glibc-gconv-ebcdic-es, glibc-gconv-iso8859-10, glibc-gconv-cp1257, glibc-gconv-ibm1156, glibc-gconv-ibm037, glibc-gconv-ibm902, glibc-gconv-pt154, glibc-
gconv-ibm038, glibc-gconv-ebcdic-ca-fr, glibc-gconv-cp1255, glibc-gconv-ibm921, glibc-gconv-tscii, glibc-gconv-iec-p27-1, glibc-gconv-cp1254, glibc-gconv-cp774, glibc-g
conv-iso-5427-ext, glibc-gconv-libjisx0213, glibc-gconv-georgian-academy, glibc-gconv-ibm1026, glibc-gconv-rk1048, glibc-gconv-ibm1025, glibc-gconv-ibm1137, glibc-gconv
-ibm1130, glibc-gconv-big5, glibc-gconv-ibm1132, glibc-gconv-ibm1133, glibc-gconv-ibm904, glibc-gconv-ibm280, glibc-gconv-ibm281, glibc-gconv-utf-32, glibc-gconv-ibm284
, glibc-gconv-ibm285, glibc-gconv-ebcdic-uk, glibc-gconv-iso-6937, glibc-gconv-iso-2033, glibc-gconv-iso-5428, glibc-gconv-koi8-ru, glibc-gconv-ibm862, glibc-gconv-dec-
mcs, glibc-gconv-cp737, glibc-gconv-iso-2022-cn, glibc-gconv-ebcdic-us, glibc-gconv-csn-369103
Section: base
Architecture: mips32el
Maintainer: OE-Core Developers <openembedded-core@lists.openembedded.org>
MD5Sum: 1a24b123109e4ec7641e7b4743c3d04e
Size: 1782
Filename: glibc-gconvs_2.20-r0.0_mips32el.ipk
Source: None
Description:  Locale data from glibc  Locale data from glibc.
OE: glibc-locale
License: GPLv2 & LGPLv2.1
Priority: optional
 
 
I understand that at some point we have to declare this case a lost cause and do a clean flash. Just tell me if we have reached this point.
 
Thanks.


Re: DM8000 opkg error #10 WanWizard

  • PLi® Core member
  • 56,543 posts

+1,175
Excellent

Posted 26 October 2016 - 22:24

I now tell you. ;)

 

With this information I have no clue where your box gets it's old information.

 

Plug a USB stick in, the the autobackup plugin to manually make a backup of your config and your installed plugins if you don't do this automatically, and flash the latest image. It should restore your backup automatically when the box reboots after the flash.


Currently in use: VU+Duo 4K (2xFBC S2), Amiko Viper T2C (T2+fallback), Octagon SF8008 (S2+T2), Zgemma H9.2H (T2+fallback)

Many answers to your question can be found in our new and improved wiki.

Because to health reasons, I will not be active very often anymore.


Re: DM8000 opkg error #11 pryggi

  • Senior Member
  • 48 posts

0
Neutral

Posted 27 October 2016 - 20:08

Thanks man,

As a last attempt I thought that I should search file contents for 2.20-r0.10. This resulted:
root@dm8000:/# find / -type f -exec grep -H '2.20-r0.10' {} \; 

/var/lib/opkg/info/glibc-gconv.control:Version: 2.20-r0.10
/var/lib/opkg/info/libc6.control:Version: 2.20-r0.10
/var/lib/opkg/status:Version: 2.20-r0.10
/var/lib/opkg/status:Version: 2.20-r0.10
/var/lib/opkg/status:Version: 2.20-r0.10
/home/root/ipkgupgrade.log:Installing glibc-gconv-iso8859-15 (2.20-r0.10) on root.
/home/root/.ash_history:find / -type f -exec grep -H '2.20-r0.10' {} \;
 
 
I removed all the references to 2.20-r0.10 section by section from /var/lib/opkg/status
did opkg update
Tried to install again:
root@dm8000:/# opkg install glibc-gconv-iso8859-15
Installing glibc-gconv-iso8859-15 (2.20-r0.0) on root.
Installing glibc-gconv (2.20-r0.0) on root.
To remove package debris, try `opkg remove glibc-gconv`.
To re-attempt the install, try `opkg install glibc-gconv`.
Collected errors:
 * check_data_file_clashes: Package glibc-gconv wants to install file /usr/lib/gconv/gconv-modules
        But that file is already provided by package  * eglibc-gconv
 * opkg_install_cmd: Cannot install package glibc-gconv-iso8859-15.
 
Uninstalled eglibc-gconv
root@dm8000:/# opkg remove eglibc-gconv
Removing package eglibc-gconv from root...
 
 
root@dm8000:/# opkg install glibc-gconv-iso8859-15
Installing glibc-gconv-iso8859-15 (2.20-r0.0) on root.
Installing glibc-gconv (2.20-r0.0) on root.
Configuring glibc-gconv.
Configuring glibc-gconv-iso8859-15.


Seems like it worked. Anyway, thank you very much for your support and for pointing me in the right direction.


Re: DM8000 opkg error #12 WanWizard

  • PLi® Core member
  • 56,543 posts

+1,175
Excellent

Posted 27 October 2016 - 20:25

Glad you've got it sorted.


Currently in use: VU+Duo 4K (2xFBC S2), Amiko Viper T2C (T2+fallback), Octagon SF8008 (S2+T2), Zgemma H9.2H (T2+fallback)

Many answers to your question can be found in our new and improved wiki.

Because to health reasons, I will not be active very often anymore.






Also tagged with one or more of these keywords: DM8000

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users