Jump to content


Photo

Decoding not work on most UPC channels

bug

  • Please log in to reply
10 replies to this topic

#1 skyjet

  • Member
  • 11 posts

0
Neutral

Posted 23 November 2016 - 20:26

I have VU+ Solo SE v2 and after commit https://github.com/O...ccd3097a7d5eb91 most UPC Direct channels on 0,8W doesn't decode. Here is oscam log from 19.11.2016 image - channel stays black.

2016/11/23 20:02:03 20834EA7 c (dvbapi) Demuxer 0 ecmpid 0 CAID: 1815 ECM_PID: 1FFF PROVID: 000000
2016/11/23 20:02:03 20834EA7 c (dvbapi) Demuxer 0 ecmpid 1 CAID: 0D97 ECM_PID: 1FFF PROVID: 000000
2016/11/23 20:02:03 20834EA7 c (dvbapi) Demuxer 0 ecmpid 2 CAID: 0B02 ECM_PID: 1FFF PROVID: 000000
2016/11/23 20:02:03 20834EA7 c (dvbapi) Demuxer 0 ecmpid 3 CAID: 0653 ECM_PID: 1FFF PROVID: 000000
2016/11/23 20:02:03 20834EA7 c (dvbapi) Demuxer 0 stream Videostream (MPEG-2)(type: 02 pid: 00c9 length: 25)
2016/11/23 20:02:03 20834EA7 c (dvbapi) Demuxer 0 ecmpid 4 CAID: 1815 ECM_PID: 138A PROVID: 000000
2016/11/23 20:02:03 20834EA7 c (dvbapi) Demuxer 0 ecmpid 5 CAID: 0B02 ECM_PID: 15E2 PROVID: 000000
2016/11/23 20:02:03 20834EA7 c (dvbapi) Demuxer 0 ecmpid 6 CAID: 0D97 ECM_PID: 170E PROVID: 000000
2016/11/23 20:02:03 20834EA7 c (dvbapi) Demuxer 0 ecmpid 7 CAID: 0653 ECM_PID: 183A PROVID: 000000
2016/11/23 20:02:03 20834EA7 c (dvbapi) Demuxer 0 stream Audiostream (MPEG-1)(type: 03 pid: 00d2 length: 25)
2016/11/23 20:02:03 20834EA7 c (dvbapi) Demuxer 0 stream Audiostream (MPEG-1)(type: 03 pid: 00d3 length: 25)
2016/11/23 20:02:03 20834EA7 c (dvbapi) Demuxer 0 stream Audiostream (MPEG-1)(type: 03 pid: 00d4 length: 25)
2016/11/23 20:02:03 20834EA7 c (dvbapi) Demuxer 0 found 8 ECMpids and 4 STREAMpids in caPMT
2016/11/23 20:02:03 20834EA7 c (dvbapi) Demuxer 0 serving srvid 78B7 (Discovery Channel) on adapter 0000 camask 0001 index 0000 pmtpid 00C8
2016/11/23 20:02:03 20834EA7 c (dvbapi) Demuxer 0 trying to descramble PID 1 CAID 0D97 PROVID 000000 ECMPID 1FFF ANY CHID PMTPID 00C8 VPID 00C9
2016/11/23 20:02:03 20834EA7 c (dvbapi) Demuxer 0 stream Videostream (MPEG-2)(type: 02 pid: 00c9 length: 27)
2016/11/23 20:02:03 20834EA7 c (dvbapi) Demuxer 0 stream Audiostream (MPEG-1)(type: 03 pid: 00d2 length: 33)
2016/11/23 20:02:03 20834EA7 c (dvbapi) Demuxer 0 stream Audiostream (MPEG-1)(type: 03 pid: 00d3 length: 33)
2016/11/23 20:02:03 20834EA7 c (dvbapi) Demuxer 0 stream Audiostream (MPEG-1)(type: 03 pid: 00d4 length: 33)
2016/11/23 20:02:03 20834EA7 c (dvbapi) Demuxer 0 found 8 ECMpids and 4 STREAMpids in PMT
2016/11/23 20:02:03 20834EA7 c (dvbapi) Demuxer 0 serving srvid 78B7 (Discovery Channel) on adapter 0000 camask 0001 index 0000 pmtpid 00C8
2016/11/23 20:02:06 20834EA7 c (dvbapi) Demuxer 0 restarting decodingrequests after 16 ms with 1 enabled and 7 disabled ecmpids!
2016/11/23 20:02:06 20834EA7 c (dvbapi) Demuxer 0 trying to descramble PID 1 CAID 0D97 PROVID 000000 ECMPID 1FFF ANY CHID PMTPID 00C8 VPID 00C9
2016/11/23 20:02:07 20834EA7 c (dvbapi) Demuxer 0 continue decoding of SRVID 78B7
2016/11/23 20:02:07 20834EA7 c (dvbapi) Demuxer 0 stream Videostream (MPEG-2)(type: 02 pid: 00c9 length: 25)
2016/11/23 20:02:07 20834EA7 c (dvbapi) Demuxer 0 stream Audiostream (MPEG-1)(type: 03 pid: 00d2 length: 25)
2016/11/23 20:02:07 20834EA7 c (dvbapi) Demuxer 0 stream Audiostream (MPEG-1)(type: 03 pid: 00d3 length: 25)
2016/11/23 20:02:07 20834EA7 c (dvbapi) Demuxer 0 stream Audiostream (MPEG-1)(type: 03 pid: 00d4 length: 25)
2016/11/23 20:02:07 20834EA7 c (dvbapi) Demuxer 0 found 8 ECMpids and 4 STREAMpids in caPMT
2016/11/23 20:02:07 20834EA7 c (dvbapi) Demuxer 0 serving srvid 78B7 (Discovery Channel) on adapter 0000 camask 0001 index 0000 pmtpid 00C8
2016/11/23 20:02:09 20834EA7 c (dvbapi) Demuxer 0 restarting decodingrequests after 16 ms with 1 enabled and 7 disabled ecmpids!
2016/11/23 20:02:09 20834EA7 c (dvbapi) Demuxer 0 trying to descramble PID 1 CAID 0D97 PROVID 000000 ECMPID 1FFF ANY CHID PMTPID 00C8 VPID 00C9
2016/11/23 20:02:12 20834EA7 c (dvbapi) Demuxer 0 restarting decodingrequests after 16 ms with 1 enabled and 7 disabled ecmpids!
2016/11/23 20:02:12 20834EA7 c (dvbapi) Demuxer 0 trying to descramble PID 1 CAID 0D97 PROVID 000000 ECMPID 1FFF ANY CHID PMTPID 00C8 VPID 00C9
2016/11/23 20:02:15 20834EA7 c (dvbapi) Demuxer 0 restarting decodingrequests after 16 ms with 1 enabled and 7 disabled ecmpids!
2016/11/23 20:02:15 20834EA7 c (dvbapi) Demuxer 0 trying to descramble PID 1 CAID 0D97 PROVID 000000 ECMPID 1FFF ANY CHID PMTPID 00C8 VPID 00C9
2016/11/23 20:02:18 20834EA7 c (dvbapi) Demuxer 0 restarting decodingrequests after 16 ms with 1 enabled and 7 disabled ecmpids!
2016/11/23 20:02:18 20834EA7 c (dvbapi) Demuxer 0 trying to descramble PID 1 CAID 0D97 PROVID 000000 ECMPID 1FFF ANY CHID PMTPID 00C8 VPID 00C9
2016/11/23 20:02:18 20834EA7 c (dvbapi) sdt-info (provider: UPC Direct - channel: Discovery Channel)
2016/11/23 20:02:21 20834EA7 c (dvbapi) Demuxer 0 restarting decodingrequests after 16 ms with 1 enabled and 7 disabled ecmpids!
2016/11/23 20:02:21 20834EA7 c (dvbapi) Demuxer 0 trying to descramble PID 1 CAID 0D97 PROVID 000000 ECMPID 1FFF ANY CHID PMTPID 00C8 VPID 00C9
2016/11/23 20:02:24 20834EA7 c (dvbapi) Demuxer 0 restarting decodingrequests after 16 ms with 1 enabled and 7 disabled ecmpids!
2016/11/23 20:02:24 20834EA7 c (dvbapi) Demuxer 0 trying to descramble PID 1 CAID 0D97 PROVID 000000 ECMPID 1FFF ANY CHID PMTPID 00C8 VPID 00C9
2016/11/23 20:02:27 20834EA7 c (dvbapi) Demuxer 0 restarting decodingrequests after 15 ms with 1 enabled and 7 disabled ecmpids!

And here is oscam log from 15.11.2016 image (everything works).

2016/11/23 20:07:31 20834EA7 c (dvbapi) Demuxer 0 stream Videostream (MPEG-2)(type: 02 pid: 00c9 length: 25)
2016/11/23 20:07:31 20834EA7 c (dvbapi) Demuxer 0 ecmpid 0 CAID: 1815 ECM_PID: 138A PROVID: 000000
2016/11/23 20:07:31 20834EA7 c (dvbapi) Demuxer 0 ecmpid 1 CAID: 0B02 ECM_PID: 15E2 PROVID: 000000
2016/11/23 20:07:31 20834EA7 c (dvbapi) Demuxer 0 ecmpid 2 CAID: 0D97 ECM_PID: 170E PROVID: 000000
2016/11/23 20:07:31 20834EA7 c (dvbapi) Demuxer 0 ecmpid 3 CAID: 0653 ECM_PID: 183A PROVID: 000000
2016/11/23 20:07:31 20834EA7 c (dvbapi) Demuxer 0 stream Audiostream (MPEG-1)(type: 03 pid: 00d2 length: 25)
2016/11/23 20:07:31 20834EA7 c (dvbapi) Demuxer 0 stream Audiostream (MPEG-1)(type: 03 pid: 00d3 length: 25)
2016/11/23 20:07:31 20834EA7 c (dvbapi) Demuxer 0 stream Audiostream (MPEG-1)(type: 03 pid: 00d4 length: 25)
2016/11/23 20:07:31 20834EA7 c (dvbapi) Demuxer 0 found 4 ECMpids and 4 STREAMpids in caPMT
2016/11/23 20:07:31 20834EA7 c (dvbapi) Demuxer 0 serving srvid 78B7 (Discovery Channel) on adapter 0000 camask 0001 index 0000 pmtpid 00C8
2016/11/23 20:07:31 20834EA7 c (dvbapi) Demuxer 0 trying to descramble PID 2 CAID 0D97 PROVID 000000 ECMPID 170E ANY CHID PMTPID 00C8 VPID 00C9
2016/11/23 20:07:31 20834EA7 c (dvbapi) Demuxer 0 stream Videostream (MPEG-2)(type: 02 pid: 00c9 length: 27)
2016/11/23 20:07:31 20834EA7 c (dvbapi) Demuxer 0 stream Audiostream (MPEG-1)(type: 03 pid: 00d2 length: 33)
2016/11/23 20:07:31 20834EA7 c (dvbapi) Demuxer 0 stream Audiostream (MPEG-1)(type: 03 pid: 00d3 length: 33)
2016/11/23 20:07:31 20834EA7 c (dvbapi) Demuxer 0 stream Audiostream (MPEG-1)(type: 03 pid: 00d4 length: 33)
2016/11/23 20:07:31 20834EA7 c (dvbapi) Demuxer 0 found 4 ECMpids and 4 STREAMpids in PMT
2016/11/23 20:07:31 20834EA7 c (dvbapi) Demuxer 0 serving srvid 78B7 (Discovery Channel) on adapter 0000 camask 0001 index 0000 pmtpid 00C8
2016/11/23 20:07:31 20834EA7 c (ecm) dvbapiau (0D97@000004/0000/78B7/B8:75863BB91B4BAAB37A7E73F1CD05D21C): found (163 ms) by rdr_internal - Discovery Channel
2016/11/23 20:07:37 20834EA7 c (ecm) dvbapiau (0D97@000004/0000/78B7/B8:DD56BAB8375A1FFAD1453F4E50D94110): found (143 ms) by rdr_internal - Discovery Channel

If you look at comment by this problematic commit then someone has the same problem as I. Please look at it or revert this commit. If you need more info, then let me know. In enigma2 log I don't see anything interesting.

Thanks!


Edited by skyjet, 23 November 2016 - 20:28.


Re: Decoding not work on most UPC channels #2 Dimmie

  • Senior Member
  • 2,134 posts

+24
Neutral

Posted 24 November 2016 - 01:36

Compile latest oscam and put it in your receiver. When problem is still there go to oscam streamboard and make a ticket about this so the oscam developers can investigate and solve it.



Re: Decoding not work on most UPC channels #3 Tech

  • Forum Moderator
    PLi® Core member
  • 32,720 posts

+353
Excellent

Posted 24 November 2016 - 15:45

yesterday I updated the oscam feed to rev.11281, so the latest version is available in the feeds.
Aan de rand van de afgrond is een stap voorwaarts niet altijd vooruitgang....

Re: Decoding not work on most UPC channels #4 skyjet

  • Member
  • 11 posts

0
Neutral

Posted 24 November 2016 - 20:17

I tried latest oscam with no result. But if you look at oscam logs I posted, then you see the difference. In the first log (when it doesn't decode) there are 8 ecm pids and all CAIDs are doubled. For first 4, ECM_PID is set to 1FFF. In the second log only 4 ecm pids are set with correct ECM_PID field. So it's not oscam's but enigma's bug. Enigma adds caid's doubled entries to caPMT. Hope it helps someone to investigate it. In the first post is already link to conflicting commit so I hope it shouldn't be so difficult.



Re: Decoding not work on most UPC channels #5 athoik

  • PLi® Core member
  • 8,395 posts

+321
Excellent

Posted 24 November 2016 - 21:51

It shoud not use the cached caids if there are caids present, ok but why the following part doesn't work?

Anyone has a clue?

	bool scrambled = false;
	for (std::vector<ProgramMapSection*>::const_iterator pmt = ptr->getSections().begin();
		pmt != ptr->getSections().end() && !scrambled; ++pmt)
	{
		for (DescriptorConstIterator desc = (*pmt)->getDescriptors()->begin();
			desc != (*pmt)->getDescriptors()->end() && !scrambled; ++desc)
		{
			if ((*desc)->getTag() == CA_DESCRIPTOR)
				scrambled = true;
		}
	}
We can revert it, or search for a solution.

A posible solution is to use cached caids only when instructed by the service! (&& service->m_flags & useCache)
Wavefield T90: 0.8W - 1.9E - 4.8E - 13E - 16E - 19.2E - 23.5E - 26E - 33E - 39E - 42E - 45E on EMP Centauri DiseqC 16/1
Unamed: 13E Quattro - 9E Quattro on IKUSI MS-0916

Re: Decoding not work on most UPC channels #6 athoik

  • PLi® Core member
  • 8,395 posts

+321
Excellent

Posted 24 November 2016 - 22:14

The following part is from libdvbsi++-0.3.7 (src/ca_program_map_section.cpp).

bool CaProgramMapSection::append(const ProgramMapSection * const pmt)
{
        if (pmt->tableIdExtension != programNumber ||
            pmt->versionNumber != versionNumber ||
            currentNextIndicator != pmt->currentNextIndicator)
                return false;

        for (DescriptorConstIterator i = pmt->getDescriptors()->begin(); i != pmt->getDescriptors()->end(); ++i)
                if ((*i)->getTag() == CA_DESCRIPTOR) {
                        uint16_t caid = ((CaDescriptor*)(*i))->getCaSystemId();
                        CaIdVectorConstIterator it = std::lower_bound(caids.begin(), caids.end(), caid);
                        if (caids.empty() || (it != caids.end() && *it == caid)) {
                                descriptorList.push_back(new CaDescriptor(*(CaDescriptor *)*i));
                                programInfoLength += (*i)->getLength() + 2;
                                length += (*i)->getLength() + 2;
                        }
                }

        for (ElementaryStreamInfoConstIterator i = pmt->esInfo.begin(); i != pmt->esInfo.end(); ++i) {
                CaElementaryStreamInfo *info = new CaElementaryStreamInfo(*i, caPmtCmdId, caids);
                esInfo.push_back(info);
                length += info->getLength();
        }

        return true;
}


CaElementaryStreamInfo::CaElementaryStreamInfo(const ElementaryStreamInfo * const info, const uint8_t cmdId, const CaIdVector &caids)
{
        streamType = info->streamType;
        elementaryPid = info->elementaryPid;
        esInfoLength = 0;

        for (DescriptorConstIterator i = info->getDescriptors()->begin(); i != info->getDescriptors()->end(); ++i)
                if ((*i)->getTag() == CA_DESCRIPTOR) {
                        uint16_t caid = ((CaDescriptor*)(*i))->getCaSystemId();
                        CaIdVectorConstIterator it = std::lower_bound(caids.begin(), caids.end(), caid);
                        if ( caids.empty() || (it != caids.end() && *it == caid) )
                        {
                                descriptors.push_back(new CaDescriptor(*(CaDescriptor *)*i));
                                esInfoLength += (*i)->getLength() + 2;
                        }
                }

        if (esInfoLength) {
                caPmtCmdId = cmdId;
                esInfoLength++;
        }
}

So there is CA_DESCRIPTOR in PMT descriptors and in Elementary Stream Info.

I guess if libdvbsi++ had a function isScrambled() would be easier instead of trying to get that info from PMT.
Wavefield T90: 0.8W - 1.9E - 4.8E - 13E - 16E - 19.2E - 23.5E - 26E - 33E - 39E - 42E - 45E on EMP Centauri DiseqC 16/1
Unamed: 13E Quattro - 9E Quattro on IKUSI MS-0916

Re: Decoding not work on most UPC channels #7 skyjet

  • Member
  • 11 posts

0
Neutral

Posted 25 November 2016 - 22:35

I tested for athoik a fix and UPC channels can be decoded again. So if anybody has the same problem as I, then wait until the fix will be in master.

Thanks to athoik for fast reaction!



Re: Decoding not work on most UPC channels #8 athoik

  • PLi® Core member
  • 8,395 posts

+321
Excellent

Posted 25 November 2016 - 23:23

Patches are available for merge.

Sorry for the confusion, hope it works now.
Wavefield T90: 0.8W - 1.9E - 4.8E - 13E - 16E - 19.2E - 23.5E - 26E - 33E - 39E - 42E - 45E on EMP Centauri DiseqC 16/1
Unamed: 13E Quattro - 9E Quattro on IKUSI MS-0916

Re: Decoding not work on most UPC channels #9 WanWizard

  • PLi® Core member
  • 58,432 posts

+1,274
Excellent

Posted 25 November 2016 - 23:45

Both PR's merged.


Currently in use: VU+Duo 4K (2xFBC S2), Amiko Viper T2C (T2+fallback), Octagon SF8008 (S2+T2), Zgemma H9.2H (T2+fallback)

Many answers to your question can be found in our new and improved wiki.

Because to health reasons, I will not be active online very often anymore.


Re: Decoding not work on most UPC channels #10 Robinson

  • Senior Member
  • 2,523 posts

+30
Good

Posted 27 November 2016 - 11:54

Is this fix already included if I run an online update, please?


ET9000, OpenPLi 4.0, 13E, 19E

HD51, OpenPLi 6.2, 75E - 30W


Re: Decoding not work on most UPC channels #11 Abu Baniaz

  • PLi® Contributor
  • 1,845 posts

+45
Good

Posted 27 November 2016 - 17:47

Is this fix already included if I run an online update, please?

The commit is here
https://github.com/O...82cc685ae6c0d51

Was merged on 25/11/2016





Also tagged with one or more of these keywords: bug

1 user(s) are reading this topic

0 members, 1 guests, 0 anonymous users