Jump to content


Photo

Some keys don't work on Miraclebox Micro.


  • Please log in to reply
28 replies to this topic

#1 hawkeye116477

  • Member
  • 16 posts

0
Neutral

Posted 24 December 2016 - 11:12

Welcome! On Miraclebox Premium Micro keys media and fav don't work. Previously I had OpenMB and Egami-Image and in those softwares - these keys work (key media open recording list). Can you fix it?

Attached Files


Miraclebox Premium Micro (v1)


Re: Some keys don't work on Miraclebox Micro. #2 Frenske

  • Forum Moderator
    PLi® Core member
  • 21,496 posts

+179
Excellent

Posted 24 December 2016 - 11:26

I have always been told that the code should be present in the drivers. In case those buttons don't work, this should be changed in the drivers, I guess.
Mijn schotel is een T90 met 10 LNB's. Daarnaast voor de fun nog een draaibaar systeem met een Triax TD 78.

Dreamboxen heb ik niet meer. Verder nog een een VU+ duo2 met 500Gb harddisk + een VU+ Uno, Zero, Solo 4K, Ultimo 4K, Zero 4K, Uno 4Kse. + ook nog een Xtrend ET4000. Daarnaast heb ik ook nog diverse andere modellen w.o. een Formuler F4, ET8500, ET7500, Mut@nt 2400HD, Xsarius Fusion HD se en verder nog wel het e.e.a. waarmee op verzoek vanalles wordt getest. Iemand moet het tenslotte doen. ;) :)

Voor centrale opslag van media gebruik ik een Qnap 219P met tweemaal 2 Tb harddisks.

-------------------------------------------------------------------------------------------
Many answers to your question can be found in our wiki: Just one click away from this "solutioncentre".

Als ik alles al wist hoefde ik ook niets te vragen. If I had all the knowledge I had no questions at all.

Re: Some keys don't work on Miraclebox Micro. #3 Erik Slagter

  • PLi® Core member
  • 45,235 posts

+496
Excellent

Posted 24 December 2016 - 15:05

Try the hotfix configuration, if that doesn't work, it must be fixed in the drivers.


* Wavefrontier T90 with 28E/23E/19E/13E/9E/4.8E/0.8W/5W via SCR switches 2 x 2 x 6 user bands
* Ziggo digital cable TV (FTA)
I don't read PM -> if you have something to ask or to report, do it in the forum so others can benefit. I don't take freelance jobs.
Ik lees geen PM -> als je iets te vragen of te melden hebt, doe het op het forum, zodat anderen er ook wat aan hebben.

Re: Some keys don't work on Miraclebox Micro. #4 Rob van der Does

  • Senior Member
  • 7,731 posts

+184
Excellent

Posted 24 December 2016 - 17:16

I have always been told that the code should be present in the drivers.

That is the first prerequisite.
The second is that the button (keycode) is also present in the active keymap. And that is image dependant.

Edited by Rob van der Does, 24 December 2016 - 17:17.


Re: Some keys don't work on Miraclebox Micro. #5 hawkeye116477

  • Member
  • 16 posts

0
Neutral

Posted 24 December 2016 - 21:13

With keymap from OpenMB, key media works, but key fav don't work.

Attached Files


Edited by hawkeye116477, 24 December 2016 - 21:13.

Miraclebox Premium Micro (v1)


Re: Some keys don't work on Miraclebox Micro. #6 WanWizard

  • Forum Moderator
    PLi® Core member
  • 47,159 posts

+784
Excellent

Posted 25 December 2016 - 00:46

Where exactly does this file come from? Because I don't see any OpenMB specific changes here: https://github.com/o...data/keymap.xml


Currently in use: VU+Duo 4K (2xFBC S2), Amiko Viper T2C (T2), SAB Alpha Triple HD (S2+T2), Zgemma H3.T2C (T/C), Zgemma H6 (fallback), VU+Zero (fallback)

Many answers to your question can be found in our new and improved wiki.

note: I do not provide support via PM !

 


Re: Some keys don't work on Miraclebox Micro. #7 Dimmie

  • Senior Member
  • 1,857 posts

+17
Neutral

Posted 25 December 2016 - 02:23

This is the OpenMB that illegally call their images "OpenPLI 5". I have reported this before long time ago but nothing seems to be done about it, which is strange because the site is linked by the manufacturer that has an agreement with OpenPLI for original support, so why then link to illegal OpenPLI 5 ?

 

 

 
 
Download
openpli-4-mbmicro-20161103_usb.zip
openpli-5-mbmicro-20160919_usb.zip
openpli-5-mbmicro-20160921_usb.zip
openpli-5-mbmicro-20160922_usb.zip
 
According to the OpenPLI rules the images cannot be called 'openpli-5-mbmicro-20160922_usb.zip' but should be called something like 'openmb-5-mbmicro-20160922_usb.zip'. And in the info it should not say "OpenPLI 5".

Edited by Dimmie, 25 December 2016 - 02:24.


Re: Some keys don't work on Miraclebox Micro. #8 Rob van der Does

  • Senior Member
  • 7,731 posts

+184
Excellent

Posted 25 December 2016 - 04:57

On the top-left of the page you linked to it says "OpenMB based on OpenPLi".



Re: Some keys don't work on Miraclebox Micro. #9 Pr2

  • PLi® Contributor
  • 3,449 posts

+151
Excellent

Posted 25 December 2016 - 10:25

Except that now OpenPLi officially support 2 models of MiracleBox.

https://www.openpli....oad/miraclebox/

So indeed Miracle Box provide "abusive OpenPli brand" images under www.openpli.com and at the same time OpenPLi officially support two of their boxes...
I would have hope that since OpenPLi now get in touch officially with MiracleBox will clarify once for all this situation, but now it is even worse.

The suggestion that I perform doesn't receive any remarks, nor feedback but this is typically a nice case to have the feature I ask for:

https://forums.openp...-key-discovery/

Pr2

NO SUPPORT by PM, it is a forum make your question public so everybody can benefit from the question/answer.
If you think that my answer helps you, you can press the up arrow in bottom right of the answer.

Wanna help with OpenPLi Translation? Please read our Wiki Information for translators

Sat: Hotbird 13.0E, Astra 19.2E, Eutelsat5A 5.0W
VU+ Solo 4K: 2*DVB-S2 + 2*DVB-C/T/T2 (used in DVB-C) & Duo 4K: 2*DVB-S2X + DVB-C (FBC)
Edision OS Mio 4K: 1*DVB-S2X + 1*DVB-C/T/T2
 


Re: Some keys don't work on Miraclebox Micro. #10 hawkeye116477

  • Member
  • 16 posts

0
Neutral

Posted 25 December 2016 - 10:46

Where exactly does this file come from? Because I don't see any OpenMB specific changes here: https://github.com/o...data/keymap.xml

Here is -> https://github.com/o...87199b1b0f39c72 .


Miraclebox Premium Micro (v1)


Re: Some keys don't work on Miraclebox Micro. #11 Rob van der Does

  • Senior Member
  • 7,731 posts

+184
Excellent

Posted 25 December 2016 - 10:47

I just flashed such an image and indeed: once on the box it's all PLi, never any 'based on PLi'.

Bah....

 

BTW: A similar behaviour as GB does: they manipulated VU's HbbTV so it runs on their MIPS image.

Conclusion: No ethics when it comes to money making....



Re: Some keys don't work on Miraclebox Micro. #12 hawkeye116477

  • Member
  • 16 posts

0
Neutral

Posted 25 December 2016 - 11:14

I just flashed such an image and indeed: once on the box it's all PLi, never any 'based on PLi'.

Bah....

 

BTW: A similar behaviour as GB does: they manipulated VU's HbbTV so it runs on their MIPS image.

Conclusion: No ethics when it comes to money making....

On bootlogo is written „OpenMB based on OpenPli", but on other places is as you write.


Miraclebox Premium Micro (v1)


Re: Some keys don't work on Miraclebox Micro. #13 Yo!

  • Member
  • 17 posts

0
Neutral

Posted 27 December 2016 - 12:07

I just ran into the same issue. I created a startup script that modifies the keymap.xml, so I can update my miraclebox premium again without issues ;) It just replaced the "InfobarActions" section of the keymap.xml with the additional entries needed for the miraclebox remote control...

 

For creating the startup script, place the attached file 'user.txt' in /etc/init.d, remove the .txt extention, make it executable (chmod 777 user) and link it from /etc/rcS.d (ln -s ../init.d/user S80user).

Attached Files

  • Attached File  user.txt   1.04KB   20 downloads

Edited by Yo!, 27 December 2016 - 12:07.


Re: Some keys don't work on Miraclebox Micro. #14 hawkeye116477

  • Member
  • 16 posts

0
Neutral

Posted 27 December 2016 - 14:45

I found other bug, when playing recording with default media player after press audio key and change audio, movie rewinds forward.


Miraclebox Premium Micro (v1)


Re: Some keys don't work on Miraclebox Micro. #15 Dimmie

  • Senior Member
  • 1,857 posts

+17
Neutral

Posted 27 December 2016 - 19:30

I just flashed such an image and indeed: once on the box it's all PLi, never any 'based on PLi'.

Bah....

 

BTW: A similar behaviour as GB does: they manipulated VU's HbbTV so it runs on their MIPS image.

Conclusion: No ethics when it comes to money making....

 

 

Exactly, I already reported this long time ago. I was surprised that nothing is done about it. The picture on the website and also the 'based on' is false/fake just to mislead the OpenPLI crew.


Edited by Dimmie, 27 December 2016 - 19:31.


Re: Some keys don't work on Miraclebox Micro. #16 WanWizard

  • Forum Moderator
    PLi® Core member
  • 47,159 posts

+784
Excellent

Posted 27 December 2016 - 21:44

We can't do anything about it, we don't know who to address.

 

There is no way to contact anybody, and there is no direct (visible) link between Miraclebox and OpenMB. If there was, there wouldn't be a need for them to ask us to make an image for their boxes.

 

If you have more information, please share so we can try to contact them again.


Currently in use: VU+Duo 4K (2xFBC S2), Amiko Viper T2C (T2), SAB Alpha Triple HD (S2+T2), Zgemma H3.T2C (T/C), Zgemma H6 (fallback), VU+Zero (fallback)

Many answers to your question can be found in our new and improved wiki.

note: I do not provide support via PM !

 


Re: Some keys don't work on Miraclebox Micro. #17 Pr2

  • PLi® Contributor
  • 3,449 posts

+151
Excellent

Posted 28 December 2016 - 23:32

Come on!
 
You support already 2 STBs branded Miraclebox so you have the contacts.
 
https://openpli.org/...oad/miraclebox/
 
And of course openpli.com is only linked with Miraclebox!  They called the image OpenMB  which means Open Miracle Box ! In the bottom of the page:  "The open image for Miraclebox Premium"

They also registered:  openmb.net  (they cannot get openmb.com since it was already registered by someone else).

 

If OpenPLi is a registered trademark you can always try to contact:

Registrar Abuse Contact Email: c4b6ccc262493b5dd75a4ee534f2a8c7cf911ca9@godaddy.com

 

Pr2


NO SUPPORT by PM, it is a forum make your question public so everybody can benefit from the question/answer.
If you think that my answer helps you, you can press the up arrow in bottom right of the answer.

Wanna help with OpenPLi Translation? Please read our Wiki Information for translators

Sat: Hotbird 13.0E, Astra 19.2E, Eutelsat5A 5.0W
VU+ Solo 4K: 2*DVB-S2 + 2*DVB-C/T/T2 (used in DVB-C) & Duo 4K: 2*DVB-S2X + DVB-C (FBC)
Edision OS Mio 4K: 1*DVB-S2X + 1*DVB-C/T/T2
 


Re: Some keys don't work on Miraclebox Micro. #18 WanWizard

  • Forum Moderator
    PLi® Core member
  • 47,159 posts

+784
Excellent

Posted 29 December 2016 - 16:48

The fact that it is an MB image doesn't imply it is owned and made by MB.

 

Off course we have contacted them, but it not that easy, the same issues exist with Zgemma for example, where the website that provides "fake" OpenPLi images isn't from the manufacturer, but run by some distributor (which doesn't respond at all).

 

For GoDaddy the same is true as for OVH: you can report all you want, it goes directly to /dev/null, and you never get a response.


Currently in use: VU+Duo 4K (2xFBC S2), Amiko Viper T2C (T2), SAB Alpha Triple HD (S2+T2), Zgemma H3.T2C (T/C), Zgemma H6 (fallback), VU+Zero (fallback)

Many answers to your question can be found in our new and improved wiki.

note: I do not provide support via PM !

 


Re: Some keys don't work on Miraclebox Micro. #19 hawkeye116477

  • Member
  • 16 posts

0
Neutral

Posted 30 December 2016 - 12:55

Let's get back to the topic better. So is there any chance that soon the problem with the Miraclebox remote control buttons will be repaired? On OpenMB so it is done: https://github.com/o...87199b1b0f39c72 . I hope this helps a little.


Miraclebox Premium Micro (v1)


Re: Some keys don't work on Miraclebox Micro. #20 mrvica

  • Senior Member
  • 673 posts

+39
Good

Posted 16 February 2019 - 14:30

the favourites key is OK now, still not OK is the Plugin key, according to evtest it is the KEY_BOOKMARKS key code 156, putting this in keymap.xml does not resolve the problem, still unhandled key
<map context="InfobarActions">
..............................................................
<key id="KEY_BOOKMARKS" mapto="showPluginBrowser" flags="b" />
..............................................................´
</map>
can you put it please in HotKey.py

Attached Files

  • Attached File  rc.png   31.86KB   0 downloads





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users