Jump to content


Photo

Solo 4K freezing during zapping


  • Please log in to reply
14 replies to this topic

#1 Satpal

  • Senior Member
  • 221 posts

+2
Neutral

Posted 19 March 2017 - 16:43

I had this issue some weeks ago on an almost daily basis, then it seemed to have disappeared but as it occured again today I think I have to post it. Usually the box froze just by trying to zap to another channel. Today it happened while I was in the channel list trying to move the cursor to a different channel. Openpli version is from March 1st.

 

Here's the dmesg output:

[1432971.951435] FE tune [DMX]: paserband_remove_pid pid 0x60 not found
[1433934.964927] [DMX]: paserband_remove_pid pid 0x60 not found
[1433934.972872]
[1434859.044860] Unable to handle kernel NULL pointer dereference at virtual address 0000002c
[1434859.053257] pgd = c3c49f00
[1434859.056153] [0000002c] *pgd=07719003, *pmd=041d4003, *pte=00000000
[1434859.063006] Internal error: Oops: 207 [#1] SMP ARM
[1434859.067979] Modules linked in: ipv6 brcmfb(O) dvb_bcm7376(PO) dvb_base(PO) bcm_event(PO) procmk(O) rt2800usb rt2800lib rt2x00usb rt2x00lib led_class mac80211
[1434859.082431] CPU: 0 PID: 15903 Comm: enigma2 Tainted: P           O 3.14.28-1.8 #1
[1434859.090098] task: ccc30dc0 ti: cbea6000 task.ti: cbea6000
[1434859.095939] PC is at NEXUS_BaseObject_P_RegisterUnregister+0x1d8/0x344 [dvb_base]
[1434859.103803] LR is at NEXUS_BaseObject_P_RegisterUnregister+0x1d8/0x344 [dvb_base]
[1434859.111469] pc : [<bf09a028>]    lr : [<bf09a028>]    psr: 600b0013
[1434859.111469] sp : cbea7e48  ip : 00000000  fp : 00000000
[1434859.123306] r10: bf829f54  r9 : 00000000  r8 : 00000000
[1434859.128709] r7 : bf4e96e8  r6 : cc0c0a00  r5 : 00000000  r4 : cc0c0a00
[1434859.135417] r3 : 0000c4f6  r2 : cccf9844  r1 : 600b0013  r0 : cccf9844
[1434859.142127] Flags: nZCv  IRQs on  FIQs on  Mode SVC_32  ISA ARM  Segment user
[1434859.149444] Control: 30c5387d  Table: 03c49f00  DAC: fffffffd
[1434859.155370] Process enigma2 (pid: 15903, stack limit = 0xcbea6238)
[1434859.161731] Stack: (0xcbea7e48 to 0xcbea8000)
[1434859.166267] 7e40:                   bf4e7848 00000000 de6cb13c cae53800 bf82b320 bf823bd4
[1434859.174628] 7e60: bf829f54 bf0e8f90 cc0c0a00 bf37c308 bf4e7848 bf0fdd90 00000003 00000000
[1434859.182988] 7e80: bf82b320 bf7ae828 200b0113 ffffffff cbea7ecc c0012e00 c07b1380 600b0113
[1434859.191348] 7ea0: cd946980 c009360c cd7c67f8 c07e77c0 cd7c6804 00100100 00200200 c07e7800
[1434859.199708] 7ec0: cd918b80 00000001 00000000 cd918b60 00000001 c00929bc cd918b60 bf823dc4
[1434859.208069] 7ee0: de6ca13c bf823300 bf823dac de6cb13c 00000008 ce2f4f08 b6a1a1a8 c0413eb0
[1434859.216429] 7f00: de3c82b0 de3c82b0 bf823300 cc818d38 de3c832c c0411d08 de6ca13c de3c82b0
[1434859.224789] 7f20: de3c82b0 c0411eb8 de3c82b0 bf8232b8 bf823300 cc818d38 de3c832c c0412398
[1434859.233149] 7f40: ce2f4f00 00000000 ccfda3c0 cc818d38 cce03d90 c00cb34c 00000000 00000000
[1434859.241510] 7f60: ccc31164 00000000 c07f69b0 ccc30dc0 c000f1e4 cbea6000 00000000 c003b85c
[1434859.249871] 7f80: ce2f4f00 cbea6018 c000f1e4 cbea7fb0 cbea6000 c0011ee0 b638a850 03877a40
[1434859.258231] 7fa0: 00000000 00000002 00000006 c000f0a0 00000000 b638a414 00000002 b638a850
[1434859.266591] 7fc0: 03877a40 00000000 00000002 00000006 032f0bc8 03697944 03697948 b6a1a1a8
[1434859.274951] 7fe0: 00000000 bed99db0 00000000 b6577434 800b0010 00000052 00000000 00000000
[1434859.283627] [<bf09a028>] (NEXUS_BaseObject_P_RegisterUnregister [dvb_base]) from [<bf0e8f90>] (NEXUS_PidChannel_BaseObject_P_RegisterUnregister+0x28/0x34 [dvb_base])
[1434859.298895] [<bf0e8f90>] (NEXUS_PidChannel_BaseObject_P_RegisterUnregister[dvb_base]) from [<bf0fdd90>] (NEXUS_PidChannel_Close+0x38/0x54 [dvb_base])
[1434859.312735] [<bf0fdd90>] (NEXUS_PidChannel_Close [dvb_base]) from [<bf7ae828>] (bcm7335_demux_stop_feed_trans+0x410/0xf68 [dvb_bcm7376])
[1434859.325200] [<bf7ae828>] (bcm7335_demux_stop_feed_trans [dvb_bcm7376]) from [<c0413eb0>] (dmx_section_feed_stop_filtering+0x34/0x8c)
[1434859.337303] [<c0413eb0>] (dmx_section_feed_stop_filtering) from [<c0411d08>] (dvb_dmxdev_feed_stop+0xa8/0xb0)
[1434859.347404] [<c0411d08>] (dvb_dmxdev_feed_stop) from [<c0411eb8>] (dvb_dmxdev_filter_stop+0x90/0xd0)
[1434859.356722] [<c0411eb8>] (dvb_dmxdev_filter_stop) from [<c0412398>] (dvb_demux_release+0x2c/0x18c)
[1434859.365872] [<c0412398>] (dvb_demux_release) from [<c00cb34c>] (__fput+0x80/0x200)
[1434859.373632] [<c00cb34c>] (__fput) from [<c003b85c>] (task_work_run+0xa8/0xe0)
[1434859.380958] [<c003b85c>] (task_work_run) from [<c0011ee0>] (do_work_pending+0x98/0xa4)
[1434859.389061] [<c0011ee0>] (do_work_pending) from [<c000f0a0>] (work_pending+0xc/0x20)
[1434859.396988] Code: e1a00001 e1a02005 e1a01009 e12fff3c (e598302c)
[1434859.403455] ---[ end trace 8e54be8612c401d6 ]---
root@vusolo4k:~#


Re: Solo 4K freezing during zapping #2 WanWizard

  • Forum Moderator
    PLi® Core member
  • 30,918 posts

+422
Excellent

Posted 19 March 2017 - 17:10

Looks like a driver bug.


Many answers to your question can be found in our wiki.

Currently stacked up: VU+Duo2 (3xS2), ET10000 (4xS2), HD2400 (4xS2), Formuler F1 (2xS2), XP1000, Zgemma H2.H (S2+C), VU+ZeroMiraclebox Premium Micro (S2+C/T) and ET7500 (S2)ET8500 (S2) spare.


Re: Solo 4K freezing during zapping #3 Erik Slagter

  • PLi® Core member
  • 37,769 posts

+402
Excellent

Posted 20 March 2017 - 19:15

It not only likes like a driver bug, it IS a driver bug ;)


* Wavefrontier T90 with:
- 19.2E/13.0E/4.8E/0.8W/5W single LNB's via uncomitted switch 8->1
- 28.2E/23.5E quattro LNB's via unicable switch
UPC digital cable TV (FTA) on all receivers


Re: Solo 4K freezing during zapping #4 Satpal

  • Senior Member
  • 221 posts

+2
Neutral

Posted 20 March 2017 - 21:02

Hm, but shouldn't then not only this but all other boards about other images as well be full of reports on this issue? Just zapping doesn't seem to be such an odd thing.



Re: Solo 4K freezing during zapping #5 JasonM8

  • Senior Member
  • 27 posts

0
Neutral

Posted 27 March 2017 - 07:51

So this is only fixable by manufacturer? I am considering Solo 4k.

 

Are new Uno 4k or Ultimo 4k also affected?



Re: Solo 4K freezing during zapping #6 Pr2

  • Senior Member
  • 1,764 posts

+65
Good

Posted 27 March 2017 - 11:44

Hi,

 

I never experience this problem (fortunately) on my Solo4K.

Do you have a (very) good signal or do you have a weak signal?

 

Pr2


Xtrend ET-9000 Openpli 4.0: Hotbird 13.0E, Astra 19.2E, Eutelsat5A 5.0W  + Sundtek DVB-C

VU+ Solo 4K: 2*DVB-S2 + 2*DVB-C/T/T2 (used in DVB-C)

Zgemma H5: 1*DVB-S2 + 1*DVB-C

 


Re: Solo 4K freezing during zapping #7 Satpal

  • Senior Member
  • 221 posts

+2
Neutral

Posted 27 March 2017 - 15:16

I don't think reception quality is part of this issue. On most satellites I get values between 11 and 17 dB. On some others like 3E or 26E only 8 or 6 dB. But the freezing usually happens on the more frequently used strongest satellites like Astra 1, Hotbird, Thor and Hispasat.

 

But I strongly believe that it didn't happen before, only after one of the driver updates in the last few months. As there were quite a few of them and the problem occurs only randomly I can't really pinpoint when it started exactly.

 

Apparently I'm also still the only one with wrong frequencies shown on the additional dual tuner where I get e.g. 14.449 H instead of 12.034 H.



Re: Solo 4K freezing during zapping #8 Eloick

  • Member
  • 1 posts

0
Neutral

Posted 27 March 2017 - 23:04

Hello,
I am new and using an ultimo 4k with last image and i have the same issue (oops crash kernel, then terminal is frozen until reboot)
I am only using iptv (no dvb connexion) and crash happen after 4/5 times i am changing of channel.
I tried other kind of image to ensure it s not an hardware issue and it s fine.

Re: Solo 4K freezing during zapping #9 totollio

  • Member
  • 2 posts

0
Neutral

Posted 28 March 2017 - 17:26

Hello,
I recently bought last 4k + v and everything ok with s2 and dvb-t, but when I go on IPTV channel after channel switching 3/4 hangs around and I have to reboot the system.
Tried other images OpenTV 6.0 type and everything is ok with no block, but for the truth OpenPLi the picture would not change with any other image.
When you have time you can fix it ....... thanks


Re: Solo 4K freezing during zapping #10 Erik Slagter

  • PLi® Core member
  • 37,769 posts

+402
Excellent

Posted 28 March 2017 - 17:54

Hello,
I am new and using an ultimo 4k with last image and i have the same issue (oops crash kernel, then terminal is frozen until reboot)
I am only using iptv (no dvb connexion) and crash happen after 4/5 times i am changing of channel.
I tried other kind of image to ensure it s not an hardware issue and it s fine.

You are aware that we do not give ANY guarantee on IPTV (because we can't).


* Wavefrontier T90 with:
- 19.2E/13.0E/4.8E/0.8W/5W single LNB's via uncomitted switch 8->1
- 28.2E/23.5E quattro LNB's via unicable switch
UPC digital cable TV (FTA) on all receivers


Re: Solo 4K freezing during zapping #11 Erik Slagter

  • PLi® Core member
  • 37,769 posts

+402
Excellent

Posted 28 March 2017 - 17:55

 

Hello,
I recently bought last 4k + v and everything ok with s2 and dvb-t, but when I go on IPTV channel after channel switching 3/4 hangs around and I have to reboot the system.
Tried other images OpenTV 6.0 type and everything is ok with no block, but for the truth OpenPLi the picture would not change with any other image.
When you have time you can fix it ....... thanks

Really... And how then?


* Wavefrontier T90 with:
- 19.2E/13.0E/4.8E/0.8W/5W single LNB's via uncomitted switch 8->1
- 28.2E/23.5E quattro LNB's via unicable switch
UPC digital cable TV (FTA) on all receivers


Re: Solo 4K freezing during zapping #12 totollio

  • Member
  • 2 posts

0
Neutral

Posted 29 March 2017 - 12:14

then? nothing all ok. changing the engine's all.
Hello


Re: Solo 4K freezing during zapping #13 Pr2

  • Senior Member
  • 1,764 posts

+65
Good

Posted 29 March 2017 - 14:33

Wait for OpenPLi 5 to use IPTV.


Xtrend ET-9000 Openpli 4.0: Hotbird 13.0E, Astra 19.2E, Eutelsat5A 5.0W  + Sundtek DVB-C

VU+ Solo 4K: 2*DVB-S2 + 2*DVB-C/T/T2 (used in DVB-C)

Zgemma H5: 1*DVB-S2 + 1*DVB-C

 


Re: Solo 4K freezing during zapping #14 Taykun345

  • Senior Member
  • 1,033 posts

+31
Good

Posted 29 March 2017 - 16:59

Ts streams (iptv) work great on pli4.

Sent from my HTC 10 using Tapatalk
Army MoodBlue HD skin modification by me: https://github.com/T...-MoodBlueHD-mod
Matrix10 MH-HD2 skin modification by me: https://github.com/B...-MX-HD2-OpenPli
MetrixHD skin modification by me: https://github.com/T...xHD-WPstyle-mod
Slovenian translation for OpenPLi E2: https://github.com/T...ion-for-OpenPLi

Re: Solo 4K freezing during zapping #15 Satpal

  • Senior Member
  • 221 posts

+2
Neutral

Posted 8 April 2017 - 19:55

After updating to today's build the problem has gone from bad to worse. After zapping 3 or 4 times or trying to move the cursor in the channel list the box freezes with spinner. So I guess I'll try a clean flash and maybe some other image as well.






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users