Jump to content


Photo

Gstreamer audio out of sync after a few minutes VU

gstreamer

  • Please log in to reply
5 replies to this topic

#1 sonic-x

  • Member
  • 8 posts

0
Neutral

Posted 11 May 2017 - 06:28

Hi, I am having a problem with live streams on both my VU duo 2 and solo 4k, The live video stream starts ok with the video and audio in sync, however after about 5 minutes the audio and video go out of sync, after a few more minutes the delay becomes wider, basically the audio comes before the video.

 

I am using Gstreamer 1.8, is there and settings I can modify to help with the sync, I tried enabling buffer using 1 on the last 0 of the service ID, It made no difference, I also added sync=false and sync=true to the end of the stream link and it made no difference.

 

What could be causing the issue? and is there anything I can do to fix it, if I use VLC on a pc the problem doesnt occur, I also tried different image versions, Openpli, openatv and VTI and the same problem occurs.



Re: Gstreamer audio out of sync after a few minutes VU #2 ian1095

  • Senior Member
  • 462 posts

+6
Neutral

Posted 11 May 2017 - 07:47

I too have noticed this problem creep into Gstreamer and Mediaplayer recently, I cannot say when it started though, but its deffo there now.

 

There is no easy fix, so I simply do not use Gstreamer and Mediaplayer anymore.

 

Instead I use Exteplayer3 v34 together with ffmpeg 3.2.4 through Serviceapp for everything and for the few things that Exteplayer3 cannot play because they are not being passed through Serviceapp correctly, I use GSTPlayer for those.

 

No sync issues at all then ever.

 

Ian.


Edited by ian1095, 11 May 2017 - 07:47.


Re: Gstreamer audio out of sync after a few minutes VU #3 MastaG

  • PLi® Core member
  • 1,528 posts

+116
Excellent

Posted 11 May 2017 - 21:41

Are you also getting this on a clean PLi5 build from the develop branch?

Re: Gstreamer audio out of sync after a few minutes VU #4 sonic-x

  • Member
  • 8 posts

0
Neutral

Posted 11 May 2017 - 22:06

I too have noticed this problem creep into Gstreamer and Mediaplayer recently, I cannot say when it started though, but its deffo there now.

 

There is no easy fix, so I simply do not use Gstreamer and Mediaplayer anymore.

 

Instead I use Exteplayer3 v34 together with ffmpeg 3.2.4 through Serviceapp for everything and for the few things that Exteplayer3 cannot play because they are not being passed through Serviceapp correctly, I use GSTPlayer for those.

 

No sync issues at all then ever.

 

Ian.

Ok, thanks for confirming that, I have installed service app and Exteplayer3 it has fixed the issue of the audio going out of sync, but some streams already seem to have a second delay, is it possible to get the audio sync plugin to work with service app? currently setting a delya does nothing, also I cannot record anything the box hangs if I try, I don't know how to install GSTplayer the IPTV Player addon didn't install it but I assume I still wouldnt be able to record with that?



Re: Gstreamer audio out of sync after a few minutes VU #5 sonic-x

  • Member
  • 8 posts

0
Neutral

Posted 11 May 2017 - 22:08

Are you also getting this on a clean PLi5 build from the develop branch?

I do yes if I use Gstreamer, but not on all streams, some remain in sync others develop a delay that get's worse over time, stopping and restarting the stream fixes it, but then it creeps in again. It isnt a problem with openpli though on openatv and VTI it happens too



Re: Gstreamer audio out of sync after a few minutes VU #6 ian1095

  • Senior Member
  • 462 posts

+6
Neutral

Posted 12 May 2017 - 06:44

Yes its a Gstreamer issue that has recently crept in, this is why it happens with OpenATV ect too

 

I'm running Gstreamer 1.11.2 and its deffo apparent, but as you say its not all streams, only some.

 

So as I stated above, I simply no longer use Gstreamer for anything until this issue is corrected, which I'm sure it will be eventually.

 

Ian.

 

ps the audio setup delay working with Serviceapp would be a good enhancement, perhaps mx3L will take a look.


Edited by ian1095, 12 May 2017 - 06:47.






1 user(s) are reading this topic

0 members, 1 guests, 0 anonymous users