Jump to content


Photo

Miraclebox Ultra, not supported?


  • Please log in to reply
19 replies to this topic

#1 Tipo874

  • Member
  • 23 posts

0
Neutral

Posted 12 June 2017 - 08:01

I have two Miraclebox Ultra boxes running a fairly old openmb (last?) image.

 

It seems that the openmb builds stopped for the ultra boxes a while back, and now it looks like openmb.net is dead too.

 

I see that there are recent openpli images for some miraclebox boxes, but not the ultra.

 

Is it possible to request images for these boxes?

 

Thanks



Re: Miraclebox Ultra, not supported? #2 Rob van der Does

  • Senior Member
  • 7,732 posts

+184
Excellent

Posted 12 June 2017 - 08:29

Driver development for that box has stopped January 2016. The manufacturer doesn't support PLi for this box, so a PLi-image is unlikely.

You could try ViX or ATV; both have recent images for the Ultra.



Re: Miraclebox Ultra, not supported? #3 Tipo874

  • Member
  • 23 posts

0
Neutral

Posted 12 June 2017 - 19:24

Ok, too bad.

I see Egami images are available too.

What would people recommend?

Re: Miraclebox Ultra, not supported? #4 Abu Baniaz

  • PLi® Contributor
  • 1,678 posts

+38
Good

Posted 12 June 2017 - 20:28

Try them, settle on you like most.

Re: Miraclebox Ultra, not supported? #5 Tipo874

  • Member
  • 23 posts

0
Neutral

Posted 13 June 2017 - 10:46

I tried OpenVIX, which had severe problems with pixelization on some T/T2 channels, went back to the old OpenMB image to check, and it still works great.

 

Then checked OpenATV, but that hasn't been updatd since 2015, even older than the OpenMB/OpenPLI image.

 

Then installed the latest Egami, which has the same issues with T/T2 pixelization as OpenVIX.

 

So looks like I will be back on the old OpenMB image.



Re: Miraclebox Ultra, not supported? #6 hawkeye116477

  • Member
  • 16 posts

0
Neutral

Posted 13 June 2017 - 13:03

You can also try "Japhrapli". It's pli-based image like OpenMB ("OpenPLi 4.0 IPTV from our Member Japhar, built with ExtePlayer and GStreamer 1.11"). 

For MB Ultra there is OpenDroid, OpenESI and PKT Hyperion too.

Links for these softwares for MB Ultra are here: https://enigma2image.../premium-ultra/ .

I do not own this box, so I will not tell you what software is the best.


Edited by hawkeye116477, 13 June 2017 - 13:05.

Miraclebox Premium Micro (v1)


Re: Miraclebox Ultra, not supported? #7 Abu Baniaz

  • PLi® Contributor
  • 1,678 posts

+38
Good

Posted 13 June 2017 - 13:32

On the other forum, he says PLi dropped support for Box. You can't drop support if you have never supported it in the first place.

No issues with pixelisation of T2 channels on OpenVix. More than likely getting channels from neighbouring mast and not his own one.

Re: Miraclebox Ultra, not supported? #8 WanWizard

  • Forum Moderator
    PLi® Core member
  • 54,620 posts

+1,085
Excellent

Posted 13 June 2017 - 13:38

Correct. There has never been an OpenPLi image for a Miraclebox Ultra.


Currently in use: VU+Duo 4K (2xFBC S2), Amiko Viper T2C (T2+fallback), Octagon SF8008 (S2+T2), Zgemma H9.2H (T2+fallback)

Many answers to your question can be found in our new and improved wiki.

note: I do not provide support via PM !

 


Re: Miraclebox Ultra, not supported? #9 Tipo874

  • Member
  • 23 posts

0
Neutral

Posted 13 June 2017 - 15:50

Ok, the second boot screen says "Based on OPENPLi", everywhere else it says just OpenPLi.

 

I normally have to scan the T2 tuner manually as most of the images only contain the frequencies for another town, and I did so with both OpenVIX and Egami, and I do that also on the working OpenMB image. I enter the frequencies that are appropriate for the tower I'm aiming at, so unless there is some magic that makes it pick up the wrong frequency, I'm fairly sure it is correct.

 

I may give it another try.

 

I don't really have an issue with the OpenMB image, it is just that the repositories are gone, so no new packages, and no updates.



Re: Miraclebox Ultra, not supported? #10 Rob van der Does

  • Senior Member
  • 7,732 posts

+184
Excellent

Posted 13 June 2017 - 17:58

Then checked OpenATV, but that hasn't been updatd since 2015, even older than the OpenMB/OpenPLI image.

It seems you looked at the wrong place. The ATV images are located @ http://images.mynonp...hp?open=mbultra

Re: Miraclebox Ultra, not supported? #11 Abu Baniaz

  • PLi® Contributor
  • 1,678 posts

+38
Good

Posted 13 June 2017 - 22:15

I would keep your lamedb and try it on the other images. This avoids any issues with scanning wrong masts. If it is a scanning issue, it can be addressed later. You could also use the terrestrial scan plugin.



Re: Miraclebox Ultra, not supported? #12 Tipo874

  • Member
  • 23 posts

0
Neutral

Posted 14 June 2017 - 15:07

Thanks, I've now tested OpenATV 6, and it was the only fresh image that allowed me to restore the system settings from an OpenMB backup, so lamedb is the same, and no scan done, and it behaves the same.

 

What is weird is that some channels on one of the problematic muxes works fine, while others, on the same mux, pixelises like crazy, unwatchable.

 

All unencrypted channels work, while the ones that doesn't work properly are encrypted and is using a CI+ CAM, with an official card. Not all encrypted channels have a problem, but I think that all encrypted HD channels has problems.

 

It felt a bit like something running out of steam, but top said the box was 96% idle when it was pixelizing.

 

So now back to the old OpenMB again...

 

If anyone was any ideas how to debug this, I would be happy to try things out.

 

As all recent images seem to have this issue, it looks like it is some common issue.



Re: Miraclebox Ultra, not supported? #13 Tipo874

  • Member
  • 23 posts

0
Neutral

Posted 2 October 2017 - 18:18

Revisiting this issue as the old OpenMB image appears to have issues with https stream auth, it only accept it once after enigma starts.

 

I tried the latest OpenATV image, and it has the same issues, and I assume this is a low level driver issue.

 

Who is developing the low level stuff? open-oe or? Any forum I can bring this issue up?

 

What is weird is that some channels work fine while other pixelizes severly on the same mux. SNR is 99%, so no issue with the signal.

 

Here is what it looks like:

 



Re: Miraclebox Ultra, not supported? #14 WanWizard

  • Forum Moderator
    PLi® Core member
  • 54,620 posts

+1,085
Excellent

Posted 2 October 2017 - 18:25

Drivers are supplied by the manufacturer, as a binary .ko file. We don't know what's in it.


Currently in use: VU+Duo 4K (2xFBC S2), Amiko Viper T2C (T2+fallback), Octagon SF8008 (S2+T2), Zgemma H9.2H (T2+fallback)

Many answers to your question can be found in our new and improved wiki.

note: I do not provide support via PM !

 


Re: Miraclebox Ultra, not supported? #15 Pr2

  • PLi® Contributor
  • 4,314 posts

+173
Excellent

Posted 2 October 2017 - 19:42

Driver development for that box has stopped January 2016. ...


NO SUPPORT by PM, it is a forum make your question public so everybody can benefit from the question/answer.
If you think that my answer helps you, you can press the up arrow in bottom right of the answer.

Wanna help with OpenPLi Translation? Please read our Wiki Information for translators

Sat: Hotbird 13.0E, Astra 19.2E, Eutelsat5A 5.0W
VU+ Solo 4K: 2*DVB-S2 + 2*DVB-C/T/T2 (used in DVB-C) & Duo 4K: 2*DVB-S2X + DVB-C (FBC)
Edision OS Mio 4K: 1*DVB-S2X + 1*DVB-C/T/T2
 


Re: Miraclebox Ultra, not supported? #16 Tipo874

  • Member
  • 23 posts

0
Neutral

Posted 2 October 2017 - 21:33

I found that moving /lib/modules/3.14.2/extra/dvb.ko from my OpenMB install to OpenATV appears to work, and I assume it will work for the other images as well, as long as the kernel stays the same.

 

So given that the support is gone, can I supply the module I have that appears to work?


Edited by Tipo874, 2 October 2017 - 21:37.


Re: Miraclebox Ultra, not supported? #17 Pr2

  • PLi® Contributor
  • 4,314 posts

+173
Excellent

Posted 4 October 2017 - 11:15

Hi,

 

Zip it and attach it on the forum so if somebody find your thread and want to test he can have the file.

But OpenPli doesn't support Miracle Box Ultra.

 

https://openpli.org/...oad/miraclebox/

 

Pr2


NO SUPPORT by PM, it is a forum make your question public so everybody can benefit from the question/answer.
If you think that my answer helps you, you can press the up arrow in bottom right of the answer.

Wanna help with OpenPLi Translation? Please read our Wiki Information for translators

Sat: Hotbird 13.0E, Astra 19.2E, Eutelsat5A 5.0W
VU+ Solo 4K: 2*DVB-S2 + 2*DVB-C/T/T2 (used in DVB-C) & Duo 4K: 2*DVB-S2X + DVB-C (FBC)
Edision OS Mio 4K: 1*DVB-S2X + 1*DVB-C/T/T2
 


Re: Miraclebox Ultra, not supported? #18 Tipo874

  • Member
  • 23 posts

0
Neutral

Posted 4 October 2017 - 15:07

Ok, here it is.

 

I see that there are some other Miracleboxen that are supported by OpenPLi, how hard/much work would it be to add the Ultra too, given that the OpenMB stuff appears to be available on github?

 

Who is supporting these?

 

I really liked OpenMB, which apparently was an unofficial OpenPLi, and although the other projects (OpenATV, OpenVIX, Egami, etc) do build images for this box, I would prefer to have OpenPLi.

 

I would be willing to have a go at it if it isn't too hard.

Attached Files


Edited by Tipo874, 4 October 2017 - 15:09.


Re: Miraclebox Ultra, not supported? #19 WanWizard

  • Forum Moderator
    PLi® Core member
  • 54,620 posts

+1,085
Excellent

Posted 4 October 2017 - 15:39

We can only support what the manufacturer wants us to support, as they make the BSP.  If you want it, you'll have to build the image yourself, using local changes to the BSP.


Currently in use: VU+Duo 4K (2xFBC S2), Amiko Viper T2C (T2+fallback), Octagon SF8008 (S2+T2), Zgemma H9.2H (T2+fallback)

Many answers to your question can be found in our new and improved wiki.

note: I do not provide support via PM !

 


Re: Miraclebox Ultra, not supported? #20 babsy98

  • Senior Member
  • 150 posts

+9
Neutral

Posted 4 October 2017 - 16:26

use the old driver and insert to last atv image

 

last drivers was shit with ci

 

but old drivers have many other bugs






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users