Jump to content


Photo

NFS share mount wel op PLI4 niet op PLI6.1

NFS

  • Please log in to reply
26 replies to this topic

#1 noud

  • Senior Member
  • 63 posts

+1
Neutral

Posted 17 January 2018 - 15:18

Ik heb 3 PLI boxen,

 

mijn vuduo met pli4 kan 3 shares mounten 1 vanaf een pli6 box  en 2 van af een WD worldbook 

 

als ik de config overzet dmv /etc/enigma2/autoamount.xml copy

 

naar mijn vuduo2 met PLI6.1 dan werkt alleen de share vanaf de andere PLI6 box

 

op de WD staan geen IP beperkingen.

 

als ik met de hand de mount uitvoer krijg ik:

 

root@vuduox:/media/net# mount -t nfs -o rw,nolock,tcp 192.168.1.126:DataVolume/Public /media/net/TEST
mount.nfs: requested NFS version or transport protocol is not supported
mount: mounting 192.168.1.126:DataVolume/Public on /media/net/TEST failed: Operation not supported

 

 

her en der gegoogled maar kan niks vinden, weet iemand met welke optie's

dit weer aan de gang te krijgen is,


Vu+duo & 2x Vu+duo2  Vu+ultimo4K
28.2E | 23.5E | 19.2E | 13E | Terrestirial


Re: NFS share mount wel op PLI4 niet op PLI6.1 #2 WanWizard

  • PLi® Core member
  • 59,617 posts

+1,351
Excellent

Posted 17 January 2018 - 15:27

Je kan eens proberen er expliciet "vers=3" bij te zetten (in de -o optie lijst).


Currently in use: VU+Duo 4K (2xFBC S2), Amiko Viper T2C (T2+fallback), Octagon SF8008 (S2+T2), Zgemma H9.2H (T2+fallback)

Due to health reasons, I will have periods of inactivity, during which I don't respond to posts or PM.

Many answers to your question can be found in our new and improved wiki.


Re: NFS share mount wel op PLI4 niet op PLI6.1 #3 noud

  • Senior Member
  • 63 posts

+1
Neutral

Posted 17 January 2018 - 15:33

helaas:

 

root@vuduox:/media/net# mount -t nfs -o vers=3,rw,nolock,tcp 192.168.1.126:DataVolume/Public /media/net/TEST
mount.nfs: requested NFS version or transport protocol is not supported
mount: mounting 192.168.1.126:DataVolume/Public on /media/net/TEST failed: Operation not supported

 

Nog wat meer aan het vergelijken geweest, als ik Browse network neighbourhood doe dan krijg ik netjes shares op de WD te zien op de pli4

maar niks op de pli6.1


Edited by noud, 17 January 2018 - 15:33.

Vu+duo & 2x Vu+duo2  Vu+ultimo4K
28.2E | 23.5E | 19.2E | 13E | Terrestirial


Re: NFS share mount wel op PLI4 niet op PLI6.1 #4 40H3X

  • Forum Moderator
    PLi® Contributor
  • 4,559 posts

+140
Excellent

Posted 17 January 2018 - 15:57

Kun je achterhalen wat voor NFS packages op de worldbook beschikbaar zijn cq. zijn geinstalleerd?


Hardware: Vu+ Uno 4k SE - Fuba 78 cm - Tripleblock LNB Quad 19.2/23.5/28.2 - DS918+
Software : OpenPLi - OScam - Settings van Hans - Autotimer - EPGImport
---------------------------------------------------------------------------------------------------------------------------------------
Remember: Upvote with the rep_up.png button for any user/post you find to be helpful, informative, or deserving of recognition!
---------------------------------------------------------------------------------------------------------------------------------------
Many answers to your question can be found in our new and improved wiki

Note: I do not provide support via PM !.


Re: NFS share mount wel op PLI4 niet op PLI6.1 #5 WanWizard

  • PLi® Core member
  • 59,617 posts

+1,351
Excellent

Posted 17 January 2018 - 16:04

"network neighbourhood" = SMB (en dus CIFS), dat heeft niks met NFS te maken. Bovendien gaat dat over een connectie de andere kant op.


Currently in use: VU+Duo 4K (2xFBC S2), Amiko Viper T2C (T2+fallback), Octagon SF8008 (S2+T2), Zgemma H9.2H (T2+fallback)

Due to health reasons, I will have periods of inactivity, during which I don't respond to posts or PM.

Many answers to your question can be found in our new and improved wiki.


Re: NFS share mount wel op PLI4 niet op PLI6.1 #6 noud

  • Senior Member
  • 63 posts

+1
Neutral

Posted 17 January 2018 - 16:07

Ik kan inloggen op de WD, met welk command kan ik zien welk paket er op zit?


Vu+duo & 2x Vu+duo2  Vu+ultimo4K
28.2E | 23.5E | 19.2E | 13E | Terrestirial


Re: NFS share mount wel op PLI4 niet op PLI6.1 #7 40H3X

  • Forum Moderator
    PLi® Contributor
  • 4,559 posts

+140
Excellent

Posted 17 January 2018 - 16:11

misschien met

dpkg -s nfs-common 

en er staat me iets bij van

rpcinfo -p mybooklive


					
					

Hardware: Vu+ Uno 4k SE - Fuba 78 cm - Tripleblock LNB Quad 19.2/23.5/28.2 - DS918+
Software : OpenPLi - OScam - Settings van Hans - Autotimer - EPGImport
---------------------------------------------------------------------------------------------------------------------------------------
Remember: Upvote with the rep_up.png button for any user/post you find to be helpful, informative, or deserving of recognition!
---------------------------------------------------------------------------------------------------------------------------------------
Many answers to your question can be found in our new and improved wiki

Note: I do not provide support via PM !.


Re: NFS share mount wel op PLI4 niet op PLI6.1 #8 40H3X

  • Forum Moderator
    PLi® Contributor
  • 4,559 posts

+140
Excellent

Posted 17 January 2018 - 16:11

"network neighbourhood" = SMB (en dus CIFS), dat heeft niks met NFS te maken. Bovendien gaat dat over een connectie de andere kant op.

Ah, die had ik gemist...


Edited by 40H3X, 17 January 2018 - 16:11.

Hardware: Vu+ Uno 4k SE - Fuba 78 cm - Tripleblock LNB Quad 19.2/23.5/28.2 - DS918+
Software : OpenPLi - OScam - Settings van Hans - Autotimer - EPGImport
---------------------------------------------------------------------------------------------------------------------------------------
Remember: Upvote with the rep_up.png button for any user/post you find to be helpful, informative, or deserving of recognition!
---------------------------------------------------------------------------------------------------------------------------------------
Many answers to your question can be found in our new and improved wiki

Note: I do not provide support via PM !.


Re: NFS share mount wel op PLI4 niet op PLI6.1 #9 noud

  • Senior Member
  • 63 posts

+1
Neutral

Posted 17 January 2018 - 16:17

Helaas is een oud beestje, snap geen van bijde ;-(

 

P.S.

ik zie in de networkbrouwser  toch echt ook NFS shares niet allen cifs. NFS heeft zelfs een eigen logo


Vu+duo & 2x Vu+duo2  Vu+ultimo4K
28.2E | 23.5E | 19.2E | 13E | Terrestirial


Re: NFS share mount wel op PLI4 niet op PLI6.1 #10 WanWizard

  • PLi® Core member
  • 59,617 posts

+1,351
Excellent

Posted 17 January 2018 - 16:20

Ah, je bedoelt "network browser" op de box? En niet "network neighborhood" (wat iets in Windows is)?

 

Dat zegt vrij weinig, die code is dermate brak, als een server luistert op een bepaalde poort vind die het nfs, los van welke nfs, en of er wel of niet een connectie mogelijk is,.


Currently in use: VU+Duo 4K (2xFBC S2), Amiko Viper T2C (T2+fallback), Octagon SF8008 (S2+T2), Zgemma H9.2H (T2+fallback)

Due to health reasons, I will have periods of inactivity, during which I don't respond to posts or PM.

Many answers to your question can be found in our new and improved wiki.


Re: NFS share mount wel op PLI4 niet op PLI6.1 #11 noud

  • Senior Member
  • 63 posts

+1
Neutral

Posted 17 January 2018 - 16:38

op de werkende:

 

192.168.1.126:/DataVolume/DM7025_HDD on /media/net/HDD type nfs (rw,noatime,vers
=3,rsize=8192,wsize=8192,namlen=255,soft,nolock,proto=tcp,timeo=600,retrans=2,se
c=sys,mountaddr=192.168.1.126,mountvers=3,mountproto=tcp,local_lock=all,addr=192
.168.1.126)
192.168.1.126:/DataVolume/Public on /media/net/MYBOOK type nfs (rw,noatime,vers=
3,rsize=8192,wsize=8192,namlen=255,hard,nolock,proto=tcp,timeo=600,retrans=2,sec
=sys,mountaddr=192.168.1.126,mountvers=3,mountproto=tcp,local_lock=all,addr=192.
168.1.126)
192.168.1.110:/media/hdd on /media/net/HarddiskVUDUO type nfs (rw,noatime,vers=3
,rsize=8192,wsize=8192,namlen=255,soft,nolock,proto=tcp,timeo=600,retrans=2,sec=
sys,mountaddr=192.168.1.110,mountvers=3,mountproto=tcp,local_lock=all,addr=192.1
68.1.110)

 

op de niet werkende

 

192.168.1.110:/media/hdd on /media/net/HarddiskVUDUO type nfs (rw,noatime,vers=3
,rsize=8192,wsize=8192,namlen=255,soft,nolock,proto=tcp,timeo=600,retrans=2,sec=
sys,mountaddr=192.168.1.110,mountvers=3,mountproto=tcp,local_lock=all,addr=192.1
68.1.110)

 

lijkt dus de zelde opties te sturen,

helaas is de accu van mijn laptop nu op ;-(


Vu+duo & 2x Vu+duo2  Vu+ultimo4K
28.2E | 23.5E | 19.2E | 13E | Terrestirial


Re: NFS share mount wel op PLI4 niet op PLI6.1 #12 WanWizard

  • PLi® Core member
  • 59,617 posts

+1,351
Excellent

Posted 17 January 2018 - 17:10

Apart. En zeker te weten geen IP adressen in de export file?


Currently in use: VU+Duo 4K (2xFBC S2), Amiko Viper T2C (T2+fallback), Octagon SF8008 (S2+T2), Zgemma H9.2H (T2+fallback)

Due to health reasons, I will have periods of inactivity, during which I don't respond to posts or PM.

Many answers to your question can be found in our new and improved wiki.


Re: NFS share mount wel op PLI4 niet op PLI6.1 #13 noud

  • Senior Member
  • 63 posts

+1
Neutral

Posted 17 January 2018 - 19:52

omdat uit te sluiten ff pli4 op de niuewe box gezet,

en dan doet hij het ook niet, dus er is iets anders aan de hand,

dit is wel de niuewste pli4 en op mijn duo staat een oudere 

 

maar in de exports staat in elk geval goed:

 

/etc # cat exports
/nfs/DM7025_HDD *(rw,all_squash,sync,insecure,anonuid=65534,anongid=1000)
/nfs/Download *(ro,all_squash,sync,insecure,anonuid=65534,anongid=1000)
/nfs/Movies *(rw,all_squash,sync,insecure,anonuid=65534,anongid=1000)
/nfs/Public *(ro,all_squash,sync,insecure,anonuid=65534,anongid=1000)
/nfs/Private *(rw,all_squash,sync,insecure,anonuid=65534,anongid=1000)


Vu+duo & 2x Vu+duo2  Vu+ultimo4K
28.2E | 23.5E | 19.2E | 13E | Terrestirial


Re: NFS share mount wel op PLI4 niet op PLI6.1 #14 noud

  • Senior Member
  • 63 posts

+1
Neutral

Posted 17 January 2018 - 20:23

volgende test verander IP op PLI4 box, en nfs mounts blijfen het doen,

lijkt toch iets in nieuwe en oude  NFS (2017-08-13 last update) anders te zijn.

ik heb alleen geen oude pli4 voor duo2 om dit echt te testen.


Vu+duo & 2x Vu+duo2  Vu+ultimo4K
28.2E | 23.5E | 19.2E | 13E | Terrestirial


Re: NFS share mount wel op PLI4 niet op PLI6.1 #15 WanWizard

  • PLi® Core member
  • 59,617 posts

+1,351
Excellent

Posted 17 January 2018 - 20:24

Ik kan me daar niet zo veel bij voorstellen, NFS v3 is onderhand al antiek.


Currently in use: VU+Duo 4K (2xFBC S2), Amiko Viper T2C (T2+fallback), Octagon SF8008 (S2+T2), Zgemma H9.2H (T2+fallback)

Due to health reasons, I will have periods of inactivity, during which I don't respond to posts or PM.

Many answers to your question can be found in our new and improved wiki.


Re: NFS share mount wel op PLI4 niet op PLI6.1 #16 40H3X

  • Forum Moderator
    PLi® Contributor
  • 4,559 posts

+140
Excellent

Posted 17 January 2018 - 20:50

Ik kan inloggen op de WD, met welk command kan ik zien welk paket er op zit?

 

 

misschien met

dpkg -s nfs-common 

en er staat me iets bij van

rpcinfo -p mybooklive

Als je telnet of met SSH naar je "NAS"  = WD worldbook gaat en op de command line deze commando's invoert. Het command met rpcinfo mits de hostname ook mybooklive is anders even opvragen met het command

hostname

Hardware: Vu+ Uno 4k SE - Fuba 78 cm - Tripleblock LNB Quad 19.2/23.5/28.2 - DS918+
Software : OpenPLi - OScam - Settings van Hans - Autotimer - EPGImport
---------------------------------------------------------------------------------------------------------------------------------------
Remember: Upvote with the rep_up.png button for any user/post you find to be helpful, informative, or deserving of recognition!
---------------------------------------------------------------------------------------------------------------------------------------
Many answers to your question can be found in our new and improved wiki

Note: I do not provide support via PM !.


Re: NFS share mount wel op PLI4 niet op PLI6.1 #17 noud

  • Senior Member
  • 63 posts

+1
Neutral

Posted 18 January 2018 - 10:15

ik was met SSH ingelocht op de NAS maar bijde commando's gaven "command not found", :huh: lijkt me niet aan de parameter te liggen, helaas.

 

 

er zit firmware versie 01.02.14 uit 2011 is de nieuwste.

https://support.wdc....er.aspx?ID=3304

 

helaas kan ik daar op internet ook niks met NFS versie op vinden.

 

Ik zag gister ook dat de duo2 in de woonkamer die ook een share hoort te mounten van de WD dit nu ook niet meer doet.

weet alleen niet sinds wanneer dit niet meer gemound word omdat ik deze mount zelden gebruik, maar hij heeft het in het verleden ook

op deze box gedaan. lijkt dus ook ergens met een update verloren te zijn gegaan.

 

Vreemde vind ik dat mijn oude duo met oudere PLI4 hem prima mount, (ongeacht IP van de box) ook geen extra spannende mount optie's

deze share gebruikte ik al met mijn DM7025 en pli3, nooit een problem mee gehad.

De Nieuwe box met PLI 6.1 mount ook prima de NFS share van de andere PLI6.0 box kortom NFS doet het.

Kan het zijn dat dit ergens in de VU "drivers" mis gaat?

 

Wie heeft een usb image voor een duo2 met een built waarin nog de VU drivers zitten welke ook 4 tuners ondersteunden in PLI4


Vu+duo & 2x Vu+duo2  Vu+ultimo4K
28.2E | 23.5E | 19.2E | 13E | Terrestirial


Re: NFS share mount wel op PLI4 niet op PLI6.1 #18 WanWizard

  • PLi® Core member
  • 59,617 posts

+1,351
Excellent

Posted 18 January 2018 - 13:17

NFS client heeft niets met de drivers te maken, dus daar moet je het niet in zoeken.

 

Ik heb zelf geen toegang tot mijn boxen op dit moment, ik heb in het team gevraagd of iemand met 6.1 op een Duo of Duo2 een NFS mount wilt testen.


Currently in use: VU+Duo 4K (2xFBC S2), Amiko Viper T2C (T2+fallback), Octagon SF8008 (S2+T2), Zgemma H9.2H (T2+fallback)

Due to health reasons, I will have periods of inactivity, during which I don't respond to posts or PM.

Many answers to your question can be found in our new and improved wiki.


Re: NFS share mount wel op PLI4 niet op PLI6.1 #19 erwinde

  • Senior Member
  • 32 posts

+1
Neutral

Posted 18 January 2018 - 14:33

Ik heb tot afgelopen week altijd nfs3 gebruikt om een share te mounten op mijn VuDuo in de slaapkamer. Heeft jaren goed gewerkt en de laatste tijd met OpenPLI 6.1. De box is nu helaas overleden (het bekende condensator probleem). In de woonkamer heb ik een Solo2 en die werkt ook met een nfs3 share. De server is een Ubuntu 16.04 servertje.

 

Ik heb ook geprobeerd een nfs4 mount te maken, maar dat geeft altijd een 'protocol not supported' melding op de vuduo's. Het gekke is dat volgens /proc/filesystems nfs4 wel ondersteund zou zijn.


Edited by erwinde, 18 January 2018 - 14:38.


Re: NFS share mount wel op PLI4 niet op PLI6.1 #20 WanWizard

  • PLi® Core member
  • 59,617 posts

+1,351
Excellent

Posted 18 January 2018 - 14:40

Je server moet dan wel een NFS v4 server zijn, aan de client kant worden beide versies ondersteund. Mijn boxen hangen met NFS v3 vast aan een Synology, ook nog nooit een issue mee gehad.


Currently in use: VU+Duo 4K (2xFBC S2), Amiko Viper T2C (T2+fallback), Octagon SF8008 (S2+T2), Zgemma H9.2H (T2+fallback)

Due to health reasons, I will have periods of inactivity, during which I don't respond to posts or PM.

Many answers to your question can be found in our new and improved wiki.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users