Jump to content


Photo

oscam-emu startup


  • Please log in to reply
58 replies to this topic

#1 Robinson

  • Senior Member
  • 2,371 posts

+26
Good

Posted 25 January 2018 - 23:23

I think there is something wrong with oscam-emu startup script because I have experienced the same problem on ET9000 and HD51.

The oscam process simply disappears and does not re-appear using any simple method like:

- LONG BLUE - softcam restart,

- GUI restart,

- Box restart.

None of it helps. The only thing that helps is issuing the following command via telnet:

root@hd51:~# /usr/bin/oscam-emu --config-dir /etc/tuxbox/config/oscam-emu --daemon --pidfile /tmp/oscam-emu.pid --restart 2 --utf8
WARNING: Web interface UTF-8 mode enabled. Carefully read documentation as bugs may arise.
root@hd51:~#

This brings oscam-emu process back.

 

My softcam.oscam-emu file looks like this:

#!/bin/sh
case "$1" in
start)
        ulimit -s 1024
        /usr/bin/oscam-emu --config-dir /etc/tuxbox/config/oscam-emu --daemon --pidfile /tmp/oscam-emu.pid --restart 2 --utf8
        ;;
stop)
        kill `cat /tmp/oscam-emu.pid` 2> /dev/null
        ;;
restart|reload)
        $0 stop
        sleep 1
        $0 start
        ;;
version)
        echo "svn11391"
        ;;
info)
        echo "oscam-emu svn11391"
        ;;
*)
        echo "Usage: $0 start|stop|restart"
        exit 1
        ;;
esac
exit 0

What could be wrong?

 


ET9000, OpenPLi 4.0, 75E - 30W

HD51, OpenPLi 6.1, 13E, 19E


Re: oscam-emu startup #2 littlesat

  • PLi® Core member
  • 44,905 posts

+455
Excellent

Posted 26 January 2018 - 07:44

Nothing here...???
WaveFrontier 28.2E | 23.5E | 19.2E | 16E | 13E | 10/9E | 7E | 5E | 1W | 4/5W | 15W Thanks to Henksat

Re: oscam-emu startup #3 Robinson

  • Senior Member
  • 2,371 posts

+26
Good

Posted 26 January 2018 - 08:26

Noone else having an issue with oscam-emu startup?


ET9000, OpenPLi 4.0, 75E - 30W

HD51, OpenPLi 6.1, 13E, 19E


Re: oscam-emu startup #4 Pr2

  • PLi® Contributor
  • 2,719 posts

+111
Excellent

Posted 26 January 2018 - 12:24

Hi,
 
Can you try to rename your folder:
 
/etc/tuxbox/config/oscam-emu
 
to
 
/etc/tuxbox/config/oscamemu
 
So suppress the - on it, there is perhaps a bug in the oscam command line parser that consider the - as a command.
 
Pr2


NO SUPPORT by PM, it is a forum make your question public so everybody can benefit from the question/answer.

If you think that my answer helps you, you can press the up arrow in bottom right the answer.

 

Octagon SF-4008: Hotbird 13.0E, Astra 19.2E, Eutelsat5A 5.0W (+DVB-C)
VU+ Solo 4K: 2*DVB-S2 + 2*DVB-C/T/T2 (used in DVB-C)
Zgemma H5: 1*DVB-S2 + 1*DVB-C

Zgemma H7C: 1*DVB-S2 + 2*DVB-C


Re: oscam-emu startup #5 007.4

  • Senior Member
  • 33 posts

+2
Neutral

Posted 26 January 2018 - 12:27

@Robinson

Yes. I am too.

The softcam.oscam-emu start script (same as yours - which has worked without issue for a long time) is no longer reliable.

It often does not work on a cold reboot and sometimes simply restarting the softcam from the blue softcam menu does not work either.

Repeating the process occasionally works but more often than not I have have to revert to telnet to start the softcam.

I'm using PLi 6.1 on both Ultimo4k and Duo2.


Edited by 007.4, 26 January 2018 - 12:28.


Re: oscam-emu startup #6 007.4

  • Senior Member
  • 33 posts

+2
Neutral

Posted 26 January 2018 - 12:34

I have.  There is no "-" in the folder name but an underscore "_" in the oscam binary name.  I'll remove it and report back.

ulimit -s 1024
/usr/bin/oscam_11398arm --config-dir /var/tuxbox/config --daemon --pidfile /tmp/oscam.pid --restart 2 --utf8

Edited by 007.4, 26 January 2018 - 12:35.


Re: oscam-emu startup #7 Robinson

  • Senior Member
  • 2,371 posts

+26
Good

Posted 26 January 2018 - 13:02

Thaks Pr2.

I will try it in the evening, although 007.4 does not have the "-" and still experiences the issue.
It seems I have had the same issue on an OpenPLi-based image (SatDreamGr) recently too.


ET9000, OpenPLi 4.0, 75E - 30W

HD51, OpenPLi 6.1, 13E, 19E


Re: oscam-emu startup #8 Pr2

  • PLi® Contributor
  • 2,719 posts

+111
Excellent

Posted 26 January 2018 - 13:32

Yes indeed and since it works from the command line it is not the problem.


NO SUPPORT by PM, it is a forum make your question public so everybody can benefit from the question/answer.

If you think that my answer helps you, you can press the up arrow in bottom right the answer.

 

Octagon SF-4008: Hotbird 13.0E, Astra 19.2E, Eutelsat5A 5.0W (+DVB-C)
VU+ Solo 4K: 2*DVB-S2 + 2*DVB-C/T/T2 (used in DVB-C)
Zgemma H5: 1*DVB-S2 + 1*DVB-C

Zgemma H7C: 1*DVB-S2 + 2*DVB-C


Re: oscam-emu startup #9 Freon

  • Senior Member
  • 208 posts

+2
Neutral

Posted 27 January 2018 - 09:05

I have the same problem on my Solo2. It's the same on Oscam, and Oscam-emu.

Sometimes it doesen't auto-start, sometimes I have to start it on softcam setup 4-5 times until it starts.

All in script is fine (both of them).


MAY THE FORCE BE WITH YOU!


Re: oscam-emu startup #10 athoik

  • PLi® Core member
  • 7,321 posts

+251
Excellent

Posted 27 January 2018 - 09:20

Maybe it's the CLOCKFUCK...
 
 -w, --wait <secs>       | Set how much seconds to wait at startup for the
                         . system clock to be set correctly. Default: 60
Use -w 0 and see if that works fine.

start)
        ulimit -s 1024
        /usr/bin/oscam-emu --config-dir /etc/tuxbox/config/oscam-emu --daemon --pidfile /tmp/oscam-emu.pid --restart 2 --utf8 --wait 0
        ;;

Edited by athoik, 27 January 2018 - 09:24.

Wavefield T90: 0.8W - 5E - 7E - 13E - 16E - 19E - 23E - 26E - 28E - 39E - 42E - 45E on EMP Centauri DiseqC 16/1
Unamed: 13E Quattro - 9E Quattro on IKUSI MS-0916

Re: oscam-emu startup #11 Freon

  • Senior Member
  • 208 posts

+2
Neutral

Posted 27 January 2018 - 09:37

For this reboot now it worked... Shall see.


MAY THE FORCE BE WITH YOU!


Re: oscam-emu startup #12 Robinson

  • Senior Member
  • 2,371 posts

+26
Good

Posted 29 January 2018 - 22:59

Use -w 0 and see if that works fine.
start)
        ulimit -s 1024
        /usr/bin/oscam-emu --config-dir /etc/tuxbox/config/oscam-emu --daemon --pidfile /tmp/oscam-emu.pid --restart 2 --utf8 --wait 0
        ;;

 

After adding -w 0 the issue seems to have gone. :)

I guess this parameter should be added to the default softcam start script. What do you think?


ET9000, OpenPLi 4.0, 75E - 30W

HD51, OpenPLi 6.1, 13E, 19E


Re: oscam-emu startup #13 Robinson

  • Senior Member
  • 2,371 posts

+26
Good

Posted 3 February 2018 - 15:36

I ran an online update today and after booting "oscam-emu" did not start automatically.

Also the "--wait 0" disappeared from softcam.oscam-emu file.


ET9000, OpenPLi 4.0, 75E - 30W

HD51, OpenPLi 6.1, 13E, 19E


Re: oscam-emu startup #14 WanWizard

  • Forum Moderator
    PLi® Core member
  • 41,181 posts

+650
Excellent

Posted 3 February 2018 - 16:00

I don't see a commit in 6.1-release that introduces that parameter, so it is logical it disappeared (as the package itself did update).


Many answers to your question can be found in our new and improved wiki.

Currently in active use: VU+Solo 4K (1xFBC, 2xS2), VU+Zero, Edision OS mini+, Amiko Viper 2TC, Zgemma H3.2TC, Zgemma H6

For testing purposes: XP1000, Formuler F1 (2xS2), Miraclebox Premium Micro (S2+C/T), ET7500 (S2), ET8500 (S2), Zgemma H2.H (S2+C), Zgemma H5.2TC, SAB TripleAlpha (S2+C/T), Galaxy 4K (FBC), VU Zero 4K, HD2400 (4xS2), ET10000 (4xS2), VU+Duo2 (1xS2), Edision OS nino


Re: oscam-emu startup #15 darkman13

  • Senior Member
  • 62 posts

0
Neutral

Posted 3 February 2018 - 16:04

I am using

 

etc/tuxbox/config.....here files

usr/bin/oscam

 

no problem



Re: oscam-emu startup #16 FRAP

  • Senior Member
  • 72 posts

+5
Neutral

Posted 4 February 2018 - 17:10

if you have problems with the automatic launch of OSCAM (after turning on the receiver), I solved my problem this way when the emulator is running a command in telnet ..... update-rc.d softcam defaults 50
  .... then I give the command to init 6 after all these actions for me when you turn on the receiver, my emulator turns on automatically


Re: oscam-emu startup #17 Robinson

  • Senior Member
  • 2,371 posts

+26
Good

Posted 6 February 2018 - 23:56

I'm afraid the "--wait 0" does not solve the issue.

For example today, I wanted to restart oscam-emu from its WebInterface and it just shut down, it was not restarted. Then I issued the following command from telnet:

/usr/bin/oscam-emu --config-dir /etc/tuxbox/config/oscam-emu --daemon --pidfile /tmp/oscam-emu.pid --restart 2 --utf8 --wait 0

and it still did not start.

Then I issued the command again and it was restarted.

After a few minutes I wanted to restart oscam-emu and the same thing happened but this time I had to issue the command 3 times before oscam-emu finally got restarted.


ET9000, OpenPLi 4.0, 75E - 30W

HD51, OpenPLi 6.1, 13E, 19E


Re: oscam-emu startup #18 nautilus7

  • Senior Member
  • 114 posts

+1
Neutral

Posted 7 February 2018 - 00:50

Hi, is your oscam built with clockfix? Try using builds without the clockfix feature. Do you use systemtime plugin to setup the time though ntp server?

 

I had similar issues with systemtime plugin and switching to oscam without the clockfix almost solved the issue. I would say 99% of the times I restart my box oscam starts ok. 



Re: oscam-emu startup #19 Robinson

  • Senior Member
  • 2,371 posts

+26
Good

Posted 7 February 2018 - 08:35

Yes, I use systemtime.

Could you please help me find a recent oscam build with clockfix for oscam emu, both for ARM and MIPSEL?


Edited by Robinson, 7 February 2018 - 08:37.

ET9000, OpenPLi 4.0, 75E - 30W

HD51, OpenPLi 6.1, 13E, 19E


Re: oscam-emu startup #20 littlesat

  • PLi® Core member
  • 44,905 posts

+455
Excellent

Posted 7 February 2018 - 09:08

Can you also verify the performance with systemtime disabled.???


WaveFrontier 28.2E | 23.5E | 19.2E | 16E | 13E | 10/9E | 7E | 5E | 1W | 4/5W | 15W Thanks to Henksat




1 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users


    Bing (1)