Jump to content


Photo

NFS OpenPLi to OpenPLi


  • Please log in to reply
31 replies to this topic

#1 doglover

  • Rytec EPG Team
  • 11,743 posts

+327
Excellent

Posted 12 February 2018 - 17:14

Heb problemen met het opzetten van een NFS mount OpenPLi - Open PLi

 

Het lukt me niet om via dit een mount te maken:

https://wiki.openpli.org/MountManager

Zie aangehechte screenshot

 

Ook wanneer ik e.e.a probeer via fstab lukt het niet.

Ik krijg steeds wanneer ik mount -a uitvoer.  Permission denied.

 

Ik heb nochtans op de server nfsserver geïnstalleerd.

Nu lijkt het me dat ik daar ook wel enkele toelatingen zal moeten configureren.  Maar waar?

 

Dank bij voorbaat.

 

Willy

 

PS:  Mijn NAS is wel netjes gemount via nfs.  Dat lukt mij dus wel.

 

 

Attached Files


Edited by doglover, 12 February 2018 - 17:15.

~~Rytec Team~~
Xtrend ET6000 OpenPli (used as mediaplayer)
Mutant HD2400 OpenPli
Vu+ Duo OpenPli (backup)

Synology NAS

Sat: 13E, 19.2E, 23.5E and 28.2E
*Pli/Rytec EPG POWERED*


Re: NFS OpenPLi to OpenPLi #2 WanWizard

  • Forum Moderator
    PLi® Core member
  • 40,803 posts

+641
Excellent

Posted 12 February 2018 - 17:24

Je moet op de server box ook de shares nog definieren, ik denk niet dat er defaults meekomen met nfsserver. Dat doe je in de plugin.

 

En wellicht moet je ook de box nog wel een schop verkopen om nfs te starten...


Edited by WanWizard, 12 February 2018 - 17:30.

Many answers to your question can be found in our new and improved wiki.

Currently in active use: HD2400 (4xS2)VU+Duo2 (3xS2)VU+Zero, Edision OS mini+, ET10000 (4xS2)

For testing purposes: XP1000Formuler F1 (2xS2)Miraclebox Premium Micro (S2+C/T),  ET7500 (S2)ET8500 (S2), Zgemma H2.H (S2+C)Zgemma H5.2TC (S2+C/T), SAB TripleAlpha (S2+C/T), Galaxy 4K (FBC), VU Zero 4K, Edision OS nino 


Re: NFS OpenPLi to OpenPLi #3 doglover

  • Rytec EPG Team
  • 11,743 posts

+327
Excellent

Posted 12 February 2018 - 17:39

Dat doe je in de plugin.

 

 

In welke plug-in?

Waar?

Dat is nu net wat ik niet begrijp.  Hier mis ik iets.

 

Heb die box al tig maal een schop onder zijn kont gegeven in de hoop leven in de brouwerij te krijgen..  (herstart)

 

PS: Ik heb al geprobeerd onder /etc/exports

Werkt niet.  En als ik zoek op het net vind ik allerhande syntaxes die moeten gebruikt worden.

Kan er geen touw aan vastknopen.


Edited by doglover, 12 February 2018 - 17:41.

~~Rytec Team~~
Xtrend ET6000 OpenPli (used as mediaplayer)
Mutant HD2400 OpenPli
Vu+ Duo OpenPli (backup)

Synology NAS

Sat: 13E, 19.2E, 23.5E and 28.2E
*Pli/Rytec EPG POWERED*


Re: NFS OpenPLi to OpenPLi #4 WanWizard

  • Forum Moderator
    PLi® Core member
  • 40,803 posts

+641
Excellent

Posted 12 February 2018 - 17:49

Je schrijft dat je nfsserver hebt geinstalleerd. Dat is een plugin, en die staat dantussen de plugins als "NFS server setup". 

 

Als je die start heb je 1 optie, "Export". Druk pijltjes links/rechts om het gewenste pad te kiezen (de plugin snapt er maar 1), en druk op ok om de correcte config te genereren en aan nfs door te geven.

 

Kies je bv /media/hdd, dan moet je aan de client kant dus "<ip-adres>/media/hdd" mounten...


Many answers to your question can be found in our new and improved wiki.

Currently in active use: HD2400 (4xS2)VU+Duo2 (3xS2)VU+Zero, Edision OS mini+, ET10000 (4xS2)

For testing purposes: XP1000Formuler F1 (2xS2)Miraclebox Premium Micro (S2+C/T),  ET7500 (S2)ET8500 (S2), Zgemma H2.H (S2+C)Zgemma H5.2TC (S2+C/T), SAB TripleAlpha (S2+C/T), Galaxy 4K (FBC), VU Zero 4K, Edision OS nino 


Re: NFS OpenPLi to OpenPLi #5 doglover

  • Rytec EPG Team
  • 11,743 posts

+327
Excellent

Posted 12 February 2018 - 17:56

Ik heb al geprobeerd onder /etc/exports

Werkt niet.  En als ik zoek op het net vind ik allerhande syntaxes die moeten gebruikt worden.

 

Op de server - Exports file

 

/etc/enigma2 *(rw,no_root_squash,sync)

 

Op de client:

 

fstab:

 

192.168.178.19:/etc/enigma2 /media/bouquets2  nfs rw,soft,async,nolock  0 0

 

Result:

 

root@sh1:~# mount -a                                                          
mount.nfs: Protocol not supported                                      
mount: mounting 192.168.178.19:/etc/enigma2 on /media/bouquets2 failed: Permisson denied                                                                     
root@sh1:~#


~~Rytec Team~~
Xtrend ET6000 OpenPli (used as mediaplayer)
Mutant HD2400 OpenPli
Vu+ Duo OpenPli (backup)

Synology NAS

Sat: 13E, 19.2E, 23.5E and 28.2E
*Pli/Rytec EPG POWERED*


Re: NFS OpenPLi to OpenPLi #6 WanWizard

  • Forum Moderator
    PLi® Core member
  • 40,803 posts

+641
Excellent

Posted 12 February 2018 - 18:15

Wat zegt

opkg list-installed nfs-utils-client

op die sh1?

 

Indien niks, installeer 'm eens:

opkg install nfs-utils-client

Many answers to your question can be found in our new and improved wiki.

Currently in active use: HD2400 (4xS2)VU+Duo2 (3xS2)VU+Zero, Edision OS mini+, ET10000 (4xS2)

For testing purposes: XP1000Formuler F1 (2xS2)Miraclebox Premium Micro (S2+C/T),  ET7500 (S2)ET8500 (S2), Zgemma H2.H (S2+C)Zgemma H5.2TC (S2+C/T), SAB TripleAlpha (S2+C/T), Galaxy 4K (FBC), VU Zero 4K, Edision OS nino 


Re: NFS OpenPLi to OpenPLi #7 littlesat

  • PLi® Core member
  • 44,606 posts

+449
Excellent

Posted 12 February 2018 - 18:19

And mount -t nfs ...

Edited by littlesat, 12 February 2018 - 18:19.

WaveFrontier 28.2E | 23.5E | 19.2E | 16E | 13E | 10/9E | 7E | 5E | 1W | 4/5W | 15W Thanks to Henksat

Re: NFS OpenPLi to OpenPLi #8 WanWizard

  • Forum Moderator
    PLi® Core member
  • 40,803 posts

+641
Excellent

Posted 12 February 2018 - 18:27

Not needed, this is an fstab mount.

 

Just to double check, on the server box, if you do "exportfs -v", does it show the exported mountpoint? And if you do "ps", do you see the "nfsd" processes running?


Many answers to your question can be found in our new and improved wiki.

Currently in active use: HD2400 (4xS2)VU+Duo2 (3xS2)VU+Zero, Edision OS mini+, ET10000 (4xS2)

For testing purposes: XP1000Formuler F1 (2xS2)Miraclebox Premium Micro (S2+C/T),  ET7500 (S2)ET8500 (S2), Zgemma H2.H (S2+C)Zgemma H5.2TC (S2+C/T), SAB TripleAlpha (S2+C/T), Galaxy 4K (FBC), VU Zero 4K, Edision OS nino 


Re: NFS OpenPLi to OpenPLi #9 Erik Slagter

  • PLi® Core member
  • 42,884 posts

+464
Excellent

Posted 12 February 2018 - 20:03

Iets als "exportfs -ra" op de server wellicht?


* Wavefrontier T90 with 28E/23E/19E/13E/9E/4.8E/0.8W/5W via SCR switches 2 x 2 x 6 user bands
* Ziggo digital cable TV (FTA)

I don't read PM -> if you have something to ask or to report, do it in the forum so others can benefit. I don't take freelance jobs.

Ik lees geen PM -> als je iets te vragen of te melden hebt, doe het op het forum, zodat anderen er ook wat aan hebben.


Re: NFS OpenPLi to OpenPLi #10 doglover

  • Rytec EPG Team
  • 11,743 posts

+327
Excellent

Posted 12 February 2018 - 20:04

Kan momenteel de client niet nakijken, omdat ie afgezet is. Zal dat morgen doen.

 

Op de server:

root@hd2400:~# exportfs -v
/etc/enigma2    <world>(rw,wdelay,no_root_squash,no_subtree_check,sec=sys,rw,secure,no_root_squash,no_all_squash)
root@hd2400:~#

and

472 root         0 SW   [lockd]
  473 root         0 SW   [nfsd]
  474 root         0 SW   [nfsd]
  475 root         0 SW   [nfsd]
  476 root         0 SW   [nfsd]
  477 root         0 SW   [nfsd]
  478 root         0 SW   [nfsd]
  479 root         0 SW   [nfsd]
  480 root         0 SW   [nfsd]
  482 root      3428 S    /usr/sbin/rpc.mountd -f /etc/exports
root@hd2400:~# exportfs -ra
exportfs: /etc/exports [1]: Neither 'subtree_check' or 'no_subtree_check' specified for export "*:/etc/enigma2".
  Assuming default behaviour ('no_subtree_check').
  NOTE: this default has changed since nfs-utils version 1.0.x
exportfs: /etc/enigma2 does not support NFS export
root@hd2400:~#

Willy


Edited by doglover, 12 February 2018 - 20:05.

~~Rytec Team~~
Xtrend ET6000 OpenPli (used as mediaplayer)
Mutant HD2400 OpenPli
Vu+ Duo OpenPli (backup)

Synology NAS

Sat: 13E, 19.2E, 23.5E and 28.2E
*Pli/Rytec EPG POWERED*


Re: NFS OpenPLi to OpenPLi #11 40H3X

  • Senior Member
  • 2,664 posts

+94
Good

Posted 12 February 2018 - 20:40

Ik heb al geprobeerd onder /etc/exports
Werkt niet.  En als ik zoek op het net vind ik allerhande syntaxes die moeten gebruikt worden.
 
Op de server - Exports file
 
/etc/enigma2 *(rw,no_root_squash,sync)
 
Op de client:
 
fstab:
 
192.168.178.19:/etc/enigma2 /media/bouquets2  nfs rw,soft,async,nolock  0 0
 
Result:
 
root@sh1:~# mount -a                                                          
mount.nfs: Protocol not supported                                      
mount: mounting 192.168.178.19:/etc/enigma2 on /media/bouquets2 failed: Permisson denied                                                                     
root@sh1:~#


/media/hdd *(rw,no_root_squash,sync)

Hardware: Vu+ Uno 4k SE - Samsung HM500JI 500GB - Spycat Mini Plus - Vu+ Zero - Vu+ Duo - WD 1TB - Fuba 78 cm - Tripleblock LNB Quad 19.2/23.5/28.2 - NAS 3TB RAID 1
Software : OpenPLi 6.x - OSCam r11xxx - Settings van Hans


Re: NFS OpenPLi to OpenPLi #12 WanWizard

  • Forum Moderator
    PLi® Core member
  • 40,803 posts

+641
Excellent

Posted 12 February 2018 - 21:26

Hij wil zijn enigma settings sharen, niet zijn harddisk. ;)


Many answers to your question can be found in our new and improved wiki.

Currently in active use: HD2400 (4xS2)VU+Duo2 (3xS2)VU+Zero, Edision OS mini+, ET10000 (4xS2)

For testing purposes: XP1000Formuler F1 (2xS2)Miraclebox Premium Micro (S2+C/T),  ET7500 (S2)ET8500 (S2), Zgemma H2.H (S2+C)Zgemma H5.2TC (S2+C/T), SAB TripleAlpha (S2+C/T), Galaxy 4K (FBC), VU Zero 4K, Edision OS nino 


Re: NFS OpenPLi to OpenPLi #13 littlesat

  • PLi® Core member
  • 44,606 posts

+449
Excellent

Posted 12 February 2018 - 22:58

Blijkt met een bouquets map te functioneren als je bouquets wilt delen..
WaveFrontier 28.2E | 23.5E | 19.2E | 16E | 13E | 10/9E | 7E | 5E | 1W | 4/5W | 15W Thanks to Henksat

Re: NFS OpenPLi to OpenPLi #14 doglover

  • Rytec EPG Team
  • 11,743 posts

+327
Excellent

Posted 13 February 2018 - 08:53

Sinds gisteren spreekt de client box de bouquetten aan via een mount van mijn andere box.

 

Alleen.......

 

Deze ochtend lag samba er weer eens uit.  Dit gebeurt af en toe.  Maar nu was dit wel catastrofaal.

Geen ochtend radio.

 

Samba herstart - en probleem opgelost.

 

Daarom wil ik deze mount via nfs laten lopen.  En laat nu net nfs mounten een probleem zijn. 

 

 

Trouwens, op deze client box, mount ik wel de NAS via nfs.

 

Enkele dingen die hoger gevraggd worden:

root@sh1:~# opkg list-installed nfs-utils-client 
nfs-utils-client - 1.3.3-r0.0

and als ik mount op vraag:

192.168.178.30:/volume1/Movie on /home/Movie type nfs (rw,relatime,vers=3,rsize=131072,wsize=131072,namlen=255,soft,nolock,proto=tcp,timeo=600,retrans=2,sec=sys,mountaddr=192.168.178.30,mountvers=3,mountproto=tcp,local_lock=all,addr=192.168.178.30)
//192.168.178.19/Root/etc/enigma2 on /media/bouquets type cifs (ro,relatime,vers=1.0,cache=strict,username=root,domain=,uid=0,noforceuid,gid=0,noforcegid,addr=192.168.178.19,iocharset=utf8,unix,posixpaths,serverino,mapposix,acl,rsize=1048576,wsize=65536,echo_interval=60,actimeo=1)

Je ziet ik kan een mount maken naar de NAS met nfs.

Met nfs van box naar box lukt mij niet.  Daarom heb ik een cifs gebruikt met alle gevolgen vandien.

 

 

Willy


~~Rytec Team~~
Xtrend ET6000 OpenPli (used as mediaplayer)
Mutant HD2400 OpenPli
Vu+ Duo OpenPli (backup)

Synology NAS

Sat: 13E, 19.2E, 23.5E and 28.2E
*Pli/Rytec EPG POWERED*


Re: NFS OpenPLi to OpenPLi #15 doglover

  • Rytec EPG Team
  • 11,743 posts

+327
Excellent

Posted 13 February 2018 - 09:00

En ja

enigma2-plugin-extensions-nfsserver - 2.0+git2+cff1432-r0.2

 

is geinstalleerd, gecontroleerd.

 

Willy


~~Rytec Team~~
Xtrend ET6000 OpenPli (used as mediaplayer)
Mutant HD2400 OpenPli
Vu+ Duo OpenPli (backup)

Synology NAS

Sat: 13E, 19.2E, 23.5E and 28.2E
*Pli/Rytec EPG POWERED*


Re: NFS OpenPLi to OpenPLi #16 40H3X

  • Senior Member
  • 2,664 posts

+94
Good

Posted 13 February 2018 - 11:06

Ondank de opmerking #11 van mij, die niet voor "dit" forum was bedoeld, misschien is het nog een idee om om de mount de forcen naar NFS3?

 

zie ook https://forums.openp...-niet-op-pli61/


Edited by 40H3X, 13 February 2018 - 11:07.

Hardware: Vu+ Uno 4k SE - Samsung HM500JI 500GB - Spycat Mini Plus - Vu+ Zero - Vu+ Duo - WD 1TB - Fuba 78 cm - Tripleblock LNB Quad 19.2/23.5/28.2 - NAS 3TB RAID 1
Software : OpenPLi 6.x - OSCam r11xxx - Settings van Hans


Re: NFS OpenPLi to OpenPLi #17 doglover

  • Rytec EPG Team
  • 11,743 posts

+327
Excellent

Posted 13 February 2018 - 11:54

nfs3:

 

192.168.178.19:/etc/enigma2 /media/bouquets2  nfs ro,vers=3,soft,async,nolock  0 0

root@sh1:~# mount -a                                                          
mount.nfs: access denied by server while mounting 192.168.178.19:/etc/enigma2 
mount: mounting 192.168.178.19:/etc/enigma2 on /media/bouquets2 failed: Permisson denied                                                                     
mount.nfs: Protocol not supported                                             
root@sh1:~#

No result.

 

Willy

 

PS: de host.allow file heb ik niet.


Edited by doglover, 13 February 2018 - 11:59.

~~Rytec Team~~
Xtrend ET6000 OpenPli (used as mediaplayer)
Mutant HD2400 OpenPli
Vu+ Duo OpenPli (backup)

Synology NAS

Sat: 13E, 19.2E, 23.5E and 28.2E
*Pli/Rytec EPG POWERED*


Re: NFS OpenPLi to OpenPLi #18 WanWizard

  • Forum Moderator
    PLi® Core member
  • 40,803 posts

+641
Excellent

Posted 13 February 2018 - 12:03

Ik ga wel even kijken of ik vanmiddag wat test tijd vrij kan maken, want snappen doe ik het niet helemaal.


Many answers to your question can be found in our new and improved wiki.

Currently in active use: HD2400 (4xS2)VU+Duo2 (3xS2)VU+Zero, Edision OS mini+, ET10000 (4xS2)

For testing purposes: XP1000Formuler F1 (2xS2)Miraclebox Premium Micro (S2+C/T),  ET7500 (S2)ET8500 (S2), Zgemma H2.H (S2+C)Zgemma H5.2TC (S2+C/T), SAB TripleAlpha (S2+C/T), Galaxy 4K (FBC), VU Zero 4K, Edision OS nino 


Re: NFS OpenPLi to OpenPLi #19 doglover

  • Rytec EPG Team
  • 11,743 posts

+327
Excellent

Posted 13 February 2018 - 13:01

Ik snap het ook niet.  Een nfs mount van de NAS - geen probleem.

Van een enigma2 receiver - probleem.

 

Willy


~~Rytec Team~~
Xtrend ET6000 OpenPli (used as mediaplayer)
Mutant HD2400 OpenPli
Vu+ Duo OpenPli (backup)

Synology NAS

Sat: 13E, 19.2E, 23.5E and 28.2E
*Pli/Rytec EPG POWERED*


Re: NFS OpenPLi to OpenPLi #20 WanWizard

  • Forum Moderator
    PLi® Core member
  • 40,803 posts

+641
Excellent

Posted 13 February 2018 - 13:46

We hebben ergens een bug te pakken:

root@galaxy4k:~# /etc/init.d/nfsserver start
starting 8 nfsd kernel threads: done
starting mountd: Usage: rpc.mountd [-F|--foreground] [-h|--help] [-v|--version] [-d kind|--debug kind]
	[-o num|--descriptors num]
	[-p|--port port] [-V version|--nfs-version version]
	[-N version|--no-nfs-version version] [-n|--no-tcp]
	[-H prog |--ha-callout prog] [-r |--reverse-lookup]
	[-s|--state-directory-path path] [-g|--manage-gids]
	[-t num|--num-threads=num] [-u|--no-udp]

Dit kun je oplossen door "/etc/init.d/nfsserver" te openen in een editor, en dan de start_mountd() functie aan te passen naar

start_mountd(){
        echo -n 'starting mountd: '
        start-stop-daemon --start --exec "$NFS_MOUNTD" -- "$@"
        echo done
}

dus verwijderen van de "-f /etc/exports", een optie die niet ondersteund wordt.

 

Hierna

/etc/init.d/nfsserver/restart

en de mount moet het nu doen.


Many answers to your question can be found in our new and improved wiki.

Currently in active use: HD2400 (4xS2)VU+Duo2 (3xS2)VU+Zero, Edision OS mini+, ET10000 (4xS2)

For testing purposes: XP1000Formuler F1 (2xS2)Miraclebox Premium Micro (S2+C/T),  ET7500 (S2)ET8500 (S2), Zgemma H2.H (S2+C)Zgemma H5.2TC (S2+C/T), SAB TripleAlpha (S2+C/T), Galaxy 4K (FBC), VU Zero 4K, Edision OS nino 





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users