Jump to content


Photo

Zgemma H7 no kernel-module-tun

openvpn tun/tap

  • Please log in to reply
12 replies to this topic

#1 nokias

  • Member
  • 12 posts

0
Neutral

Posted 22 February 2018 - 10:45

Hi all.

 

Did PLI forget to compile the kernel-module-tun for pli4 and 6/6.1 Zgemma H7?

 

Does anyone have it? It is not on the repository!

 

Realy need it for openvpn!

 

Thanks!


Edited by nokias, 22 February 2018 - 10:47.


Re: Zgemma H7 no kernel-module-tun #2 WanWizard

  • Forum Moderator
    PLi® Core member
  • 47,149 posts

+784
Excellent

Posted 22 February 2018 - 16:23

It is a kernel driver, so it needs to be enabled in the BSP.  A quick search reveils that these don't have that:

./meta-zgemma/recipes-bsp/linux/files/h7/defconfig:# CONFIG_TUN is not set
./meta-gi/recipes-bsp/linux/linux-et1x000-4.1.37/et1x000/defconfig:# CONFIG_TUN is not set

so we'll need to ping Zgemma and GI to have it corrected. I've created PR's for it:

https://github.com/z...-zgemma/pull/12

https://github.com/G.../meta-gi/pull/8


Currently in use: VU+Duo 4K (2xFBC S2), Amiko Viper T2C (T2), SAB Alpha Triple HD (S2+T2), Zgemma H3.T2C (T/C), Zgemma H6 (fallback), VU+Zero (fallback)

Many answers to your question can be found in our new and improved wiki.

note: I do not provide support via PM !

 


Re: Zgemma H7 no kernel-module-tun #3 nokias

  • Member
  • 12 posts

0
Neutral

Posted 22 February 2018 - 20:54

Thank you for your help.
You really are right.

What I do not understand is why other competing images have the compiled driver in their repository.
Before comming here to report the problem, I took the driver from the repository of another image
(kernel-module-tun-4.10.12_4.10.12-.10_h7.ipk) and I installed it in PLI, but it gave me a "bad argument" error when loading the module with modprobe and insmod.

(probably because it is "4.10.12-.10" instead of "4.10.12-.0.1")

Now that you've taken action, does it take to long  before the driver is available to install in pli?

Thanks for everything!



Re: Zgemma H7 no kernel-module-tun #4 WanWizard

  • Forum Moderator
    PLi® Core member
  • 47,149 posts

+784
Excellent

Posted 22 February 2018 - 21:36

Other image builders use their own BSP's, we use the BSP the manufacturer maintains. Simply because we choose stability and support over bleeding edge.

 

It will be part of the next release, If Zgemma updates it in time. Alternatively, build your own develop image, which will contact it immediately after it is updated (so it can be tested).


Currently in use: VU+Duo 4K (2xFBC S2), Amiko Viper T2C (T2), SAB Alpha Triple HD (S2+T2), Zgemma H3.T2C (T/C), Zgemma H6 (fallback), VU+Zero (fallback)

Many answers to your question can be found in our new and improved wiki.

note: I do not provide support via PM !

 


Re: Zgemma H7 no kernel-module-tun #5 Erik Slagter

  • PLi® Core member
  • 45,235 posts

+496
Excellent

Posted 24 February 2018 - 11:07

Update: Zgemma already acted an added it.


* Wavefrontier T90 with 28E/23E/19E/13E/9E/4.8E/0.8W/5W via SCR switches 2 x 2 x 6 user bands
* Ziggo digital cable TV (FTA)
I don't read PM -> if you have something to ask or to report, do it in the forum so others can benefit. I don't take freelance jobs.
Ik lees geen PM -> als je iets te vragen of te melden hebt, doe het op het forum, zodat anderen er ook wat aan hebben.

Re: Zgemma H7 no kernel-module-tun #6 nokias

  • Member
  • 12 posts

0
Neutral

Posted 25 February 2018 - 03:05

Thank you guys.
I noticed that zgemma acted almost immediately.

Now I'm just waiting for you to release the next release ... or
at least you recompile the modules so that the tun / tap driver became available in your repository for this kernel. (a few months ago a release came almost every day ... but lately not ... so I've been waiting very carefully.)

Thank you!



Re: Zgemma H7 no kernel-module-tun #7 WanWizard

  • Forum Moderator
    PLi® Core member
  • 47,149 posts

+784
Excellent

Posted 25 February 2018 - 03:19

There's a 6.2 release in the planning.


Currently in use: VU+Duo 4K (2xFBC S2), Amiko Viper T2C (T2), SAB Alpha Triple HD (S2+T2), Zgemma H3.T2C (T/C), Zgemma H6 (fallback), VU+Zero (fallback)

Many answers to your question can be found in our new and improved wiki.

note: I do not provide support via PM !

 


Re: Zgemma H7 no kernel-module-tun #8 nokias

  • Member
  • 12 posts

0
Neutral

Posted 27 February 2018 - 00:21

Hello guys!

Today came a new release for pli4 and 6.1, but I noticed that the kernel-module-tun driver is not yet available! :huh:

Have the modules not been compiled?
What now?

Thanks for everything!



Re: Zgemma H7 no kernel-module-tun #9 WanWizard

  • Forum Moderator
    PLi® Core member
  • 47,149 posts

+784
Excellent

Posted 27 February 2018 - 00:33

No, the new BSP will be introduced in 6.2-release. Updates within a release only include data files and hotfixes to Enigma (or plugins).

 

6.2-release is penciled in for mid-March (if all goes well).

 

In the meantime you can see if this one works for you.

Attached Files


Currently in use: VU+Duo 4K (2xFBC S2), Amiko Viper T2C (T2), SAB Alpha Triple HD (S2+T2), Zgemma H3.T2C (T/C), Zgemma H6 (fallback), VU+Zero (fallback)

Many answers to your question can be found in our new and improved wiki.

note: I do not provide support via PM !

 


Re: Zgemma H7 no kernel-module-tun #10 nokias

  • Member
  • 12 posts

0
Neutral

Posted 27 February 2018 - 02:30

hello @WanWizard

I can hardly wait for the new pli6.2 and the high quality that you have accustomed us. ;)

Thank you very much for the effort and I inform you that the version of Tun Drivers you published works perfectly in 6/6.1!

(You could have made me suffer a little less and published that version earlier, hehe) :rolleyes:

Thanks again, bro!



Re: Zgemma H7 no kernel-module-tun #11 WanWizard

  • Forum Moderator
    PLi® Core member
  • 47,149 posts

+784
Excellent

Posted 27 February 2018 - 15:11

(You could have made me suffer a little less and published that version earlier, hehe) :rolleyes:

 

The impossible I do today, for miracles I have a waiting list. ;)


Currently in use: VU+Duo 4K (2xFBC S2), Amiko Viper T2C (T2), SAB Alpha Triple HD (S2+T2), Zgemma H3.T2C (T/C), Zgemma H6 (fallback), VU+Zero (fallback)

Many answers to your question can be found in our new and improved wiki.

note: I do not provide support via PM !

 


Re: Zgemma H7 no kernel-module-tun #12 mysat

  • Senior Member
  • 59 posts

+2
Neutral

Posted 26 June 2019 - 11:42

No, the new BSP will be introduced in 6.2-release. Updates within a release only include data files and hotfixes to Enigma (or plugins).

 

6.2-release is penciled in for mid-March (if all goes well).

 

In the meantime you can see if this one works for you.

 

Is this a possible solution for my problem with Zerotier also ? Currently running openpli 7.1 and I can try this if compatible with 7.1



Re: Zgemma H7 no kernel-module-tun #13 WTE

  • Senior Member
  • 676 posts

+30
Good

Posted 26 June 2019 - 11:52

telnet command: opkg install kernel-module-tun


Mut@nt HD51 STB 4K

   :rolleyes:                :rolleyes:





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users