Jump to content


Dreambox DM500HD


  • Please log in to reply
2 replies to this topic

#1 mav2005

  • Member
  • 12 posts


Posted 8 April 2018 - 19:24


I am unable to flash the dreambox DM500HD

The box had openPli and during a SW update I switched the box off by mistake, that seem to have packe it up

I tried flashing the box with both original dreambox and with openpli firmwares but none worked

I used dreamp, it does connect to the box but when I try to flash nothing happens

Aldo tried to flash useing the dreambox interface with the box connected to the tv, pressing power button in the front, then switch box on and nothing happens

if I only press the power on the dreambox screen appears but nothing else

is the box dead or can it be recovered somehow?


Thank you!


Re: Dreambox DM500HD #2 mimisiku

  • Senior Member
  • 2,415 posts


Posted 8 April 2018 - 19:36

You need to specify a bit more. There are 2 versions of the DM500HD. The v1 which IS OpenPli certified and the v2 which is NOT. The v2 is sold after july 2014 and has larger memory. Trying to flash OpenPli in a v2 would produce exactly the error you ate facing.

Flashing a DM500HD either version WILL require the VCP driver from Dream Multimedia. Install these first on your PC. When done, select a virtual COM port to use. Set the baudrate to 115200,n8,1 and select Hardware Flowcontrol.

Turn OFF the DM500HD completely, connect the mini-USB cable to your DM500HD and the PC. Next start DreamUp and select the proper COM port you have just defined. Press 'Connect'. When DreamUp is done with it's prerequisites it asks you to turn on the box. Now turn on your box. DreamUp should connect an report the box. The flash button now becomes active.
Met één been in het graf..... Helaas

Re: Dreambox DM500HD #3 mav2005

  • Member
  • 12 posts


Posted 8 April 2018 - 19:58

issue resolve

I have version 1 of DM500HD

I tried again with box connected to tv, switched on from the back while pressing power on in the front and then went to pc to ip address and I finally could see the page to flash it

I was expecting to see something on the tv screen as per instructions but nothing was appearing

now all is ok


thank you!

Also tagged with one or more of these keywords: Flash

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users